Loading ...
Sorry, an error occurred while loading the content.

Re: [simpson-simmol] Re: Has anybody managed to compile Simpson 3 under Ubuntu ?

Expand Messages
  • Julien TREBOSC
    Your lib file should be in /usr/lib64/ since you try to build 64bit app ? Try to change to that pathway. Julien ... Your lib file should be in /usr/lib64/
    Message 1 of 17 , Apr 26 9:32 AM
    View Source
    • 0 Attachment
      Your lib file should be in /usr/lib64/ since you try to build 64bit app ?

      Try to change to that pathway.

      Julien

      Le 26/04/2012 18:21, Gansmuller a écrit :
       

      Hi Thomas,
      thank you for helping out.
      My tcl.h file is located in /usr/include/tcl8.5
      and the lib files are in /usr/lib
      I tried again using these lines

      INCLUDES = -I/usr/include/tcl8.5
      LIBRARIES = -L/usr/lib -latlas -ltcl8.5 -lm -llapack -lgslcblas -lcblas -lblas
      BINDIR = /usr/bin
      EXTRA_FLAGS = -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE

      but it the problem remains.

      I also tried on another computer with ubuntu 11.10 but the output is still the same...
      (by the way, I'm using gcc 4.6.1)

      --- In simpson-simmol@yahoogroups.com, Thomas Vosegaard <tv@...> wrote:
      >
      > Hi Axel
      >
      > Where is your tcl.h file located? Try to locate it and add the following to the compilation:
      >
      > -I/path/to/tcl -L/path/to/tcl -ltcl
      >
      > And note that -I points to the directory containing tcl.h, while -L points to the directory containing libtcl.so (or something like that).
      >
      > Thomas
      >
      > On Apr 25, 2012, at 16:22, Gansmuller <axelgans@...> wrote:
      >
      > > I just installed tcl8.6 and tried your extra flags, but unfortunately it didn't help.
      > > Strangely enough, when I leave out the libraries in the Makefile (leaving the line blank), I get the same error output...
      > >
      > > PS: I uploaded the Makefile in the files section.
      > >
      > > --- In simpson-simmol@yahoogroups.com, Julien TREBOSC <simpson.trebosc@> wrote:
      > > >
      > > > Did you try with tcl8.6 (or default one) and the options EXTRA_FLAGS =
      > > > -DMPI -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE ?
      > > >
      > > > Julien
      > > >
      > > > Le 24/04/2012 12:28, Gansmuller a écrit :
      > > > >
      > > > > Hi Julien,
      > > > > I have already installed the 64 bits dev files; and they seem to be
      > > > > where should be. The libraries also seem to be found when I run the
      > > > > test Vadim suggested (gcc -llapack etc...)
      > > > > So basically I don't know what's wrong...
      > > > > Axel.
      > > > >
      > > > > PS: the error output can be found in the Files section.
      > > > >
      > > > > --- In simpson-simmol@yahoogroups.com
      > > > > <mailto:simpson-simmol%40yahoogroups.com>, Julien TREBOSC
      > > > > <simpson.trebosc@> wrote:
      > > > > >
      > > > > > Hi Axel,
      > > > > >
      > > > > > maybe you should check where the dev files have been installed and if
      > > > > > you installed the 64bit package ones (even for the dev one). Then
      > > > > it's a
      > > > > > matter of telling gcc and the linker where to find the shared library :
      > > > > >
      > > > > > Personnally I manage to compile/run simpson with MPI (parallelisation)
      > > > > > and tcl8.6 with the following options :
      > > > > > # Linux MPI + GCC
      > > > > > INCLUDES = -I/usr/include/tcl8.6
      > > > > > LIBRARIES = -L/usr/lib64/atlas -ltcl8.6 -lm -llapack -lcblas
      > > > > > CC = mpicc
      > > > > > EXTRA_FLAGS = -DMPI -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE
      > > > > >
      > > > > > -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE are for using old tcl style
      > > > > > because the API has changed since then.
      > > > > >
      > > > > > Note that I'm running a Mandriva distrib and not ubuntu.
      > > > > >
      > > > > > Julien
      > > > > >
      > > > > > Le 23/04/2012 12:06, Gansmuller a écrit :
      > > > > > >
      > > > > > > Dear Vadim,
      > > > > > > I removed both versions tcl/tk8.5 and tcl/tk8.4 and reinstalled the
      > > > > > > 8.5 version with the corresponding -dev files. The problem is still
      > > > > > > there... even if I always run "make clean" before recompiling.
      > > > > > >
      > > > > > > --- In simpson-simmol@yahoogroups.com
      > > > > <mailto:simpson-simmol%40yahoogroups.com>
      > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, VADIM ZORIN
      > > > > > > <vadim.zorin@> wrote:
      > > > > > > >
      > > > > > > > Those suggest it's a problem linking against Tcl:
      > > > > > > >
      > > > > > > > > >
      > > > > > > > > >B0inhom.o: In function `tclZgradList':
      > > > > > > > > >B0inhom.c:(.text+0xbb): undefined reference to `Tcl_GetInt'
      > > > > > > > > >B0inhom.c:(.text+0xe0): undefined reference to `Tcl_NewListObj'
      > > > > > > > > >B0inhom.c:(.text+0x12a): undefined reference to
      > > > > > > `Tcl_ListObjAppendElement'
      > > > > > > > > >B0inhom.c:(.text+0x15a): undefined reference to
      > > > > `Tcl_NewDoubleObj'
      > > > > > > > > >B0inhom.c:(.text+0x187): undefined reference to
      > > > > `Tcl_SetObjResult'Â
      > > > > > > >
      > > > > > > >
      > > > > > > > Could it be that tcl-dev (containing .h files with definitions) and
      > > > > > > tcl packages (containing the binary library) have different versions?Â
      > > > > > > >
      > > > > > > > Just another idea: could you also check that you removed all
      > > > > > > possible .o files from the source directories before compilation
      > > > > > > (usually 'make clean' should do that but I don't know how it is for
      > > > > > > SIMPSON). If you accidentally have .o files created on other
      > > > > > > platforms (like MacOS/Win/32bit Linux) 'make' may skip compilation of
      > > > > > > the corresponding .c file. The linkage will fail because
      > > > > non-native .o
      > > > > > > files have a wrong format.
      > > > > > > >
      > > > > > > > Vadim
      > > > > > > >
      > > > > > > >
      > > > > > > > ________________________________
      > > > > > > > From: Gansmuller <axelgans@>
      > > > > > > > To: simpson-simmol@yahoogroups.com
      > > > > <mailto:simpson-simmol%40yahoogroups.com>
      > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
      > > > > > > > Sent: Friday, 20 April 2012, 15:29
      > > > > > > > Subject: [simpson-simmol] Re: Please help... Can't Install from
      > > > > > > sources under ubuntu 11.10
      > > > > > > >
      > > > > > > >
      > > > > > > > Â
      > > > > > > > Thank you all for your quick reply, unfortunately it still
      > > > > doesn't work.
      > > > > > > > I already had installed cblas libraries:
      > > > > > > >
      > > > > > > > gsl-bin
      > > > > > > > libgsl0-dev
      > > > > > > > libgsl0ldbl
      > > > > > > > libgsl0-dbg
      > > > > > > >
      > > > > > > > I tested whether the libraries were found as Vadim suggested but
      > > > > > > everything was found...
      > > > > > > > Any more ideas ?
      > > > > > > >
      > > > > > > > --- In simpson-simmol@yahoogroups.com
      > > > > <mailto:simpson-simmol%40yahoogroups.com>
      > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, VADIM ZORIN <vadim.zorin@>
      > > > > > > wrote:
      > > > > > > > >
      > > > > > > > > As Zdenek mention it should be a problem with one of the linked
      > > > > > > libraries. To check which one is a troublemaker you can for every
      > > > > > > library from the list:
      > > > > > > > >
      > > > > > > > > LIBRARIES = -lm -llapack -lblas -ltcl8.5 -lgslcblasÃ,Â
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > run command: gcc -llapack (and so on).Ã, if you get 'ld: library
      > > > > > > not found for -llapack' it means that gcc has not found the library
      > > > > > > (but it don't mean that it's not installed), if you get something
      > > > > like
      > > > > > > 'Undefined symbols: "_main", referenced from: ...' it means that
      > > > > > > liblapack has been found.
      > > > > > > > >
      > > > > > > > > For missing library try to look for a file
      > > > > 'lib<libarary_name>.so'
      > > > > > > (can have .a extension too) on your system. If file is not found you
      > > > > > > need to install the library from the Ubuntu repository.Ã,Â
      > > > > > > > >
      > > > > > > > > VadimÃ,Â
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > ________________________________
      > > > > > > > > From: ZdenÃ"âEURºk ToÃ...¡ner <tosner@>
      > > > > > > > > To: simpson-simmol@yahoogroups.com
      > > > > <mailto:simpson-simmol%40yahoogroups.com>
      > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
      > > > > > > > > Sent: Friday, 20 April 2012, 10:19
      > > > > > > > > Subject: Re: [simpson-simmol] Please help... Can't Install from
      > > > > > > sources under ubuntu 11.10
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > Ã,Â
      > > > > > > > > As someone says warnings are not errors ;-) I guess the make
      > > > > error
      > > > > > > is due to linking. You do not mention you have installed GSL CBLAS.
      > > > > > > Simpson is using CBLAS not BLAS, so some variant of CBLAS is
      > > > > necessary
      > > > > > > (GSL is one of them).
      > > > > > > > >
      > > > > > > > > Zdenek
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > 2012/4/20 Gansmuller <axelgans@>
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > >Ã,Â
      > > > > > > > > >Dear Simpson users,
      > > > > > > > > >I'm using ubuntu 11.1 on a 64bits machine and I want to install
      > > > > > > simpson 3.1 from sources in order to run parallel calculations (the
      > > > > > > precompiled version is running since I removed ATLAS).
      > > > > > > > > >After trying several times I still didn't manage to compile the
      > > > > > > program.
      > > > > > > > > >When I run the make command I obtain plenty of warnings (cf end
      > > > > > > of this message and attachment) but no error except the final :
      > > > > > > > > >
      > > > > > > > > >collect2: ld returned 1 exit status
      > > > > > > > > >make: *** [simpson] Error 1
      > > > > > > > > >
      > > > > > > > > >Please can someone help me, I spent a lot of time trying but now
      > > > > > > I'm stuck...
      > > > > > > > > >
      > > > > > > > > >Thank's in advance,
      > > > > > > > > >Axel.
      > > > > > > > > >
      > > > > > > > > >PS:here is how I modified the my make file:
      > > > > > > > > >
      > > > > > > > > ># Linux
      > > > > > > > > >INCLUDES = -I/usr/include/tcl8.5 -I/usr/include
      > > > > > > > > >LIBRARIES = -lm -llapack -lblas -ltcl8.5 -lgslcblas
      > > > > > > > > >BINDIR = /usr/local/bin
      > > > > > > > > >
      > > > > > > > > >I have installed:
      > > > > > > > > >
      > > > > > > > > >libblas-test
      > > > > > > > > >libblas-dev
      > > > > > > > > >libblas3gf
      > > > > > > > > >
      > > > > > > > > >liblapack3gf
      > > > > > > > > >liblapack-dev
      > > > > > > > > >
      > > > > > > > > >tcl8.5
      > > > > > > > > >tcl8.5-dev
      > > > > > > > > >tk8.5
      > > > > > > > > >tk8.5-dev
      > > > > > > > > >
      > > > > > > > > >openmpi-bin
      > > > > > > > > >openmpi-common
      > > > > > > > > >openmpi-checkpoint
      > > > > > > > > >
      > > > > > > > > >Here are a few examples of the warnings I get:
      > > > > > > > > >
      > > > > > > > > >B0inhom.c: In function `tclZgradLoad':
      > > > > > > > > >B0inhom.c:395:12: warning: ignoring return value of `fgets',
      > > > > > > declared with attribute warn_unused_result [-Wunused-result]
      > > > > > > > > >
      > > > > > > > > >iodata.c: In function `FD_write_rmn':
      > > > > > > > > >iodata.c:988:3: warning: format not a string literal and no
      > > > > > > format arguments [-Wformat-security]
      > > > > > > > > >
      > > > > > > > > >spinsys.c: In function `tclDist2Dip':
      > > > > > > > > >spinsys.c:1096:7: warning: assignment discards `const' qualifier
      > > > > > > from pointer target type [enabled by default]spinsys.c: In function
      > > > > > > `tclGamma':
      > > > > > > > > >spinsys.c:1148:3: warning: passing argument 1 of
      > > > > `ss_findisotope'
      > > > > > > discards `const' qualifier from pointer target type [enabled by
      > > > > default]
      > > > > > > > > >spinsys.c:56:10: note: expected `char *' but argument is of type
      > > > > > > `const char *'
      > > > > > > > > >etc...
      > > > > > > > > >
      > > > > > > > > >and then it ends with a long list of:
      > > > > > > > > >
      > > > > > > > > >B0inhom.o: In function `tclZgradList':
      > > > > > > > > >B0inhom.c:(.text+0xbb): undefined reference to `Tcl_GetInt'
      > > > > > > > > >B0inhom.c:(.text+0xe0): undefined reference to `Tcl_NewListObj'
      > > > > > > > > >B0inhom.c:(.text+0x12a): undefined reference to
      > > > > > > `Tcl_ListObjAppendElement'
      > > > > > > > > >B0inhom.c:(.text+0x15a): undefined reference to
      > > > > `Tcl_NewDoubleObj'
      > > > > > > > > >B0inhom.c:(.text+0x187): undefined reference to
      > > > > `Tcl_SetObjResult'
      > > > > > > > > >
      > > > > > > > > >etc...
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > --
      > > > > > > > > RNDr. ZdenÃ"âEURºk ToÃ...¡ner, Ph.D.
      > > > > > > > > Tel.: +420 221 95 1323
      > > > > > > > > E-mail: zdenek.tosner@
      > > > > > > > >
      > > > > > > > > ServisnÃf­ centrum chemickÃf© sekce, VedoucÃf­
      > > > > > > > > Univerzita Karlova v Praze
      > > > > > > > > PÃ...â"¢Ãf­rodovÃ"âEURºdeckÃf¡ fakulta
      > > > > > > > > Hlavova 8, 128 43 Praha 2
      > > > > > > > > www.natur.cuni.cz
      > > > > > > > >
      > > > > > > > > Head of Service Centre of the Chemical Section
      > > > > > > > > Charles University in Prague
      > > > > > > > > Faculty of Science
      > > > > > > > > Hlavova 8, 128 43 Praha 2
      > > > > > > > > www.natur.cuni.cz/en
      > > > > > > > >
      > > > > > > >
      > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > > >
      > > >
      > >
      > >
      >


    • Gansmuller
      Hello, just one final email to let you know that I gave up... Compilation of simpson 2.0.1pre5 on my machine works fine, so I m going to use that version when
      Message 2 of 17 , May 10, 2012
      View Source
      • 0 Attachment
        Hello,
        just one final email to let you know that I gave up...
        Compilation of simpson 2.0.1pre5 on my machine works fine, so I'm going to use that version when I'll need cluster calculations.
        If at some point somebody does manage to compile simpson3 under ubuntu please let me know.

        Big thank you to those who tried to help.
        Axel.







        --- In simpson-simmol@yahoogroups.com, Julien TREBOSC <simpson.trebosc@...> wrote:
        >
        > Your lib file should be in /usr/lib64/ since you try to build 64bit app ?
        >
        > Try to change to that pathway.
        >
        > Julien
        >
        > Le 26/04/2012 18:21, Gansmuller a écrit :
        > >
        > > Hi Thomas,
        > > thank you for helping out.
        > > My tcl.h file is located in /usr/include/tcl8.5
        > > and the lib files are in /usr/lib
        > > I tried again using these lines
        > >
        > > INCLUDES = -I/usr/include/tcl8.5
        > > LIBRARIES = -L/usr/lib -latlas -ltcl8.5 -lm -llapack -lgslcblas
        > > -lcblas -lblas
        > > BINDIR = /usr/bin
        > > EXTRA_FLAGS = -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE
        > >
        > > but it the problem remains.
        > >
        > > I also tried on another computer with ubuntu 11.10 but the output is
        > > still the same...
        > > (by the way, I'm using gcc 4.6.1)
        > >
        > > --- In simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>, Thomas Vosegaard <tv@>
        > > wrote:
        > > >
        > > > Hi Axel
        > > >
        > > > Where is your tcl.h file located? Try to locate it and add the
        > > following to the compilation:
        > > >
        > > > -I/path/to/tcl -L/path/to/tcl -ltcl
        > > >
        > > > And note that -I points to the directory containing tcl.h, while -L
        > > points to the directory containing libtcl.so (or something like that).
        > > >
        > > > Thomas
        > > >
        > > > On Apr 25, 2012, at 16:22, Gansmuller <axelgans@> wrote:
        > > >
        > > > > I just installed tcl8.6 and tried your extra flags, but
        > > unfortunately it didn't help.
        > > > > Strangely enough, when I leave out the libraries in the Makefile
        > > (leaving the line blank), I get the same error output...
        > > > >
        > > > > PS: I uploaded the Makefile in the files section.
        > > > >
        > > > > --- In simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>, Julien TREBOSC
        > > <simpson.trebosc@> wrote:
        > > > > >
        > > > > > Did you try with tcl8.6 (or default one) and the options
        > > EXTRA_FLAGS =
        > > > > > -DMPI -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE ?
        > > > > >
        > > > > > Julien
        > > > > >
        > > > > > Le 24/04/2012 12:28, Gansmuller a écrit :
        > > > > > >
        > > > > > > Hi Julien,
        > > > > > > I have already installed the 64 bits dev files; and they seem
        > > to be
        > > > > > > where should be. The libraries also seem to be found when I
        > > run the
        > > > > > > test Vadim suggested (gcc -llapack etc...)
        > > > > > > So basically I don't know what's wrong...
        > > > > > > Axel.
        > > > > > >
        > > > > > > PS: the error output can be found in the Files section.
        > > > > > >
        > > > > > > --- In simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, Julien TREBOSC
        > > > > > > <simpson.trebosc@> wrote:
        > > > > > > >
        > > > > > > > Hi Axel,
        > > > > > > >
        > > > > > > > maybe you should check where the dev files have been
        > > installed and if
        > > > > > > > you installed the 64bit package ones (even for the dev one).
        > > Then
        > > > > > > it's a
        > > > > > > > matter of telling gcc and the linker where to find the
        > > shared library :
        > > > > > > >
        > > > > > > > Personnally I manage to compile/run simpson with MPI
        > > (parallelisation)
        > > > > > > > and tcl8.6 with the following options :
        > > > > > > > # Linux MPI + GCC
        > > > > > > > INCLUDES = -I/usr/include/tcl8.6
        > > > > > > > LIBRARIES = -L/usr/lib64/atlas -ltcl8.6 -lm -llapack -lcblas
        > > > > > > > CC = mpicc
        > > > > > > > EXTRA_FLAGS = -DMPI -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE
        > > > > > > >
        > > > > > > > -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE are for using old
        > > tcl style
        > > > > > > > because the API has changed since then.
        > > > > > > >
        > > > > > > > Note that I'm running a Mandriva distrib and not ubuntu.
        > > > > > > >
        > > > > > > > Julien
        > > > > > > >
        > > > > > > > Le 23/04/2012 12:06, Gansmuller a écrit :
        > > > > > > > >
        > > > > > > > > Dear Vadim,
        > > > > > > > > I removed both versions tcl/tk8.5 and tcl/tk8.4 and
        > > reinstalled the
        > > > > > > > > 8.5 version with the corresponding -dev files. The problem
        > > is still
        > > > > > > > > there... even if I always run "make clean" before recompiling.
        > > > > > > > >
        > > > > > > > > --- In simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, VADIM ZORIN
        > > > > > > > > <vadim.zorin@> wrote:
        > > > > > > > > >
        > > > > > > > > > ThoseÃ, suggest it's a problem linking against Tcl:
        > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > >B0inhom.o: In function `tclZgradList':
        > > > > > > > > > > >B0inhom.c:(.text+0xbb): undefined reference to
        > > `Tcl_GetInt'
        > > > > > > > > > > >B0inhom.c:(.text+0xe0): undefined reference to
        > > `Tcl_NewListObj'
        > > > > > > > > > > >B0inhom.c:(.text+0x12a): undefined reference to
        > > > > > > > > `Tcl_ListObjAppendElement'
        > > > > > > > > > > >B0inhom.c:(.text+0x15a): undefined reference to
        > > > > > > `Tcl_NewDoubleObj'
        > > > > > > > > > > >B0inhom.c:(.text+0x187): undefined reference to
        > > > > > > `Tcl_SetObjResult'Ã,
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > Could it be that tcl-dev (containing .h files with
        > > definitions) and
        > > > > > > > > tcl packages (containing the binary library) have
        > > different versions?Ã,
        > > > > > > > > >
        > > > > > > > > > Just another idea: could you also check that you removed all
        > > > > > > > > possible .o files from the source directories before
        > > compilation
        > > > > > > > > (usually 'make clean' should do that but I don't know how
        > > it is for
        > > > > > > > > SIMPSON). If youÃ, accidentallyÃ, have .o files created on
        > > other
        > > > > > > > > platforms (like MacOS/Win/32bit Linux) 'make' may skip
        > > compilation of
        > > > > > > > > the corresponding .c file. The linkage will fail because
        > > > > > > non-native .o
        > > > > > > > > files have a wrong format.
        > > > > > > > > >
        > > > > > > > > > Vadim
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > ________________________________
        > > > > > > > > > From: Gansmuller <axelgans@>
        > > > > > > > > > To: simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > > > > Sent: Friday, 20 April 2012, 15:29
        > > > > > > > > > Subject: [simpson-simmol] Re: Please help... Can't
        > > Install from
        > > > > > > > > sources under ubuntu 11.10
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > Ã,
        > > > > > > > > > Thank you all for your quick reply, unfortunately it still
        > > > > > > doesn't work.
        > > > > > > > > > I already had installed cblas libraries:
        > > > > > > > > >
        > > > > > > > > > gsl-bin
        > > > > > > > > > libgsl0-dev
        > > > > > > > > > libgsl0ldbl
        > > > > > > > > > libgsl0-dbg
        > > > > > > > > >
        > > > > > > > > > I tested whether the libraries were found as Vadim
        > > suggested but
        > > > > > > > > everything was found...
        > > > > > > > > > Any more ideas ?
        > > > > > > > > >
        > > > > > > > > > --- In simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, VADIM ZORIN
        > > <vadim.zorin@>
        > > > > > > > > wrote:
        > > > > > > > > > >
        > > > > > > > > > > As Zdenek mention it should be a problem with one of
        > > the linked
        > > > > > > > > libraries. To check which one is a troublemaker you can
        > > for every
        > > > > > > > > library from the list:
        > > > > > > > > > >
        > > > > > > > > > > LIBRARIES = -lm -llapack -lblas -ltcl8.5 -lgslcblasÃf,Ã,
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > run command: gcc -llapack (and so on).Ãf,Ã, if you get
        > > 'ld: library
        > > > > > > > > not found for -llapack' it means that gcc has not found
        > > the library
        > > > > > > > > (but it don't mean that it's not installed), if you get
        > > something
        > > > > > > like
        > > > > > > > > 'Undefined symbols: "_main", referenced from: ...' it
        > > means that
        > > > > > > > > liblapack has been found.
        > > > > > > > > > >
        > > > > > > > > > > For missing library try to look for a file
        > > > > > > 'lib<libarary_name>.so'
        > > > > > > > > (can have .a extension too) on your system. If file is not
        > > found you
        > > > > > > > > need to install the library from the Ubuntu repository.Ãf,Ã,
        > > > > > > > > > >
        > > > > > > > > > > VadimÃf,Ã,
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > ________________________________
        > > > > > > > > > > From: ZdenÃf"âEURºk ToÃf...Ã,¡ner <tosner@>
        > > > > > > > > > > To: simpson-simmol@yahoogroups.com
        > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
        > > > > > > > > > > Sent: Friday, 20 April 2012, 10:19
        > > > > > > > > > > Subject: Re: [simpson-simmol] Please help... Can't
        > > Install from
        > > > > > > > > sources under ubuntu 11.10
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > Ãf,Ã,
        > > > > > > > > > > As someone says warnings are not errors ;-) I guess
        > > the make
        > > > > > > error
        > > > > > > > > is due to linking. You do not mention you have installed
        > > GSL CBLAS.
        > > > > > > > > Simpson is using CBLAS not BLAS, so some variant of CBLAS is
        > > > > > > necessary
        > > > > > > > > (GSL is one of them).
        > > > > > > > > > >
        > > > > > > > > > > Zdenek
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > 2012/4/20 Gansmuller <axelgans@>
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > >Ãf,Ã,
        > > > > > > > > > > >Dear Simpson users,
        > > > > > > > > > > >I'm using ubuntu 11.1 on a 64bits machine and I want
        > > to install
        > > > > > > > > simpson 3.1 from sources in order to run parallel
        > > calculations (the
        > > > > > > > > precompiled version is running since I removed ATLAS).
        > > > > > > > > > > >After trying several times I still didn't manage to
        > > compile the
        > > > > > > > > program.
        > > > > > > > > > > >When I run the make command I obtain plenty of
        > > warnings (cf end
        > > > > > > > > of this message and attachment) but no error except the
        > > final :
        > > > > > > > > > > >
        > > > > > > > > > > >collect2: ld returned 1 exit status
        > > > > > > > > > > >make: *** [simpson] Error 1
        > > > > > > > > > > >
        > > > > > > > > > > >Please can someone help me, I spent a lot of time
        > > trying but now
        > > > > > > > > I'm stuck...
        > > > > > > > > > > >
        > > > > > > > > > > >Thank's in advance,
        > > > > > > > > > > >Axel.
        > > > > > > > > > > >
        > > > > > > > > > > >PS:here is how I modified the my make file:
        > > > > > > > > > > >
        > > > > > > > > > > ># Linux
        > > > > > > > > > > >INCLUDES = -I/usr/include/tcl8.5 -I/usr/include
        > > > > > > > > > > >LIBRARIES = -lm -llapack -lblas -ltcl8.5 -lgslcblas
        > > > > > > > > > > >BINDIR = /usr/local/bin
        > > > > > > > > > > >
        > > > > > > > > > > >I have installed:
        > > > > > > > > > > >
        > > > > > > > > > > >libblas-test
        > > > > > > > > > > >libblas-dev
        > > > > > > > > > > >libblas3gf
        > > > > > > > > > > >
        > > > > > > > > > > >liblapack3gf
        > > > > > > > > > > >liblapack-dev
        > > > > > > > > > > >
        > > > > > > > > > > >tcl8.5
        > > > > > > > > > > >tcl8.5-dev
        > > > > > > > > > > >tk8.5
        > > > > > > > > > > >tk8.5-dev
        > > > > > > > > > > >
        > > > > > > > > > > >openmpi-bin
        > > > > > > > > > > >openmpi-common
        > > > > > > > > > > >openmpi-checkpoint
        > > > > > > > > > > >
        > > > > > > > > > > >Here are a few examples of the warnings I get:
        > > > > > > > > > > >
        > > > > > > > > > > >B0inhom.c: In function `tclZgradLoad':
        > > > > > > > > > > >B0inhom.c:395:12: warning: ignoring return value of
        > > `fgets',
        > > > > > > > > declared with attribute warn_unused_result [-Wunused-result]
        > > > > > > > > > > >
        > > > > > > > > > > >iodata.c: In function `FD_write_rmn':
        > > > > > > > > > > >iodata.c:988:3: warning: format not a string literal
        > > and no
        > > > > > > > > format arguments [-Wformat-security]
        > > > > > > > > > > >
        > > > > > > > > > > >spinsys.c: In function `tclDist2Dip':
        > > > > > > > > > > >spinsys.c:1096:7: warning: assignment discards
        > > `const' qualifier
        > > > > > > > > from pointer target type [enabled by default]spinsys.c: In
        > > function
        > > > > > > > > `tclGamma':
        > > > > > > > > > > >spinsys.c:1148:3: warning: passing argument 1 of
        > > > > > > `ss_findisotope'
        > > > > > > > > discards `const' qualifier from pointer target type
        > > [enabled by
        > > > > > > default]
        > > > > > > > > > > >spinsys.c:56:10: note: expected `char *' but argument
        > > is of type
        > > > > > > > > `const char *'
        > > > > > > > > > > >etc...
        > > > > > > > > > > >
        > > > > > > > > > > >and then it ends with a long list of:
        > > > > > > > > > > >
        > > > > > > > > > > >B0inhom.o: In function `tclZgradList':
        > > > > > > > > > > >B0inhom.c:(.text+0xbb): undefined reference to
        > > `Tcl_GetInt'
        > > > > > > > > > > >B0inhom.c:(.text+0xe0): undefined reference to
        > > `Tcl_NewListObj'
        > > > > > > > > > > >B0inhom.c:(.text+0x12a): undefined reference to
        > > > > > > > > `Tcl_ListObjAppendElement'
        > > > > > > > > > > >B0inhom.c:(.text+0x15a): undefined reference to
        > > > > > > `Tcl_NewDoubleObj'
        > > > > > > > > > > >B0inhom.c:(.text+0x187): undefined reference to
        > > > > > > `Tcl_SetObjResult'
        > > > > > > > > > > >
        > > > > > > > > > > >etc...
        > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > --
        > > > > > > > > > > RNDr. ZdenÃf"âEURºk ToÃf...Ã,¡ner, Ph.D.
        > > > > > > > > > > Tel.: +420 221 95 1323
        > > > > > > > > > > E-mail: zdenek.tosner@
        > > > > > > > > > >
        > > > > > > > > > > ServisnÃffÃ,­ centrum chemickÃffÃ,© sekce, VedoucÃffÃ,­
        > > > > > > > > > > Univerzita Karlova v Praze
        > > > > > > > > > > PÃf...â"¢ÃffÃ,­rodovÃf"âEURºdeckÃffÃ,¡ fakulta
        > > > > > > > > > > Hlavova 8, 128 43 Praha 2
        > > > > > > > > > > www.natur.cuni.cz
        > > > > > > > > > >
        > > > > > > > > > > Head of Service Centre of the Chemical Section
        > > > > > > > > > > Charles University in Prague
        > > > > > > > > > > Faculty of Science
        > > > > > > > > > > Hlavova 8, 128 43 Praha 2
        > > > > > > > > > > www.natur.cuni.cz/en
        > > > > > > > > > >
        > > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > >
        > > > > > >
        > > > > > >
        > > > > >
        > > > >
        > > > >
        > > >
        > >
        > >
        >
      • janarthanan_k2004
        Hi Axel, Despite properly setting the path to tcl library, I also had the same problem when compiling Simpson3.1. I found that the following lines in the
        Message 3 of 17 , Nov 17, 2012
        View Source
        • 0 Attachment
          Hi Axel,

          Despite properly setting the path to tcl library, I also had the same problem when compiling Simpson3.1. I found that the following lines in the current 'makefile' has to be changed from


          ------------
          simpson: $(OBJ)
          $(CC) $(OBJ)$(LIBRARIES) -o simpson

          to

          simpson: $(OBJ)
          $(CC) $(OBJ) -o simpson $(LIBRARIES)
          -------------

          Then it compiles well.


          Here are some of the modifications i made to Makefile other than the ones i mentioned above, (make sure to add gfortran, pthread and dl libraries)

          -------------
          F77=gfortran
          CC=mpicc
          CXX=g++
          INCLUDES=-I/home/janar/Post_doc/Libraries/Simpson_lib/include

          LIBRARIES = /home/janar/Post_doc/Libraries/Simpson_lib/lib/liblapack.a /home/janar/Post_doc/Libraries/Simpson_lib/lib/libblas.a /home/janar/Post_doc/Libraries/Simpson_lib/lib/libmpi.a /home/janar/Post_doc/Libraries/Simpson_lib/lib/libtcl8.5.a -L/usr/lib/gcc/x86_64-linux-gnu/4.6/ -lm -lgslcblas -lgfortran -lpthread -ldl

          FLAGS= -DMPI -c -O3
          -------------

          Regards,
          Jana.K




          --- In simpson-simmol@yahoogroups.com, "Gansmuller" <axelgans@...> wrote:
          >
          > Hello,
          > just one final email to let you know that I gave up...
          > Compilation of simpson 2.0.1pre5 on my machine works fine, so I'm going to use that version when I'll need cluster calculations.
          > If at some point somebody does manage to compile simpson3 under ubuntu please let me know.
          >
          > Big thank you to those who tried to help.
          > Axel.
          >
          >
          >
          >
          >
          >
          >
          > --- In simpson-simmol@yahoogroups.com, Julien TREBOSC <simpson.trebosc@> wrote:
          > >
          > > Your lib file should be in /usr/lib64/ since you try to build 64bit app ?
          > >
          > > Try to change to that pathway.
          > >
          > > Julien
          > >
          > > Le 26/04/2012 18:21, Gansmuller a écrit :
          > > >
          > > > Hi Thomas,
          > > > thank you for helping out.
          > > > My tcl.h file is located in /usr/include/tcl8.5
          > > > and the lib files are in /usr/lib
          > > > I tried again using these lines
          > > >
          > > > INCLUDES = -I/usr/include/tcl8.5
          > > > LIBRARIES = -L/usr/lib -latlas -ltcl8.5 -lm -llapack -lgslcblas
          > > > -lcblas -lblas
          > > > BINDIR = /usr/bin
          > > > EXTRA_FLAGS = -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE
          > > >
          > > > but it the problem remains.
          > > >
          > > > I also tried on another computer with ubuntu 11.10 but the output is
          > > > still the same...
          > > > (by the way, I'm using gcc 4.6.1)
          > > >
          > > > --- In simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>, Thomas Vosegaard <tv@>
          > > > wrote:
          > > > >
          > > > > Hi Axel
          > > > >
          > > > > Where is your tcl.h file located? Try to locate it and add the
          > > > following to the compilation:
          > > > >
          > > > > -I/path/to/tcl -L/path/to/tcl -ltcl
          > > > >
          > > > > And note that -I points to the directory containing tcl.h, while -L
          > > > points to the directory containing libtcl.so (or something like that).
          > > > >
          > > > > Thomas
          > > > >
          > > > > On Apr 25, 2012, at 16:22, Gansmuller <axelgans@> wrote:
          > > > >
          > > > > > I just installed tcl8.6 and tried your extra flags, but
          > > > unfortunately it didn't help.
          > > > > > Strangely enough, when I leave out the libraries in the Makefile
          > > > (leaving the line blank), I get the same error output...
          > > > > >
          > > > > > PS: I uploaded the Makefile in the files section.
          > > > > >
          > > > > > --- In simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>, Julien TREBOSC
          > > > <simpson.trebosc@> wrote:
          > > > > > >
          > > > > > > Did you try with tcl8.6 (or default one) and the options
          > > > EXTRA_FLAGS =
          > > > > > > -DMPI -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE ?
          > > > > > >
          > > > > > > Julien
          > > > > > >
          > > > > > > Le 24/04/2012 12:28, Gansmuller a écrit :
          > > > > > > >
          > > > > > > > Hi Julien,
          > > > > > > > I have already installed the 64 bits dev files; and they seem
          > > > to be
          > > > > > > > where should be. The libraries also seem to be found when I
          > > > run the
          > > > > > > > test Vadim suggested (gcc -llapack etc...)
          > > > > > > > So basically I don't know what's wrong...
          > > > > > > > Axel.
          > > > > > > >
          > > > > > > > PS: the error output can be found in the Files section.
          > > > > > > >
          > > > > > > > --- In simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, Julien TREBOSC
          > > > > > > > <simpson.trebosc@> wrote:
          > > > > > > > >
          > > > > > > > > Hi Axel,
          > > > > > > > >
          > > > > > > > > maybe you should check where the dev files have been
          > > > installed and if
          > > > > > > > > you installed the 64bit package ones (even for the dev one).
          > > > Then
          > > > > > > > it's a
          > > > > > > > > matter of telling gcc and the linker where to find the
          > > > shared library :
          > > > > > > > >
          > > > > > > > > Personnally I manage to compile/run simpson with MPI
          > > > (parallelisation)
          > > > > > > > > and tcl8.6 with the following options :
          > > > > > > > > # Linux MPI + GCC
          > > > > > > > > INCLUDES = -I/usr/include/tcl8.6
          > > > > > > > > LIBRARIES = -L/usr/lib64/atlas -ltcl8.6 -lm -llapack -lcblas
          > > > > > > > > CC = mpicc
          > > > > > > > > EXTRA_FLAGS = -DMPI -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE
          > > > > > > > >
          > > > > > > > > -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE are for using old
          > > > tcl style
          > > > > > > > > because the API has changed since then.
          > > > > > > > >
          > > > > > > > > Note that I'm running a Mandriva distrib and not ubuntu.
          > > > > > > > >
          > > > > > > > > Julien
          > > > > > > > >
          > > > > > > > > Le 23/04/2012 12:06, Gansmuller a écrit :
          > > > > > > > > >
          > > > > > > > > > Dear Vadim,
          > > > > > > > > > I removed both versions tcl/tk8.5 and tcl/tk8.4 and
          > > > reinstalled the
          > > > > > > > > > 8.5 version with the corresponding -dev files. The problem
          > > > is still
          > > > > > > > > > there... even if I always run "make clean" before recompiling.
          > > > > > > > > >
          > > > > > > > > > --- In simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, VADIM ZORIN
          > > > > > > > > > <vadim.zorin@> wrote:
          > > > > > > > > > >
          > > > > > > > > > > ThoseÃ, suggest it's a problem linking against Tcl:
          > > > > > > > > > >
          > > > > > > > > > > > >
          > > > > > > > > > > > >B0inhom.o: In function `tclZgradList':
          > > > > > > > > > > > >B0inhom.c:(.text+0xbb): undefined reference to
          > > > `Tcl_GetInt'
          > > > > > > > > > > > >B0inhom.c:(.text+0xe0): undefined reference to
          > > > `Tcl_NewListObj'
          > > > > > > > > > > > >B0inhom.c:(.text+0x12a): undefined reference to
          > > > > > > > > > `Tcl_ListObjAppendElement'
          > > > > > > > > > > > >B0inhom.c:(.text+0x15a): undefined reference to
          > > > > > > > `Tcl_NewDoubleObj'
          > > > > > > > > > > > >B0inhom.c:(.text+0x187): undefined reference to
          > > > > > > > `Tcl_SetObjResult'Ã,
          > > > > > > > > > >
          > > > > > > > > > >
          > > > > > > > > > > Could it be that tcl-dev (containing .h files with
          > > > definitions) and
          > > > > > > > > > tcl packages (containing the binary library) have
          > > > different versions?Ã,
          > > > > > > > > > >
          > > > > > > > > > > Just another idea: could you also check that you removed all
          > > > > > > > > > possible .o files from the source directories before
          > > > compilation
          > > > > > > > > > (usually 'make clean' should do that but I don't know how
          > > > it is for
          > > > > > > > > > SIMPSON). If youÃ, accidentallyÃ, have .o files created on
          > > > other
          > > > > > > > > > platforms (like MacOS/Win/32bit Linux) 'make' may skip
          > > > compilation of
          > > > > > > > > > the corresponding .c file. The linkage will fail because
          > > > > > > > non-native .o
          > > > > > > > > > files have a wrong format.
          > > > > > > > > > >
          > > > > > > > > > > Vadim
          > > > > > > > > > >
          > > > > > > > > > >
          > > > > > > > > > > ________________________________
          > > > > > > > > > > From: Gansmuller <axelgans@>
          > > > > > > > > > > To: simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > > > > Sent: Friday, 20 April 2012, 15:29
          > > > > > > > > > > Subject: [simpson-simmol] Re: Please help... Can't
          > > > Install from
          > > > > > > > > > sources under ubuntu 11.10
          > > > > > > > > > >
          > > > > > > > > > >
          > > > > > > > > > > Ã,
          > > > > > > > > > > Thank you all for your quick reply, unfortunately it still
          > > > > > > > doesn't work.
          > > > > > > > > > > I already had installed cblas libraries:
          > > > > > > > > > >
          > > > > > > > > > > gsl-bin
          > > > > > > > > > > libgsl0-dev
          > > > > > > > > > > libgsl0ldbl
          > > > > > > > > > > libgsl0-dbg
          > > > > > > > > > >
          > > > > > > > > > > I tested whether the libraries were found as Vadim
          > > > suggested but
          > > > > > > > > > everything was found...
          > > > > > > > > > > Any more ideas ?
          > > > > > > > > > >
          > > > > > > > > > > --- In simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>, VADIM ZORIN
          > > > <vadim.zorin@>
          > > > > > > > > > wrote:
          > > > > > > > > > > >
          > > > > > > > > > > > As Zdenek mention it should be a problem with one of
          > > > the linked
          > > > > > > > > > libraries. To check which one is a troublemaker you can
          > > > for every
          > > > > > > > > > library from the list:
          > > > > > > > > > > >
          > > > > > > > > > > > LIBRARIES = -lm -llapack -lblas -ltcl8.5 -lgslcblasÃf,Ã,
          > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > > run command: gcc -llapack (and so on).Ãf,Ã, if you get
          > > > 'ld: library
          > > > > > > > > > not found for -llapack' it means that gcc has not found
          > > > the library
          > > > > > > > > > (but it don't mean that it's not installed), if you get
          > > > something
          > > > > > > > like
          > > > > > > > > > 'Undefined symbols: "_main", referenced from: ...' it
          > > > means that
          > > > > > > > > > liblapack has been found.
          > > > > > > > > > > >
          > > > > > > > > > > > For missing library try to look for a file
          > > > > > > > 'lib<libarary_name>.so'
          > > > > > > > > > (can have .a extension too) on your system. If file is not
          > > > found you
          > > > > > > > > > need to install the library from the Ubuntu repository.Ãf,Ã,
          > > > > > > > > > > >
          > > > > > > > > > > > VadimÃf,Ã,
          > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > > ________________________________
          > > > > > > > > > > > From: ZdenÃf"âEURºk ToÃf...Ã,¡ner <tosner@>
          > > > > > > > > > > > To: simpson-simmol@yahoogroups.com
          > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > > > <mailto:simpson-simmol%40yahoogroups.com>
          > > > > > > > > > > > Sent: Friday, 20 April 2012, 10:19
          > > > > > > > > > > > Subject: Re: [simpson-simmol] Please help... Can't
          > > > Install from
          > > > > > > > > > sources under ubuntu 11.10
          > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > > Ãf,Ã,
          > > > > > > > > > > > As someone says warnings are not errors ;-) I guess
          > > > the make
          > > > > > > > error
          > > > > > > > > > is due to linking. You do not mention you have installed
          > > > GSL CBLAS.
          > > > > > > > > > Simpson is using CBLAS not BLAS, so some variant of CBLAS is
          > > > > > > > necessary
          > > > > > > > > > (GSL is one of them).
          > > > > > > > > > > >
          > > > > > > > > > > > Zdenek
          > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > > 2012/4/20 Gansmuller <axelgans@>
          > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > > >Ãf,Ã,
          > > > > > > > > > > > >Dear Simpson users,
          > > > > > > > > > > > >I'm using ubuntu 11.1 on a 64bits machine and I want
          > > > to install
          > > > > > > > > > simpson 3.1 from sources in order to run parallel
          > > > calculations (the
          > > > > > > > > > precompiled version is running since I removed ATLAS).
          > > > > > > > > > > > >After trying several times I still didn't manage to
          > > > compile the
          > > > > > > > > > program.
          > > > > > > > > > > > >When I run the make command I obtain plenty of
          > > > warnings (cf end
          > > > > > > > > > of this message and attachment) but no error except the
          > > > final :
          > > > > > > > > > > > >
          > > > > > > > > > > > >collect2: ld returned 1 exit status
          > > > > > > > > > > > >make: *** [simpson] Error 1
          > > > > > > > > > > > >
          > > > > > > > > > > > >Please can someone help me, I spent a lot of time
          > > > trying but now
          > > > > > > > > > I'm stuck...
          > > > > > > > > > > > >
          > > > > > > > > > > > >Thank's in advance,
          > > > > > > > > > > > >Axel.
          > > > > > > > > > > > >
          > > > > > > > > > > > >PS:here is how I modified the my make file:
          > > > > > > > > > > > >
          > > > > > > > > > > > ># Linux
          > > > > > > > > > > > >INCLUDES = -I/usr/include/tcl8.5 -I/usr/include
          > > > > > > > > > > > >LIBRARIES = -lm -llapack -lblas -ltcl8.5 -lgslcblas
          > > > > > > > > > > > >BINDIR = /usr/local/bin
          > > > > > > > > > > > >
          > > > > > > > > > > > >I have installed:
          > > > > > > > > > > > >
          > > > > > > > > > > > >libblas-test
          > > > > > > > > > > > >libblas-dev
          > > > > > > > > > > > >libblas3gf
          > > > > > > > > > > > >
          > > > > > > > > > > > >liblapack3gf
          > > > > > > > > > > > >liblapack-dev
          > > > > > > > > > > > >
          > > > > > > > > > > > >tcl8.5
          > > > > > > > > > > > >tcl8.5-dev
          > > > > > > > > > > > >tk8.5
          > > > > > > > > > > > >tk8.5-dev
          > > > > > > > > > > > >
          > > > > > > > > > > > >openmpi-bin
          > > > > > > > > > > > >openmpi-common
          > > > > > > > > > > > >openmpi-checkpoint
          > > > > > > > > > > > >
          > > > > > > > > > > > >Here are a few examples of the warnings I get:
          > > > > > > > > > > > >
          > > > > > > > > > > > >B0inhom.c: In function `tclZgradLoad':
          > > > > > > > > > > > >B0inhom.c:395:12: warning: ignoring return value of
          > > > `fgets',
          > > > > > > > > > declared with attribute warn_unused_result [-Wunused-result]
          > > > > > > > > > > > >
          > > > > > > > > > > > >iodata.c: In function `FD_write_rmn':
          > > > > > > > > > > > >iodata.c:988:3: warning: format not a string literal
          > > > and no
          > > > > > > > > > format arguments [-Wformat-security]
          > > > > > > > > > > > >
          > > > > > > > > > > > >spinsys.c: In function `tclDist2Dip':
          > > > > > > > > > > > >spinsys.c:1096:7: warning: assignment discards
          > > > `const' qualifier
          > > > > > > > > > from pointer target type [enabled by default]spinsys.c: In
          > > > function
          > > > > > > > > > `tclGamma':
          > > > > > > > > > > > >spinsys.c:1148:3: warning: passing argument 1 of
          > > > > > > > `ss_findisotope'
          > > > > > > > > > discards `const' qualifier from pointer target type
          > > > [enabled by
          > > > > > > > default]
          > > > > > > > > > > > >spinsys.c:56:10: note: expected `char *' but argument
          > > > is of type
          > > > > > > > > > `const char *'
          > > > > > > > > > > > >etc...
          > > > > > > > > > > > >
          > > > > > > > > > > > >and then it ends with a long list of:
          > > > > > > > > > > > >
          > > > > > > > > > > > >B0inhom.o: In function `tclZgradList':
          > > > > > > > > > > > >B0inhom.c:(.text+0xbb): undefined reference to
          > > > `Tcl_GetInt'
          > > > > > > > > > > > >B0inhom.c:(.text+0xe0): undefined reference to
          > > > `Tcl_NewListObj'
          > > > > > > > > > > > >B0inhom.c:(.text+0x12a): undefined reference to
          > > > > > > > > > `Tcl_ListObjAppendElement'
          > > > > > > > > > > > >B0inhom.c:(.text+0x15a): undefined reference to
          > > > > > > > `Tcl_NewDoubleObj'
          > > > > > > > > > > > >B0inhom.c:(.text+0x187): undefined reference to
          > > > > > > > `Tcl_SetObjResult'
          > > > > > > > > > > > >
          > > > > > > > > > > > >etc...
          > > > > > > > > > > > >
          > > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > >
          > > > > > > > > > > > --
          > > > > > > > > > > > RNDr. ZdenÃf"âEURºk ToÃf...Ã,¡ner, Ph.D.
          > > > > > > > > > > > Tel.: +420 221 95 1323
          > > > > > > > > > > > E-mail: zdenek.tosner@
          > > > > > > > > > > >
          > > > > > > > > > > > ServisnÃffÃ,­ centrum chemickÃffÃ,© sekce, VedoucÃffÃ,­
          > > > > > > > > > > > Univerzita Karlova v Praze
          > > > > > > > > > > > PÃf...â"¢ÃffÃ,­rodovÃf"âEURºdeckÃffÃ,¡ fakulta
          > > > > > > > > > > > Hlavova 8, 128 43 Praha 2
          > > > > > > > > > > > www.natur.cuni.cz
          > > > > > > > > > > >
          > > > > > > > > > > > Head of Service Centre of the Chemical Section
          > > > > > > > > > > > Charles University in Prague
          > > > > > > > > > > > Faculty of Science
          > > > > > > > > > > > Hlavova 8, 128 43 Praha 2
          > > > > > > > > > > > www.natur.cuni.cz/en
          > > > > > > > > > > >
          > > > > > > > > > >
          > > > > > > > > >
          > > > > > > > > >
          > > > > > > > >
          > > > > > > >
          > > > > > > >
          > > > > > >
          > > > > >
          > > > > >
          > > > >
          > > >
          > > >
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.