Loading ...
Sorry, an error occurred while loading the content.

Re: Sierra final problems

Expand Messages
  • Georges
    Hi Colin, I had a similar problem with my K2. The problem was with my switching mode power supply. At power on it produced, sometimes, a transient that
    Message 1 of 2 , Sep 13, 2012
    View Source
    • 0 Attachment
      Hi Colin,

      I had a similar problem with my K2.
      The problem was with my switching mode power supply.
      At power on it produced, sometimes, a transient that destroyed the PA.
      If you have one, try to watch with a scope the supply voltage at power on.
      If not, try to use a linear power supply to see if this problem is still there.

      You could also have parasitics.
      You may try to contact QRP Bob, he is very helpful.
      Good luck to fix this.

      Georges



      --- In sierra_wilderness_radio@yahoogroups.com, "k4cml" <cfaison@...> wrote:
      >
      > Ge All;
      >
      > I have a problem which is giving me a pain. My Sierra is blowing finals. After I blew the original somehow, I bought 2 from Futurlec
      > to replace. This past weekend I worked the SKCC WES as QRP; the rig worked FB during contest, but the next day when I turned it on I had no output from final. The rx works fine as does the driver, but no output when I replaced final again. This makes several times the final has gone out for no apparent reason. SWR is very low on antenna, so can't blame that either. Willing to take any suggestions.
      >
      >
      > Thanks for any possible suggestions
      > Colin K4CML
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.