Loading ...
Sorry, an error occurred while loading the content.

Self4.1.4 on Solaris 2.6: relocation error

Expand Messages
  • Muna Asseh
    Hy! Using Solaris 2.6 (Sparc), starting the Self binary causes the following error: ld.so.1: ./Self: fatal: relocation error: file ./Self: symbol _ld_libc:
    Message 1 of 3 , Mar 2 7:06 PM
    • 0 Attachment
      Hy!
      Using Solaris 2.6 (Sparc), starting the Self binary causes the
      following error:

      ld.so.1: ./Self: fatal: relocation error: file ./Self: symbol
      _ld_libc: referenced symbol no found
      Killed

      As I understood from some former postings, Self does run on 2.6, so I
      did something wrong, didn't I?
      Does anybody know, what it could be?

      Thanks for help,
      Rainer
    • Jecel Assumpcao Jr
      ... No, I get exactly the same error in 4.1.4, but Self 4.1.2 runs just fine in Solaris 2.6. I was also able to run the 4.1.4 snapshots with the 4.1.2 virtual
      Message 2 of 3 , Mar 3 7:12 AM
      • 0 Attachment
        Rainer wrote:
        > As I understood from some former postings, Self does run on 2.6, so I
        > did something wrong, didn't I?

        No, I get exactly the same error in 4.1.4, but Self 4.1.2 runs just
        fine in Solaris 2.6. I was also able to run the 4.1.4 snapshots with
        the 4.1.2 virtual machine.

        Perhaps they no longer have any 2.6 machines at Sun? I could try to
        compile the virtual machine on my Ultra and see what happens, but I
        won't have time in the next two weeks.

        -- Jecel
      • Muna Asseh
        Hy! ... Is the release 4.1.4 expected to run on Solaris 7? Building the vm on my box would - of course - also be an option; is there anything more needed than
        Message 3 of 3 , Mar 3 3:46 PM
        • 0 Attachment
          Hy!


          Jecel Assumpcao Jr wrote:

          > Rainer wrote:
          > > As I understood from some former postings, Self does run on 2.6, so I
          > > did something wrong, didn't I?
          >
          > No, I get exactly the same error in 4.1.4, but Self 4.1.2 runs just
          > fine in Solaris 2.6. I was also able to run the 4.1.4 snapshots with
          > the 4.1.2 virtual machine.
          >
          > Perhaps they no longer have any 2.6 machines at Sun? I could try to
          > compile the virtual machine on my Ultra and see what happens, but I
          > won't have time in the next two weeks.
          >
          > -- Jecel
          >
          >
          >
          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

          Is the release 4.1.4 expected to run on Solaris 7?
          Building the vm on my box would - of course - also be an option; is there
          anything more needed than
          (f)lex/yacc/(g)cc?

          Bye,
          Rainer.
        Your message has been successfully submitted and would be delivered to recipients shortly.