Loading ...
Sorry, an error occurred while loading the content.

14987Re: [sdr-radio-com] Re: version 1.5 crashing when tx mute is selected and I hit the cw key to transmit.

Expand Messages
  • Stu C
    May 3, 2013
    • 0 Attachment
      OK with windows update It's less of total time sink so here's what I'd try.
      We have assumed RF is not to blame but the problem seems quite analogue in that it has changed over time.
      Test could include,
      What frequencies are you on when it happens? is it the same at band edges?
      Does it happen into a dummy load?
      Have you tried changing the earthing arrangement, lead routing or just distorting the usb A type plug just enough that they provide greater friction on connection?
      Disk defrag after thorough checkdisk.
      For an exercise assume the 5V USB supply is marginal and look for proof.

      As RF is a major issue with Computers, electrolytic capacitors dry out over time and "key down" could induce some interesting spikes I think testing with a second PC or a laptop would be a good bet. At one stage you mentioned it running for quite a while and then failing, to me that is more likley heat or frequency than something that has happened with the software unless there is some memory leak or conflicting software (run task manager and watch what happens over time).

      When reseating RAM etc pinch up the motherboard mounting screws, oxidisation can affect those and that can affect stability, it also makes the symptoms sensitive to heat and vibration.

      Regards
      Stu






      On 03/05/2013 23:56, Robert Holsti wrote:
      Well, I took the leap and updated all windows files and it crashed again.
      Had Avast turned off, also did a repair of c++ again to no avail.
      next step I guess is to swap out the memory, reseat cable connectors.
      If that does not fix it, then I have a new identical PC that I will have to install
      all of the sdr software and see if that will work.
       
      The C== redistributal is 2010 version I might update it to version 2012
       
      Robert KH2BR
       

      To: sdr-radio-com@yahoogroups.com
      From: rholsti@...
      Date: Thu, 2 May 2013 17:27:24 -0700
      Subject: RE: [sdr-radio-com] Re: version 1.5 crashing when tx mute is selected and I hit the cw key to transmit.

       
      Its crashing again. I had a good evening with it. power up and down severasl times and worked like a champ. This morning SDR Radio v1.5 started crashing again.
      Any com port selected does the same thing. Ic-7600 and FT-950 rigs do the same thing.
      I ran C++ again in repair, did not fix it. removed and replaced sdr v2 and 1.5 still did not fix.
      went to msconfig and shut down a lot of stuff, that still did not fix it.
      I just dont understand it. Is it the computer since it was working? or is the software getting fouled some how??? Is there a way for me to identify the problem in the error report?
      I still have to do again--->>
      delete sdr-radio in the registry
      delete all simon folder files and user config files.
      I even went as far as sucking out all the dust from the computer.
      again the problem is in version 1.5
      sdr radio not started
      start external radio with tracking on and mute on tx on.
      hit the cw key to transmit..  then CRASH !!!
      Robert KH2BR

       

      To: sdr-radio-com@yahoogroups.com
      From: stu@...
      Date: Thu, 2 May 2013 18:44:03 +0100
      Subject: Re: [sdr-radio-com] Re: version 1.5 crashing when tx mute is selected and I hit the cw key to transmit.

       
      Excellent and that does tie up with other reports of that error type with various software.
      Sorry I didn't come back to you I saw lots of maybe's but few confirmed fixes.

      I suppose if the C++ is corrupt SDR-Radio does not look for problems with it just checks C++ is (reported) installed by the OS.

      Here is some text I copied from a forum that seemed to be similar, I meant to pursue outside of work hours - other software, can't even remember what.

      ====
      SuperPikacha 1 year ago
      Reinstall Visual C++ and download update for Visual? C++ 2010 (KB2467173)
      It works for me (Windows 7 - Home Premium - 64 Bit).
      ====

      You may find you have a patch for Visual C++ missing now.

      On the windows updates thing, I'd do the updates and then wind back the drivers, leaving any windows without patches because of drivers is just asking for trouble (and less assistance from those who have been bitten before).
      I've seen this as a contentious issue on other groups but I tend to avoid OS's in "known states of unknown" as Rumsfeld said, there is enough time to loose checking patched PC's let alone those with various broken bits left broken.

      I'm glad you sorted it and posted the fix, one slightly less wierd bit of PC land.

      Regards
      Stu

      On 02/05/2013 00:13, Robert Holsti wrote:
      I think I may have fixed the problem of crashing when mute on tx is selected and then taping the cw key.
      I downloaded and installed version 2 and I also noticed that another program had been downloaded, but dont know where that came from.
       2010 C++ redistributable. I ran it and selected repair. I ran version 2, closed it, then ran version 1.5
      My malfunction was cured No more crashing so far. Two days wasted, I hate computers.
      I hope this helps someone.
      Robert KH2BR

      To: sdr-radio-com@yahoogroups.com
      From: rholsti@...
      Date: Wed, 1 May 2013 14:41:17 -0700
      Subject: RE: [sdr-radio-com] Re: version 1.5 crashing when tx mute is selected and I hit the cw key to transmit.

       
      Oh, I wanted to add one more thing, I do not have windows update turned on because it kept messing up my
      questionable prolific drivers. It has not been turned on since january.
       

      To: sdr-radio-com@yahoogroups.com
      From: rholsti@...
      Date: Wed, 1 May 2013 14:36:05 -0700
      Subject: RE: [sdr-radio-com] Re: version 1.5 crashing when tx mute is selected and I hit the cw key to transmit.

       
      Hi Stu

      It was working, so dont know what went wrong.
      there have not been system changes that I remember.
      Default install Yes
      tried compatability mode as xp yes
      run as administrator yes.
       
      All registry entries deleted , program re-installed

      Same malfuction after all of this work.
      tried the IC-7600, it worked well for a few minutes untill I restarted the program.
      It started doing the same malfunction.
      The software is V1.5
      Robert KH2BR

       

      To:sdr-radio-com@yahoogroups.com
      From: stu@...
      Date: Wed, 1 May 2013 20:14:15 +0100
      Subject: Re: [sdr-radio-com] Re: version 1.5 crashing when tx mute is selected and I hit the cw key to transmit.

       
      Hi Robert,

      I'm not feeling exactly inspired but here are some questions;
      Do you accept default locations during install?
      Have you tried running it in compatibility mode (something like XP SP3)?
      Have you tried running the program as an administrator?

      My thoughts are that it tries to access something, location or control
      that Windows 7 UAC does not permit.

      If your V2 beta is reporting out of date that is fixed by getting the
      current one but obviously V2 does not have external radio control
      implemented yet.
      http://v2.sdr-radio.com/Download.aspx

      Regards
      Stu

      On 01/05/2013 18:11, kh2br wrote:
      > the specific error I am getting is:
      >
      > SDRConsole.exe caused ACCESS_VIOLATION in module "C:\Program Files (x86)\SDR-RADIO.com\SDRConsole.exe" at 0023:00428540
      >
      > I removed version 1.5 and version 2
      > I found a old beta version from year 2011
      > I installed that version and enabled only the external radio control.
      > I did not start the sdr radio.
      > on the external radio control I enabled mute on TX
      > Result= no crash... worked just fine. could tx with out a crash.
      >
      > that beta will not play the sdr radio because the license is expired.
      > radio control works good.
      >
      > installed v1.5 beta 1068 and when I enable mute on tx, when I key the cw key, Result = Crash with the following error message.
      >
      > SDRConsole.exe caused ACCESS_VIOLATION in module "C:\Program Files (x86)\SDR-RADIO.com\SDRConsole.exe" at 0023:00428540
      >
      > I removed all of sdr-radio files and also those in
      > C:\Users\Simon\AppData\Roaming\SDR-RADIO.com
      >
      > Same problem all over again. This is a very stubborn problem and
      > I think I need some help, I dont know what else to do.
      >
      > Robert KH2BR
      >
      > --- In sdr-radio-com@yahoogroups.com, "kh2br" <rholsti@...> wrote:
      >> That did not last long, the problem is back again. This time I saw a error message and it says..
      >> " windows mfc application is not working"
      >> the computer is windows 7
      >>
      >> Robert KH2BR
      >>
      >> --- In sdr-radio-com@yahoogroups.com, "kh2br" <rholsti@> wrote:
      >>> I FIXED IT !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      >>> :) :) :) :)
      >>>
      >>> --- In sdr-radio-com@yahoogroups.com, "kh2br" <rholsti@> wrote:
      >>>> My joy has run out. I dont know what I did to mess my sdr software up but tried to solve my problem and ran out of ideas.
      >>>> The main rig is a FT-950 and sdr radio is a fifi sdr.
      >>>> main rig is connected to com-1
      >>>> external Radio frequency control works fine.
      >>>> when tx mute is not selected and I transmit, all is fine.
      >>>> when TX Mute "IS" selected and I transmit, I get a crash.
      >>>> Restored computer to a earlier date.. no fix.
      >>>> removed, and replaced sdr-radio program, no fix.
      >>>> com port, radio and sdr-radio program settings match.
      >>>> Put radio on a dummy load, same problem.
      >>>> removed other stuff connected to the computer, still no fix.
      >>>> When it crashes, I get a please wait box.
      >>>> I turned the power down to 5 watts, that did not fix it so rf is not getting in.
      >>>> Are there any hidden files that I need to remove?
      >>>> Any and all help apprecieated.
      >>>>
      >>>> Robert KH2BR
      >>>>
      >
      >
      >
      > ------------------------------------
      >
      > - - -
      > DX Cluster: http://dxcluster.ham-radio.ch/Yahoo! Groups Links
      >
      >
      >











    • Show all 20 messages in this topic