Loading ...
Sorry, an error occurred while loading the content.

Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008

Expand Messages
  • Lindsay Blanton
    Jay, I just checked directly from the CD-ROM using a SOAP navigation utility that shows all the requests working perfectly. Can you provide specific county
    Message 1 of 15 , Oct 1, 2008
    View Source
    • 0 Attachment
      Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008 Jay,

      I just checked directly from the CD-ROM using a SOAP navigation utility that shows all the requests working perfectly.  Can you provide specific county ID’s that I can look at to maybe narrow down your issue?  Have you tried different county IDs etc?

      Is it possible you have cached some parts of the WSDL between switching?

      You mentioned below getCountyInfo “errors out”  - what error are you receiving?  
      --
      Lindsay C. Blanton III
      President / Owner
      RadioReference.com LLC
      http://www.radioreference.com



      From: Jay <crazycalifornian@...>
      Reply-To: <rr_web_service@yahoogroups.com>
      Date: Tue, 30 Sep 2008 20:58:38 -0700
      To: <rr_web_service@yahoogroups.com>
      Subject: Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008

       
       

      Ok, I did some further testing...

      With the same application I can access the database on RR.com or from the CD,  each database location uses a separate wsdl file saved locally (I verified that the saved file was downloaded from the correct database's location).

      The ZipCode Info, Country List, State List, County List, State Agencies and State TRS Systems work fine in Both Database locations...

      From the CD (using a verified ctid from the above, used exactly the same way from RR.com),  getCountyInfo errors out, getCountyFreqsByTag retrieves the getCountyFreqsByTagResponse with a "nil" envelope.

      From the CD (using the same sid as RR.com's database), getTrsSites works, getTrsDetails errors out and getTrsTalkgroupCats works...

      From the CD (using a verified aid from the RR.com's database),  getAgencyInfo works...

      I can switch back and forth between the two databases with the same results (All on RR.com works and some on the CD Don't,  each reading the appropriate wsdl file and accessing the correct EndPoint)...

      Why only a few don't work from the CD has got me baffled...

      Jay

      ----- Original Message -----
       
      From: Lindsay Blanton <mailto:lindsay@...>  
       
       
      A  little further on this – the CD-ROM is almost considered gold, and the code is  nearly complete for gold status.

      Please  indentify any issues you  are seeing ASAP so I can roll into the codebase.  

      I am expecting  to release to manufacturing Oct 3rh.

      Lindsay
      --
      Lindsay C.  Blanton III
      President / Owner
      RadioReference.com LLC
      http://www.radioreference.com


       

      From: Lindsay Blanton

      It should be working fine.  I have  another user on this list that has integrated the Web service on the CD-ROM  successfully into his application.  The only reported problem was a large  load time for all talkgroups for the Ohio Marcs and State of Michigan  Systems.
      --
      Lindsay C. Blanton III
      President /  Owner
      RadioReference.com LLC
      http://www.radioreference.com


       

      From: Jay
      Does the Beta CD include info for Counties in all  states?
      With my test app,  I can retreive the State Agencies and State  TRS systems,
      but when it comes to retreiving any County Info,  it  comes up blank...

      Is it just me or is the Beta CD not finished yet in  those areas?

      Thanks,
      Jay

          
    • Jay
      Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008Hi Lindsay, Yep, I have tried several Counties; California: - San Diego - Butte - Sacremento Colorado: -
      Message 2 of 15 , Oct 1, 2008
      View Source
      • 0 Attachment
        Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008
        Hi Lindsay,
         
        Yep, I have tried several Counties;
        California:
          - San Diego
          - Butte
          - Sacremento
        Colorado:
          - Bolder
        Texas:
          -Dallas
          -Houston
        Delaware:
          -Dover
         
        I don't beleive that the local wsdl file is being cached.  I have deleted those files several times.  When I log into the server, a new wsdl file is being downloaded from the appropriate server.  (I can verify this due to the database on the CD doesn't contain the getUserInfo function).
         
        Since I am still supporting Windows 95 in my apps,  I have to use PocketSoap since MS SOAP doesn't work on this OS.
        The Error I am receiving is soon after the "getCountyInfo" request is sent to the Soap Server.  It returns with a "invalid gzip crc value" error from any county...
         
        I'm redownloading rr1.iso.zip now, so after it's finished, I'll try again...
         
        Thanks,
        Jay
         
        ----- Original Message -----
         
        Jay,

        I just checked directly from the CD-ROM using a SOAP navigation utility that shows all the requests working perfectly.  Can you provide specific county ID’s that I can look at to maybe narrow down your issue?  Have you tried different county IDs etc?

        Is it possible you have cached some parts of the WSDL between switching?

        You mentioned below getCountyInfo “errors out”  - what error are you receiving?  
        --
        Lindsay C. Blanton III
        President / Owner
        RadioReference.com LLC
        http://www.radioreference.com
      • Lindsay Blanton
        Hmm.. Thanks Jay... That might shed some light on the problem. Let me have a peek into the gzip issue. -- Lindsay C. Blanton III President / Owner
        Message 3 of 15 , Oct 1, 2008
        View Source
        • 0 Attachment
          Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008 Hmm.. Thanks Jay... That might shed some light on the problem.  Let me have a peek into the gzip issue.
          --
          Lindsay C. Blanton III
          President / Owner
          RadioReference.com LLC
          http://www.radioreference.com




          From: Jay <crazycalifornian@...>
          Reply-To: <rr_web_service@yahoogroups.com>
          Date: Wed, 1 Oct 2008 17:13:20 -0700
          To: <rr_web_service@yahoogroups.com>
          Subject: Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008

           
           

          Hi Lindsay,

          Yep, I have tried several Counties;
          California:
            - San Diego
            - Butte
            - Sacremento
          Colorado:
            - Bolder
          Texas:
            -Dallas
            -Houston
          Delaware:
            -Dover

          I don't beleive that the local wsdl file is being cached.  I have deleted those files several times.  When I log into the server, a new wsdl file is being downloaded from the appropriate server.  (I can verify this due to the database on the CD doesn't contain the getUserInfo function).

          Since I am still supporting Windows 95 in my apps,  I have to use PocketSoap since MS SOAP doesn't work on this OS.
          The Error I am receiving is soon after the "getCountyInfo" request is sent to the Soap Server.  It returns with a "invalid gzip crc value" error from any county...

          I'm redownloading rr1.iso.zip now, so after it's finished, I'll try again...

          Thanks,
          Jay


          ----- Original Message -----
           
          From: Lindsay Blanton <mailto:lindsay@...>  
           
           
           
          Jay,

          I just checked directly from the CD-ROM  using a SOAP navigation utility that shows all the requests working perfectly.   Can you provide specific county ID’s that I can look at to maybe narrow  down your issue?  Have you tried different county IDs etc?

          Is it  possible you have cached some parts of the WSDL between switching?

          You  mentioned below getCountyInfo “errors out”  - what error are you  receiving?  
          --
          Lindsay C. Blanton III
          President /  Owner
          RadioReference.com LLC
          http://www.radioreference.com

              
        • Lindsay Blanton
          Jay, Take a look at this post: http://tech.groups.yahoo.com/group/pocketsoap/message/4701 I¹ve verified that we aren¹t sending compressed output from the
          Message 4 of 15 , Oct 2, 2008
          View Source
          • 0 Attachment
            Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008 Jay,

            Take a look at this post:

            http://tech.groups.yahoo.com/group/pocketsoap/message/4701

            I’ve verified that we aren’t sending compressed output from the CD-ROM – so I’m thinking this might be a bug in PocketSOAP.   Some of the other developers are making calls to those functions of the CD-ROM with no problems.

            Warm regards,

            Lindsay
            --
            Lindsay C. Blanton III
            President / Owner
            RadioReference.com LLC
            http://www.radioreference.com



            From: Jay <crazycalifornian@...>
            Reply-To: <rr_web_service@yahoogroups.com>
            Date: Wed, 1 Oct 2008 17:13:20 -0700
            To: <rr_web_service@yahoogroups.com>
            Subject: Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008

             
             

            Hi Lindsay,

            Yep, I have tried several Counties;
            California:
              - San Diego
              - Butte
              - Sacremento
            Colorado:
              - Bolder
            Texas:
              -Dallas
              -Houston
            Delaware:
              -Dover

            I don't beleive that the local wsdl file is being cached.  I have deleted those files several times.  When I log into the server, a new wsdl file is being downloaded from the appropriate server.  (I can verify this due to the database on the CD doesn't contain the getUserInfo function).

            Since I am still supporting Windows 95 in my apps,  I have to use PocketSoap since MS SOAP doesn't work on this OS.
            The Error I am receiving is soon after the "getCountyInfo" request is sent to the Soap Server.  It returns with a "invalid gzip crc value" error from any county...

            I'm redownloading rr1.iso.zip now, so after it's finished, I'll try again...

            Thanks,
            Jay


            ----- Original Message -----
             
            From: Lindsay Blanton <mailto:lindsay@...>  
             
             
             
            Jay,

            I just checked directly from the CD-ROM  using a SOAP navigation utility that shows all the requests working perfectly.   Can you provide specific county ID’s that I can look at to maybe narrow  down your issue?  Have you tried different county IDs etc?

            Is it  possible you have cached some parts of the WSDL between switching?

            You  mentioned below getCountyInfo “errors out”  - what error are you  receiving?  
            --
            Lindsay C. Blanton III
            President /  Owner
            RadioReference.com LLC
            http://www.radioreference.com

                
          • Jay
            Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008Followup, It looks like the 1.5.4 release of pocketsoap, was compiled on May 2 2006 and the pocketHTTP
            Message 5 of 15 , Oct 2, 2008
            View Source
            • 0 Attachment
              Re: [rr_web_service] New CD-ROM ISO posted 9/24/2008
              Followup,
               
              It looks like the 1.5.4 release of pocketsoap, was compiled on May 2 2006 and the pocketHTTP 1.3.3 was compiled on July 13 2008 (supposedly to fix the gzip crc error),  but now I'm getting a "Invalid dateTime string, unable to convert to dateTime" error.  It looks like pocketsoap is the culprit.
               
              Still weird that it works fine from RR.com's server,  while it doesn't from the CD ROM.
               
              I'll send a message to the author of pocketsoap and see what he says...
               
              Regards,
              Jay
              ----- Original Message -----
              Sent: Thursday, October 02, 2008 9:20 AM
               
              Jay,

              Take a look at this post:

              http://tech.groups.yahoo.com/group/pocketsoap/message/4701

              I’ve verified that we aren’t sending compressed output from the CD-ROM – so I’m thinking this might be a bug in PocketSOAP.   Some of the other developers are making calls to those functions of the CD-ROM with no problems.

              Warm regards,

              Lindsay
              --
              Lindsay C. Blanton III
              President / Owner
              RadioReference.com LLC
              http://www.radioreference.com
            • Lindsay C. Blanton III
              Jay, what function are you getting this error in? Warm regards, Lindsay ... Jay, what function are you getting this error in? Warm regards, Lindsay On Oct 2,
              Message 6 of 15 , Oct 2, 2008
              View Source
              • 0 Attachment
                Jay, what function are you getting this error in?

                Warm regards,

                Lindsay

                On Oct 2, 2008, at 8:37 PM, "Jay" <crazycalifornian@...> wrote:

                Followup,
                 
                It looks like the 1.5.4 release of pocketsoap, was compiled on May 2 2006 and the pocketHTTP 1.3.3 was compiled on July 13 2008 (supposedly to fix the gzip crc error),  but now I'm getting a "Invalid dateTime string, unable to convert to dateTime" error.  It looks like pocketsoap is the culprit.
                 
                Still weird that it works fine from RR.com's server,  while it doesn't from the CD ROM.
                 
                I'll send a message to the author of pocketsoap and see what he says...
                 
                Regards,
                Jay
                ----- Original Message -----
                Sent: Thursday, October 02, 2008 9:20 AM
                 
                Jay,

                Take a look at this post:

                http://tech. groups.yahoo. com/group/ pocketsoap/ message/4701

                I’ve verified that we aren’t sending compressed output from the CD-ROM – so I’m thinking this might be a bug in PocketSOAP.   Some of the other developers are making calls to those functions of the CD-ROM with no problems.

                Warm regards,

                Lindsay
                --
                Lindsay C. Blanton III
                President / Owner
                RadioReference. com LLC
                http://www.radioref erence.com

              • Bob Aune
                Hi Lindsay, Is the ISO still available? I ll like to implement the CD-ROM in to my program. Thanks, Bob Aune ... fixes on
                Message 7 of 15 , Jan 14, 2009
                View Source
                • 0 Attachment
                  Hi Lindsay,

                  Is the ISO still available? I'll like to implement the CD-ROM in to
                  my program.

                  Thanks,
                  Bob Aune

                  --- In rr_web_service@yahoogroups.com, Lindsay Blanton <lindsay@...>
                  wrote:
                  >
                  > Folks,
                  >
                  > I posted a new ISO up on the CD-ROM download page. Lots of bug
                  fixes on
                  > searches and other identified items.
                  >
                  > Give it a run through please if you are a beta tester.
                  >
                  > Thanks!
                  > --
                  > Lindsay C. Blanton III
                  > President / Owner
                  > RadioReference.com LLC
                  > http://www.radioreference.com
                  >
                • Bob Aune
                  Hi Lindsay, Is the ISO still available? I ll like to implement the CD-ROM in to my program. Thanks, Bob Aune ... fixes on
                  Message 8 of 15 , Jan 14, 2009
                  View Source
                  • 0 Attachment
                    Hi Lindsay,

                    Is the ISO still available? I'll like to implement the CD-ROM in to
                    my program.

                    Thanks,
                    Bob Aune

                    --- In rr_web_service@yahoogroups.com, Lindsay Blanton <lindsay@...>
                    wrote:
                    >
                    > Folks,
                    >
                    > I posted a new ISO up on the CD-ROM download page. Lots of bug
                    fixes on
                    > searches and other identified items.
                    >
                    > Give it a run through please if you are a beta tester.
                    >
                    > Thanks!
                    > --
                    > Lindsay C. Blanton III
                    > President / Owner
                    > RadioReference.com LLC
                    > http://www.radioreference.com
                    >
                  • Lindsay Blanton
                    Yes Bob, I can make available a CD-ROM ISO for those that want to do testing. For those that want access to the CD-ROM for testing... email me directly with
                    Message 9 of 15 , Jan 24, 2009
                    View Source
                    • 0 Attachment
                      Re: [rr_web_service] Re: New CD-ROM ISO posted 9/24/2008 Yes Bob, I can make available a CD-ROM ISO for those that want to do testing.

                      For those that want access to the CD-ROM for testing... email me directly with your RR Username and I’ll send you a link to the ISO image so you can download.

                      Thanks!
                      --
                      Lindsay C. Blanton III
                      President / Owner
                      RadioReference.com LLC
                      http://www.radioreference.com



                      From: Bob Aune <bob@...>
                      Reply-To: <rr_web_service@yahoogroups.com>
                      Date: Wed, 14 Jan 2009 20:28:05 -0800
                      To: <rr_web_service@yahoogroups.com>
                      Subject: [rr_web_service] Re: New CD-ROM ISO posted 9/24/2008

                       
                       

                      Hi Lindsay,

                      Is the ISO still available?  I'll like to implement the CD-ROM in to
                      my program.

                      Thanks,
                      Bob Aune

                      --- In rr_web_service@yahoogroups.com <mailto:rr_web_service%40yahoogroups.com> , Lindsay Blanton <lindsay@...>
                      wrote:
                      >
                      > Folks,
                      >
                      > I posted a new ISO up on the CD-ROM download page.  Lots of bug
                      fixes on
                      > searches and other identified items.
                      >
                      > Give it a run through please if you are a beta tester.
                      >
                      > Thanks!
                      > --
                      > Lindsay C. Blanton III
                      > President / Owner
                      > RadioReference.com LLC
                      > http://www.radioreference.com
                      >

                       
                          
                    Your message has been successfully submitted and would be delivered to recipients shortly.