Loading ...
Sorry, an error occurred while loading the content.
 

Re: URI ignoring?

Expand Messages
  • jmc7479
    ... Greetings. I have the almost the same problem - I want to specify a schema file (converted from RNG compact syntax using TRANG), so that it may be verified
    Message 1 of 10 , Mar 12, 2009
      >
      > The element DASINT doesn't have a definition for
      > xsi:schemaLocation attribute?
      >
      > Is it your editor that is inserting that?
      >
      > regards
      >
      >
      >
      >
      > --
      > Dave Pawson
      > XSLT XSL-FO FAQ.
      > Docbook FAQ.
      > http://www.dpawson.co.uk
      >

      Greetings.

      I have the almost the same problem - I want to specify a schema file (converted from RNG compact syntax using TRANG), so that it may be verified by a XMLSchema supporting parser. For this purpose I insert the respective attributes:

      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:noNamespaceSchemaLocation="../dtd/searchstep.xsd"

      Also tried setting the default namespace (in the schema) to empty.
      But, I also get the error that is mentioned above ("not allowed at this point ...").

      Interestingly, the file does validate against the XMLSchema schema - created from the RNC schema against which it does not.

      Someone have an idea on where the problem hides?

      Thanks
      Murat
    • Dave Pawson
      ... Relax simply doesn t have the associated schema within the instance. If you want it, try inserting it (perhaps as an attribute or PI) in the instance, then
      Message 2 of 10 , Mar 12, 2009
        2009/3/12 jmc7479 <jmc7479@...>:

        >
        > Greetings.
        >
        > I have the almost the same problem - I want to specify a schema file
        > (converted from RNG compact syntax using TRANG), so that it may be verified
        > by a XMLSchema supporting parser. For this purpose I insert the respective
        > attributes:
        >
        > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > xsi:noNamespaceSchemaLocation="../dtd/searchstep.xsd"
        >
        > Also tried setting the default namespace (in the schema) to empty.
        > But, I also get the error that is mentioned above ("not allowed at this
        > point ...").
        >
        > Interestingly, the file does validate against the XMLSchema schema - created
        > from the RNC schema against which it does not.
        >
        > Someone have an idea on where the problem hides?

        Relax simply doesn't have the associated schema within the instance.
        If you want it, try inserting it (perhaps as an attribute or PI) in
        the instance,
        then use XSLT to place it where you need it.

        HTH



        --
        Dave Pawson
        XSLT XSL-FO FAQ.
        Docbook FAQ.
        http://www.dpawson.co.uk
      Your message has been successfully submitted and would be delivered to recipients shortly.