Loading ...
Sorry, an error occurred while loading the content.
 

Re: [rng-users] URI ignoring?

Expand Messages
  • Jonathan Warren
    Thanks Dave - that solved my problem related to the namespace! However I now have another problem related to the other declarations xsi:schemaLocation and
    Message 1 of 10 , Feb 19, 2009
      Thanks Dave - that solved my problem related to the namespace! However I now have another problem related to the other declarations
      xsi:schemaLocation and xmlns:xs

      The error is this:
      Error Line Number:2 column number:152 system id:http://dasmi.bioinf.mpi-inf.mpg.de/das/sanger-core/interaction?interactor=10526 unexpected attribute "xsi:schemaLocation"
      the relavent xml from the above url is this|:

      <DASINT xmlns="http://dasmi.de" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://dasmi.de/ http://dasmi.de/dasint.xsd">
      <INTERACTOR intId="10985entrez gene/locuslink" shortLabel="GCN1L1" dbSource="entrez gene/locuslink" dbSourceCvId="MI:0477" dbVersion="" dbAccessionId="10985" dbCoordSys="Entrez,Gene_ID">
      <DETAIL property="species" value="9606" />

      The relavant relaxng is currently this:

      <?xml version="1.0" encoding="UTF-8"?>
      <grammar xmlns="http://relaxng.org/ns/structure/1.0"
          xmlns:a="http://relaxng.org/ns/compatibility/annotations/1.0"
          datatypeLibrary="http://www.w3.org/2001/XMLSchema-datatypes" ns="http://dasmi.de" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  xsi:schemaLocation="http://dasmi.de/ http://dasmi.de/dasint.xsd">
          <define name="DASINT">
              <element name="DASINT" >
                

      Any examples as to how to get around these declarations and not through errors would be good? I've tried putting the declarations in the DASINT element of the relaxng but I can't get this to work either.



      From: Dave Pawson <dave.pawson@...>
      To: rng-users@yahoogroups.com
      Sent: Tuesday, January 6, 2009 2:11:37 PM
      Subject: Re: [rng-users] URI ignoring?

      2009/1/6 Jonathan Warren <jonathan.warren@ ymail.com>:

      > Bumping this as I got no reply. Is it a stupid question or was it just
      > because it was a couple of days before Christmas?

      http://books. xmlschemata. org/relaxng/ relax-CHP- 11-SECT-3. html may help Jonathan.

      But Christmas could have been the reason :-)

      regards

      --
      Dave Pawson
      XSLT XSL-FO FAQ.
      Docbook FAQ.
      http://www.dpawson. co.uk


    • Dave Pawson
      ... The element DASINT doesn t have a definition for xsi:schemaLocation attribute? Is it your editor that is inserting that? regards -- Dave Pawson XSLT XSL-FO
      Message 2 of 10 , Feb 19, 2009
        2009/2/19 Jonathan Warren <jonathan.warren@...>:
        > Thanks Dave - that solved my problem related to the namespace! However I now
        > have another problem related to the other declarations
        >
        > xsi:schemaLocation and xmlns:xs
        >
        > The error is this:
        > Error Line Number:2 column number:152 system
        > id:http://dasmi.bioinf.mpi-inf.mpg.de/das/sanger-core/interaction?interactor=10526
        > unexpected attribute "xsi:schemaLocation"
        >
        > the relavent xml from the above url is this|:
        >
        > <DASINT xmlns="http://dasmi.de"
        > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > xsi:schemaLocation="http://dasmi.de/ http://dasmi.de/dasint.xsd">
        > <INTERACTOR intId="10985entrez gene/locuslink" shortLabel="GCN1L1"
        > dbSource="entrez gene/locuslink" dbSourceCvId="MI:0477" dbVersion=""
        > dbAccessionId="10985" dbCoordSys="Entrez,Gene_ID">
        >
        > <DETAIL property="species" value="9606" />
        >
        > The relavant relaxng is currently this:
        >
        > <?xml version="1.0" encoding="UTF-8"?>
        > <grammar xmlns="http://relaxng.org/ns/structure/1.0"
        > xmlns:a="http://relaxng.org/ns/compatibility/annotations/1.0"
        > datatypeLibrary="http://www.w3.org/2001/XMLSchema-datatypes"
        > ns="http://dasmi.de" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > xsi:schemaLocation="http://dasmi.de/ http://dasmi.de/dasint.xsd">
        > <define name="DASINT">
        > <element name="DASINT" >
        >
        >
        > Any examples as to how to get around these declarations and not through
        > errors would be good? I've tried putting the declarations in the DASINT
        > element of the relaxng but I can't get this to work either.

        The element DASINT doesn't have a definition for
        xsi:schemaLocation attribute?

        Is it your editor that is inserting that?

        regards




        --
        Dave Pawson
        XSLT XSL-FO FAQ.
        Docbook FAQ.
        http://www.dpawson.co.uk
      • Jonathan Warren
        looking at this link in the browser doesn t show it but when you show the source it is there?
        Message 3 of 10 , Feb 19, 2009
          looking at this link in the browser doesn't show it but when you show the source it is there?
          http://dasmi.bioinf.mpi-inf.mpg.de/das/sanger-core/interaction?interactor=10526


          From: Dave Pawson <dave.pawson@...>
          To: rng-users@yahoogroups.com
          Sent: Thursday, February 19, 2009 1:38:25 PM
          Subject: Re: [rng-users] URI ignoring?

          2009/2/19 Jonathan Warren <jonathan.warren@ ymail.com>:

          > Thanks Dave - that solved my problem related to the namespace! However I now
          > have another problem related to the other declarations
          >
          > xsi:schemaLocation and xmlns:xs
          >
          > The error is this:
          > Error Line Number:2 column number:152 system
          > id:http://dasmi. bioinf.mpi- inf.mpg.de/ das/sanger- core/interaction ?interactor= 10526
          > unexpected attribute "xsi:schemaLocation "
          >
          > the relavent xml from the above url is this|:
          >
          > <DASINT xmlns="http://dasmi. de"
          > xmlns:xsi="http://www.w3. org/2001/ XMLSchema- instance"
          > xsi:schemaLocation= "http://dasmi. de/ http://dasmi. de/dasint. xsd">
          > <INTERACTOR intId="10985entrez gene/locuslink" shortLabel=" GCN1L1"
          > dbSource="entrez gene/locuslink" dbSourceCvId= "MI:0477" dbVersion=""
          > dbAccessionId= "10985" dbCoordSys=" Entrez,Gene_ ID">
          >
          > <DETAIL property="species" value="9606" />
          >
          > The relavant relaxng is currently this:
          >
          > <?xml version="1.0" encoding="UTF- 8"?>
          > <grammar xmlns="http://relaxng. org/ns/structure /1.0"
          > xmlns:a="http://relaxng. org/ns/compatibi lity/annotations /1.0"
          > datatypeLibrary= "http://www.w3. org/2001/ XMLSchema- datatypes"
          > ns="http://dasmi. de" xmlns:xsi="http://www.w3. org/2001/ XMLSchema- instance"
          > xsi:schemaLocation= "http://dasmi. de/ http://dasmi. de/dasint. xsd">
          > <define name="DASINT" >
          > <element name="DASINT" >
          >
          >
          > Any examples as to how to get around these declarations and not through
          > errors would be good? I've tried putting the declarations in the DASINT
          > element of the relaxng but I can't get this to work either.

          The element DASINT doesn't have a definition for
          xsi:schemaLocation attribute?

          Is it your editor that is inserting that?

          regards

          --
          Dave Pawson
          XSLT XSL-FO FAQ.
          Docbook FAQ.
          http://www.dpawson. co.uk


        • Dave Pawson
          2009/2/19 Jonathan Warren : 1. Your html emails are (for me) unreadable. Please use plain text. 2. Try using a plain text editor for
          Message 4 of 10 , Feb 19, 2009
            2009/2/19 Jonathan Warren <jonathan.warren@...>:

            1. Your html emails are (for me) unreadable. Please use plain text.
            2. Try using a plain text editor for your files in preference to a browser view.

            regards


            --
            Dave Pawson
            XSLT XSL-FO FAQ.
            Docbook FAQ.
            http://www.dpawson.co.uk
          • Jonathan Warren
            Solved it now based on your previous answer- so thanks. To join this group I ended up having to get a yahoo account- which was a pain in the butt!! This is
            Message 5 of 10 , Feb 20, 2009
              Solved it now based on your previous answer- so thanks.
              To join this group I ended up having to get a yahoo account- which was a pain in  the butt!! This is the only reason I use yahoo email.
              How do I get it to accept my normal email address???


              From: Dave Pawson <dave.pawson@...>
              To: rng-users@yahoogroups.com
              Sent: Thursday, February 19, 2009 5:43:30 PM
              Subject: Re: [rng-users] URI ignoring?

              2009/2/19 Jonathan Warren <jonathan.warren@ ymail.com>:

              1. Your html emails are (for me) unreadable. Please use plain text.
              2. Try using a plain text editor for your files in preference to a browser view.

              regards

              --
              Dave Pawson
              XSLT XSL-FO FAQ.
              Docbook FAQ.
              http://www.dpawson. co.uk


            • jmc7479
              ... Greetings. I have the almost the same problem - I want to specify a schema file (converted from RNG compact syntax using TRANG), so that it may be verified
              Message 6 of 10 , Mar 12, 2009
                >
                > The element DASINT doesn't have a definition for
                > xsi:schemaLocation attribute?
                >
                > Is it your editor that is inserting that?
                >
                > regards
                >
                >
                >
                >
                > --
                > Dave Pawson
                > XSLT XSL-FO FAQ.
                > Docbook FAQ.
                > http://www.dpawson.co.uk
                >

                Greetings.

                I have the almost the same problem - I want to specify a schema file (converted from RNG compact syntax using TRANG), so that it may be verified by a XMLSchema supporting parser. For this purpose I insert the respective attributes:

                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                xsi:noNamespaceSchemaLocation="../dtd/searchstep.xsd"

                Also tried setting the default namespace (in the schema) to empty.
                But, I also get the error that is mentioned above ("not allowed at this point ...").

                Interestingly, the file does validate against the XMLSchema schema - created from the RNC schema against which it does not.

                Someone have an idea on where the problem hides?

                Thanks
                Murat
              • Dave Pawson
                ... Relax simply doesn t have the associated schema within the instance. If you want it, try inserting it (perhaps as an attribute or PI) in the instance, then
                Message 7 of 10 , Mar 12, 2009
                  2009/3/12 jmc7479 <jmc7479@...>:

                  >
                  > Greetings.
                  >
                  > I have the almost the same problem - I want to specify a schema file
                  > (converted from RNG compact syntax using TRANG), so that it may be verified
                  > by a XMLSchema supporting parser. For this purpose I insert the respective
                  > attributes:
                  >
                  > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                  > xsi:noNamespaceSchemaLocation="../dtd/searchstep.xsd"
                  >
                  > Also tried setting the default namespace (in the schema) to empty.
                  > But, I also get the error that is mentioned above ("not allowed at this
                  > point ...").
                  >
                  > Interestingly, the file does validate against the XMLSchema schema - created
                  > from the RNC schema against which it does not.
                  >
                  > Someone have an idea on where the problem hides?

                  Relax simply doesn't have the associated schema within the instance.
                  If you want it, try inserting it (perhaps as an attribute or PI) in
                  the instance,
                  then use XSLT to place it where you need it.

                  HTH



                  --
                  Dave Pawson
                  XSLT XSL-FO FAQ.
                  Docbook FAQ.
                  http://www.dpawson.co.uk
                Your message has been successfully submitted and would be delivered to recipients shortly.