Loading ...
Sorry, an error occurred while loading the content.
 

Newbie With jing Problem

Expand Messages
  • Jim Orcheson
    As a test, I created a simple DocBook document by copying example 1.2 from DocBook 5: The Definitive Guide:
    Message 1 of 5 , Dec 18 4:04 AM
      As a test, I created a simple DocBook document by copying example 1.2
      from DocBook 5: The Definitive Guide:

      <?xml version="1.0" encoding="utf-8"?>
      <article xmlns="http://docbook.org/ns/docbook" version="5.0" xml:lang="en">
      <title>Sample article</title>
      <para>This is a very short article.</para>
      </article>

      I then attempted to validate this using jing:

      java -jar /usr/share/java/jing.jar relaxng.rng test.xml

      and also:

      java -jar /usr/share/java/jing.jar -c relaxng.rnc test.xml

      In both cases I get the following output:

      > /home/jim/test/documentation/test.xml:2:78: error: element "article"
      > not allowed here; expected element "ns:attribute", "ns:choice",
      > "ns:data", "ns:element", "ns:empty", "ns:externalRef", "ns:grammar",
      > "ns:group", "ns:interleave", "ns:list", "ns:mixed", "ns:notAllowed",
      > "ns:oneOrMore", "ns:optional", "ns:parentRef", "ns:ref", "ns:text",
      > "ns:value" or "ns:zeroOrMore" (with
      > xmlns:ns="http://relaxng.org/ns/structure/1.0")

      So, I am obviously doing something wrong, but I cannot figure out what
      by reading the jing documentation. Any help would be greatly appreciated.

      Jim
    • Dave Pawson
      ... Same file script java -Xss4m -classpath $cp -Dorg.apache.xerces.xni.parser.XMLParserConfiguration=org.apache.xerces.parsers.XIncludeParserConfiguration
      Message 2 of 5 , Dec 18 4:52 AM
        On 18 December 2011 12:04, Jim Orcheson <jim@...> wrote:
        As a test, I created a simple DocBook document by copying example 1.2
        from DocBook 5: The Definitive Guide:

        <?xml version="1.0" encoding="utf-8"?>
        <article xmlns="http://docbook.org/ns/docbook" version="5.0" xml:lang="en">
        <title>Sample article</title>
        <para>This is a very short article.</para>
        </article>

        I then attempted to validate this using jing:

        java -jar /usr/share/java/jing.jar relaxng.rng test.xml

        and also:

        java -jar /usr/share/java/jing.jar -c relaxng.rnc test.xml

        In both cases I get the following output:

        > /home/jim/test/documentation/test.xml:2:78: error: element "article"
        > not allowed here; expected element "ns:attribute", "ns:choice",
        > "ns:data", "ns:element", "ns:empty", "ns:externalRef", "ns:grammar",
        > "ns:group", "ns:interleave", "ns:list", "ns:mixed", "ns:notAllowed",
        > "ns:oneOrMore", "ns:optional", "ns:parentRef", "ns:ref", "ns:text",
        > "ns:value" or "ns:zeroOrMore" (with
        > xmlns:ns="http://relaxng.org/ns/structure/1.0")

        So, I am obviously doing something wrong, but I cannot figure out what
        by reading the jing documentation. Any help would be greatly appreciated.

        Jim

        Same file 
        script
        java -Xss4m -classpath $cp -Dorg.apache.xerces.xni.parser.XMLParserConfiguration=org.apache.xerces.parsers.XIncludeParserConfiguration com.thaiopensource.relaxng.util.Driver  -i $@

        validates using docbookxi.rng

        Same using java -jar ....

        You are using namespaces? 

        HTH

         


        ------------------------------------

        Yahoo! Groups Links

        <*> To visit your group on the web, go to:
           http://groups.yahoo.com/group/rng-users/

        <*> Your email settings:
           Individual Email | Traditional

        <*> To change settings online go to:
           http://groups.yahoo.com/group/rng-users/join
           (Yahoo! ID required)

        <*> To change settings via email:
           rng-users-digest@yahoogroups.com
           rng-users-fullfeatured@yahoogroups.com

        <*> To unsubscribe from this group, send an email to:
           rng-users-unsubscribe@yahoogroups.com

        <*> Your use of Yahoo! Groups is subject to:
           http://docs.yahoo.com/info/terms/




        --
        Dave Pawson
        XSLT XSL-FO FAQ.
        Docbook FAQ.
        http://www.dpawson.co.uk

      • Jim Orcheson
        See below. ... No, I am using exactly what I entered above. Hence my confusion. Jim
        Message 3 of 5 , Dec 18 5:49 AM
          See below.

          On 11-12-18 07:52 AM, Dave Pawson wrote:  



          On 18 December 2011 12:04, Jim Orcheson <jim@...> wrote:
          As a test, I created a simple DocBook document by copying example 1.2
          from DocBook 5: The Definitive Guide:

          <?xml version="1.0" encoding="utf-8"?>
          <article xmlns="http://docbook.org/ns/docbook" version="5.0" xml:lang="en">
          <title>Sample article</title>
          <para>This is a very short article.</para>
          </article>

          I then attempted to validate this using jing:

          java -jar /usr/share/java/jing.jar relaxng.rng test.xml

          and also:

          java -jar /usr/share/java/jing.jar -c relaxng.rnc test.xml

          In both cases I get the following output:

          > /home/jim/test/documentation/test.xml:2:78: error: element "article"
          > not allowed here; expected element "ns:attribute", "ns:choice",
          > "ns:data", "ns:element", "ns:empty", "ns:externalRef", "ns:grammar",
          > "ns:group", "ns:interleave", "ns:list", "ns:mixed", "ns:notAllowed",
          > "ns:oneOrMore", "ns:optional", "ns:parentRef", "ns:ref", "ns:text",
          > "ns:value" or "ns:zeroOrMore" (with
          > xmlns:ns="http://relaxng.org/ns/structure/1.0")

          So, I am obviously doing something wrong, but I cannot figure out what
          by reading the jing documentation. Any help would be greatly appreciated.

          Jim

          Same file 
          script
          java -Xss4m -classpath $cp -Dorg.apache.xerces.xni.parser.XMLParserConfiguration=org.apache.xerces.parsers.XIncludeParserConfiguration com.thaiopensource.relaxng.util.Driver  -i $@

          validates using docbookxi.rng

          Same using java -jar ....

          You are using namespaces?

          No, I am using exactly what I entered above. Hence my confusion.

          Jim

          HTH

        • Sebastian Rahtz
          You seem to be validation a docbook document against the schema for relaxng achemas. Hence the error. Sent from my HTC ... From: Jim Orcheson
          Message 4 of 5 , Dec 18 6:01 AM
            You seem to be validation a docbook document against the schema for relaxng achemas. Hence the error.

            Sent from my HTC

            ----- Reply message -----
            From: "Jim Orcheson" <jim@...>
            Date: Sun, Dec 18, 2011 12:38
            Subject: [rng-users] Newbie With jing Problem
            To: "rng-users@yahoogroups.com" <rng-users@yahoogroups.com>

            As a test, I created a simple DocBook document by copying example 1.2
            from DocBook 5: The Definitive Guide:

            <?xml version="1.0" encoding="utf-8"?>
            <article xmlns="http://docbook.org/ns/docbook" version="5.0" xml:lang="en">
            <title>Sample article</title>
            <para>This is a very short article.</para>
            </article>

            I then attempted to validate this using jing:

            java -jar /usr/share/java/jing.jar relaxng.rng test.xml

            and also:

            java -jar /usr/share/java/jing.jar -c relaxng.rnc test.xml

            In both cases I get the following output:

            > /home/jim/test/documentation/test.xml:2:78: error: element "article"
            > not allowed here; expected element "ns:attribute", "ns:choice",
            > "ns:data", "ns:element", "ns:empty", "ns:externalRef", "ns:grammar",
            > "ns:group", "ns:interleave", "ns:list", "ns:mixed", "ns:notAllowed",
            > "ns:oneOrMore", "ns:optional", "ns:parentRef", "ns:ref", "ns:text",
            > "ns:value" or "ns:zeroOrMore" (with
            > xmlns:ns="http://relaxng.org/ns/structure/1.0")

            So, I am obviously doing something wrong, but I cannot figure out what
            by reading the jing documentation. Any help would be greatly appreciated.

            Jim


            ------------------------------------

            Yahoo! Groups Links

            <*> To visit your group on the web, go to:
                http://groups.yahoo.com/group/rng-users/

            <*> Your email settings:
                Individual Email | Traditional

            <*> To change settings online go to:
                http://groups.yahoo.com/group/rng-users/join
                (Yahoo! ID required)

            <*> To change settings via email:
                rng-users-digest@yahoogroups.com
                rng-users-fullfeatured@yahoogroups.com

            <*> To unsubscribe from this group, send an email to:
                rng-users-unsubscribe@yahoogroups.com

            <*> Your use of Yahoo! Groups is subject to:
                http://docs.yahoo.com/info/terms/

          • Jim Orcheson
            Thanks, that explains it. By using the correct schema, it now works. Jim
            Message 5 of 5 , Dec 18 7:18 AM
              Thanks, that explains it. By using the correct schema, it now works.

              Jim

              On 11-12-18 09:01 AM, Sebastian Rahtz wrote:  

              You seem to be validation a docbook document against the schema for relaxng achemas. Hence the error.

              Sent from my HTC

              ----- Reply message -----
              From: "Jim Orcheson" <jim@...>
              Date: Sun, Dec 18, 2011 12:38
              Subject: [rng-users] Newbie With jing Problem
              To: "rng-users@yahoogroups.com" <rng-users@yahoogroups.com>

              As a test, I created a simple DocBook document by copying example 1.2
              from DocBook 5: The Definitive Guide:

              <?xml version="1.0" encoding="utf-8"?>
              <article xmlns="http://docbook.org/ns/docbook" version="5.0" xml:lang="en">
              <title>Sample article</title>
              <para>This is a very short article.</para>
              </article>

              I then attempted to validate this using jing:

              java -jar /usr/share/java/jing.jar relaxng.rng test.xml

              and also:

              java -jar /usr/share/java/jing.jar -c relaxng.rnc test.xml

              In both cases I get the following output:

              > /home/jim/test/documentation/test.xml:2:78: error: element "article"
              > not allowed here; expected element "ns:attribute", "ns:choice",
              > "ns:data", "ns:element", "ns:empty", "ns:externalRef", "ns:grammar",
              > "ns:group", "ns:interleave", "ns:list", "ns:mixed", "ns:notAllowed",
              > "ns:oneOrMore", "ns:optional", "ns:parentRef", "ns:ref", "ns:text",
              > "ns:value" or "ns:zeroOrMore" (with
              > xmlns:ns="http://relaxng.org/ns/structure/1.0")

              So, I am obviously doing something wrong, but I cannot figure out what
              by reading the jing documentation. Any help would be greatly appreciated.

              Jim


              ------------------------------------

              Yahoo! Groups Links

              <*> To visit your group on the web, go to:
                  http://groups.yahoo.com/group/rng-users/

              <*> Your email settings:
                  Individual Email | Traditional

              <*> To change settings online go to:
                  http://groups.yahoo.com/group/rng-users/join
                  (Yahoo! ID required)

              <*> To change settings via email:
                  rng-users-digest@yahoogroups.com
                  rng-users-fullfeatured@yahoogroups.com

              <*> To unsubscribe from this group, send an email to:
                  rng-users-unsubscribe@yahoogroups.com

              <*> Your use of Yahoo! Groups is subject to:
                  http://docs.yahoo.com/info/terms/

            Your message has been successfully submitted and would be delivered to recipients shortly.