Loading ...
Sorry, an error occurred while loading the content.

16797Re: [riojug] Annotations Hibernate (annotations are not supported in -source 1.4)???

Expand Messages
  • André Pinto
    Jul 2, 2006
      Você tem que ativar o Java 5 para usar "annotations" :)

      Use o JDK 1.5 e depois ative as funcionalidades do Java 5 em sua ferramenta IDE.

      abs,
      André Pinto

      marcio cunha escreveu:

      Ola ,
      Depois de baixar o Hibernate Annotations e fui em projeto>>Libraries >>
      add/jar folder e adicionei o hibernate-annotatio ns.jar ae apareceu as
      bibliotecas

      import org.hibernate. cfg.AnnotationCo nfiguration;
      import org.hibernate. cfg.Configuratio n;

      ae criei a classe Cliente.java:
      package dao;

      /**
      *
      * @author a
      */
      import java.util.HashSet;
      import java.util.Set;
      import javax.persistence. *;
      import org.hibernate. cfg.AnnotationCo nfiguration;
      import org.hibernate. cfg.Configuratio n;

      @Entity
      public class Cliente {
      @Id @GeneratedValue( )
      private int idCliente;
      private String Nome;

      /** Creates a new instance of Cliente */
      public Cliente() {
      }

      }

      mas na hora de compilar aparece o erro:

      C:\Documents and Settings\a\Tcc\ src\java\ dao\Cliente. java:22: annotations
      are not supported in -source 1.4
      (try -source 1.5 to enable annotations)
      @Entity
      1 error


      _______________________________________________________ Você quer respostas para suas perguntas? Ou você sabe muito e quer compartilhar seu conhecimento? Experimente o Yahoo! Respostas ! http://br.answers.yahoo.com/
    • Show all 9 messages in this topic