Loading ...
Sorry, an error occurred while loading the content.

Re: [redhat] Setting Up A Modem From The Command Line

Expand Messages
  • Paul Grenyer
    Hi I ve made a little progress. By putting either side of my user name and password in wvdial.conf. Now I get the following: [root@localhost ppp]# wvdial --
    Message 1 of 9 , May 31, 2002
    • 0 Attachment
      Hi

      I've made a little progress. By putting " either side of my user name and
      password in wvdial.conf. Now I get the following:

      [root@localhost ppp]# wvdial
      --> WvDial: Internet dialer version 1.41
      --> Initializing modem.
      --> Sending: ATZ
      ATZ
      OK
      --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
      ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
      OK
      --> Modem initialized.
      --> Sending: ATDT 0844 040 2001
      --> Waiting for carrier.
      ATDT 0844 040 2001
      CONNECT 38400
      --> Carrier detected. Waiting for prompt.
      ~[7f]}#@!}!}!} }!}$}%\}"}&} }*} } }#}$@#}%}&[0f]}"h_}'}"}(}"}1}$}%b;M~
      --> PPP negotiation detected.
      --> Starting pppd at Fri May 31 18:35:14 2002
      --> PPP daemon has died! (exit code = 16)
      --> Disconnecting at Fri May 31 18:35:37 2002
      --> Auto Reconnect will be attempted in 5 seconds
      --> pppd error! Look at files in /var/log for an explanation.
      --> Initializing modem.
      --> Sending: ATZ
      NO CARRIER
      --> Modem not responding.
      --> Initializing modem.
      --> Sending: ATZ
      ATZ
      OK

      Which is progress because now wvdial gives up and tries again. The contents
      of my messages file is now:

      May 31 18:36:05 localhost pppd[1419]: pppd 2.4.1 started by root, uid 0
      May 31 18:36:05 localhost pppd[1419]: Using interface ppp0May 31 18:36:05
      localhost pppd[1419]: Connect: ppp0 <--> /dev/ttyS0
      May 31 18:36:05 localhost /etc/hotplug/net.agent: assuming ppp0 is already
      up
      May 31 18:36:26 localhost pppd[1419]: Hangup (SIGHUP)
      May 31 18:36:26 localhost pppd[1419]: Modem hangup
      May 31 18:36:26 localhost pppd[1419]: Connection terminated.
      May 31 18:36:26 localhost pppd[1419]: Exit.May 31 18:36:26 localhost
      /etc/hotplug/net.agent: NET unregister event not supported
      May 31 18:39:14 localhost pppd[1440]: pppd 2.4.1 started by root, uid 0May
      31 18:39:14 localhost pppd[1440]: Using interface ppp0
      May 31 18:39:14 localhost pppd[1440]: Connect: ppp0 <--> /dev/ttyS0
      May 31 18:39:14 localhost /etc/hotplug/net.agent: assuming ppp0 is already
      up
      May 31 18:39:36 localhost pppd[1440]: Hangup (SIGHUP)
      May 31 18:39:36 localhost pppd[1440]: Modem hangup
      May 31 18:39:36 localhost pppd[1440]: Connection terminated.
      May 31 18:39:36 localhost pppd[1440]: Exit.May 31 18:39:36 localhost
      /etc/hotplug/net.agent: NET unregister event not supported

      Does this give you any more ideas?

      Thanks!

      Regards
      /pjg

      Paul Grenyer
      pjgrenyer@...
      http://www.paulgrenyer.co.uk
    Your message has been successfully submitted and would be delivered to recipients shortly.