Loading ...
Sorry, an error occurred while loading the content.

nfs file permissions

Expand Messages
  • mansoor ali
    I have a nfs server ........ my exported file is here     /opt/Server exports entry                    /opt/Server *(rw,sync) in my
    Message 1 of 13 , Jul 26, 2010
    • 0 Attachment
      I have a nfs server ........
      my exported file is here     /opt/Server
      exports entry                    /opt/Server *(rw,sync)

      in my client machine i configured like this to access the nfs share (in fstab)
        192.168.1.133:/opt/Server  /opt/server   nfs defaults  0 0

      I can access the nfs share .........but the files are read only....any idea....can you help me plese...my manager is scolding me... please.....















      [Non-text portions of this message have been removed]
    • Sriharsha Kalluru
      Please mention which version nfs you are using and OS version. Also try this to fix the issue. [skalluru@posdev ~]$ cat /etc/exports/d01/RHEL5_32bit
      Message 2 of 13 , Jul 27, 2010
      • 0 Attachment
        Please mention which version nfs you are using and OS version.
        Also try this to fix the issue.
        [skalluru@posdev ~]$ cat /etc/exports/d01/RHEL5_32bit *(rw,sync,no_root_squash)
        The above one will fix the issue some times.
        Regards,Sriharsha Kalluru.

        --- On Tue, 27/7/10, mansoor ali <sneahatheeram@...> wrote:

        From: mansoor ali <sneahatheeram@...>
        Subject: [redhat] nfs file permissions
        To: redhat@yahoogroups.com
        Received: Tuesday, 27 July, 2010, 11:09 AM
















         









        I have a nfs server ........

        my exported file is here     /opt/Server

        exports entry                    /opt/Server *(rw,sync)



        in my client machine i configured like this to access the nfs share (in fstab)

          192.168.1.133:/opt/Server  /opt/server   nfs defaults  0 0



        I can access the nfs share .........but the files are read only....any idea....can you help me plese...my manager is scolding me... please.....



        [Non-text portions of this message have been removed]






























        [Non-text portions of this message have been removed]
      • Prajish S
        On Tue, Jul 27, 2010 at 11:09 AM, mansoor ali ... Check the user permissions of the files in server. my manager is scolding me... please..... ... -- Prajish S
        Message 3 of 13 , Jul 27, 2010
        • 0 Attachment
          On Tue, Jul 27, 2010 at 11:09 AM, mansoor ali
          <sneahatheeram@...> wrote:
          >
          > I have a nfs server ........
          > my exported file is here     /opt/Server
          > exports entry                    /opt/Server *(rw,sync)
          >
          > in my client machine i configured like this to access the nfs share (in fstab)
          >   192.168.1.133:/opt/Server  /opt/server   nfs defaults  0 0
          >
          > I can access the nfs share .........but the files are read only....any idea....can you help me plese...

          Check the user permissions of the files in server.

          my manager is scolding me... please.....
          >
          > [Non-text portions of this message have been removed]
          >
          >


          --
          Prajish S
          Tweet me @Prajish
        • david mouchoir
          when you use NFS, by default root is squashed ie it becomes nobody if you wan t root on clientside to access files on nfs exported directory add no_root_squash
          Message 4 of 13 , Jul 30, 2010
          • 0 Attachment
            when you use NFS, by default root is squashed ie it becomes nobody
            if you wan't root on clientside to access files on nfs exported directory
            add no_root_squash to you export options
            be careful with exported to * with no_root_squash
            any body booting liveusb/cd linux on his computer will be able to mount the export and access all of it
            hope this help


            --- In redhat@yahoogroups.com, mansoor ali <sneahatheeram@...> wrote:
            >
            > I have a nfs server ........
            > my exported file is here     /opt/Server
            > exports entry                    /opt/Server *(rw,sync)
            >
            > in my client machine i configured like this to access the nfs share (in fstab)
            >   192.168.1.133:/opt/Server  /opt/server   nfs defaults  0 0
            >
            > I can access the nfs share .........but the files are read only....any idea....can you help me plese...my manager is scolding me... please.....
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            > [Non-text portions of this message have been removed]
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.