Loading ...
Sorry, an error occurred while loading the content.

Linux Samba, Windows Client

Expand Messages
  • <papercodes/>
    Hi Guys, This question involves a windows machine/client. But since we re talking about system administration and the server is linux, I d like to know if
    Message 1 of 4 , Dec 5, 2008
    • 0 Attachment
      Hi Guys,

      This question involves a windows machine/client. But since we're talking about system administration and the server is linux, I'd like to know if you've experienced this problem.

      I have a linux box for a fileserver with samba properly configured in it. Samba works like a charm. After I login to my WindowsXP client, I opened my samba share by its ip \\192.168.1.2 and a window asking for a username and password pops up. I typed my username and password I created in my linux box using smbpasswd which is user1. It successfully logged me in. Now the problem is, I want to re-login in my samba share as a another user(e.g. user2) that I also created in my linux box but it keeps on logging me in to the first user(user1). I want my WindowsXP machine to ask me again for a username and password whenever I try to connect to a samba share. The only fix that I found is to restart your WindowsXP machine.

      Is there a parameter in smb.conf that would require ANY(windows,mac,linux,bsds,unixes, everyone) client to type in a username and password every time they want to connect to my samba machine?

      Thanks!

      <papercodes/>
    • John Johansen
      Windows caches the authentication and will reuse it whenever you access a resource on the same server - it won t let you authenticate as two different
      Message 2 of 4 , Dec 6, 2008
      • 0 Attachment
        Windows caches the authentication and will reuse it whenever you
        access a resource on the same server - it won't let you authenticate
        as two different identities to the same server. You need to kill all
        your current connections to that server before attempting to connect
        using the NET command

        NET /d <resource>

        John Johansen
        http://www.linkedin.com/in/johnkjohansen


        --- In redhat@yahoogroups.com, "<papercodes/>" <papercodes@...> wrote:
        >
        > Hi Guys,
        >
        > This question involves a windows machine/client. But since
        we're talking about system administration and the server is linux,
        I'd like to know if you've experienced this problem.
        >
        > I have a linux box for a fileserver with samba properly
        configured in it. Samba works like a charm. After I login to my
        WindowsXP client, I opened my samba share by its ip \\192.168.1.2 and
        a window asking for a username and password pops up. I typed my
        username and password I created in my linux box using smbpasswd which
        is user1. It successfully logged me in. Now the problem is, I want to
        re-login in my samba share as a another user(e.g. user2) that I also
        created in my linux box but it keeps on logging me in to the first
        user(user1). I want my WindowsXP machine to ask me again for a
        username and password whenever I try to connect to a samba share. The
        only fix that I found is to restart your WindowsXP machine.
        >
        > Is there a parameter in smb.conf that would require ANY
        (windows,mac,linux,bsds,unixes, everyone) client to type in a
        username and password every time they want to connect to my samba
        machine?
        >
        > Thanks!
        >
        > <papercodes/>
        >
      • <papercodes/>
        hmmm i was thinking there might be a parameter for that in smb.conf. Anyway, thanks for the help John! =) ... From: John Johansen
        Message 3 of 4 , Dec 8, 2008
        • 0 Attachment
          hmmm i was thinking there might be a parameter for that in smb.conf. Anyway, thanks for the help John! =)<papercodes/>
          --- On Sun, 12/7/08, John Johansen <johnkjohansen@...> wrote:
          From: John Johansen <johnkjohansen@...>
          Subject: [redhat] Re: Linux Samba, Windows Client
          To: redhat@yahoogroups.com
          Date: Sunday, December 7, 2008, 1:30 AM


















          Windows caches the authentication and will reuse it whenever you

          access a resource on the same server - it won't let you authenticate

          as two different identities to the same server. You need to kill all

          your current connections to that server before attempting to connect

          using the NET command



          NET /d <resource>



          John Johansen

          http://www.linkedin .com/in/johnkjoh ansen



          --- In redhat@yahoogroups. com, "<papercodes/ >" <papercodes@ ...> wrote:

          >

          > Hi Guys,

          >

          > This question involves a windows machine/client. But since

          we're talking about system administration and the server is linux,

          I'd like to know if you've experienced this problem.

          >

          > I have a linux box for a fileserver with samba properly

          configured in it. Samba works like a charm. After I login to my

          WindowsXP client, I opened my samba share by its ip \\192.168.1. 2 and

          a window asking for a username and password pops up. I typed my

          username and password I created in my linux box using smbpasswd which

          is user1. It successfully logged me in. Now the problem is, I want to

          re-login in my samba share as a another user(e.g. user2) that I also

          created in my linux box but it keeps on logging me in to the first

          user(user1). I want my WindowsXP machine to ask me again for a

          username and password whenever I try to connect to a samba share. The

          only fix that I found is to restart your WindowsXP machine.

          >

          > Is there a parameter in smb.conf that would require ANY

          (windows,mac, linux,bsds, unixes, everyone) client to type in a

          username and password every time they want to connect to my samba

          machine?

          >

          > Thanks!

          >

          > <papercodes/ >

          >


































          [Non-text portions of this message have been removed]
        Your message has been successfully submitted and would be delivered to recipients shortly.