Loading ...
Sorry, an error occurred while loading the content.

RE: [redhat] Re: Why Can't I find hda7?

Expand Messages
  • Germán Andrés Pulido F.
    ... You mounted your hard drive on /mnt, to see its files, just change to /mnt. Files are there. Read man for mount and umount.
    Message 1 of 11 , Apr 30, 2004
    • 0 Attachment
      > -----Original Message-----
      > From: Tom Husband [mailto:thusband@...]
      > Sent: Friday, April 30, 2004 8:36 PM
      > To: redhat@yahoogroups.com
      > Subject: [redhat] Re: Why Can't I find hda7?
      >
      >
      >
      > > Try
      > >
      > > mount -t vfat /dev/hda7 /mnt
      > >
      > > and see what happens. (Not tested)
      > >
      > >
      > > --
      > >
      > > Scott Robbins
      >
      > Something happened. Not sure what though:
      >
      > [root@localhost thusband]# mount -t vfat /dev/hda7 /mnt

      You mounted your hard drive on /mnt, to see its files, just change to /mnt.
      Files are there. Read man for mount and umount.

      > [root@localhost thusband]# mount /dev/hda7 /mnt/hda7
      > mount: mount point /mnt/hda7 does not exist
      > [root@localhost thusband]# cat /etc/fstab
      > LABEL=/ / ext3 defaults
      > 1 1
      > LABEL=/boot /boot ext3 defaults
      > 1 2
      > none /dev/pts devpts gid=5,mode=620
      > 0 0
      > none /proc proc defaults
      > 0 0
      > none /dev/shm tmpfs defaults
      > 0 0
      > /dev/hdb9 swap swap defaults
      > 0 0
      > /dev/cdrom /mnt/cdrom udf,iso9660
      > noauto,owner,kudzu,ro 0 0
      > [root@localhost thusband]# mount -t vfat /dev/hda7 /mnt
      > mount: /dev/hda7 already mounted or /mnt busy
      > mount: according to mtab, /dev/hda7 is already mounted on /mnt
      > [root@localhost thusband]# cat /etc/mtab
      > /dev/hdb10 / ext3 rw 0 0
      > none /proc proc rw 0 0
      > usbdevfs /proc/bus/usb usbdevfs rw 0 0
      > /dev/hdb8 /boot ext3 rw 0 0
      > none /dev/pts devpts rw,gid=5,mode=620 0 0
      > none /dev/shm tmpfs rw 0 0
      > /dev/hda7 /mnt vfat rw 0 0
      > [root@localhost thusband]# cd hda7
      > [root@localhost hda7]# ls
      > [root@localhost hda7]# ls
      >
      >
      > It's there in mtab but I can't see anything in it (there are
      > files there).
      >
      > Thanks for your help.
      >
      > Tom
      >
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      > ---------------------~-->
      > Buy Ink Cartridges or Refill Kits for your HP, Epson, Canon or Lexmark
      > Printer at MyInks.com. Free s/h on orders $50 or more to the
      > US & Canada.
      > http://www.c1tracking.com/l.asp?cid=5511
      > http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/0XFolB/TM
      > --------------------------------------------------------------
      > -------~->
      >
      > To post to the redhat group, send your post to redhat@yahoogroups.com
      > To reach the moderators, email to redhat-owner@yahoogroups.com
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    • Amadeus Zilfinski
      it would seem to me that the directory /mnt/hda7 doesn t exist. When you mount something the command mount filesystem {with} drive {at} location the location
      Message 2 of 11 , May 1, 2004
      • 0 Attachment
        it would seem to me that the directory /mnt/hda7 doesn't exist. When you
        mount something the command "mount filesystem {with} drive {at}
        location" the location must be a directory/folder that already exists,
        and what you choose to mount there is mounted "under" that folder. So
        when you goto the directory /mnt is there a folder called hda7?

        AmadeusZ.-
      • charles f zeitler
        ... at this point, /dev/hda7 is mounted at /mnt ... your machine wont even _try_ to mount to a non-existant dir (verify by ls /mnt ) ... yup. ... yup. ... ls
        Message 3 of 11 , May 5, 2004
        • 0 Attachment
          --- In redhat@yahoogroups.com, "Tom Husband" <thusband@s...> wrote:
          >
          >
          > > Try
          > >
          > > mount -t vfat /dev/hda7 /mnt
          > >
          > > and see what happens. (Not tested)
          > >
          > >
          > > --
          > >
          > > Scott Robbins
          >
          > Something happened. Not sure what though:
          >
          > [root@localhost thusband]# mount -t vfat /dev/hda7 /mnt

          at this point, /dev/hda7 is mounted at /mnt

          > [root@localhost thusband]# mount /dev/hda7 /mnt/hda7
          > mount: mount point /mnt/hda7 does not exist

          your machine wont even _try_ to mount to a non-existant dir
          (verify by 'ls /mnt')

          > [root@localhost thusband]# cat /etc/fstab
          > LABEL=/ / ext3 defaults
          > 1 1
          > LABEL=/boot /boot ext3 defaults
          > 1 2
          > none /dev/pts devpts gid=5,mode=620
          > 0 0
          > none /proc proc defaults
          > 0 0
          > none /dev/shm tmpfs defaults
          > 0 0
          > /dev/hdb9 swap swap defaults
          > 0 0
          > /dev/cdrom /mnt/cdrom udf,iso9660
          > noauto,owner,kudzu,ro 0 0
          > [root@localhost thusband]# mount -t vfat /dev/hda7 /mnt
          > mount: /dev/hda7 already mounted or /mnt busy
          > mount: according to mtab, /dev/hda7 is already mounted on /mnt
          yup.
          > [root@localhost thusband]# cat /etc/mtab
          > /dev/hdb10 / ext3 rw 0 0
          > none /proc proc rw 0 0
          > usbdevfs /proc/bus/usb usbdevfs rw 0 0
          > /dev/hdb8 /boot ext3 rw 0 0
          > none /dev/pts devpts rw,gid=5,mode=620 0 0
          > none /dev/shm tmpfs rw 0 0
          > /dev/hda7 /mnt vfat rw 0 0
          yup.
          > [root@localhost thusband]# cd hda7
          > [root@localhost hda7]# ls
          ls shows '/hda7' to be empty,
          but /dev/hda7 is mounted at '/mnt'.
          > [root@localhost hda7]# ls
          >
          >

          i suggest 'mount -t vfat /dev/hda7 /hda7'

          > It's there in mtab but I can't see anything in it (there are files
          there).
          >
          > Thanks for your help.
          >
          > Tom

          &, you only need to change fstab if
          you want /dev/hda7 mounted _every_ time
          you boot up. :-}

          cfzeitler
        • Godwin Stewart
          On Wed, 05 May 2004 17:59:16 -0000, charles f zeitler ... This is not correct. You only need to change /etc/fstab if you don t want to have to issue the full
          Message 4 of 11 , May 5, 2004
          • 0 Attachment
            On Wed, 05 May 2004 17:59:16 -0000, "charles f zeitler"
            <cfzeitler@...> wrote:

            > &, you only need to change fstab if
            > you want /dev/hda7 mounted _every_ time
            > you boot up. :-}

            This is not correct.

            You only need to change /etc/fstab if you don't want to have to issue the
            full "mount" command with all the parameters (therefore as root) in order to
            mount something. Nothing's to stop you using the "noauto" option...

            --
            G. Stewart -- gstewart@... -- gstewart@...
            Registered Linux user #284683 (Slackware 9.0, Linux 2.6.5)
            --------------------------------------------------------------
            Don't some of these fortunes just drive you nuts?! Wouldn't you like
            to see some of them deleted from the system? You can! Just mail to
            "fortune" with the fortune you hate most, and we MIGHT make sure it
            gets expunged.
          • Tom Husband
            ... Right. Figured it out with everyone s help and I added hda7 to /etc/fstab so it mounts automatically now. Thanks again, Tom
            Message 5 of 11 , May 5, 2004
            • 0 Attachment
              > &, you only need to change fstab if
              > you want /dev/hda7 mounted _every_ time
              > you boot up. :-}
              >
              > cfzeitler

              Right. Figured it out with everyone's help and I added hda7
              to /etc/fstab so it mounts automatically now.

              Thanks again,

              Tom
            Your message has been successfully submitted and would be delivered to recipients shortly.