Loading ...
Sorry, an error occurred while loading the content.

942Re: [redhat] User with Root power

Expand Messages
  • Brian L. Johnson
    Oct 3, 2000
      On Oct 4, Mazen wrote to redhat@egroups.com:

      >Luiz, I have tried this one then I have got the following message
      >"Only root user can get 0 in the user ID number.

      Because you used a GUI tool to create the account.

      If you want to create a second UID 0 account, you have to hack it by
      hand, here's how:

      *) In a text editor, open up /etc/passwd
      *) Duplicate the line for root
      *) Change the relevant info like username and personal name and home
      dir to whatever's appropriate
      *) Save and exit /etc/passwd
      *) Open up /etc/shadow in a text editor
      *) Duplicate the line for root
      *) Change the username to what your new UID 0 user is but don't change
      anything else
      *) Save and exit /etc/shadow

      Now you will have a second UID 0 user with the same password as
      root. Change this new user's password, and you're set.

      DON'T eliminate the root account!

      -=Brian L. Johnson, blj8.com=-
      http://www.blj8.com
      Total Bookmarks in file= 7577
      ---------------------------------
      For PGP key email pgpkey@...

      >
      >Thanks
      >Mazen
      > ----- Original Message -----
      > From: Luiz Antonio A. de Carvalho
      > To: 'redhat@egroups.com'
      > Sent: Monday, October 02, 2000 2:57 PM
      > Subject: RES: [redhat] User with Root power
      >
      >
      > Did u try to put 0 in this new user ID (as the root) in passwd ???
      >
      > ----- Mensagem original -----
      > De: Mazen [SMTP:linuxuser@...]
      > Enviada em: Sunday, October 01, 2000 8:22 AM
      > Para: redhat@egroups.com
      > Assunto: [redhat] User with Root power
      >
      > Hi all
      >
      > I have created a user in the 'root' group.
      > I wanted this user to have a complete access to everything exactly as
      > the root
      > user.
      > When I telneted to the system I found that I wasn't able to run
      > everything.
      > Do you have any idea?
      >
      > Thanks
      > Mazen
      >
    • Show all 8 messages in this topic