Loading ...
Sorry, an error occurred while loading the content.

Re: How to change SYSADM password with PTools 8.41 (FSCM 8.4) ?

Expand Messages
  • CBenson <charles.benson@belgacom.be>
    SYSADM, or whatever schema owner id you are using, shouldn t exist anywhere on the webserver. The only possibility is if you re using the id for a batch
    Message 1 of 5 , Feb 18, 2003
    • 0 Attachment
      SYSADM, or whatever schema owner id you are using, shouldn't exist
      anywhere on the webserver. The only possibility is if you're using
      the id for a batch process to connect, and you have it stored in a
      password file somewhere on your system, but that wouldn't be a very
      smart design...

      As far as PeopleSoft itself goes, SYSADM is just for the database. If
      you change it through appdesigner -> tools -> misc -> access
      profiles, this will propogate down to the database level, and you
      won't need to change it directly in oracle.

      --- In psftdba@yahoogroups.com, "litbighor <lehuyluan@h...>"
      <lehuyluan@h...> wrote:
      > Hi,
      >
      > I would like to know what to do to change SYSADM password.
      >
      > I know i must change the database password of SYSADM (RDBMS=Oracle
      for
      > me) and the Access profile in App. Designer.
      >
      > But what about the web server (weblogic here)?
      > What must I change ? How ?
      > Which config files ?
      > Something else to change ?
      >
      > (With HRMS 8.3, it seems that I only need to change the access
      profile
      > in App Designer.)
      >
      > Config: FSCM 8.4; PTools 8.41; HP-UX 11i; Oracle 8.1.7.2
      >
      > Thanks
    • litbighor <lehuyluan@hotmail.com>
      Hi, With PTools 8.18, just need to use Access Profile. But with Ptools 8.41, changing the Access profile does not change the password of the user SYSADM in the
      Message 2 of 5 , Feb 18, 2003
      • 0 Attachment
        Hi,

        With PTools 8.18, just need to use Access Profile.

        But with Ptools 8.41, changing the Access profile does not change the
        password of the user SYSADM in the Oracle database.

        Is it a bug ???
        I have to change it with 'alter user SYSADM identified by ...'
        I have to open App Designer before I alter the password in the db
        because after, I can't open app Designer (it says invalid pass)



        --- In psftdba@yahoogroups.com, "CBenson <charles.benson@b...>"
        <charles.benson@b...> wrote:
        > SYSADM, or whatever schema owner id you are using, shouldn't exist
        > anywhere on the webserver. The only possibility is if you're using
        > the id for a batch process to connect, and you have it stored in a
        > password file somewhere on your system, but that wouldn't be a very
        > smart design...
        >
        > As far as PeopleSoft itself goes, SYSADM is just for the database. If
        > you change it through appdesigner -> tools -> misc -> access
        > profiles, this will propogate down to the database level, and you
        > won't need to change it directly in oracle.
        >
      • Henry Poras
        It s been a while, but I just got around to trying this myself in our PTools 8.41.05 Financials database. I found a document on Customer Connection which
        Message 3 of 5 , Mar 6, 2003
        • 0 Attachment
          It's been a while, but I just got around to trying this myself in our
          PTools 8.41.05 Financials database. I found a document on Customer
          Connection which covers it (Resolution ID 200725197). It describes 3
          methods:

          Always shutdown appserver, process scheduler before proceeding.

          1. Log into DataMover in Bootstrap mode. Then
          run 'CHANGE_ACCESS_PASSWORD 'symbolicid' 'new password'
          This changes the password both in the database and the application.

          2. First change the oracle user password for sysadm (in the dba_users
          table). Then update PSACCESSPRFL, setting accessid (sysadm),
          accesspswd (new password), encrypted (set to 0). You then need to log
          in 2-tier to peoplesoft and that will encrypt the password in
          psaccessprfl.

          3. Use Application Designer/tools/miscellaneous/access profiles. You
          also need to logon to the database and change the password there.
          PeopleSoft claims this is a bug which is fixed in 8.42

          HTH

          Henry

          --- In psftdba@yahoogroups.com, "litbighor <lehuyluan@h...>"
          <lehuyluan@h...> wrote:
          > Hi,
          >
          > I would like to know what to do to change SYSADM password.
          >
          > I know i must change the database password of SYSADM (RDBMS=Oracle
          for
          > me) and the Access profile in App. Designer.
          >
          > But what about the web server (weblogic here)?
          > What must I change ? How ?
          > Which config files ?
          > Something else to change ?
          >
          > (With HRMS 8.3, it seems that I only need to change the access
          profile
          > in App Designer.)
          >
          > Config: FSCM 8.4; PTools 8.41; HP-UX 11i; Oracle 8.1.7.2
          >
          > Thanks
        • litbighor
          hi, Thanks Henry. I used the third method and it worked but there s a order : 1/ Connect with app Des in 2-tier. 2/ Change Application
          Message 4 of 5 , Mar 7, 2003
          • 0 Attachment
            hi,

            Thanks Henry. I used the third method and it worked but there's a
            order :
            1/ Connect with app Des in 2-tier.
            2/ Change Application Designer/tools/miscellaneous/access profiles.
            Don't close App Designer.
            3/ Connect to database with sqlplus and change sysadm password.
            4/ Close App Designer.

            About the password with the webserver Weblogic, the pass is in
            $WL_HOME/wlserver6.1/config/peoplesoft/setEnv.sh
            change SYSTEMID/SYSTEMPASSWORD.
            Connect to weblogic console and change it too.

            Regards,

            Litbighor


            --- In psftdba@yahoogroups.com, "Henry Poras" <hporas@a...> wrote:
            > It's been a while, but I just got around to trying this myself in
            our
            > PTools 8.41.05 Financials database. I found a document on Customer
            > Connection which covers it (Resolution ID 200725197). It describes
            3
            > methods:
            >
            > Always shutdown appserver, process scheduler before proceeding.
            >
            > 1. Log into DataMover in Bootstrap mode. Then
            > run 'CHANGE_ACCESS_PASSWORD 'symbolicid' 'new password'
            > This changes the password both in the database and the application.
            >
            > 2. First change the oracle user password for sysadm (in the
            dba_users
            > table). Then update PSACCESSPRFL, setting accessid (sysadm),
            > accesspswd (new password), encrypted (set to 0). You then need to
            log
            > in 2-tier to peoplesoft and that will encrypt the password in
            > psaccessprfl.
            >
            > 3. Use Application Designer/tools/miscellaneous/access profiles.
            You
            > also need to logon to the database and change the password there.
            > PeopleSoft claims this is a bug which is fixed in 8.42
            >
            > HTH
            >
            > Henry
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.