Loading ...
Sorry, an error occurred while loading the content.

Re: [pro-gen] VirtualBox probleempje

Expand Messages
  • Alex Mettau
    Beste PRO-GENners, Ook ik heb VirtualBox geïnstalleerd, met daaronder Win XP Pro. Via een Shared folder maak ik verbinding met het Pro-Gen bestand en het ziet
    Message 1 of 28 , Jul 6, 2011
    • 0 Attachment
      Beste PRO-GENners,

      Ook ik heb VirtualBox geïnstalleerd, met daaronder Win XP Pro. Via een
      Shared folder maak ik verbinding met het Pro-Gen bestand en het ziet er
      allemaal prima uit, maar... Pro-Gen wordt in "Alleen lezen" modus
      geopend. Dat is natuurlijk niet de bedoeling.

      Ik heb onder Win 7 de betreffende mappen gedeeld en kan ook vanuit
      VirtualBox tekstbestanden in de PG30-mappen openen en bewerken, dus de
      juiste toegang heb ik wel. Toch blijft ProGen "Alleen lezen!" vermelden.

      Heeft iemand enig idee wat ik over het hoofd zie?

      Met vriendelijke groet,
      Alex Mettau,
      PG nr. 314.

      Op 6-3-2011 10:28, Paul De Clerck schreef:
      > Beste PRO-GEN gebruikers,
      >
      > Sedert een jaar heb ik een nieuwe PC met Win7 64 bits.
      > Mijn zoon, die wel een informaticus is, heeft daarin het toenmalige SUN VM
      > VirtualBox geïnstalleerd (gratis tool) en daarin mijn oude Win XP Pro, met
      > een gebruik van HD van 10 GB, wat dus zeer beperkt is maar ruim voldoende
      > voor PG30.
      > Binnen die VirtualBox, die ook onder Unix, Mac, enz draait, heb ik PG30
      > geïnstalleerd zoals deze de laatste jaren heel goed heeft gewerkt onder
      > WinXP en ik werk nu dus nog zoals vroeger, met alle sneltoetsen enz.
      > ongewijzigd en foutloos.
      > Ik heb al een paar keer een update van VirtualBox naar een nieuwe versie
      > uitgevoerd, zonder het minste probleem.
      >
      > Onder de Win7 van mijn PC heg ik ook een DosBox geïstalleerd, waar ik soms
      > gebruik van maak om snel iets op te zoeken. Maar dat gebruik ik nooit meer
      > om iets in te voeren of te bewerken, juist omdat het voor mij niet meer
      > helemaal werkt zo goed werkt als vroeger.
      >
      > Ondertussen is SUN overgenomen door ORACLE, en de VirtualBox is er alleen op
      > verbeterd. Ik heb nu de versie 4.04 en die is nog beter.
      > Als u de mogelijkheid hebt om dit te gebruiken, dan kan ik u dat zeker sterk
      > aanraden. Al het plezier om met PG30 te werken is dan terug zoals voorheen.
      >
      > Kunnen Johan en Dinant er niet eens een studie aan wijden en de gebruikers
      > helpen bij het installeren van die VirtualBox?
      > Velen zouden hen zeer dankbaar zijn, want iedereen moet vroeg of laat wel
      > eens een nieuwe PC aanschaffen en Win7 is een must.
      > Natuurlijk is er ook een mogelijkheid om zich te beperken tot 32 bits, maar
      > dan is het RAM geheugen ook beperkt tot 1 GB in de plaats van 4 of meer, en
      > dat kan dan het gebruik van andere topassingen (vooral grafische) negatief
      > beïnvloeden.
      >
      >
      > Met genealogische groet,
      > Paul De Clerck
      > VVF-lid 395 PG nr 401
      > pdeclerck(ad)scarlet.be-
      >
      >
      >
      > ------------------------------------
      >
      > Om uzelf uit te schrijven van deze groep, stuur een mailtje naar:
      > pro-gen-unsubscribe@yahoogroups.com
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      > -----
      > Geen virus gevonden in dit bericht.
      > Gecontroleerd door AVG - www.avg.com
      > Versie: 10.0.1204 / Virusdatabase: 1435/3484 - datum van uitgifte: 03/05/11
      >
      >
    • Johannes Sijbom
      ... Beste Alex ... Misschien lost dit je probleem op. Zelf draai ik Pro-gen vanuit VirtualBox met Windows XP Pro op een Mac. Daar mis ik de Insert-knop, maar
      Message 2 of 28 , Jul 6, 2011
      • 0 Attachment
        Op 06-07-11 11:52, Alex Mettau schreef:
        > Beste PRO-GENners,
        >
        > Ook ik heb VirtualBox geïnstalleerd, met daaronder Win XP Pro. Via een
        > Shared folder maak ik verbinding met het Pro-Gen bestand en het ziet er
        > allemaal prima uit, maar... Pro-Gen wordt in "Alleen lezen" modus
        > geopend. Dat is natuurlijk niet de bedoeling.
        >
        > Ik heb onder Win 7 de betreffende mappen gedeeld en kan ook vanuit
        > VirtualBox tekstbestanden in de PG30-mappen openen en bewerken, dus de
        > juiste toegang heb ik wel. Toch blijft ProGen "Alleen lezen!" vermelden.
        >
        > Heeft iemand enig idee wat ik over het hoofd zie?
        >
        > Met vriendelijke groet,
        > Alex Mettau,
        > PG nr. 314.
        >
        >
        Beste Alex

        In de handleiding vind ik bij "status" het volgende:
        > Deze instelling toont welke toegang u tot het actieve genealogische
        > bestand heeft. Mogelijke instellingen zijn: 'lezen & schrijven' en
        > 'alleen
        > lezen !'.
        > In de meeste gevallen heeft u volledige toegang d.w.z. lezen en
        > schrijven. Echter wanneer u het programma start met de /RO-optie of
        > indien
        > u het genealogische bestand met het read-only attribuut heeft gemarkeerd
        > dan heeft u alleen toegang om te lezen. Dat betekent dus dat u
        > alleen maar
        > kunt kijken en geen wijzigen kunt aanbrengen.
        Misschien lost dit je probleem op.

        Zelf draai ik Pro-gen vanuit VirtualBox met Windows XP Pro op een Mac.
        Daar mis ik de Insert-knop, maar met het virtuele toetsenbord van
        Windows valt prima te werken in Pro-gen.

        --
        Hartelijke groeten

        Johannes Sijbom


        bezoek ook eens onze website
        <http://www.xs4all.nl/%7Ejbsijbom/gen_alg1.html>


        [Non-text portions of this message have been removed]
      • Alex Mettau
        ... Beste Johannes, Bedankt voor de reactie. Ik had dit zelf inmiddels ook al in de handleiding teruggevonden. Ik heb echter de /RO-optie niet gebruikt bij het
        Message 3 of 28 , Jul 6, 2011
        • 0 Attachment
          Op 6-7-2011 13:14, Johannes Sijbom schreef:
          > Op 06-07-11 11:52, Alex Mettau schreef:
          >> Beste PRO-GENners,
          >>
          >> Ook ik heb VirtualBox geïnstalleerd, met daaronder Win XP Pro. Via een
          >> Shared folder maak ik verbinding met het Pro-Gen bestand en het ziet er
          >> allemaal prima uit, maar... Pro-Gen wordt in "Alleen lezen" modus
          >> geopend. Dat is natuurlijk niet de bedoeling.
          >>
          >> Ik heb onder Win 7 de betreffende mappen gedeeld en kan ook vanuit
          >> VirtualBox tekstbestanden in de PG30-mappen openen en bewerken, dus de
          >> juiste toegang heb ik wel. Toch blijft ProGen "Alleen lezen!" vermelden.
          >> Heeft iemand enig idee wat ik over het hoofd zie?
          >>
          >> Met vriendelijke groet,
          >> Alex Mettau,
          >> PG nr. 314.
          >>
          >>
          > Beste Alex
          >
          > In de handleiding vind ik bij "status" het volgende:
          >> Deze instelling toont welke toegang u tot het actieve genealogische
          >> bestand heeft. Mogelijke instellingen zijn: 'lezen& schrijven' en
          >> 'alleen
          >> lezen !'.
          >> In de meeste gevallen heeft u volledige toegang d.w.z. lezen en
          >> schrijven. Echter wanneer u het programma start met de /RO-optie of
          >> indien
          >> u het genealogische bestand met het read-only attribuut heeft gemarkeerd
          >> dan heeft u alleen toegang om te lezen. Dat betekent dus dat u
          >> alleen maar
          >> kunt kijken en geen wijzigen kunt aanbrengen.
          > Misschien lost dit je probleem op.
          >
          > Zelf draai ik Pro-gen vanuit VirtualBox met Windows XP Pro op een Mac.
          > Daar mis ik de Insert-knop, maar met het virtuele toetsenbord van
          > Windows valt prima te werken in Pro-gen.
          >
          Beste Johannes,

          Bedankt voor de reactie. Ik had dit zelf inmiddels ook al in de
          handleiding teruggevonden. Ik heb echter de /RO-optie niet gebruikt bij
          het starten en de bestanden hebben ook geen read-only attribuut. Vanuit
          DOSBOX kan ik dezelfde bestanden ook normaal muteren, alleen vanuit
          VirtualBox lukt het niet. Sorteren en dergelijke gaan prima en razend
          snel, maar wijzigingen aanbrengen niet.

          Ik heb ook al geprobeerd om te starten met /RW als optie (staat niet in
          de handleiding, maar toch maar geprobeerd), maar dat helpt ook niet.

          Ik heb nog niet geprobeerd of het wel werkt als ik de hele Pro-Gen map
          ook naar de virtuele machine haal, omdat het mijn bedoeling is als ik
          even snel wat wil raadplegen dit via DOSBOX te blijven doen.

          Zijn er nog anderen met soortgelijke ervaringen?

          Groeten, Alex.
        • aat_versteegt
          Alex, Ik heb zelf geen problemen met VirtualBox. Heb Pro-Gen op de virtuele C: schijf staan. Als ik klaar ben met invoeren zorg ik wel dat alle data bestanden
          Message 4 of 28 , Jul 6, 2011
          • 0 Attachment
            Alex,
            Ik heb zelf geen problemen met VirtualBox. Heb Pro-Gen op de virtuele C: schijf staan. Als ik klaar ben met invoeren zorg ik wel dat alle data bestanden naar een shared folder worden doorgekopieerd d.m.v. een batchbestandje.
            Las op het VirtualBox forum wel een issue met vorige versies dat shared folders read only konden worden. Zie http://forums.virtualbox.org/viewtopic.php?f=5&t=19753
            Maar in de huidige versie mag dat niet meer voorkomen.

            Je kunt natuurlijk altijd PG even op je virtuele C: schijf zetten om te zien of het dan wel werkt.

            Met vriendelijke groeten,
            Aat Versteegt


            --- In pro-gen@yahoogroups.com, Alex Mettau <alp.mettau@...> wrote:
            >
            >
            >
            > Op 6-7-2011 13:14, Johannes Sijbom schreef:
            > > Op 06-07-11 11:52, Alex Mettau schreef:
            > >> Beste PRO-GENners,
            > >>
            > >> Ook ik heb VirtualBox geïnstalleerd, met daaronder Win XP Pro. Via een
            > >> Shared folder maak ik verbinding met het Pro-Gen bestand en het ziet er
            > >> allemaal prima uit, maar... Pro-Gen wordt in "Alleen lezen" modus
            > >> geopend. Dat is natuurlijk niet de bedoeling.
            > >>
            > >> Ik heb onder Win 7 de betreffende mappen gedeeld en kan ook vanuit
            > >> VirtualBox tekstbestanden in de PG30-mappen openen en bewerken, dus de
            > >> juiste toegang heb ik wel. Toch blijft ProGen "Alleen lezen!" vermelden.
            > >> Heeft iemand enig idee wat ik over het hoofd zie?
            > >>
            > >> Met vriendelijke groet,
            > >> Alex Mettau,
            > >> PG nr. 314.
            > >>
            > >>
            > > Beste Alex
            > >
            > > In de handleiding vind ik bij "status" het volgende:
            > >> Deze instelling toont welke toegang u tot het actieve genealogische
            > >> bestand heeft. Mogelijke instellingen zijn: 'lezen& schrijven' en
            > >> 'alleen
            > >> lezen !'.
            > >> In de meeste gevallen heeft u volledige toegang d.w.z. lezen en
            > >> schrijven. Echter wanneer u het programma start met de /RO-optie of
            > >> indien
            > >> u het genealogische bestand met het read-only attribuut heeft gemarkeerd
            > >> dan heeft u alleen toegang om te lezen. Dat betekent dus dat u
            > >> alleen maar
            > >> kunt kijken en geen wijzigen kunt aanbrengen.
            > > Misschien lost dit je probleem op.
            > >
            > > Zelf draai ik Pro-gen vanuit VirtualBox met Windows XP Pro op een Mac.
            > > Daar mis ik de Insert-knop, maar met het virtuele toetsenbord van
            > > Windows valt prima te werken in Pro-gen.
            > >
            > Beste Johannes,
            >
            > Bedankt voor de reactie. Ik had dit zelf inmiddels ook al in de
            > handleiding teruggevonden. Ik heb echter de /RO-optie niet gebruikt bij
            > het starten en de bestanden hebben ook geen read-only attribuut. Vanuit
            > DOSBOX kan ik dezelfde bestanden ook normaal muteren, alleen vanuit
            > VirtualBox lukt het niet. Sorteren en dergelijke gaan prima en razend
            > snel, maar wijzigingen aanbrengen niet.
            >
            > Ik heb ook al geprobeerd om te starten met /RW als optie (staat niet in
            > de handleiding, maar toch maar geprobeerd), maar dat helpt ook niet.
            >
            > Ik heb nog niet geprobeerd of het wel werkt als ik de hele Pro-Gen map
            > ook naar de virtuele machine haal, omdat het mijn bedoeling is als ik
            > even snel wat wil raadplegen dit via DOSBOX te blijven doen.
            >
            > Zijn er nog anderen met soortgelijke ervaringen?
            >
            > Groeten, Alex.
            >
          • Paul De Clerck
            Beste, Ik draai PG30 vlot op de virtuele C-schijf, waar XP Pro op draait, wel volledig gekopieerd van de originele C-schijf (onder WIN7), waar DosBox op
            Message 5 of 28 , Jul 6, 2011
            • 0 Attachment
              Beste,

              Ik draai PG30 vlot op de virtuele C-schijf, waar XP Pro op draait, wel volledig gekopieerd van de originele C-schijf (onder WIN7), waar DosBox op draait.
              Na elke aanpassing van gegevens (soms meemalen per dag omdat ik honderden rouwbrieven aan het verwerken ben) maak ik een backup (bij vb. RBVVF.LZH) in de map C:\PG30\BACKUP die ik daarvoor heb aangemaakt, maar onmiddellijk kopieer ik dit bestand naar de C-schijf van de server. Ik heb daartoe in de VirtualBox een link gemaakt naar die originele C.
              Deze link is als drive (P) bekend, op “mijn computer” voluit als: c_drive op 'Vboxsvr' (P)

              Dat betekent dat ik uit de map PG30 van de VirtualBox kan kopiëren naar de map PG30 op de originele computer door een kopie te maken van C:\PG30\... naar P:\PG30\...

              Ik stelde daarbij wel vast dat deze link niet kon worden gebruikt om in Pro-Gen direct bestanden onder P te openen en ook niet om parentelen en andere uitvoerbestanden direct op de P-drive te laten opslaan. Ik vermoed dat het is omdat de langere naam (P moet worden omgezet naar ...) niet erkend wordt door Pro-Gen, dat toch nog steeds een DOS-pogramma is gebleven.

              Maar het werkt prima om alles volledig op de virtuele schijf te laten werken, onder WIN XP, en dan de resultaten over te brengen naar de P-drive, die dus mijn originele C-drive is, waar ik dan RBVVF.LZH met Restore ook beschikbaar maak in de daar draaiende PG30..

              Andere vaststelling is dat je de printer of scanner niet op beide machines tegelijk beschikbaar hebt. Wil je printen uit PG30 op de virtual box, dan moet je de printer aan de box toekennen, maar dan kan je niet printen vanuit de originele computer. Dat is maar iets waar je moet op letten als de VirtualBox open is.

              Met genealogische groet,
              Paul De Clerck
              VVF-lid 395
              pdeclerck(ad)scarlet.be

              -----Oorspronkelijk bericht-----
              Van: aat_versteegt
              Datum: woensdag 6 juli 2011 19:23
              Aan: pro-gen@yahoogroups.com
              Onderwerp: [pro-gen] Re: VirtualBox probleempje

              Alex,
              Ik heb zelf geen problemen met VirtualBox. Heb Pro-Gen op de virtuele C: schijf staan. Als ik klaar ben met invoeren zorg ik wel dat alle data bestanden naar een shared folder worden doorgekopieerd d.m.v. een batchbestandje.
              Las op het VirtualBox forum wel een issue met vorige versies dat shared folders read only konden worden. Zie http://forums.virtualbox.org/viewtopic.php?f=5&t=19753
              Maar in de huidige versie mag dat niet meer voorkomen.

              Je kunt natuurlijk altijd PG even op je virtuele C: schijf zetten om te zien of het dan wel werkt.

              Met vriendelijke groeten,
              Aat Versteegt



              [Non-text portions of this message have been removed]
            • Alex Mettau
              Beste Aat en Paul, Bedankt voor de informatie en het meedenken. Ik heb één van de bestandensets naar de Virtuele C: schijf gecopieerd en dan werkt alles
              Message 6 of 28 , Jul 6, 2011
              • 0 Attachment
                Beste Aat en Paul,

                Bedankt voor de informatie en het meedenken.

                Ik heb één van de bestandensets naar de Virtuele C: schijf gecopieerd en
                dan werkt alles perfect. Eigenlijk wilde ik voorkomen om de bestanden
                allemaal naar de virtuele schijf te moeten kopiëren. Als ik ook nog
                gebruik van DOSBOX wil blijven maken om even snel wat na te kijken en
                eventueel een kleine aanvulling of wijziging aan te brengen moet ik de
                bestanden weer naar de virtuele schijf kopiëren. En na een wijziging via
                de VirtualBox weer de andere kant op.

                Ik moet maar iets zien te creëeren om ProGen op de Virtuele schijf op te
                starten vanuit een batch-file, die eerst alle data-bestanden kopieert
                vanaf de Win7-map. En dan na afsluiten van ProGen alle die bestanden via
                de shared-folder weer automatisch naar de oorspronkelijke plaats
                kopieert. Misschien is het zelfs verstandig om de DOSBOX-versie maar met
                de /RO-optie op te starten om verschillen te voorkomen (ik ken mezelf).

                Toch vind ik het vreemd dat ik wel vanuit VirtualBox bestanden via de
                shared folder kan openen, bewerken en opslaan (ook in de ProGen-mappen),
                maar dat Pro-Gen zelf al opstart met de "Alleen lezen!" melding.
                Misschien dat Johan of Dinant hier wat duidelijkheid over kan verschaffen?

                Nogmaals dank voor de ondersteuning. Ik kan mijn geplande aanschaf van
                een nieuw genealogieprogramma voorlopig weer op de lange baan schuiven
                en lekker met Pro-Gen blijven werken!

                Met vriendelijke groet,
                Alex Mettau.

                Op 6-7-2011 19:58, Paul De Clerck schreef:
                > Beste,
                >
                > Ik draai PG30 vlot op de virtuele C-schijf, waar XP Pro op draait, wel volledig gekopieerd van de originele C-schijf (onder WIN7), waar DosBox op draait.
                > Na elke aanpassing van gegevens (soms meemalen per dag omdat ik honderden rouwbrieven aan het verwerken ben) maak ik een backup (bij vb. RBVVF.LZH) in de map C:\PG30\BACKUP die ik daarvoor heb aangemaakt, maar onmiddellijk kopieer ik dit bestand naar de C-schijf van de server. Ik heb daartoe in de VirtualBox een link gemaakt naar die originele C.
                > Deze link is als drive (P) bekend, op “mijn computer” voluit als: c_drive op 'Vboxsvr' (P)
                >
                > Dat betekent dat ik uit de map PG30 van de VirtualBox kan kopiëren naar de map PG30 op de originele computer door een kopie te maken van C:\PG30\.... naar P:\PG30\...
                >
                > Ik stelde daarbij wel vast dat deze link niet kon worden gebruikt om in Pro-Gen direct bestanden onder P te openen en ook niet om parentelen en andere uitvoerbestanden direct op de P-drive te laten opslaan. Ik vermoed dat het is omdat de langere naam (P moet worden omgezet naar ...) niet erkend wordt door Pro-Gen, dat toch nog steeds een DOS-pogramma is gebleven.
                >
                > Maar het werkt prima om alles volledig op de virtuele schijf te laten werken, onder WIN XP, en dan de resultaten over te brengen naar de P-drive, die dus mijn originele C-drive is, waar ik dan RBVVF.LZH met Restore ook beschikbaar maak in de daar draaiende PG30..
                >
                > Andere vaststelling is dat je de printer of scanner niet op beide machines tegelijk beschikbaar hebt. Wil je printen uit PG30 op de virtual box, dan moet je de printer aan de box toekennen, maar dan kan je niet printen vanuit de originele computer. Dat is maar iets waar je moet op letten als de VirtualBox open is.
                >
                > Met genealogische groet,
                > Paul De Clerck
                > VVF-lid 395
                > pdeclerck(ad)scarlet.be
                >
                > -----Oorspronkelijk bericht-----
                > Van: aat_versteegt
                > Datum: woensdag 6 juli 2011 19:23
                > Aan: pro-gen@yahoogroups.com
                > Onderwerp: [pro-gen] Re: VirtualBox probleempje
                >
                > Alex,
                > Ik heb zelf geen problemen met VirtualBox. Heb Pro-Gen op de virtuele C: schijf staan. Als ik klaar ben met invoeren zorg ik wel dat alle data bestanden naar een shared folder worden doorgekopieerd d.m.v. een batchbestandje.
                >
                > Las op het VirtualBox forum wel een issue met vorige versies dat shared folders read only konden worden. Zie http://forums.virtualbox.org/viewtopic.php?f=5&t=19753
                > Maar in de huidige versie mag dat niet meer voorkomen.
                >
                > Je kunt natuurlijk altijd PG even op je virtuele C: schijf zetten om te zien of het dan wel werkt.
                >
                > Met vriendelijke groeten,
                > Aat Versteegt
                >
                >
                >
                > [Non-text portions of this message have been removed]
                >
                >
                >
                > ------------------------------------
                >
                > Om uzelf uit te schrijven van deze groep, stuur een mailtje naar:
                > pro-gen-unsubscribe@yahoogroups.com
                >
                > Yahoo! Groups Links
                >
                >
                >
                >
                >
                > -----
                > Geen virus gevonden in dit bericht.
                > Gecontroleerd door AVG - www.avg.com
                > Versie: 10.0.1388 / Virusdatabase: 1516/3747 - datum van uitgifte: 07/06/11
                >
                >
                >
              • Johan Mulderij
                ... Hallo Alex, Ik heb geen ervaring met VirtualBox, dus ik kan daar zo geen tip geven. Maar het is inderdaad wel vreemd dat dit niet werkt. Wellicht dat die
                Message 7 of 28 , Jul 14, 2011
                • 0 Attachment
                  Op 6-7-2011 21:25, Alex Mettau schreef:
                  > Toch vind ik het vreemd dat ik wel vanuit VirtualBox bestanden via de
                  > shared folder kan openen, bewerken en opslaan (ook in de ProGen-mappen),
                  > maar dat Pro-Gen zelf al opstart met de "Alleen lezen!" melding.
                  > Misschien dat Johan of Dinant hier wat duidelijkheid over kan verschaffen?


                  Hallo Alex,

                  Ik heb geen ervaring met VirtualBox, dus ik kan daar zo geen tip geven.
                  Maar het is inderdaad wel vreemd dat dit niet werkt. Wellicht dat die
                  link van Aat nog wat oplevert.

                  We hebben in Aanvulling 15 (01-09-2007) aanpassingen voor VirtualPC van
                  Microsoft gemaakt, waarbij de constructie zodanig was dat binnen
                  VirtualPC enkel een snelkoppeling stond naar de PRO-GEN software en data
                  die gewoon op de 64-bit Windows-schijf geinstalleerd stond.
                  Als je voor dat read-only probleem een instelling weet te vinden, dan is
                  zo'n zelfde constructie vanuit VirtualBox waarschijnlijk ook wel mogelijk.
                  --
                  Met vriendelijke groet,
                  Johan Mulderij

                  PRO-GEN homepage : http://www.pro-gen.nl
                  ========================================
                Your message has been successfully submitted and would be delivered to recipients shortly.