Loading ...
Sorry, an error occurred while loading the content.
 

Re: Pro-Gen op Apple Mac met Boxer

Expand Messages
  • vanderschaaff@netscape.net
    Hallo Erik, Probleem komt mij niet bekend voor. Ik heb twee testen gedaan: 1. Installatie van een demo pg3.0b-p15 om Boxer te testen, geen probleem. Ik heb
    Message 1 of 4 , May 6, 2008
      Hallo Erik,




      Probleem komt mij niet bekend voor. Ik heb twee testen gedaan:



      1. Installatie van een demo pg3.0b-p15 om Boxer te testen, geen probleem. Ik heb hierbij echter geen licenties ingevoerd.

      2. Kopie van mijn bestaande pg3.0-p13 (oudere) versie vanaf een Linux machine, deze werkte in Boxer prima.

      3. Upgrade van deze p13 naar de p15 (recentste) versie. Deze is in twee stappen uitgevoerd waarna ik Pro Gen normaal kan gebruiken (met geldige licentie overgenomen dus).



      Het probleem zoals jij dat aankaart lijkt mij geen Boxer / DOSbox probleem, schat ik in. Lijkt mij eerder in Pro Gen en de licensering te zitten.



      Groeten,

      Danny





      ________________________________________________________________________
      1a. Re: Pro-Gen op Apple Mac met Boxer
      Posted by: "Erik Groenhuis" e.groenhuis@... domovertus
      Date: Tue May 6, 2008 4:05 am ((PDT))

      As Danny van der Schaaff wrote on 1 May 2008:

      > Hallo,
      >
      > Geen probleem, wel een oplossing, voor de geinteresseerden.
      >
      > Ik heb Pro-Gen op mijn MacBook Pro aan de praat gekregen. Daarbij
      > gebruik ik het pakket Boxer, hetgeen een Mac-vriendelijke versie is
      > van DOSBox.
      >
      > http://boxer.washboardabs.net/

      Geweldig!

      Ik heb dit ook geprobeerd, op mijn iBook 12" G4, maar na het installeren
      van Pro-Gen 3a vanaf CD en het invoeren van mijn persoonlijke gegevens
      weigert Pro-Gen verder te werken en geeft een scherm met de tekst dat
      mijn persoonlijke gegevens waarschijnlijk voor een oudere versie van
      Pro-Gen waren en niet geschikt zijn.

      Had jij dit probleem ook?
      --
      Erik Groenhuis











      Plan your next roadtrip with MapQuest.com: America's #1 Mapping Site.







      [Non-text portions of this message have been removed]
    • Erik Groenhuis
      ... Zonder de licentie heb ik ook (vooralsnog) geen probleem. ... Ik heb uiteindelijk ook een copie genomen van een pg3.0b-p11 vanaf Windows. Hetzelfde
      Message 2 of 4 , May 15, 2008
        As vanderschaaff@... wrote on 6 May 2008:

        > Probleem komt mij niet bekend voor. Ik heb twee testen gedaan:
        >
        > 1. Installatie van een demo pg3.0b-p15 om Boxer te testen, geen
        > probleem. Ik heb hierbij echter geen licenties ingevoerd.

        Zonder de licentie heb ik ook (vooralsnog) geen probleem.

        > 2. Kopie van mijn bestaande pg3.0-p13 (oudere) versie vanaf een Linux
        > machine, deze werkte in Boxer prima.

        Ik heb uiteindelijk ook een copie genomen van een pg3.0b-p11 vanaf
        Windows. Hetzelfde probleem: na opstarten klaagt Pro-Gen over de
        licentie.

        > 3. Upgrade van deze p13 naar de p15 (recentste) versie. Deze is in
        > twee stappen uitgevoerd waarna ik Pro Gen normaal kan gebruiken (met
        > geldige licentie overgenomen dus).

        Niet door mij uitvoerbaar, omdat de versie van stap 2 al niet wilde
        werken.

        Wat we hier waarschijnlijk zien is een probleem dat optreed als Pro-Gen
        moet draaien op een emulator die draait op een non-Intel processor.

        Zolang de emulator draait op een processor uit de Intel 8086 serie, dan
        werkt alles vlekkeloos. Het maakt daarbij niet uit wat het onderliggende
        operating system is: Linux, MacOS[1] of zelfs Windows. De meeste
        emulators (zoals Bochs en DosBox) doen het goed. De smaak van de
        gebruikte Dos kan nog wel eens invloed hebben. Zo is Freedos af te
        raden. Gelukkig zijn er complete oude MS-DOS versies op internet te
        vinden.

        Moet de emulator draaien op een andere processor, dan zijn er problemen.

        Zo geeft Bochs na het opstartscherm:

        "Overflow in module ALGEMEEN at address 7F2C:0FA4

        Hit any key to return to system"

        (debug informatie zegt: math_abort: MSDOS compatibility FPU exception).

        En geeft DOSBox (zowel direct als in de Boxer incarnatie) na het
        opstartscherm de melding:

        "De gebruikersgegevens in PRO-GEN.USR staan verder gebruik niet toe !

        Waarschijnlijk is dit bestand geregistreerd voor een oudere PRO-GEN
        versie.

        <etcetera>"

        Dit alles op een Apple iBook met een G4 PowerPC.

        Nu kan je zeggen: Koop dan een laptop met een Intel processor. Maar dat
        gaat een beetje voorbij aan de reden waarom we een emulator gebruiken:
        We willen Pro-Gen draaien op een systeem waar het niet voor ontworpen
        is.

        Om dit probleem op te lossen zal ofwel Pro-Gen aan gepast moeten worden
        zodat het draait op een DOS emulator op een PowerPC, ofwel een DOS
        emulator speciaal geschikt gemaakt moeten worden om Pro-Gen te draaien.

        Idealiter zie ik een compleet pakket voor ogen: de gebruiker installeert
        dit op zijn computer en krijgt na het starten een window met MS-DOS voor
        zich, waarbij een recente Pro-Gen is voorgeinstalleerd in drive C als
        demoversie. Gebruikersgegevens invoeren en presto! Alles werkt.

        [1] Sinds ongeveer april 2006 worden alle nieuwe Apple computers
        geleverd met Intel 8086-serie processors. Tot die tijd gebruikte Apple
        PowerPC processors (zoals de G4 en de G5).
        --
        Erik Groenhuis
      Your message has been successfully submitted and would be delivered to recipients shortly.