Loading ...
Sorry, an error occurred while loading the content.

Re: New PowerSDR-IQ 1.19.3.2 version OK in Vista with USBtoI2C and CW key/paddle/PTT

Expand Messages
  • Graeme
    Hi Christos, Yes it is puzzling but also a pointer to the problem. I am using a Mobo 4.3 with firmware version 16.11 There is a more recent version but as I
    Message 1 of 22 , Jan 6, 2010
    • 0 Attachment
      Hi Christos,

      Yes it is puzzling but also a pointer to the problem. I am using a Mobo 4.3 with firmware version 16.11 There is a more recent version but as I have many tests done with this version I am reluctant to upgrade until I am finished. However the latest version won't be the problem. It is almost certain to be an incompatibility between your USB_I2C board firmware and the v16.11 firmware which was developed by a collusion with Alex and Loftur from the Mobo development team in cooperation with Fred. Your firmware will be based on the original DG8SAQ firmware and although everyone thinks it is backward compatible I suspect you have found a difference. Murphy strikes again!

      I program in PIC assembly and would be lost in AVR programs so am not the right guy to confer with over this issue. I suggest that you email Alex or Loftur in the first instance although they will probably call on Fred as well. I am sure this can be resolved, it is just so close now.

      Bye the way the CW is going so well. I can qso on a single frequency which I set with the CfgSRv2.0 tool. I can run dots faster than I could ever send CW. I am just thrilled with it.

      73 Graeme ZL2APV


      --- In powersdr-iq@yahoogroups.com, "sv1eia" <sv1eia@...> wrote:
      >
      > Graeme,
      >
      > It is puzzling, the frequency control does work on my side, I use a little USB_I2C board from Tony with the initial firmware (never bothered to change it) and it is operating properly.
      >
      > It seems that something is changed in the firmware revisions, I have no other explanation since I've seen other posts also saying that they also do not control the frequency.
      >
      > What is exactly your firmware revision?
      >
      > 73,
      > Christos SV1EIA
      <SNIP>
    • sv1eia
      Hi Graeme, The puzzle has been solved. I discussed it with Fred and you can see relevant posts. Fred s firmware is not compatible with the original DG8SAQ and
      Message 2 of 22 , Jan 6, 2010
      • 0 Attachment
        Hi Graeme,

        The puzzle has been solved.

        I discussed it with Fred and you can see relevant posts.
        Fred's firmware is not compatible with the original DG8SAQ and that was a today's discovery for me.
        I've implemented the original one so that is why you could not change the frequency although you had partial control of the device.
        So you need to wait for a newer release soon that will take care of both firmware produced, the original DG8SAQ and the PE0FKO branch.

        73,
        Christos SV1EIA



        --- In powersdr-iq@yahoogroups.com, "Graeme" <gvj@...> wrote:
        >
        > Hi Christos,
        >
        > Yes it is puzzling but also a pointer to the problem. I am using a Mobo 4.3 with firmware version 16.11 There is a more recent version but as I have many tests done with this version I am reluctant to upgrade until I am finished. However the latest version won't be the problem. It is almost certain to be an incompatibility between your USB_I2C board firmware and the v16.11 firmware which was developed by a collusion with Alex and Loftur from the Mobo development team in cooperation with Fred. Your firmware will be based on the original DG8SAQ firmware and although everyone thinks it is backward compatible I suspect you have found a difference. Murphy strikes again!
        >
        > I program in PIC assembly and would be lost in AVR programs so am not the right guy to confer with over this issue. I suggest that you email Alex or Loftur in the first instance although they will probably call on Fred as well. I am sure this can be resolved, it is just so close now.
        >
        > Bye the way the CW is going so well. I can qso on a single frequency which I set with the CfgSRv2.0 tool. I can run dots faster than I could ever send CW. I am just thrilled with it.
        >
        > 73 Graeme ZL2APV
        >
        >
        > --- In powersdr-iq@yahoogroups.com, "sv1eia" <sv1eia@> wrote:
        > >
        > > Graeme,
        > >
        > > It is puzzling, the frequency control does work on my side, I use a little USB_I2C board from Tony with the initial firmware (never bothered to change it) and it is operating properly.
        > >
        > > It seems that something is changed in the firmware revisions, I have no other explanation since I've seen other posts also saying that they also do not control the frequency.
        > >
        > > What is exactly your firmware revision?
        > >
        > > 73,
        > > Christos SV1EIA
        > <SNIP>
        >
      • pe0fko
        ... today s discovery for me. First there was the DG8SAQ firmware V1.4 then the PE0FKO firmware V15.x upward compatible with V1.4 then came SDR-Kits firmware
        Message 3 of 22 , Jan 6, 2010
        • 0 Attachment
          >> 2010/1/6 sv1eia <sv1eia@...>
          >> Fred's firmware is not compatible with the original DG8SAQ and that was a today's discovery for me.

          First there was the DG8SAQ firmware V1.4 then the PE0FKO firmware V15.x upward compatible with V1.4 then came SDR-Kits firmware V2.x *not* upward compatible with V15.x.

          --
          73, Fred
          PE0FKO


        • Graeme
          Hi Christos, Thanks for everything. Glad you and Fred have your heads together and I ame sure an amazing resolution will result. Thank you for everything so
          Message 4 of 22 , Jan 6, 2010
          • 0 Attachment
            Hi Christos,

            Thanks for everything. Glad you and Fred have your heads together and I ame sure an amazing resolution will result. Thank you for everything so far and I will patiently wait for the updated version.

            73 Graeme ZL2APV


            --- In powersdr-iq@yahoogroups.com, "sv1eia" <sv1eia@...> wrote:
            >
            > Hi Graeme,
            >
            > The puzzle has been solved.
            >
            > I discussed it with Fred and you can see relevant posts.
            > Fred's firmware is not compatible with the original DG8SAQ and that was a today's discovery for me.
            > I've implemented the original one so that is why you could not change the frequency although you had partial control of the device.
            > So you need to wait for a newer release soon that will take care of both firmware produced, the original DG8SAQ and the PE0FKO branch.
            >
            > 73,
            > Christos SV1EIA
            <SNIP>
          • Ken Lotts
            I was enjoying the new version 1.19.3.6 and then I shut it down and launched PowerSDR 1.18.3 for a second.. now my PowerSDR 1.19.3.6 will no longer boot
            Message 5 of 22 , Jan 8, 2010
            • 0 Attachment
              I was enjoying the new version 1.19.3.6 and then I shut it down and launched PowerSDR 1.18.3 for a second..  now my PowerSDR 1.19.3.6 will no longer boot up....  It comes up with a list of errors.  I rebooted and re-installed and un installed and reinstalled again but nothing works.. I am thinking that the two versions probably share somthing in the registry and something was over wrote when I launched the old version.  any one else have this happen?
               
              Here is the error:
               
               
              I know this is a pre-release..  but it is awesome.  I am totally spoiled.
               
              Ken Lotts
              aa7jc
               
            • sv1eia
              Hi Ken, Settings are stored for PSDR in Vista here C: Users AppData Roaming FlexRadio Systems PowerSDR v1.19.3 it is in the form of a
              Message 6 of 22 , Jan 9, 2010
              • 0 Attachment
                Hi Ken,

                Settings are stored for PSDR in Vista here

                C:\Users\<your user name>\AppData\Roaming\FlexRadio Systems\PowerSDR v1.19.3

                it is in the form of a powersdr.xml file, if you delete it then it is ok.

                73,
                Christos SV1EIA



                --- In powersdr-iq@yahoogroups.com, "Ken Lotts" <ken@...> wrote:
                >
                > I was enjoying the new version 1.19.3.6 and then I shut it down and launched
                > PowerSDR 1.18.3 for a second.. now my PowerSDR 1.19.3.6 will no longer boot
                > up.... It comes up with a list of errors. I rebooted and re-installed and
                > un installed and reinstalled again but nothing works.. I am thinking that
                > the two versions probably share somthing in the registry and something was
                > over wrote when I launched the old version. any one else have this happen?
                >
                > Here is the error:
                > http://farm3.static.flickr.com/2691/4258600926_6b0225996f_o.jpg
                >
                >
                > I know this is a pre-release.. but it is awesome. I am totally spoiled.
                > http://www.flickr.com/photos/lotts-family/4255498770/in/photostream/
                >
                > Ken Lotts
                > aa7jc
                >
              • Ken Lotts
                OK I found the fix.. Interesting that no body had replied ... From: powersdr-iq@yahoogroups.com [mailto:powersdr-iq@yahoogroups.com]On Behalf Of Ken Lotts
                Message 7 of 22 , Jan 9, 2010
                • 0 Attachment
                  OK I found the fix..  Interesting that no body had replied
                   
                   
                  -----Original Message-----
                  From: powersdr-iq@yahoogroups.com [mailto:powersdr-iq@yahoogroups.com]On Behalf Of Ken Lotts
                  Sent: Friday, January 08, 2010 9:11 PM
                  To: powersdr-iq@yahoogroups.com
                  Subject: [powersdr-iq] New PowerSDR-IQ 1.19.3.2 version -- help?

                   

                  I was enjoying the new version 1.19.3.6 and then I shut it down and launched PowerSDR 1.18.3 for a second..  now my PowerSDR 1.19.3.6 will no longer boot up....  It comes up with a list of errors.  I rebooted and re-installed and un installed and reinstalled again but nothing works.. I am thinking that the two versions probably share somthing in the registry and something was over wrote when I launched the old version.  any one else have this happen?
                   
                  Here is the error:
                   
                   
                  I know this is a pre-release. .  but it is awesome.  I am totally spoiled.
                   
                  Ken Lotts
                  aa7jc
                   

                • sv1eia
                  Hi Ken, That post did came to your reply - http://groups.yahoo.com/group/powersdr-iq/message/962
                  Message 8 of 22 , Jan 10, 2010
                  • 0 Attachment
                    Hi Ken,

                    That post did came to your reply
                    -> http://groups.yahoo.com/group/powersdr-iq/message/962


                    --- In powersdr-iq@yahoogroups.com, "Ken Lotts" <ken@...> wrote:
                    >
                    > OK I found the fix.. Interesting that no body had replied
                    >
                    >
                    > -----Original Message-----
                    > From: powersdr-iq@yahoogroups.com [mailto:powersdr-iq@yahoogroups.com]On
                    > Behalf Of Ken Lotts
                    > Sent: Friday, January 08, 2010 9:11 PM
                    > To: powersdr-iq@yahoogroups.com
                    > Subject: [powersdr-iq] New PowerSDR-IQ 1.19.3.2 version -- help?
                    >
                    >
                    >
                    >
                    > I was enjoying the new version 1.19.3.6 and then I shut it down and
                    > launched PowerSDR 1.18.3 for a second.. now my PowerSDR 1.19.3.6 will no
                    > longer boot up.... It comes up with a list of errors. I rebooted and
                    > re-installed and un installed and reinstalled again but nothing works.. I am
                    > thinking that the two versions probably share somthing in the registry and
                    > something was over wrote when I launched the old version. any one else have
                    > this happen?
                    >
                    > Here is the error:
                    > http://farm3.static.flickr.com/2691/4258600926_6b0225996f_o.jpg
                    >
                    >
                    > I know this is a pre-release.. but it is awesome. I am totally spoiled.
                    > http://www.flickr.com/photos/lotts-family/4255498770/in/photostream/
                    >
                    > Ken Lotts
                    > aa7jc
                    >
                  Your message has been successfully submitted and would be delivered to recipients shortly.