Loading ...
Sorry, an error occurred while loading the content.

Re: PowerSDR v2.4.4 for Homemade Rigs and UHFSDR

Expand Messages
  • tony_g3ovh
    Hi Venkat I checked out CFGSDR on my kit - it reports USB Si570 connected Version V15.15 Product DG8 SAQ-I2C Serial number PE0FK0-0 Tony
    Message 1 of 17 , Aug 22 3:52 PM
    • 0 Attachment
      Hi Venkat

      I checked out CFGSDR on my kit - it reports USB Si570 connected
      Version V15.15
      Product DG8 SAQ-I2C
      Serial number PE0FK0-0

      Tony

      --- In powersdr-iq@yahoogroups.com, "ab2zt" <ab2zt@...> wrote:
      >
      > Hi Tony,
      > I am trying to setup my UHFSDR with QRP2000 (minus the si570). I am able to set the freq correctly by using CFGSDR and the SI570_USB_Test. But with PowerSDR 2.4.4 X2 the freq is being set to 16x the selected freq. I am not sure if I have the right firmware version on the ATTiny chip. What does CFGSDR report as 'connected to version'? Mine says V1.4. Do you see V15.15?
      > Thanks, 73
      > Venkat
      > AB2ZT
      >
      > --- In powersdr-iq@yahoogroups.com, "tony_g3ovh" <tabbey01@> wrote:
      > >
      > > Hi Ignacio and Christos
      > >
      > > Thank you - I set up the XVTR page to use button 3 on VHF 70.0 to 70.5 with zero IF.
      > > Works a treat. I should have guessed that it might me that simple ;-)
      > > I hope anyone else watching this thread has learnt something as well.
      > >
      > > best 73's
      > > Tony
      > >
      > > --- In powersdr-iq@yahoogroups.com, "eb4apl" <eb4apl@> wrote:
      > > >
      > > > Hi,
      > > >
      > > > The BandText section of the XML file only affects the display, it doesn't allow to transmit in out-of-band frequencies. This is hard coded in the program due to some US FCC ideas regarding SDR's.
      > > >
      > > > But there is a trick that works (at least on older PowerSDR versions, I didn't tested it in the current one): configure the system using a transverter definition with a 0 Hz local oscillator, it worked for me very well.
      > > >
      > > > 73 de Ignacio EB4APL
      > > >
      > > >
      > > > --- In powersdr-iq@yahoogroups.com, "tony_g3ovh" <tabbey01@> wrote:
      > > > >
      > > > > Hi Christos
      > > > >
      > > > > Thanks for the link. Interestingly, I had already worked that out for myself, so I also get the correct indications on the tuning instead of "out of band". However, as I said in my last post, it still wont transmit - there must be another Tx prevention mechanism yet to be discovered. Maybe I have to experiment with the transverter settings, since PowerSDR doesnt expect to be able to use VHF without one.
      > > > >
      > > > > Tony
      > > > >
      > > > >
      > > > >
      > > > > --- In powersdr-iq@yahoogroups.com, "sv1eia" <sv1eia@> wrote:
      > > > > >
      > > > > > Tony,
      > > > > >
      > > > > > I have not done so, yet you could give it a try
      > > > > >
      > > > > > -> http://www.geekshed.co.uk/adding-70mhz-4m-allocation-to-flex-powersdr/
      > > > > >
      > > > > > 73,
      > > > > > Christos SV1EIA
      > > > > >
      > > > > >
      > > > > > --- In powersdr-iq@yahoogroups.com, "tony_g3ovh" <tabbey01@> wrote:
      > > > > > >
      > > > > > > Hi Christos
      > > > > > >
      > > > > > > I finally got the new ATTiny85 installed with V15.15 firmware. Now it works OK with PowerSDR V2.4.4 X2 version giving the correct receive frequency - thanks for the help.
      > > > > > > However, I now have a new problem - I want to use this for the UK 4m amateur band 70.0 to 70.5 MHz. I have edited the .xml configuration file to add the correct band texts for the band plan, but cant get Tx enabled. S/W reports "The frequency 70.200000MHz in combination with your TX filter settings [200,3100] are not within the Band specifications for your region (0)." But I can't find where these are specified. Have you emulated the SDR1000 firmware in the extensions to the original code, so that we can't transmit outside the US band plans? This wasn't a problem in PowerSDR-IQ v1.12.20 because I could tick the extended button to allow it. Help please. I'll post in the PowerSDR group as well.
      > > > > > >
      > > > > > > 73's
      > > > > > > Tony
      > > > > > >
      > > > > > >
      > > > > > > --- In powersdr-iq@yahoogroups.com, "sv1eia" <sv1eia@> wrote:
      > > > > > > >
      > > > > > > > There is no separate X 2 configuration.
      > > > > > > > That setup is exclusively for those with ATTiny controlled Si570 on UHFSDRs and has manual VFO up to 999MHz.
      > > > > > > >
      > > > > > > >
      > > > > > > > --- In powersdr-iq@yahoogroups.com, "tony_g3ovh" wrote:
      > > > > > > > >
      > > > > > > > > Hi Christos
      > > > > > > > >
      > > > > > > > > I see you have just posted "PowerSDRv2.4.4_for_Homemade_Rigs_Div2.zip". I am presuming that this is the awaited program for the UHFSDR divide by 2 Si570.
      > > > > > > > > So I downloaded your new code and updated my program files. I am sorry to report that it doesnt seem to work - there is no div 2 box to tick, and I cant even get the performance I got previously by setting 2X the received frequency. Since there is no box to tick, I presume that it is a fixed implementation of the div 2 Si570. Or perhaps I need to do a fresh install of everything, although I cannot see why.
      > > > > > > > > Any help welcome
      > > > > > > > > Tony
      > > > > > > > >
      > > > > > > > > --- In powersdr-iq@yahoogroups.com, "sv1eia" wrote:
      > > > > > > > > >
      > > > > > > > > > Hi Tony,
      > > > > > > > > >
      > > > > > > > > > Your earlier setup it was working ok from what you say, so at least you have one solution.
      > > > > > > > > >
      > > > > > > > > > The new version of things though, is targeted to the mainstream of homebrew SDR rigs having the X4 LO.
      > > > > > > > > >
      > > > > > > > > > I'll try to have a solution for your specific needs soon as I did in the past for the X2 LO of UHFSDR.
      > > > > > > > > >
      > > > > > > > > > 73,
      > > > > > > > > > Christos SV1EIA
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > > > --- In powersdr-iq@yahoogroups.com, "tony_g3ovh" wrote:
      > > > > > > > > > >
      > > > > > > > > > > I have scoured all the groups for the answer to this but have failed:
      > > > > > > > > > > I just installed PowerSDR v2.4.4 for Homemade Rigs, having been successfully using PowerSDR-IQ v 1.12.20 with the UHFSDR, Delta 44 sound card and QRP2000 USB controlled Si570 synthesiser modified to drive the SI570 on the UHFSDR. This uses the ATTiny45 programmed with DG8ASQ firmware. PowerSDR-IQ had the necessary tick box for the UHFSDR divide-by-2 operation. However, I cannot get the same functionality with the new version. It is driving the Si570 OK, but at 2X the needed frequency - i can for instance receive 70.00MHz at a setting of 35.009MHz. I found a suggestion about using SdrSi570Usb.dll, but PowerSDR v2.4.4 doesn't recognise this. I tried renaming SdrSi570Usb.dll to SdrSi570Usb.dll but that made no difference. Any help would be most welcome.
      > > > > > > > > > > Tony
      > > > > > > > > > >
      > > > > > > > > >
      > > > > > > > >
      > > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.