Loading ...
Sorry, an error occurred while loading the content.
 

Perl script using sendmail to forward spam reports

Expand Messages
  • Chris
    This is a stand-alone system. I m using postfix to forward to myself outputs of various cron-jobs and reporting spam to spam@uce.gov. I have postfix up and
    Message 1 of 15 , Jul 24 6:39 PM
      This is a stand-alone system. I'm using postfix to forward to myself
      outputs of various cron-jobs and reporting spam to spam@.... I have
      postfix up and running on this new box as it was before the crash a
      couple of weeks ago and the cronjob reports are coming in correctly.
      This script is called via a procmail recipe after SA does a markup on a
      spam message:

      Jul 24 17:37:07 localhost postfix/pickup[25093]: 1785111C10E8: uid=1000
      from=<cpollock@...>
      Jul 24 17:37:07 localhost postfix/cleanup[964]: 1785111C10E8:
      message-id=<20140724223707.1785111C10E8@...>
      Jul 24 17:37:07 localhost postfix/qmgr[12001]: 1785111C10E8:
      from=<cpollock@...>, size=14170, nrcpt=1 (queue active)
      Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
      to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
      dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)

      Here is how the header information is setup in the script:
      open(SENDMAIL, "|/usr/sbin/sendmail -f cpollock\@... -oi -t")
      || die "Cannot open sendmail output";
      print SENDMAIL <<"ENDENDEND";
      From: <cpollock\@...>
      To: <spam\@...>
      Subject: report spam
      MIME-Version: 1.0
      Content-Type: multipart/mixed;

      It's been awhile since I had to set this up and most of the settings
      from the old box worked only had to tweak a few. Here is the output of
      postconf - http://pastebin.com/1J2p7X4E The synatx of the sendmail
      commands look correct and it appears that it was sent only to bounce. I
      manually forwarded a spam to the address and it hasn't bounced yet and
      checked the FTC site and found no information about this address being
      down.

      Thanks for any advice/assistance.

      --
      Chris
      31.11°N 97.89°W (Elev. 1092 ft)
      19:51:34 up 4 days, 2:05, 2 users, load average: 0.10, 0.16, 0.24
      Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
    • Wietse Venema
      ... Look at the content of the delivery status notification. Wietse
      Message 2 of 15 , Jul 25 4:02 AM
        Chris:
        > This is a stand-alone system. I'm using postfix to forward to myself
        > outputs of various cron-jobs and reporting spam to spam@.... I have
        > postfix up and running on this new box as it was before the crash a
        > couple of weeks ago and the cronjob reports are coming in correctly.
        > This script is called via a procmail recipe after SA does a markup on a
        > spam message:
        >
        > Jul 24 17:37:07 localhost postfix/pickup[25093]: 1785111C10E8: uid=1000
        > from=<cpollock@...>
        > Jul 24 17:37:07 localhost postfix/cleanup[964]: 1785111C10E8:
        > message-id=<20140724223707.1785111C10E8@...>
        > Jul 24 17:37:07 localhost postfix/qmgr[12001]: 1785111C10E8:
        > from=<cpollock@...>, size=14170, nrcpt=1 (queue active)
        > Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
        > to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
        > dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)

        Look at the content of the delivery status notification.

        Wietse
        > Here is how the header information is setup in the script:
        > open(SENDMAIL, "|/usr/sbin/sendmail -f cpollock\@... -oi -t")
        > || die "Cannot open sendmail output";
        > print SENDMAIL <<"ENDENDEND";
        > From: <cpollock\@...>
        > To: <spam\@...>
        > Subject: report spam
        > MIME-Version: 1.0
        > Content-Type: multipart/mixed;
        >
        > It's been awhile since I had to set this up and most of the settings
        > from the old box worked only had to tweak a few. Here is the output of
        > postconf - http://pastebin.com/1J2p7X4E The synatx of the sendmail
        > commands look correct and it appears that it was sent only to bounce. I
        > manually forwarded a spam to the address and it hasn't bounced yet and
        > checked the FTC site and found no information about this address being
        > down.
        >
        > Thanks for any advice/assistance.
        >
        > --
        > Chris
        > 31.11?N 97.89?W (Elev. 1092 ft)
        > 19:51:34 up 4 days, 2:05, 2 users, load average: 0.10, 0.16, 0.24
        > Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
        >
        >
      • Chris
        ... Here is one from the first attempt yesterday: Reporting-MTA: dns; cpollock.localdomain X-Postfix-Queue-ID: 44A4311C10E8 X-Postfix-Sender: rfc822;
        Message 3 of 15 , Jul 25 7:23 AM
          On Fri, 2014-07-25 at 07:02 -0400, Wietse Venema wrote:
          > Chris:
          > > This is a stand-alone system. I'm using postfix to forward to myself
          > > outputs of various cron-jobs and reporting spam to spam@.... I have
          > > postfix up and running on this new box as it was before the crash a
          > > couple of weeks ago and the cronjob reports are coming in correctly.
          > > This script is called via a procmail recipe after SA does a markup on a
          > > spam message:
          > >
          > > Jul 24 17:37:07 localhost postfix/pickup[25093]: 1785111C10E8: uid=1000
          > > from=<cpollock@...>
          > > Jul 24 17:37:07 localhost postfix/cleanup[964]: 1785111C10E8:
          > > message-id=<20140724223707.1785111C10E8@...>
          > > Jul 24 17:37:07 localhost postfix/qmgr[12001]: 1785111C10E8:
          > > from=<cpollock@...>, size=14170, nrcpt=1 (queue active)
          > > Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
          > > to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
          > > dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)
          >
          > Look at the content of the delivery status notification.
          >
          > Wietse

          Here is one from the first attempt yesterday:

          Reporting-MTA: dns; cpollock.localdomain
          X-Postfix-Queue-ID: 44A4311C10E8
          X-Postfix-Sender: rfc822; cpollock@...
          Arrival-Date: Thu, 24 Jul 2014 17:37:22 -0500 (CDT)

          Final-Recipient: rfc822; spam@...
          Action: failed
          Status: 5.0.0
          Diagnostic-Code: X-Postfix; smtp.embarqmail.com:587

          After looking this morning I noticed that I had an 'sasl_passwd.db file
          (from the old computers backup) but didn't have the 'sasl_passwd file. I
          copied it over and ran 'postmap /etc/postfix/sasl_passwd' which created
          a new .db file. Uncommented the recipe and when an attempt was made to
          forward the next spam the delivery status showed:

          Reporting-MTA: dns; cpollock.localdomain
          X-Postfix-Queue-ID: 0CDF111C10B7
          X-Postfix-Sender: rfc822; cpollock@...
          Arrival-Date: Fri, 25 Jul 2014 08:59:31 -0500 (CDT)

          Final-Recipient: rfc822; spam@...
          Action: failed
          Status: 5.0.0
          Diagnostic-Code: X-Postfix; smtp.embarqmail.com

          looking again at my 'main.cf' I noticed that 'relayhost =
          smtp.embarqmail.com' not sure if the port number needed to be added so I
          changed it to read 'relayhost = smtp.embarqmail.com:587'. I also noticed
          that on the old backup in the /etc/postfix/SASL folder my two
          sasl_passwd files were also located there, copied them over and again
          awaiting a spam to come through to see the results. I also ran of course
          'postmap main.cf' and 'postfix reload'.


          --
          Chris
          31.11°N 97.89°W (Elev. 1092 ft)
          09:05:10 up 4 days, 15:19, 2 users, load average: 0.24, 0.34, 0.32
          Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
        • Wietse Venema
          ... You have smtp.embarqmail.com somehow routed towards the error delivery agent. This can happen when you have incorrect virtual_alias_domains settings in
          Message 4 of 15 , Jul 25 7:35 AM
            Chris:
            > Jul 24 17:37:07 localhost postfix/qmgr[12001]: 1785111C10E8:
            > from=<cpollock@...>, size=14170, nrcpt=1 (queue active)
            > Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
            > to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
            > dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)
            ...
            > Here is one from the first attempt yesterday:
            >
            > Reporting-MTA: dns; cpollock.localdomain
            > X-Postfix-Queue-ID: 44A4311C10E8
            > X-Postfix-Sender: rfc822; cpollock@...
            > Arrival-Date: Thu, 24 Jul 2014 17:37:22 -0500 (CDT)
            >
            > Final-Recipient: rfc822; spam@...
            > Action: failed
            > Status: 5.0.0
            > Diagnostic-Code: X-Postfix; smtp.embarqmail.com:587

            You have smtp.embarqmail.com somehow routed towards the error
            delivery agent. This can happen when you have incorrect
            virtual_alias_domains settings in main.cf or in master.cf.

            Let's have a look at those.

            Wietse
          • Chris
            ... Virtual_alias_maps in main.cf points to: virtual_alias_maps = hash:/etc/postfix/virtual Virtual is: cpollock@embarqmail.com chris in the backed-up
            Message 5 of 15 , Jul 25 8:25 AM
              On Fri, 2014-07-25 at 10:35 -0400, Wietse Venema wrote:
              > Chris:
              > > Jul 24 17:37:07 localhost postfix/qmgr[12001]: 1785111C10E8:
              > > from=<cpollock@...>, size=14170, nrcpt=1 (queue active)
              > > Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
              > > to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
              > > dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)
              > ...
              > > Here is one from the first attempt yesterday:
              > >
              > > Reporting-MTA: dns; cpollock.localdomain
              > > X-Postfix-Queue-ID: 44A4311C10E8
              > > X-Postfix-Sender: rfc822; cpollock@...
              > > Arrival-Date: Thu, 24 Jul 2014 17:37:22 -0500 (CDT)
              > >
              > > Final-Recipient: rfc822; spam@...
              > > Action: failed
              > > Status: 5.0.0
              > > Diagnostic-Code: X-Postfix; smtp.embarqmail.com:587
              >
              > You have smtp.embarqmail.com somehow routed towards the error
              > delivery agent. This can happen when you have incorrect
              > virtual_alias_domains settings in main.cf or in master.cf.
              >
              > Let's have a look at those.
              >
              > Wietse

              Virtual_alias_maps in main.cf points to:

              virtual_alias_maps = hash:/etc/postfix/virtual

              Virtual is:

              cpollock@... chris

              in the backed-up configuration virtual is:

              root@... cpollock@...

              I can find no virtual settings in master.cf

              Chris

              --
              Chris
              31.11°N 97.89°W (Elev. 1092 ft)
              10:20:32 up 4 days, 16:34, 2 users, load average: 0.52, 0.42, 0.31
              Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
            • Viktor Dukhovni
              ... Instead of hand-copied snippets, it is best to post the complete output of postconf -n . ... That would be virtual_alias_domains, but there could also be
              Message 6 of 15 , Jul 25 1:26 PM
                On Fri, Jul 25, 2014 at 10:25:04AM -0500, Chris wrote:

                > > > Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
                > > > to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
                > > > dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)
                > > ...
                > > > Diagnostic-Code: X-Postfix; smtp.embarqmail.com:587
                > >
                > > You have smtp.embarqmail.com somehow routed towards the error
                > > delivery agent. This can happen when you have incorrect
                > > virtual_alias_domains settings in main.cf or in master.cf.
                >
                > Virtual_alias_maps in main.cf points to:
                >
                > virtual_alias_maps = hash:/etc/postfix/virtual

                Instead of hand-copied snippets, it is best to post the complete
                output of "postconf -n".

                > I can find no virtual settings in master.cf

                That would be virtual_alias_domains, but there could also be issues
                with various main.cf transport settings or a "*" entry in the
                transport table.

                Is there "*" key in transport_maps? Otherwise, a full "postconf -n"
                should suffice.

                --
                Viktor.
              • Chris
                ... Thank you Viktor for being so patient, here is the output of postconf -n root@localhost:/etc/postfix# postconf -n alias_database =
                Message 7 of 15 , Jul 25 1:57 PM
                  On Fri, 2014-07-25 at 20:26 +0000, Viktor Dukhovni wrote:
                  > On Fri, Jul 25, 2014 at 10:25:04AM -0500, Chris wrote:
                  >
                  > > > > Jul 24 17:37:08 localhost postfix/error[988]: 1785111C10E8:
                  > > > > to=<spam@...>, relay=none, delay=1.2, delays=0.55/0.41/0/0.24,
                  > > > > dsn=5.0.0, status=bounced (smtp.embarqmail.com:587)
                  > > > ...
                  > > > > Diagnostic-Code: X-Postfix; smtp.embarqmail.com:587
                  > > >
                  > > > You have smtp.embarqmail.com somehow routed towards the error
                  > > > delivery agent. This can happen when you have incorrect
                  > > > virtual_alias_domains settings in main.cf or in master.cf.
                  > >
                  > > Virtual_alias_maps in main.cf points to:
                  > >
                  > > virtual_alias_maps = hash:/etc/postfix/virtual
                  >
                  > Instead of hand-copied snippets, it is best to post the complete
                  > output of "postconf -n".
                  >
                  > > I can find no virtual settings in master.cf
                  >
                  > That would be virtual_alias_domains, but there could also be issues
                  > with various main.cf transport settings or a "*" entry in the
                  > transport table.
                  >
                  > Is there "*" key in transport_maps? Otherwise, a full "postconf -n"
                  > should suffice.
                  >

                  Thank you Viktor for being so patient, here is the output of postconf -n

                  root@localhost:/etc/postfix# postconf -n
                  alias_database = hash:/etc/postfix/aliases.db
                  alias_maps = hash:/etc/postfix/aliases
                  append_dot_mydomain = no
                  biff = no
                  config_directory = /etc/postfix
                  data_directory = /var/lib/postfix
                  debug_peer_level = 2
                  debugger_command = PATH-/usr/bin:/usr/X11R6/bin xxgdb
                  $daemon_directory/$process_name $process_id & sleep 5
                  default_destination_concurrency_limit = 5
                  default_transport = error
                  delay_warning_time = 4h
                  home_mailbox = Maildir/
                  html_directory = /usr/share/doc/postfix/html
                  inet_interfaces = all
                  local_destination_concurrency_limit = 2
                  mail_spool_directory = /var/spool/mail
                  mailbox_command = /usr/bin/procmail -Y -a $DOMAIN
                  mailbox_size_limit = 0
                  mailq_path = /usr/bin/mailq
                  mydestination = localhost, localhost.localdomain, localhost
                  myhostname = cpollock.localdomain
                  mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
                  mynetworks_style = host
                  myorigin = /etc/mailname
                  newaliases_path = /usr/bin/newaliases
                  readme_directory = /usr/share/doc/postfix
                  recipient_delimiter = +
                  relay_transport = error
                  relayhost = smtp.embarqmail.com:587
                  sample_directory = /etc/postfix
                  sender_canonical_maps = hash:/etc/postfix/sender_canonical
                  sendmail_path = /usr/sbin/sendmail.postfix
                  setgid_group = postdrop
                  smtp_connect_timeout = 300
                  smtp_data_done_timeout = 600
                  smtp_helo_timeout = 600
                  smtp_mail_timeout = 600
                  smtp_rcpt_timeout = 300
                  smtp_sasl_auth_enable = yes
                  smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
                  smtp_sasl_security_options =
                  smtp_tls_loglevel = 2
                  smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
                  smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
                  smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated
                  defer_unauth_destination
                  smtpd_sasl_path = smtpd
                  smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
                  syslog_facility = mail
                  unknown_local_recipient_reject_code = 450
                  virtual_alias_maps = hash:/etc/postfix/virtual
                  root@localhost:/etc/postfix#

                  --
                  Chris
                  31.11°N 97.89°W (Elev. 1092 ft)
                  15:56:03 up 4 days, 22:10, 4 users, load average: 0.46, 0.51, 0.52
                  Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
                • Viktor Dukhovni
                  ... Any questions? -- Viktor.
                  Message 8 of 15 , Jul 25 2:01 PM
                    On Fri, Jul 25, 2014 at 03:57:43PM -0500, Chris wrote:

                    > > That would be virtual_alias_domains, but there could also be issues
                    > > with various main.cf transport settings or a "*" entry in the
                    > > transport table.
                    > >
                    > > Is there "*" key in transport_maps? Otherwise, a full "postconf -n"
                    > > should suffice.
                    >
                    > Thank you Viktor for being so patient, here is the output of postconf -n
                    >
                    > root@localhost:/etc/postfix# postconf -n
                    > default_transport = error
                    > mydestination = localhost, localhost.localdomain, localhost
                    > relay_transport = error
                    > relayhost = smtp.embarqmail.com:587

                    Any questions?

                    --
                    Viktor.
                  • Wietse Venema
                    ... It s like somebody took two guns and aimed at both feed. Wietse
                    Message 9 of 15 , Jul 25 2:14 PM
                      Chris:
                      > default_transport = error
                      > relay_transport = error

                      It's like somebody took two guns and aimed at both feed.

                      Wietse
                    • Chris
                      ... They should both be smtp not error, no wonder it didn t work Thank you so much, hopefully that was the only issue I had. For some reason that wasn t set
                      Message 10 of 15 , Jul 25 2:23 PM
                        On Fri, 2014-07-25 at 17:14 -0400, Wietse Venema wrote:
                        > Chris:
                        > > default_transport = error
                        > > relay_transport = error
                        >
                        > It's like somebody took two guns and aimed at both feed.
                        >
                        > Wietse

                        They should both be 'smtp' not error, no wonder it didn't work

                        Thank you so much, hopefully that was the only issue I had. For some
                        reason that wasn't set in the old backup main.cf I had.


                        --
                        Chris
                        31.11°N 97.89°W (Elev. 1092 ft)
                        16:19:17 up 4 days, 22:33, 3 users, load average: 0.02, 0.11, 0.24
                        Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
                      • Chris
                        ... I hopefully have it correct now Viktor, changed both to smtp Thank you Chris -- Chris 31.11°N 97.89°W (Elev. 1092 ft) 16:27:37 up 4 days, 22:41, 3 users,
                        Message 11 of 15 , Jul 25 2:29 PM
                          On Fri, 2014-07-25 at 21:01 +0000, Viktor Dukhovni wrote:
                          > On Fri, Jul 25, 2014 at 03:57:43PM -0500, Chris wrote:
                          >
                          > > > That would be virtual_alias_domains, but there could also be issues
                          > > > with various main.cf transport settings or a "*" entry in the
                          > > > transport table.
                          > > >
                          > > > Is there "*" key in transport_maps? Otherwise, a full "postconf -n"
                          > > > should suffice.
                          > >
                          > > Thank you Viktor for being so patient, here is the output of postconf -n
                          > >
                          > > root@localhost:/etc/postfix# postconf -n
                          > > default_transport = error
                          > > mydestination = localhost, localhost.localdomain, localhost
                          > > relay_transport = error
                          > > relayhost = smtp.embarqmail.com:587
                          >
                          > Any questions?
                          >

                          I hopefully have it correct now Viktor, changed both to smtp

                          Thank you
                          Chris

                          --
                          Chris
                          31.11°N 97.89°W (Elev. 1092 ft)
                          16:27:37 up 4 days, 22:41, 3 users, load average: 0.36, 0.21, 0.23
                          Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
                        • Viktor Dukhovni
                          ... Both have sensible defaults, instead of setting these to smtp , remove the main.cf overrides. You should have a relay transport in master.cf, which
                          Message 12 of 15 , Jul 25 2:45 PM
                            On Fri, Jul 25, 2014 at 04:29:27PM -0500, Chris wrote:

                            > > > default_transport = error
                            > > > mydestination = localhost, localhost.localdomain, localhost
                            > > > relay_transport = error
                            > > > relayhost = smtp.embarqmail.com:587
                            > >
                            > > Any questions?
                            >
                            > I hopefully have it correct now Viktor, changed both to smtp

                            Both have sensible defaults, instead of setting these to "smtp",
                            remove the main.cf overrides. You should have a "relay" transport
                            in master.cf, which will be the default value of "relay_transport".

                            --
                            Viktor.
                          • Chris
                            ... I guess I should have changed it to smtp.embarqmail.com shouldn t I. I m getting to flustered here. I thought I had it right: Jul 25 16:41:52 localhost
                            Message 13 of 15 , Jul 25 2:52 PM
                              On Fri, 2014-07-25 at 16:23 -0500, Chris wrote:
                              > On Fri, 2014-07-25 at 17:14 -0400, Wietse Venema wrote:
                              > > Chris:
                              > > > default_transport = error
                              > > > relay_transport = error
                              > >
                              > > It's like somebody took two guns and aimed at both feed.
                              > >
                              > > Wietse
                              >
                              > They should both be 'smtp' not error, no wonder it didn't work
                              >
                              > Thank you so much, hopefully that was the only issue I had. For some
                              > reason that wasn't set in the old backup main.cf I had.
                              >
                              >

                              I guess I should have changed it to smtp.embarqmail.com shouldn't I. I'm
                              getting to flustered here. I thought I had it right:

                              Jul 25 16:41:52 localhost postfix/qmgr[8309]: 9949011C10B7:
                              from=<cpollock@...>, size=7419, nrcpt=1 (queue active)
                              Jul 25 16:41:52 localhost postfix/qmgr[8309]: warning: connect to
                              transport private/smtp.embarqmail.com: No such file or directory
                              Jul 25 16:41:52 localhost postfix/error[8311]: 9949011C10B7:
                              to=<spam@...>, relay=none, delay=479, delays=479/0.01/0/0.05,
                              dsn=4.3.0, status=deferred (mail transport unavailable)


                              --
                              Chris
                              31.11°N 97.89°W (Elev. 1092 ft)
                              16:42:22 up 4 days, 22:56, 3 users, load average: 0.23, 0.28, 0.26
                              Ubuntu 14.04 LTS, kernel 3.13.0-32-generic
                            • Wietse Venema
                              ... Enough! Don t override Postfix settings before you know what you are doing. Wietse
                              Message 14 of 15 , Jul 25 3:04 PM
                                Chris:
                                > On Fri, 2014-07-25 at 16:23 -0500, Chris wrote:
                                > > On Fri, 2014-07-25 at 17:14 -0400, Wietse Venema wrote:
                                > > > Chris:
                                > > > > default_transport = error
                                > > > > relay_transport = error
                                > > >
                                > > > It's like somebody took two guns and aimed at both feed.
                                > > >
                                > > > Wietse
                                > >
                                > > They should both be 'smtp' not error, no wonder it didn't work
                                > >
                                > > Thank you so much, hopefully that was the only issue I had. For some
                                > > reason that wasn't set in the old backup main.cf I had.
                                > >
                                > >
                                >
                                > I guess I should have changed it to smtp.embarqmail.com shouldn't I. I'm
                                > getting to flustered here. I thought I had it right:
                                >
                                > Jul 25 16:41:52 localhost postfix/qmgr[8309]: 9949011C10B7:
                                > from=<cpollock@...>, size=7419, nrcpt=1 (queue active)
                                > Jul 25 16:41:52 localhost postfix/qmgr[8309]: warning: connect to
                                > transport private/smtp.embarqmail.com: No such file or directory
                                > Jul 25 16:41:52 localhost postfix/error[8311]: 9949011C10B7:
                                > to=<spam@...>, relay=none, delay=479, delays=479/0.01/0/0.05,
                                > dsn=4.3.0, status=deferred (mail transport unavailable)

                                Enough! Don't override Postfix settings before you know
                                what you are doing.

                                Wietse
                              • /dev/rob0
                                ... Sorry, this is off topic here, but I am amazed to see someone who is actually doing this. I d be equally amazed if anything useful is done with your
                                Message 15 of 15 , Jul 26 5:31 PM
                                  On Thu, Jul 24, 2014 at 08:39:20PM -0500, Chris wrote:
                                  > This is a stand-alone system. I'm using postfix to forward to
                                  > myself outputs of various cron-jobs and reporting spam to
                                  > spam@....

                                  Sorry, this is off topic here, but I am amazed to see someone who is
                                  actually doing this. I'd be equally amazed if anything useful is
                                  done with your contributions.

                                  > Thanks for any advice/assistance.

                                  I would suggest that you give up on this idea. Perhaps sign up at
                                  Spamcop and do your reporting there? At least in that case your
                                  reports can show up on an actual DNSBL, even if not one that I'd
                                  consider safe to use.

                                  To provide a small bit of on-topic information, please review your
                                  $myorigin setting. Yours was (Debian patch) "/etc/mailname". The
                                  string "@$myorigin" is appended to any unqualified localpart, as is
                                  your "chris" destination in virtual_alias_maps. Did you know that?
                                  Is that what you wanted? If not, change $myorigin or (better) use
                                  fully-qualified email addresses in your virtual aliases:

                                  # delivered to the Unix user or alias, "chris":
                                  chris@... chris@...
                                  --
                                  http://rob0.nodns4.us/
                                  Offlist GMX mail is seen only if "/dev/rob0" is in the Subject:
                                Your message has been successfully submitted and would be delivered to recipients shortly.