Loading ...
Sorry, an error occurred while loading the content.

Unexpected failure, please try later (in reply to end of DATA command)

Expand Messages
  • Pau Peris
    Hi all, while trying to send emails to the following address some_user@f-gs.jazztel.es i always get the following error message. Could any one tell where can i
    Message 1 of 11 , Jul 23, 2014
    • 0 Attachment
      Hi all,

      while trying to send emails to the following address some_user@... i always get the following error message. Could any one tell where can i look in order to find what's going wrong?

      This is the log lines generated by postfix:
      Jul 23 11:42:20 we postfix/smtpd[4998]: connect from we.webeloping.es[127.0.0.1]
      Jul 23 11:42:20 we postfix/smtpd[4998]: Anonymous TLS connection established from we.webeloping.es[127.0.0.1]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
      Jul 23 11:42:20 we postfix/smtpd[4998]: D27DA45639: client=we.webeloping.es[127.0.0.1], sasl_method=LOGIN, sasl_username=pau@...
      Jul 23 11:42:20 we postfix/cleanup[3602]: D27DA45639: message-id=<c7824778bc8c80c5190e8a50b561954a@...>
      Jul 23 11:42:20 we opendkim[5352]: D27DA45639: DKIM-Signature field added (s=default, d=example.com)
      Jul 23 11:42:20 we postfix/qmgr[5488]: D27DA45639: from=<pau@...>, size=914, nrcpt=1 (queue active)
      Jul 23 11:42:20 we amavis[28710]: (28710-08) ESMTP::10024 /var/lib/amavis/tmp/amavis-20140723T110050-28710-0MnkZg6B: <pau@...> -> <jlgv@...> SIZE=914 Received: from we.webeloping.es ([127.0.0.1]) by localhost (we.webeloping.es [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <jlgv@...>; Wed, 23 Jul 2014 11:42:20 +0200 (CEST)
      Jul 23 11:42:21 we in.imapproxyd[952]: LOGIN: 'pau@...' (127.0.0.1:60966) on existing sd [13]
      Jul 23 11:42:21 we amavis[28710]: (28710-08) dkim: VALID Author+Sender+MailFrom signature by d=example.com, From: <pau@...>, a=rsa-sha1, c=relaxed/simple, s=default, i=@example.com, ORIG [127.0.0.1]:53668
      Jul 23 11:42:21 we amavis[28710]: (28710-08) Checking: nKdhvt50UqWQ [127.0.0.1] <pau@...> -> <jlgv@...>
      Jul 23 11:42:21 we amavis[28710]: (28710-08) p001 1 Content-Type: text/plain, size: 212 B, name:
      Jul 23 11:42:22 we postfix/smtpd[4988]: 6B9D64563A: client=we.webeloping.es[127.0.0.1], orig_queue_id=D27DA45639, orig_client=we.webeloping.es[127.0.0.1]
      Jul 23 11:42:22 we postfix/cleanup[3602]: 6B9D64563A: message-id=<c7824778bc8c80c5190e8a50b561954a@...>
      Jul 23 11:42:22 we postfix/qmgr[5488]: 6B9D64563A: from=<pau@...>, size=1821, nrcpt=1 (queue active)
      Jul 23 11:42:22 we amavis[28710]: (28710-08) FWD from <pau@...> -> <jlgv@...>,BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6B9D64563A
      Jul 23 11:42:22 we amavis[28710]: (28710-08) Passed CLEAN {RelayedInternal}, LOCAL [127.0.0.1]:53668 [127.0.0.1] <pau@...> -> <jlgv@...>, Queue-ID: D27DA45639, Message-ID: <c7824778bc8c80c5190e8a50b561954a@...>, mail_id: nKdhvt50UqWQ, Hits: -3, size: 1224, queued_as: 6B9D64563A, dkim_sd=default:example.com, 1498 ms
      Jul 23 11:42:22 we amavis[28710]: (28710-08) TIMING-SA total 1384 ms - parse: 1.22 (0.1%), extract_message_metadata: 2.5 (0.2%), get_uri_detail_list: 0.70 (0.1%), tests_pri_-1000: 4.9 (0.4%), tests_pri_-950: 1.43 (0.1%), tests_pri_-900: 0.57 (0.0%), tests_pri_-400: 6 (0.4%), check_bayes: 5 (0.4%), b_tokenize: 1.53 (0.1%), b_tok_get_all: 1.19 (0.1%), b_comp_prob: 1.27 (0.1%), b_tok_touch_all: 0.10 (0.0%), b_finish: 0.34 (0.0%), tests_pri_0: 1237 (89.4%), check_spf: 0.18 (0.0%), check_dcc: 116 (8.4%), check_pyzor: 50 (3.6%), check_razor2: 1049 (75.8%), tests_pri_500: 2.8 (0.2%), tests_pri_1000: 28 (2.0%), total_awl: 26 (1.9%), check_awl: 0.12 (0.0%), update_awl: 0.03 (0.0%), learn: 91 (6.6%), b_learn: 89 (6.5%), b_count_change: 4.8 (0.3%), get_report: 0.77 (0.1%)
      Jul 23 11:42:22 we postfix/smtp[4982]: D27DA45639: to=<jlgv@...>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.6, delays=0.14/0/0/1.5, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6B9D64563A)
      Jul 23 11:42:22 we postfix/qmgr[5488]: D27DA45639: removed
      Jul 23 11:42:22 we amavis[28710]: (28710-08) size: 1224, TIMING [total 1503 ms] - SMTP greeting: 1 (0%)0, SMTP EHLO: 1 (0%)0, SMTP pre-MAIL: 1 (0%)0, SMTP pre-DATA-flush: 1 (0%)0, SMTP DATA: 40 (3%)3, check_init: 0 (0%)3, digest_hdr: 2 (0%)3, digest_body_dkim: 4 (0%)3, mime_decode: 6 (0%)4, get-file-type1: 11 (1%)4, parts_decode: 0 (0%)4, check_header: 1 (0%)4, AV-scan-1: 3 (0%)5, spam-wb-list: 1 (0%)5, SA parse: 2 (0%)5, SA check: 1381 (92%)97, decide_mail_destiny: 4 (0%)97, notif-quar: 0 (0%)97, fwd-connect: 4 (0%)97, fwd-xforward: 1 (0%)97, fwd-mail-pip: 3 (0%)98, fwd-rcpt-pip: 0 (0%)98, fwd-data-chkpnt: 0 (0%)98, write-header: 1 (0%)98, fwd-data-contents: 0 (0%)98, fwd-end-chkpnt: 26 (2%)99, prepare-dsn: 1 (0%)99, main_log_entry: 6 (0%)100, update_snmp: 2 (0%)100, SMTP pre-response: 0 (0%)100, SMTP response: 0 (0%)100, unlink-1-files: 0 (0%)100, rundown: 0 (0%)100
      Jul 23 11:42:29 we postfix/smtp[30874]: 6B9D64563A: to=<jlgv@...>, relay=mail.jazztel.es[62.14.3.193]:25, delay=7.3, delays=0.03/0/5.1/2.2, dsn=4.0.0, status=deferred (host mail.jazztel.es[62.14.3.193] said: 421 Unexpected failure, please try later (in reply to end of DATA command))
      Jul 23 11:42:33 we postfix/smtp[26963]: 50A3545590: to=<postmaster@...>, orig_to=<postmaster>, relay=aspmx.l.google.com[173.194.78.27]:25, delay=24, delays=0.04/0/11/13, dsn=2.0.0, status=sent (250 2.0.0 OK 1406108553 bp2si3713715wib.59 - gsmtp)
      Jul 23 11:42:33 we postfix/qmgr[5488]: 50A3545590: removed


      This is the bounce email it generates:
      <jlgv@...>: host mail.jazztel.es[62.14.3.193] said: 421 Unexpected
          failure, please try later (in reply to end of DATA command)

      Final-Recipient: rfc822; jlgv@...
      Original-Recipient: rfc822;jlgv@...
      Action: delayed
      Status: 4.0.0
      Remote-MTA: dns; mail.jazztel.es
      Diagnostic-Code: smtp; 421 Unexpected failure, please try later
      Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)

      Thanks in advanced!
    • lists@rhsoft.net
      ... first: don t post HTML - see the mess in the quote below ... mail.jazztel.es responded with a temporary error and so your postfix would try again later,
      Message 2 of 11 , Jul 23, 2014
      • 0 Attachment
        Am 23.07.2014 11:51, schrieb Pau Peris:
        > while trying to send emails to the following address some_user@... <mailto:some_user@...> i
        > always get the following error message. Could any one tell where can i look in order to find what's going wrong?

        first: don't post HTML - see the mess in the quote below

        > Jul 23 11:42:29 we postfix/smtp[30874]: 6B9D64563A: to=<jlgv@... <mailto:jlgv@...>>,
        > relay=mail.jazztel.es <http://mail.jazztel.es>[62.14.3.193]:25, delay=7.3, delays=0.03/0/5.1/2.2, dsn=4.0.0,
        > status=deferred (host mail.jazztel.es <http://mail.jazztel.es>[62.14.3.193] said: 421 Unexpected failure, please
        > try later (in reply to end of DATA command))

        "mail.jazztel.es" responded with a temporary error and so your postfix
        would try again later, we don't know what "Unexpected failure" could
        mean because we are not "jazztel.es"

        > This is the bounce email it generates

        Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)

        so why in the world did you enable notify about deferred mail?
        that's not default behavior - that case above normally just
        don't bother you because it is retried for 5 days, most likely
        delivered later and only if it fails finally bounced local

        however, follow the welcome message and provide "postconf -n"

        > <jlgv@... <mailto:jlgv@...>>: host mail.jazztel.es <http://mail.jazztel.es>[62.14.3.193]
        > said: 421 Unexpected
        > failure, please try later (in reply to end of DATA command)
        >
        > Final-Recipient: rfc822; jlgv@... <mailto:jlgv@...>
        > Original-Recipient: rfc822;jlgv@... <mailto:rfc822%3Bjlgv@...>
        > Action: delayed
        > Status: 4.0.0
        > Remote-MTA: dns; mail.jazztel.es <http://mail.jazztel.es>
        > Diagnostic-Code: smtp; 421 Unexpected failure, please try later
        > Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
      • Pau Peris
        Hi, excuses for the HTML text issue. I enabled notify for deferred to be able to handle and solve issues like the one exposed in this email. I didn t notice
        Message 3 of 11 , Jul 23, 2014
        • 0 Attachment
          Hi,

          excuses for the HTML text issue.

          I enabled notify for deferred to be able to handle and solve issues like the one exposed in this email.

          I didn't notice the postconf -n tip. Excuses. Here's the output: https://gist.github.com/sibok/f8a84b00918928885178

          Thanks a lot for your help!

          On Wed, Jul 23, 2014 at 12:20 PM, lists@... <lists@...> wrote:
          >
          >
          > Am 23.07.2014 11:51, schrieb Pau Peris:
          > > while trying to send emails to the following address some_user@... <mailto:some_user@...> i
          > > always get the following error message. Could any one tell where can i look in order to find what's going wrong?
          >
          > first: don't post HTML - see the mess in the quote below
          >
          > > Jul 23 11:42:29 we postfix/smtp[30874]: 6B9D64563A: to=<jlgv@... <mailto:jlgv@...>>,
          > > relay=mail.jazztel.es <http://mail.jazztel.es>[62.14.3.193]:25, delay=7.3, delays=0.03/0/5.1/2.2, dsn=4.0.0,
          > > status=deferred (host mail.jazztel.es <http://mail.jazztel.es>[62.14.3.193] said: 421 Unexpected failure, please
          > > try later (in reply to end of DATA command))
          >
          > "mail.jazztel.es" responded with a temporary error and so your postfix
          > would try again later, we don't know what "Unexpected failure" could
          > mean because we are not "jazztel.es"
          >
          > > This is the bounce email it generates
          >
          > Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
          >
          > so why in the world did you enable notify about deferred mail?
          > that's not default behavior - that case above normally just
          > don't bother you because it is retried for 5 days, most likely
          > delivered later and only if it fails finally bounced local
          >
          > however, follow the welcome message and provide "postconf -n"
          >
          > > <jlgv@... <mailto:jlgv@...>>: host mail.jazztel.es <http://mail.jazztel.es>[62.14.3.193]
          > > said: 421 Unexpected
          > >     failure, please try later (in reply to end of DATA command)
          > >
          > > Final-Recipient: rfc822; jlgv@... <mailto:jlgv@...>
          > > Original-Recipient: rfc822;jlgv@... <mailto:rfc822%3Bjlgv@...>
          > > Action: delayed
          > > Status: 4.0.0
          > > Remote-MTA: dns; mail.jazztel.es <http://mail.jazztel.es>
          > > Diagnostic-Code: smtp; 421 Unexpected failure, please try later
          > > Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
        • lists@rhsoft.net
          ... so you are aware that you enabled that notifies? then solve the issue on the side of jazztel.es you can t? well, and that is why these notifies are
          Message 4 of 11 , Jul 23, 2014
          • 0 Attachment
            Am 23.07.2014 12:33, schrieb Pau Peris:
            > I enabled notify for deferred to be able to handle and solve issues
            > like the one exposed in this email

            so you are aware that you enabled that notifies?

            then solve the issue on the side of "jazztel.es"
            you can't?

            well, and that is why these notifies are useless or at least
            enable them and then ask a 3rd party (the list) how to deal
            with something nobody but the admin of the RCPT server can
            answer

            > I didn't notice the postconf -n tip. Excuses. Here's the output: https://gist.github.com/sibok/f8a84b00918928885178

            no external references, please try to understand how list archives
            work - external references sooner or later go away and if a
            thread could be helpful it get lost of his references

            anyways, it's not needed because you statet your two mistakes:

            * enable non-default behavior
            * complete wrong reaction because of the non-default behavior

            so you have three solutions:

            * revert the config change
            * ignore that mails
            * ask each and every RCPT admin why deferred - i wish you luck with that

            > On Wed, Jul 23, 2014 at 12:20 PM, lists@... <mailto:lists@...> <lists@...
            > <mailto:lists@...>> wrote:
            >>
            >> Am 23.07.2014 11:51, schrieb Pau Peris:
            >> > while trying to send emails to the following address some_user@...
            > <mailto:some_user@...> <mailto:some_user@... <mailto:some_user@...>> i
            >> > always get the following error message. Could any one tell where can i look in order to find what's going wrong?
            >>
            >> first: don't post HTML - see the mess in the quote below
            >>
            >> > Jul 23 11:42:29 we postfix/smtp[30874]: 6B9D64563A: to=<jlgv@... <mailto:jlgv@...>
            > <mailto:jlgv@... <mailto:jlgv@...>>>,
            >> > relay=mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193]:25, delay=7.3,
            > delays=0.03/0/5.1/2.2, dsn=4.0.0,
            >> > status=deferred (host mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193] said: 421
            > Unexpected failure, please
            >> > try later (in reply to end of DATA command))
            >>
            >> "mail.jazztel.es <http://mail.jazztel.es>" responded with a temporary error and so your postfix
            >> would try again later, we don't know what "Unexpected failure" could
            >> mean because we are not "jazztel.es <http://jazztel.es>"
            >>
            >> > This is the bounce email it generates
            >>
            >> Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
            >>
            >> so why in the world did you enable notify about deferred mail?
            >> that's not default behavior - that case above normally just
            >> don't bother you because it is retried for 5 days, most likely
            >> delivered later and only if it fails finally bounced local
            >>
            >> however, follow the welcome message and provide "postconf -n"
            >>
            >> > <jlgv@... <mailto:jlgv@...> <mailto:jlgv@...
            > <mailto:jlgv@...>>>: host mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193]
            >> > said: 421 Unexpected
            >> > failure, please try later (in reply to end of DATA command)
            >> >
            >> > Final-Recipient: rfc822; jlgv@... <mailto:jlgv@...> <mailto:jlgv@...
            > <mailto:jlgv@...>>
            >> > Original-Recipient: rfc822;jlgv@... <mailto:rfc822%3Bjlgv@...>
            > <mailto:rfc822%3Bjlgv@... <mailto:rfc822%253Bjlgv@...>>
            >> > Action: delayed
            >> > Status: 4.0.0
            >> > Remote-MTA: dns; mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>
            >> > Diagnostic-Code: smtp; 421 Unexpected failure, please try later
            >> > Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
          • Pau Peris
            I m perfectly able to send and receive emails to/from that address through Google Apps. So that s why enabled such config, to be able to know when things went
            Message 5 of 11 , Jul 23, 2014
            • 0 Attachment
              I'm perfectly able to send and receive emails to/from that address
              through Google Apps. So that's why enabled such config, to be able to
              know when things went wrong for the users of our email system.

              Altough i really appreciate your time and effort trying to help but
              the options provided can't help me to solve that issue.

              postconf -n

              2bounce_notice_recipient = $delay_notice_recipient
              alias_database = hash:/etc/postfix/aliases
              alias_maps = hash:/etc/postfix/aliases
              biff = no
              broken_sasl_auth_clients = no
              command_directory = /usr/sbin
              config_directory = /etc/postfix
              content_filter = amavis:[127.0.0.1]:10024
              daemon_directory = /usr/lib/postfix
              data_directory = /var/lib/postfix
              debug_peer_level = 2
              debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
              ddd $daemon_directory/$process_name $process_id & sleep 5
              delay_notice_recipient = admin
              delay_warning_time = 30m
              disable_vrfy_command = yes
              inet_interfaces = all
              inet_protocols = all
              lmtp_tls_session_cache_database = btree:/var/lib/postfix/lmtp_scache
              local_recipient_maps =
              mail_owner = postfix
              mailbox_size_limit = 512000000
              mailq_path = /usr/bin/mailq.postfix
              masquerade_domains = mail.webeloping.es mail.webeloping.com
              we.webeloping.es we.webeloping.com www.webeloping.es
              www.webeloping.com
              maximal_backoff_time = 8000s
              maximal_queue_lifetime = 5d
              message_size_limit = 36700160
              milter_DKIM = inet:localhost:8891
              milter_default_action = accept
              milter_protocol = 6
              minimal_backoff_time = 1000s
              mydestination =
              mydomain = webeloping.es
              myhostname = we.webeloping.es
              mynetworks_style = host
              myorigin = webeloping.es
              newaliases_path = /usr/bin/newaliases.postfix
              non_smtpd_milters = $milter_DKIM
              notify_classes = bounce, delay, policy, protocol, resource, software
              policy-spf_time_limit = 3600s
              queue_directory = /var/spool/postfix
              receive_override_options = no_address_mappings
              relayhost =
              relocated_maps = proxy:mysql:/etc/postfix/mysql_relocated.cf
              sender_canonical_maps = hash:/etc/postfix/generic
              sendmail_path = /usr/sbin/sendmail.postfix
              setgid_group = postdrop
              show_user_unknown_table_name = no
              smtp_generic_maps = hash:/etc/postfix/generic
              smtp_helo_timeout = 60s
              smtp_tls_CAfile = $smtpd_tls_CAfile
              smtp_tls_CApath = $smtpd_tls_CApath
              smtp_tls_cert_file = $smtpd_tls_cert_file
              smtp_tls_key_file = $smtpd_tls_key_file
              smtp_tls_note_starttls_offer = yes
              smtp_tls_security_level = may
              smtp_tls_session_cache_database = btree:/var/lib/postfix/smtp_scache
              smtpd_banner = $myhostname ESMTP $mail_name
              smtpd_client_restrictions = reject_rbl_client blackholes.easynet.nl,
              reject_rbl_client zen.spamhaus.org, reject_rbl_client bl.spamcop.net,
              ,check_client_access regexp:/etc/postfix/client_restrictions permit
              smtpd_data_restrictions = reject_unauth_pipelining
              smtpd_delay_reject = yes
              smtpd_error_sleep_time = 5
              smtpd_hard_error_limit = 12
              smtpd_helo_required = yes
              smtpd_helo_restrictions = permit_sasl_authenticated,
              reject_non_fqdn_hostname, reject_invalid_hostname,
              reject_unknown_helo_hostname, reject_rhsbl_helo dbl.spamhaus.org,
              permit
              smtpd_junk_command_limit = 5
              smtpd_milters = $milter_DKIM
              smtpd_recipient_limit = 16
              smtpd_recipient_restrictions = reject_unauth_pipelining,
              reject_non_fqdn_recipient, reject_unknown_recipient_domain,
              permit_sasl_authenticated, check_policy_service
              unix:private/policy-spf, reject_unauth_destination,
              check_policy_service inet:127.0.0.1:10023, ,permit
              smtpd_relay_restrictions = permit_mynetworks,
              permit_sasl_authenticated, reject_unauth_destination
              smtpd_sasl_auth_enable = no
              smtpd_sasl_local_domain =
              smtpd_sasl_security_options = noanonymous
              smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql_sender_login_maps.cf
              smtpd_sender_restrictions = reject_non_fqdn_sender,
              reject_unknown_sender_domain, reject_rhsbl_sender dbl.spamhaus.org,
              reject_unlisted_sender, reject_authenticated_sender_login_mismatch,
              permit_sasl_authenticated, permit_dnswl_client list.dnswl.org, permit
              smtpd_soft_error_limit = 3
              smtpd_tls_CAfile = /etc/ssl/certs/startssl_ca-bundle.pem.pem
              smtpd_tls_CApath = /etc/ssl/certs
              smtpd_tls_cert_file = /etc/ssl/certs/class2.webeloping_es.pem
              smtpd_tls_key_file = /etc/ssl/private/class2.webeloping_es.key
              smtpd_tls_loglevel = 1
              smtpd_tls_received_header = yes
              smtpd_tls_security_level = may
              smtpd_tls_session_cache_database = btree:/var/lib/postfix/smtpd_scache
              smtpd_tls_session_cache_timeout = 3600s
              strict_rfc821_envelopes = no
              tls_random_source = dev:/dev/urandom
              transport_maps = proxy:mysql:/etc/postfix/mysql_transport.cf
              transport_retry_time = 30s
              unknown_local_recipient_reject_code = 450
              virtual_alias_maps = proxy:mysql:/etc/postfix/mysql_alias.cf,
              proxy:mysql:/etc/postfix/mysql_email2email.cf
              virtual_gid_maps = static:5000
              virtual_mailbox_base = /var/spool/mail/virtual
              virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql_domains.cf
              virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql_mailbox.cf
              virtual_minimum_uid = 5000
              virtual_uid_maps = static:5000


              Thanks again,


              On Wed, Jul 23, 2014 at 12:42 PM, lists@... <lists@...> wrote:
              >
              >
              > Am 23.07.2014 12:33, schrieb Pau Peris:
              > > I enabled notify for deferred to be able to handle and solve issues
              > > like the one exposed in this email
              >
              > so you are aware that you enabled that notifies?
              >
              > then solve the issue on the side of "jazztel.es"
              > you can't?
              >
              > well, and that is why these notifies are useless or at least
              > enable them and then ask a 3rd party (the list) how to deal
              > with something nobody but the admin of the RCPT server can
              > answer
              >
              > > I didn't notice the postconf -n tip. Excuses. Here's the output: https://gist.github.com/sibok/f8a84b00918928885178
              >
              > no external references, please try to understand how list archives
              > work - external references sooner or later go away and if a
              > thread could be helpful it get lost of his references
              >
              > anyways, it's not needed because you statet your two mistakes:
              >
              > * enable non-default behavior
              > * complete wrong reaction because of the non-default behavior
              >
              > so you have three solutions:
              >
              > * revert the config change
              > * ignore that mails
              > * ask each and every RCPT admin why deferred - i wish you luck with that
              >
              > > On Wed, Jul 23, 2014 at 12:20 PM, lists@... <mailto:lists@...> <lists@...
              > > <mailto:lists@...>> wrote:
              > >>
              > >> Am 23.07.2014 11:51, schrieb Pau Peris:
              > >> > while trying to send emails to the following address some_user@...
              > > <mailto:some_user@...> <mailto:some_user@... <mailto:some_user@...>> i
              > >> > always get the following error message. Could any one tell where can i look in order to find what's going wrong?
              > >>
              > >> first: don't post HTML - see the mess in the quote below
              > >>
              > >> > Jul 23 11:42:29 we postfix/smtp[30874]: 6B9D64563A: to=<jlgv@... <mailto:jlgv@...>
              > > <mailto:jlgv@... <mailto:jlgv@...>>>,
              > >> > relay=mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193]:25, delay=7.3,
              > > delays=0.03/0/5.1/2.2, dsn=4.0.0,
              > >> > status=deferred (host mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193] said: 421
              > > Unexpected failure, please
              > >> > try later (in reply to end of DATA command))
              > >>
              > >> "mail.jazztel.es <http://mail.jazztel.es>" responded with a temporary error and so your postfix
              > >> would try again later, we don't know what "Unexpected failure" could
              > >> mean because we are not "jazztel.es <http://jazztel.es>"
              > >>
              > >> > This is the bounce email it generates
              > >>
              > >> Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
              > >>
              > >> so why in the world did you enable notify about deferred mail?
              > >> that's not default behavior - that case above normally just
              > >> don't bother you because it is retried for 5 days, most likely
              > >> delivered later and only if it fails finally bounced local
              > >>
              > >> however, follow the welcome message and provide "postconf -n"
              > >>
              > >> > <jlgv@... <mailto:jlgv@...> <mailto:jlgv@...
              > > <mailto:jlgv@...>>>: host mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193]
              > >> > said: 421 Unexpected
              > >> > failure, please try later (in reply to end of DATA command)
              > >> >
              > >> > Final-Recipient: rfc822; jlgv@... <mailto:jlgv@...> <mailto:jlgv@...
              > > <mailto:jlgv@...>>
              > >> > Original-Recipient: rfc822;jlgv@... <mailto:rfc822%3Bjlgv@...>
              > > <mailto:rfc822%3Bjlgv@... <mailto:rfc822%253Bjlgv@...>>
              > >> > Action: delayed
              > >> > Status: 4.0.0
              > >> > Remote-MTA: dns; mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>
              > >> > Diagnostic-Code: smtp; 421 Unexpected failure, please try later
              > >> > Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
            • lists@rhsoft.net
              ... you need to contact jazztel.es they reject the message with a unhelpful resonse text only they know why
              Message 6 of 11 , Jul 23, 2014
              • 0 Attachment
                Am 23.07.2014 13:30, schrieb Pau Peris:
                > I'm perfectly able to send and receive emails to/from that address
                > through Google Apps. So that's why enabled such config, to be able to
                > know when things went wrong for the users of our email system.

                you need to contact "jazztel.es"
                they reject the message with a unhelpful resonse text
                only they know why

                > Altough i really appreciate your time and effort trying to help but
                > the options provided can't help me to solve that issue.
                >
                > postconf -n
                >
                > 2bounce_notice_recipient = $delay_notice_recipient
                > alias_database = hash:/etc/postfix/aliases
                > alias_maps = hash:/etc/postfix/aliases
                > biff = no
                > broken_sasl_auth_clients = no
                > command_directory = /usr/sbin
                > config_directory = /etc/postfix
                > content_filter = amavis:[127.0.0.1]:10024
                > daemon_directory = /usr/lib/postfix
                > data_directory = /var/lib/postfix
                > debug_peer_level = 2
                > debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
                > ddd $daemon_directory/$process_name $process_id & sleep 5
                > delay_notice_recipient = admin
                > delay_warning_time = 30m
                > disable_vrfy_command = yes
                > inet_interfaces = all
                > inet_protocols = all
                > lmtp_tls_session_cache_database = btree:/var/lib/postfix/lmtp_scache
                > local_recipient_maps =
                > mail_owner = postfix
                > mailbox_size_limit = 512000000
                > mailq_path = /usr/bin/mailq.postfix
                > masquerade_domains = mail.webeloping.es mail.webeloping.com
                > we.webeloping.es we.webeloping.com www.webeloping.es
                > www.webeloping.com
                > maximal_backoff_time = 8000s
                > maximal_queue_lifetime = 5d
                > message_size_limit = 36700160
                > milter_DKIM = inet:localhost:8891
                > milter_default_action = accept
                > milter_protocol = 6
                > minimal_backoff_time = 1000s
                > mydestination =
                > mydomain = webeloping.es
                > myhostname = we.webeloping.es
                > mynetworks_style = host
                > myorigin = webeloping.es
                > newaliases_path = /usr/bin/newaliases.postfix
                > non_smtpd_milters = $milter_DKIM
                > notify_classes = bounce, delay, policy, protocol, resource, software
                > policy-spf_time_limit = 3600s
                > queue_directory = /var/spool/postfix
                > receive_override_options = no_address_mappings
                > relayhost =
                > relocated_maps = proxy:mysql:/etc/postfix/mysql_relocated.cf
                > sender_canonical_maps = hash:/etc/postfix/generic
                > sendmail_path = /usr/sbin/sendmail.postfix
                > setgid_group = postdrop
                > show_user_unknown_table_name = no
                > smtp_generic_maps = hash:/etc/postfix/generic
                > smtp_helo_timeout = 60s
                > smtp_tls_CAfile = $smtpd_tls_CAfile
                > smtp_tls_CApath = $smtpd_tls_CApath
                > smtp_tls_cert_file = $smtpd_tls_cert_file
                > smtp_tls_key_file = $smtpd_tls_key_file
                > smtp_tls_note_starttls_offer = yes
                > smtp_tls_security_level = may
                > smtp_tls_session_cache_database = btree:/var/lib/postfix/smtp_scache
                > smtpd_banner = $myhostname ESMTP $mail_name
                > smtpd_client_restrictions = reject_rbl_client blackholes.easynet.nl,
                > reject_rbl_client zen.spamhaus.org, reject_rbl_client bl.spamcop.net,
                > ,check_client_access regexp:/etc/postfix/client_restrictions permit
                > smtpd_data_restrictions = reject_unauth_pipelining
                > smtpd_delay_reject = yes
                > smtpd_error_sleep_time = 5
                > smtpd_hard_error_limit = 12
                > smtpd_helo_required = yes
                > smtpd_helo_restrictions = permit_sasl_authenticated,
                > reject_non_fqdn_hostname, reject_invalid_hostname,
                > reject_unknown_helo_hostname, reject_rhsbl_helo dbl.spamhaus.org,
                > permit
                > smtpd_junk_command_limit = 5
                > smtpd_milters = $milter_DKIM
                > smtpd_recipient_limit = 16
                > smtpd_recipient_restrictions = reject_unauth_pipelining,
                > reject_non_fqdn_recipient, reject_unknown_recipient_domain,
                > permit_sasl_authenticated, check_policy_service
                > unix:private/policy-spf, reject_unauth_destination,
                > check_policy_service inet:127.0.0.1:10023, ,permit
                > smtpd_relay_restrictions = permit_mynetworks,
                > permit_sasl_authenticated, reject_unauth_destination
                > smtpd_sasl_auth_enable = no
                > smtpd_sasl_local_domain =
                > smtpd_sasl_security_options = noanonymous
                > smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql_sender_login_maps.cf
                > smtpd_sender_restrictions = reject_non_fqdn_sender,
                > reject_unknown_sender_domain, reject_rhsbl_sender dbl.spamhaus.org,
                > reject_unlisted_sender, reject_authenticated_sender_login_mismatch,
                > permit_sasl_authenticated, permit_dnswl_client list.dnswl.org, permit
                > smtpd_soft_error_limit = 3
                > smtpd_tls_CAfile = /etc/ssl/certs/startssl_ca-bundle.pem.pem
                > smtpd_tls_CApath = /etc/ssl/certs
                > smtpd_tls_cert_file = /etc/ssl/certs/class2.webeloping_es.pem
                > smtpd_tls_key_file = /etc/ssl/private/class2.webeloping_es.key
                > smtpd_tls_loglevel = 1
                > smtpd_tls_received_header = yes
                > smtpd_tls_security_level = may
                > smtpd_tls_session_cache_database = btree:/var/lib/postfix/smtpd_scache
                > smtpd_tls_session_cache_timeout = 3600s
                > strict_rfc821_envelopes = no
                > tls_random_source = dev:/dev/urandom
                > transport_maps = proxy:mysql:/etc/postfix/mysql_transport.cf
                > transport_retry_time = 30s
                > unknown_local_recipient_reject_code = 450
                > virtual_alias_maps = proxy:mysql:/etc/postfix/mysql_alias.cf,
                > proxy:mysql:/etc/postfix/mysql_email2email.cf
                > virtual_gid_maps = static:5000
                > virtual_mailbox_base = /var/spool/mail/virtual
                > virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql_domains.cf
                > virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql_mailbox.cf
                > virtual_minimum_uid = 5000
                > virtual_uid_maps = static:5000
                >
                >
                > Thanks again,
                >
                >
                > On Wed, Jul 23, 2014 at 12:42 PM, lists@... <lists@...> wrote:
                >>
                >>
                >> Am 23.07.2014 12:33, schrieb Pau Peris:
                >>> I enabled notify for deferred to be able to handle and solve issues
                >>> like the one exposed in this email
                >>
                >> so you are aware that you enabled that notifies?
                >>
                >> then solve the issue on the side of "jazztel.es"
                >> you can't?
                >>
                >> well, and that is why these notifies are useless or at least
                >> enable them and then ask a 3rd party (the list) how to deal
                >> with something nobody but the admin of the RCPT server can
                >> answer
                >>
                >>> I didn't notice the postconf -n tip. Excuses. Here's the output: https://gist.github.com/sibok/f8a84b00918928885178
                >>
                >> no external references, please try to understand how list archives
                >> work - external references sooner or later go away and if a
                >> thread could be helpful it get lost of his references
                >>
                >> anyways, it's not needed because you statet your two mistakes:
                >>
                >> * enable non-default behavior
                >> * complete wrong reaction because of the non-default behavior
                >>
                >> so you have three solutions:
                >>
                >> * revert the config change
                >> * ignore that mails
                >> * ask each and every RCPT admin why deferred - i wish you luck with that
                >>
                >>> On Wed, Jul 23, 2014 at 12:20 PM, lists@... <mailto:lists@...> <lists@...
                >>> <mailto:lists@...>> wrote:
                >>>>
                >>>> Am 23.07.2014 11:51, schrieb Pau Peris:
                >>>>> while trying to send emails to the following address some_user@...
                >>> <mailto:some_user@...> <mailto:some_user@... <mailto:some_user@...>> i
                >>>>> always get the following error message. Could any one tell where can i look in order to find what's going wrong?
                >>>>
                >>>> first: don't post HTML - see the mess in the quote below
                >>>>
                >>>>> Jul 23 11:42:29 we postfix/smtp[30874]: 6B9D64563A: to=<jlgv@... <mailto:jlgv@...>
                >>> <mailto:jlgv@... <mailto:jlgv@...>>>,
                >>>>> relay=mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193]:25, delay=7.3,
                >>> delays=0.03/0/5.1/2.2, dsn=4.0.0,
                >>>>> status=deferred (host mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193] said: 421
                >>> Unexpected failure, please
                >>>>> try later (in reply to end of DATA command))
                >>>>
                >>>> "mail.jazztel.es <http://mail.jazztel.es>" responded with a temporary error and so your postfix
                >>>> would try again later, we don't know what "Unexpected failure" could
                >>>> mean because we are not "jazztel.es <http://jazztel.es>"
                >>>>
                >>>>> This is the bounce email it generates
                >>>>
                >>>> Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
                >>>>
                >>>> so why in the world did you enable notify about deferred mail?
                >>>> that's not default behavior - that case above normally just
                >>>> don't bother you because it is retried for 5 days, most likely
                >>>> delivered later and only if it fails finally bounced local
                >>>>
                >>>> however, follow the welcome message and provide "postconf -n"
                >>>>
                >>>>> <jlgv@... <mailto:jlgv@...> <mailto:jlgv@...
                >>> <mailto:jlgv@...>>>: host mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>[62.14.3.193]
                >>>>> said: 421 Unexpected
                >>>>> failure, please try later (in reply to end of DATA command)
                >>>>>
                >>>>> Final-Recipient: rfc822; jlgv@... <mailto:jlgv@...> <mailto:jlgv@...
                >>> <mailto:jlgv@...>>
                >>>>> Original-Recipient: rfc822;jlgv@... <mailto:rfc822%3Bjlgv@...>
                >>> <mailto:rfc822%3Bjlgv@... <mailto:rfc822%253Bjlgv@...>>
                >>>>> Action: delayed
                >>>>> Status: 4.0.0
                >>>>> Remote-MTA: dns; mail.jazztel.es <http://mail.jazztel.es> <http://mail.jazztel.es>
                >>>>> Diagnostic-Code: smtp; 421 Unexpected failure, please try later
                >>>>> Will-Retry-Until: Sun, 27 Jul 2014 08:53:45 +0200 (CEST)
              • D'Arcy J.M. Cain
                On Wed, 23 Jul 2014 13:30:35 +0200 ... So you have discovered that Google knows how to run an email system and if they are getting temporary errors they are
                Message 7 of 11 , Jul 23, 2014
                • 0 Attachment
                  On Wed, 23 Jul 2014 13:30:35 +0200
                  Pau Peris <pau@...> wrote:
                  > I'm perfectly able to send and receive emails to/from that address
                  > through Google Apps. So that's why enabled such config, to be able to

                  So you have discovered that Google knows how to run an email system and
                  if they are getting temporary errors they are not notifying you about
                  each one. You have received advice suggesting that you follow the same
                  practice. You sound like "Doctor, it hurts when I do this". Just
                  don't do that.

                  Revert off that notify change as has been suggested. Then check your
                  queue (mailq) from time to time to see if messages stay in the queue
                  for a long time. If some hosts are not accepting your email for a long
                  time then contact them and ask them why.

                  If there is an actual problem here it is not something you can fix so
                  asking here again won't get you any further. Follow the advice that
                  you have already received.

                  > Altough i really appreciate your time and effort trying to help but
                  > the options provided can't help me to solve that issue.

                  Not if you won't follow the advice it won't. Revert your change and
                  follow up when the email bounces. Keep an eye on the mail queue if the
                  time to bounce (maximal_queue_lifetime) is too long or reduce that but
                  not too much. I find 3d long enough these days.

                  Also, have you checked to see if you are on any blacklists?

                  --
                  D'Arcy J.M. Cain
                  System Administrator, Vex.Net
                  http://www.Vex.Net/ IM:darcy@...
                  VoIP: sip:darcy@...
                • Viktor Dukhovni
                  ... It is perhaps OK to enable delay notifications to the sender, but I would raise the warning time to at least 2 hours. A 30 minute warning is too early,
                  Message 8 of 11 , Jul 23, 2014
                  • 0 Attachment
                    On Wed, Jul 23, 2014 at 01:30:35PM +0200, Pau Peris wrote:

                    > postconf -n
                    >
                    > 2bounce_notice_recipient = $delay_notice_recipient
                    > delay_notice_recipient = admin
                    > delay_warning_time = 30m

                    It is perhaps OK to enable delay notifications to the sender, but
                    I would raise the warning time to at least 2 hours. A 30 minute
                    warning is too early, some remote sites may be greylisting for
                    approximately that long, or may not resolve problems quite that
                    quickly. I don't recommend per event postmaster notices, they can
                    compound queue congestion. It is far better to get aggregate data
                    from log parsing.

                    I usually set:

                    # No email notices
                    notify_classes =

                    --
                    Viktor.
                  • Pau Peris
                    Hi all, i understand the whole point but the issue i was asking for help is not about trying to stop that bounce message but to understand why Jazztel is
                    Message 9 of 11 , Jul 23, 2014
                    • 0 Attachment
                      Hi all,

                      i understand the whole point but the issue i was asking for help is
                      not about trying to stop that bounce message but to understand why
                      Jazztel is blocking our emails while it's not doing the same for
                      Google Apps/Gmail sent emails.

                      I really appreciate you people trying to help, but i feel like we
                      ended up offtopic. I mean, although D'Arcy J.M. Cain insists on
                      notify_classes settings the issue is not here, as i said Google
                      manages to sucessfully send emails to that Jazztel direction while i'm
                      not able to, and that's not a matter related to notify_classes Anyway,
                      it looks like i could only solve that issue by talking to Jazztel
                      sysadmins.

                      Thanks all,

                      On Wed, Jul 23, 2014 at 4:24 PM, Viktor Dukhovni
                      <postfix-users@...> wrote:
                      > On Wed, Jul 23, 2014 at 01:30:35PM +0200, Pau Peris wrote:
                      >
                      >> postconf -n
                      >>
                      >> 2bounce_notice_recipient = $delay_notice_recipient
                      >> delay_notice_recipient = admin
                      >> delay_warning_time = 30m
                      >
                      > It is perhaps OK to enable delay notifications to the sender, but
                      > I would raise the warning time to at least 2 hours. A 30 minute
                      > warning is too early, some remote sites may be greylisting for
                      > approximately that long, or may not resolve problems quite that
                      > quickly. I don't recommend per event postmaster notices, they can
                      > compound queue congestion. It is far better to get aggregate data
                      > from log parsing.
                      >
                      > I usually set:
                      >
                      > # No email notices
                      > notify_classes =
                      >
                      > --
                      > Viktor.
                    • Wietse Venema
                      ... Only the Jazztel people can tell you why delivery fails. Meanwhile, you could have a look at DNS blocklists and see if your IP address is listed, perhaps
                      Message 10 of 11 , Jul 23, 2014
                      • 0 Attachment
                        Pau Peris:
                        > Hi all,
                        >
                        > i understand the whole point but the issue i was asking for help is
                        > not about trying to stop that bounce message but to understand why
                        > Jazztel is blocking our emails while it's not doing the same for
                        > Google Apps/Gmail sent emails.

                        Only the Jazztel people can tell you why delivery fails.

                        Meanwhile, you could have a look at DNS blocklists and see if your
                        IP address is listed, perhaps http://www.dnsbl.info/

                        Wietse
                      • Pau Peris
                        Thanks Wietse, i already checked arising successful results. Thx again.
                        Message 11 of 11 , Jul 23, 2014
                        • 0 Attachment
                          Thanks Wietse, i already checked arising successful results.

                          Thx again.

                          On Wed, Jul 23, 2014 at 7:37 PM, Wietse Venema <wietse@...> wrote:
                          > Pau Peris:
                          >> Hi all,
                          >>
                          >> i understand the whole point but the issue i was asking for help is
                          >> not about trying to stop that bounce message but to understand why
                          >> Jazztel is blocking our emails while it's not doing the same for
                          >> Google Apps/Gmail sent emails.
                          >
                          > Only the Jazztel people can tell you why delivery fails.
                          >
                          > Meanwhile, you could have a look at DNS blocklists and see if your
                          > IP address is listed, perhaps http://www.dnsbl.info/
                          >
                          > Wietse
                        Your message has been successfully submitted and would be delivered to recipients shortly.