Loading ...
Sorry, an error occurred while loading the content.
Skip to search.
 

Using master.cf to modify main.cf options

Expand Messages
  • Rob Tanner
    We use Mandrill (a MailChimp offering) for the Admissions Office bulk emailing to perspective students. We have now set up a second Mandrill account that has
    Message 1 of 2 , Mar 24, 2014
      We use Mandrill (a MailChimp offering) for the Admissions Office bulk emailing to perspective students.  We have now set up a second Mandrill account that has to authenticate with a different username/password (or key as Mandrill calls it).  The key is mapped to this hash below.

       smtp_sasl_password_maps=hash:/etc/postfix/sasl_passwd

      For the second account, I have created a second password file, sasl_passwd_campus and I’ve configured master.cf as follows:

      smtp      inet  n       -       n       -       -       smtpd
      2025      inet  n       -       n       -       -       smtpd
       -o smtp_sasl_password_maps=hash:/etc/postfix/sasl_passwd_campus

      My expectation is that when I connect to Postfix on port 2025, the one map will override the other, but it doesn’t appear to be doing do.  All the messages being delivered to Mandrill are coming in on the Admissions account and not the new second account.

      What am I doing wrong here?

      Thanks,


      Rob Tanner
      UNIX Services Manager
      Linfield College, McMinnville Oregon

      ITS will never ask you for your password.  Please don’t share yours with anyone!

    • Viktor Dukhovni
      ... This makes no sense, the setting is Postfix SMTP *client* setting, but you re applying to a Postfix SMTP *server* instance. ... The SMTP server makes no
      Message 2 of 2 , Mar 24, 2014
        On Mon, Mar 24, 2014 at 10:48:43PM +0000, Rob Tanner wrote:

        > For the second account, I have created a second password file,
        > sasl_passwd_campus and I've configured master.cf as follows:
        >
        > smtp inet n - n - - smtpd
        > 2025 inet n - n - - smtpd
        > -o smtp_sasl_password_maps=hash:/etc/postfix/sasl_passwd_campus

        This makes no sense, the setting is Postfix SMTP *client* setting,
        but you're applying to a Postfix SMTP *server* instance.

        > My expectation is that when I connect to Postfix on port 2025,
        > the one map will override the other, but it doesn't appear to be
        > doing it.

        The SMTP server makes no use of this parameter. What real problem
        are you trying to solve? In other words, what do you want to do
        differently with email that you were planning to receive on port
        2025.


        > All the messages being delivered to Mandrill are coming
        > in on the Admissions account and not the new second account.
        >
        > What am I doing wrong here?

        Mostly not yet asking the right question. Ask for help with your
        real problem (describe it in detail) not the tentative solution
        that is not working, and may not be the right approach.

        --
        Viktor.
      Your message has been successfully submitted and would be delivered to recipients shortly.