Loading ...
Sorry, an error occurred while loading the content.
 

smtp_sasl_auth_enable Being Ignored

Expand Messages
  • Dennis Putnam
    My authentication has recently stopped working (at least it appears to me there is no attempt to authenticate). The problem appears to be that the sasl
    Message 1 of 41 , Jan 28, 2014
      My authentication has recently stopped working (at least it appears to
      me there is no attempt to authenticate). The problem appears to be that
      the sasl parameters are being ignored. The following is in my main.cf.

      smtp_sasl_auth_enable = yes
      smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
      smtp_sasl_security_options =

      However, when I run postconf, I get this:

      smtp_sasl_auth_enable = no

      Here is the maillog output with debug on:

      Jan 28 18:08:21 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 220 smtp.att.yahoo.com ESMTP ready
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: >
      smtp.att.yahoo.com[98.138.31.74]:587: EHLO home.bellsouth.net
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 250-smtp.att.yahoo.com
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 250-PIPELINING
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 250-SIZE 41697280
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 250-8 BITMIME
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 250 STARTTLS
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: server features: 0x101d size
      41697280
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: Using ESMTP PIPELINING, TCP
      send buffer size is 4096
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: >
      smtp.att.yahoo.com[98.138.31.74]:587: MAIL FROM:<>
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: maps_find:
      smtp_generic_maps: dap1@...: not found
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: match_string: bellsouth.net
      ~? dap002.dap.localnet
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: match_string: bellsouth.net
      ~? localhost.dap.localnet
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: match_string: bellsouth.net
      ~? localhost
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: match_list_match:
      bellsouth.net: no match
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: maps_find:
      smtp_generic_maps: @...: not found
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: mail_addr_find:
      dap1@... -> (not found)
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: mail_addr_map:
      dap1@... -> (not found)
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: smtp_map11_external:
      dap1@... not found
      Jan 28 18:08:21 dap002 postfix/smtp[29878]: >
      smtp.att.yahoo.com[98.138.31.74]:587: RCPT TO:<dap1@...>
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: >
      smtp.att.yahoo.com[98.138.31.74]:587: DATA
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: <
      smtp.att.yahoo.com[98.138.31.74]:587: 530 5.7.1 Authentication required
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: connect to subsystem
      private/bounce
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr nrequest = 0
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr flags = 0
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr queue_id = 9566E26457
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr original_recipient
      = root@...
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr recipient =
      dap1@...
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr offset = 175
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr dsn_orig_rcpt =
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr notify_flags = 0
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr status = 5.7.1
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr diag_type = smtp
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr diag_text = 530
      5.7.1 Authentication required
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr mta_type = dns
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr mta_mname =
      smtp.att.yahoo.com
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr action = failed
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: send attr reason = host
      smtp.att.yahoo.com[98.138.31.74] said: 530 5.7.1 Authentication required
      (in reply to MAIL FROM command)
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: private/bounce socket:
      wanted attribute: status
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: input attribute name: status
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: input attribute value: 0
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: private/bounce socket:
      wanted attribute: (list terminator)
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: input attribute name: (end)
      Jan 28 18:08:22 dap002 postfix/smtp[29878]: 9566E26457:
      to=<dap1@...>, orig_to=<root@...>,
      relay=smtp.att.yahoo.com[98.138.31.74]:587, delay=0.46,
      delays=0.07/0/0.31/0.08, dsn=5.7.1, status=bounced (host
      smtp.att.yahoo.com[98.138.31.74] said: 530 5.7.1 Authentication required
      (in reply to MAIL FROM command))
      Jan 28 18:09:21 dap002 postfix/smtp[29878]: smtp_get: EOF
      Jan 28 18:09:21 dap002 postfix/smtp[29878]: 9566E26457: lost connection
      with smtp.att.yahoo.com[98.138.31.74] while sending RCPT TO
      Jan 28 18:09:21 dap002 postfix/smtp[29878]: name_mask: resource
      Jan 28 18:09:21 dap002 postfix/smtp[29878]: name_mask: software
      Jan 28 18:09:21 dap002 postfix/qmgr[29870]: 9566E26457: removed


      Can anyone explain what has happened?

      For reference I can send the entire postconf and main.cf if necessary
      but including it with this email exceeds the max size. Thanks.
    • Viktor Dukhovni
      ... It is rather sad that the problem is staring you in the face, and the required configuration was explicitly communicated upthread:o
      Message 41 of 41 , Jan 30, 2014
        On Thu, Jan 30, 2014 at 09:51:30AM -0500, Dennis Putnam wrote:

        > relayhost = [smtp.att.yahoo.com]:587
        > smtp_tls_policy_maps = hash:/etc/postfix/tls_policy
        >
        > In case it is needed here is the content of tls_policy:
        >
        > in.mailjet.com may
        > smtp.att.yahoo.com:587 encrypt

        It is rather sad that the problem is staring you in the face, and
        the required configuration was explicitly communicated upthread:o

        http://archives.neohapsis.com/archives/postfix/2013-12/0785.html

        Your original message reports problems with delivery to a bellsouth.net
        recipient via:

        relay=smtp.att.yahoo.com[98.138.31.74]:587

        presumably, you've set "relayhost=[smtp.att.yahoo.com]:587" or some
        similar setting. Per the Postfix documentation (both TLS_README
        and SASL_README). The lookup key for both TLS and SASL policy
        should be verbatim next-hop destination, namely:

        tls_policy:
        # Ideally use "secure" after configuring a suitable CAfile.
        [smtp.att.yahoo.com]:587 encrypt

        sasl_passwords:
        [smtp.att.yahoo.com]:587 user:pass

        The "[", "]" around the relay name in the tls policy and sasl password
        tables are NOT optional.

        --
        Viktor.
      Your message has been successfully submitted and would be delivered to recipients shortly.