Loading ...
Sorry, an error occurred while loading the content.

RE: disable all filtering deliver email direclty

Expand Messages
  • Jumping Mouse
    ... Here is my maildroprc it does not seem to be calling Spamassassin so not sure where the delay is. Do you see anything in the config file that could be
    Message 1 of 6 , Sep 10, 2013
    • 0 Attachment


      > Date: Mon, 9 Sep 2013 16:05:23 -0500
      > From: njones@...
      > To: postfix-users@...
      > Subject: Re: disable all filtering deliver email direclty
      >
      > On 9/9/2013 3:46 PM, Jumping Mouse wrote:
      > > Hello I have an old email server with a mail stuck in the queue.
      > >
      > > I want to flush all email out and let be delivered with out any
      > > filtering.
      > >
      > > It looks like I have turned off all filtering but still messages are
      > > delivered very slowly.
      > >
      > >
      > > Can someone help me with my config files? I can't seem to figure
      > > out were the issue is that is causing for mail to still be filtered.
      > >
      > > Thank you!
      > >
      > >
      > > Here is my main.cf
      >
      > "postconf -n" is strongly preferred, but I see no evidence of a
      > content filter here.
      >
      > Perhaps you are calling spamassassin by maildrop during delivery.
      >
      >
      >
      > -- Noel Jones


      Here is my  maildroprc  it does not seem to be calling Spamassassin so not sure where the delay is.  Do you see anything in the config file that could be causing this delay?

      logfile "/var/log/maildrop"
      VERBOSE="5"


      log "========"
      if (    /^X-Spam-Flag: YES/)
      {
        #Create SPAM IMAP folder if they don't have one
        `test -d $DEFAULT/.Junkmail`
        if( $RETURNCODE == 1 )
        {
          `/usr/bin/maildirmake -f Junkmail $DEFAULT`
          `echo INBOX.Junkmail >> $DEFAULT/courierimapsubscribed`
        }
        exception {
          to "Maildir/.Junkmail"
        }
      }



    • Jumping Mouse
      From: kafriki@hotmail.com To: postfix-users@postfix.org Subject: RE: disable all filtering deliver email direclty Date: Tue, 10 Sep 2013 11:05:00 -0400 ...
      Message 2 of 6 , Sep 10, 2013
      • 0 Attachment



        From: kafriki@...
        To: postfix-users@...
        Subject: RE: disable all filtering deliver email direclty
        Date: Tue, 10 Sep 2013 11:05:00 -0400



        > Date: Mon, 9 Sep 2013 16:05:23 -0500
        > From: njones@...
        > To: postfix-users@...
        > Subject: Re: disable all filtering deliver email direclty
        >
        > On 9/9/2013 3:46 PM, Jumping Mouse wrote:
        > > Hello I have an old email server with a mail stuck in the queue.
        > >
        > > I want to flush all email out and let be delivered with out any
        > > filtering.
        > >
        > > It looks like I have turned off all filtering but still messages are
        > > delivered very slowly.
        > >
        > >
        > > Can someone help me with my config files? I can't seem to figure
        > > out were the issue is that is causing for mail to still be filtered.
        > >
        > > Thank you!
        > >
        > >
        > > Here is my main.cf
        >
        > "postconf -n" is strongly preferred, but I see no evidence of a
        > content filter here.
        >
        > Perhaps you are calling spamassassin by maildrop during delivery.
        >
        >
        >
        > -- Noel Jones


        Here is my  maildroprc  it does not seem to be calling Spamassassin so not sure where the delay is.  Do you see anything in the config file that could be causing this delay?

        logfile "/var/log/maildrop"
        VERBOSE="5"


        log "========"
        if (    /^X-Spam-Flag: YES/)
        {
          #Create SPAM IMAP folder if they don't have one
          `test -d $DEFAULT/.Junkmail`
          if( $RETURNCODE == 1 )
          {
            `/usr/bin/maildirmake -f Junkmail $DEFAULT`
            `echo INBOX.Junkmail >> $DEFAULT/courierimapsubscribed`
          }
          exception {
            to "Maildir/.Junkmail"
          }
        }



        Here is my postconf -n

        alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
        biff = no
        broken_sasl_auth_clients = yes
        config_directory = /etc/postfix
        delay_warning_time = 4h
        home_mailbox = Maildir/
        ignore_mx_lookup_error = yes
        inet_interfaces = all
        inet_protocols = ipv4
        mailbox_command = /usr/bin/maildrop
        mailbox_size_limit = 0
        message_size_limit = 26214400
        mydestination = $myhostname, $mydomain, localhost.$mydomain, lists.domain.com
        mydomain = domain.com
        myhostname = mail.domain.com
        mynetworks = 10.0.0.0/24, 10.5.0.0/24, 127.0.0.0/8, 159.250.29.243/32
        myorigin = domain.com
        recipient_delimiter = +
        relay_domains = mailman.domain.com, domain.com, www.domain.com, localhost.domain.com, 159.250.29.243, svahs.net, kong2.domain.com, 10.5.0.25, 10.0.0.19, 10.0.0.4, 10.5.0.10, 10.0.0.10, hec-pdc, mindtouch, mindtouch.domain.com, 10.0.0.128, kablink, dev1.domain.com, dev2.domain.com, 10.0.0.15
        smtp_tls_note_starttls_offer = yes
        smtp_use_tls = yes
        smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
        smtpd_data_restrictions = reject_unauth_pipelining
        smtpd_helo_required = yes
        smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service inet:127.0.0.1:60000
        smtpd_sasl_auth_enable = yes
        smtpd_sasl_authenticated_header = yes
        smtpd_sasl_local_domain =
        smtpd_sasl_path = private/auth-client
        smtpd_sasl_security_options = noanonymous
        smtpd_sasl_type = dovecot
        smtpd_tls_CAfile = /etc/ssl/sub.class2.server.ca.pem
        smtpd_tls_auth_only = yes
        smtpd_tls_cert_file = /etc/ssl/ssl.crt
        smtpd_tls_key_file = /etc/ssl/ssl.key
        smtpd_tls_loglevel = 1
        smtpd_tls_received_header = yes
        smtpd_tls_session_cache_timeout = 3600s
        smtpd_use_tls = yes
        tls_random_source = dev:/dev/urandom
        transport_maps = hash:/etc/postfix/transport
        unknown_local_recipient_reject_code = 550
        virtual_alias_maps = hash:/etc/postfix/virtual
        virtual_transport = maildrop


      • Jumping Mouse
        I am really needing some help with this I hope someone can look at my postconf -n and let me know how can get this email delivered quickly. with no
        Message 3 of 6 , Sep 10, 2013
        • 0 Attachment
          I am really needing some help with this  I hope someone can look at my postconf -n  and let me know how can get this email delivered quickly. with no filtering.


          alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
          biff = no
          broken_sasl_auth_clients = yes
          config_directory = /etc/postfix
          delay_warning_time = 4h
          home_mailbox = Maildir/
          ignore_mx_lookup_error = yes
          inet_interfaces = all
          inet_protocols = ipv4
          mailbox_command = /usr/bin/maildrop
          mailbox_size_limit = 0
          message_size_limit = 26214400
          mydestination = $myhostname, $mydomain, localhost.$mydomain, lists.domain.com
          mydomain = domain.com
          myhostname = mail.domain.com
          mynetworks = 10.0.0.0/24, 10.5.0.0/24, 127.0.0.0/8, 159.250.29.243/32
          myorigin = domain.com
          recipient_delimiter = +
          relay_domains = mailman.domain.com, domain.com, www.domain.com, localhost.domain.com, 159.250.29.243, svahs.net, kong2.domain.com, 10.5.0.25, 10.0.0.19, 10.0.0.4, 10.5.0.10, 10.0.0.10, hec-pdc, mindtouch, mindtouch.domain.com, 10.0.0.128, kablink, dev1.domain.com, dev2.domain.com, 10.0.0.15
          smtp_tls_note_starttls_offer = yes
          smtp_use_tls = yes
          smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
          smtpd_data_restrictions = reject_unauth_pipelining
          smtpd_helo_required = yes
          smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service inet:127.0.0.1:60000
          smtpd_sasl_auth_enable = yes
          smtpd_sasl_authenticated_header = yes
          smtpd_sasl_local_domain =
          smtpd_sasl_path = private/auth-client
          smtpd_sasl_security_options = noanonymous
          smtpd_sasl_type = dovecot
          smtpd_tls_CAfile = /etc/ssl/sub.class2.server.ca.pem
          smtpd_tls_auth_only = yes
          smtpd_tls_cert_file = /etc/ssl/ssl.crt
          smtpd_tls_key_file = /etc/ssl/ssl.key
          smtpd_tls_loglevel = 1
          smtpd_tls_received_header = yes
          smtpd_tls_session_cache_timeout = 3600s
          smtpd_use_tls = yes
          tls_random_source = dev:/dev/urandom
          transport_maps = hash:/etc/postfix/transport
          unknown_local_recipient_reject_code = 550
          virtual_alias_maps = hash:/etc/postfix/virtual
          virtual_transport = maildrop




          From: kafriki@...
          To: postfix-users@...
          Subject: RE: disable all filtering deliver email direclty
          Date: Tue, 10 Sep 2013 23:43:56 -0400




          From: kafriki@...
          To: postfix-users@...
          Subject: RE: disable all filtering deliver email direclty
          Date: Tue, 10 Sep 2013 11:05:00 -0400



          > Date: Mon, 9 Sep 2013 16:05:23 -0500
          > From: njones@...
          > To: postfix-users@...
          > Subject: Re: disable all filtering deliver email direclty
          >
          > On 9/9/2013 3:46 PM, Jumping Mouse wrote:
          > > Hello I have an old email server with a mail stuck in the queue.
          > >
          > > I want to flush all email out and let be delivered with out any
          > > filtering.
          > >
          > > It looks like I have turned off all filtering but still messages are
          > > delivered very slowly.
          > >
          > >
          > > Can someone help me with my config files? I can't seem to figure
          > > out were the issue is that is causing for mail to still be filtered.
          > >
          > > Thank you!
          > >
          > >
          > > Here is my main.cf
          >
          > "postconf -n" is strongly preferred, but I see no evidence of a
          > content filter here.
          >
          > Perhaps you are calling spamassassin by maildrop during delivery.
          >
          >
          >
          > -- Noel Jones


          Here is my  maildroprc  it does not seem to be calling Spamassassin so not sure where the delay is.  Do you see anything in the config file that could be causing this delay?

          logfile "/var/log/maildrop"
          VERBOSE="5"


          log "========"
          if (    /^X-Spam-Flag: YES/)
          {
            #Create SPAM IMAP folder if they don't have one
            `test -d $DEFAULT/.Junkmail`
            if( $RETURNCODE == 1 )
            {
              `/usr/bin/maildirmake -f Junkmail $DEFAULT`
              `echo INBOX.Junkmail >> $DEFAULT/courierimapsubscribed`
            }
            exception {
              to "Maildir/.Junkmail"
            }
          }



          Here is my postconf -n

          alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
          biff = no
          broken_sasl_auth_clients = yes
          config_directory = /etc/postfix
          delay_warning_time = 4h
          home_mailbox = Maildir/
          ignore_mx_lookup_error = yes
          inet_interfaces = all
          inet_protocols = ipv4
          mailbox_command = /usr/bin/maildrop
          mailbox_size_limit = 0
          message_size_limit = 26214400
          mydestination = $myhostname, $mydomain, localhost.$mydomain, lists.domain.com
          mydomain = domain.com
          myhostname = mail.domain.com
          mynetworks = 10.0.0.0/24, 10.5.0.0/24, 127.0.0.0/8, 159.250.29.243/32
          myorigin = domain.com
          recipient_delimiter = +
          relay_domains = mailman.domain.com, domain.com, www.domain.com, localhost.domain.com, 159.250.29.243, svahs.net, kong2.domain.com, 10.5.0.25, 10.0.0.19, 10.0.0.4, 10.5.0.10, 10.0.0.10, hec-pdc, mindtouch, mindtouch.domain.com, 10.0.0.128, kablink, dev1.domain.com, dev2.domain.com, 10.0.0.15
          smtp_tls_note_starttls_offer = yes
          smtp_use_tls = yes
          smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
          smtpd_data_restrictions = reject_unauth_pipelining
          smtpd_helo_required = yes
          smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service inet:127.0.0.1:60000
          smtpd_sasl_auth_enable = yes
          smtpd_sasl_authenticated_header = yes
          smtpd_sasl_local_domain =
          smtpd_sasl_path = private/auth-client
          smtpd_sasl_security_options = noanonymous
          smtpd_sasl_type = dovecot
          smtpd_tls_CAfile = /etc/ssl/sub.class2.server.ca.pem
          smtpd_tls_auth_only = yes
          smtpd_tls_cert_file = /etc/ssl/ssl.crt
          smtpd_tls_key_file = /etc/ssl/ssl.key
          smtpd_tls_loglevel = 1
          smtpd_tls_received_header = yes
          smtpd_tls_session_cache_timeout = 3600s
          smtpd_use_tls = yes
          tls_random_source = dev:/dev/urandom
          transport_maps = hash:/etc/postfix/transport
          unknown_local_recipient_reject_code = 550
          virtual_alias_maps = hash:/etc/postfix/virtual
          virtual_transport = maildrop


        • Noel Jones
          ... Your postfix configuration shown does not appear to have any filtering enabled. If filtering is still happening, there is no evidence shown that postfix
          Message 4 of 6 , Sep 11, 2013
          • 0 Attachment
            On 9/10/2013 10:54 PM, Jumping Mouse wrote:
            > I am really needing some help with this I hope someone can look at
            > my postconf -n and let me know how can get this email delivered
            > quickly. with no filtering.


            Your postfix configuration shown does not appear to have any
            filtering enabled. If filtering is still happening, there is no
            evidence shown that postfix is calling the filter.

            Sorry, I can't help any more here.




            -- Noel Jones

            >
            >
            > alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
            > biff = no
            > broken_sasl_auth_clients = yes
            > config_directory = /etc/postfix
            > delay_warning_time = 4h
            > home_mailbox = Maildir/
            > ignore_mx_lookup_error = yes
            > inet_interfaces = all
            > inet_protocols = ipv4
            > mailbox_command = /usr/bin/maildrop
            > mailbox_size_limit = 0
            > message_size_limit = 26214400
            > mydestination = $myhostname, $mydomain, localhost.$mydomain,
            > lists.domain.com
            > mydomain = domain.com
            > myhostname = mail.domain.com
            > mynetworks = 10.0.0.0/24, 10.5.0.0/24, 127.0.0.0/8, 159.250.29.243/32
            > myorigin = domain.com
            > recipient_delimiter = +
            > relay_domains = mailman.domain.com, domain.com, www.domain.com,
            > localhost.domain.com, 159.250.29.243, svahs.net, kong2.domain.com,
            > 10.5.0.25, 10.0.0.19, 10.0.0.4, 10.5.0.10, 10.0.0.10, hec-pdc,
            > mindtouch, mindtouch.domain.com, 10.0.0.128, kablink,
            > dev1.domain.com, dev2.domain.com, 10.0.0.15
            > smtp_tls_note_starttls_offer = yes
            > smtp_use_tls = yes
            > smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
            > smtpd_data_restrictions = reject_unauth_pipelining
            > smtpd_helo_required = yes
            > smtpd_recipient_restrictions =
            > permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service
            > inet:127.0.0.1:60000
            > smtpd_sasl_auth_enable = yes
            > smtpd_sasl_authenticated_header = yes
            > smtpd_sasl_local_domain =
            > smtpd_sasl_path = private/auth-client
            > smtpd_sasl_security_options = noanonymous
            > smtpd_sasl_type = dovecot
            > smtpd_tls_CAfile = /etc/ssl/sub.class2.server.ca.pem
            > smtpd_tls_auth_only = yes
            > smtpd_tls_cert_file = /etc/ssl/ssl.crt
            > smtpd_tls_key_file = /etc/ssl/ssl.key
            > smtpd_tls_loglevel = 1
            > smtpd_tls_received_header = yes
            > smtpd_tls_session_cache_timeout = 3600s
            > smtpd_use_tls = yes
            > tls_random_source = dev:/dev/urandom
            > transport_maps = hash:/etc/postfix/transport
            > unknown_local_recipient_reject_code = 550
            > virtual_alias_maps = hash:/etc/postfix/virtual
            > virtual_transport = maildrop
            >
            >
            >
            > --------------------------------------------------------------------
            > From: kafriki@...
            > To: postfix-users@...
            > Subject: RE: disable all filtering deliver email direclty
            > Date: Tue, 10 Sep 2013 23:43:56 -0400
            >
            >
            >
            > --------------------------------------------------------------------
            > From: kafriki@...
            > To: postfix-users@...
            > Subject: RE: disable all filtering deliver email direclty
            > Date: Tue, 10 Sep 2013 11:05:00 -0400
            >
            >
            >
            >> Date: Mon, 9 Sep 2013 16:05:23 -0500
            >> From: njones@...
            >> To: postfix-users@...
            >> Subject: Re: disable all filtering deliver email direclty
            >>
            >> On 9/9/2013 3:46 PM, Jumping Mouse wrote:
            >> > Hello I have an old email server with a mail stuck in the queue.
            >> >
            >> > I want to flush all email out and let be delivered with out any
            >> > filtering.
            >> >
            >> > It looks like I have turned off all filtering but still messages are
            >> > delivered very slowly.
            >> >
            >> >
            >> > Can someone help me with my config files? I can't seem to figure
            >> > out were the issue is that is causing for mail to still be
            > filtered.
            >> >
            >> > Thank you!
            >> >
            >> >
            >> > Here is my main.cf
            >>
            >> "postconf -n" is strongly preferred, but I see no evidence of a
            >> content filter here.
            >>
            >> Perhaps you are calling spamassassin by maildrop during delivery.
            >>
            >>
            >>
            >> -- Noel Jones
            >
            >
            > Here is my maildroprc it does not seem to be calling Spamassassin
            > so not sure where the delay is. Do you see anything in the config
            > file that could be causing this delay?
            >
            > logfile "/var/log/maildrop"
            > VERBOSE="5"
            >
            >
            > log "========"
            > if ( /^X-Spam-Flag: YES/)
            > {
            > #Create SPAM IMAP folder if they don't have one
            > `test -d $DEFAULT/.Junkmail`
            > if( $RETURNCODE == 1 )
            > {
            > `/usr/bin/maildirmake -f Junkmail $DEFAULT`
            > `echo INBOX.Junkmail >> $DEFAULT/courierimapsubscribed`
            > }
            > exception {
            > to "Maildir/.Junkmail"
            > }
            > }
            >
            >
            >
            > Here is my postconf -n
            >
            > alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
            > biff = no
            > broken_sasl_auth_clients = yes
            > config_directory = /etc/postfix
            > delay_warning_time = 4h
            > home_mailbox = Maildir/
            > ignore_mx_lookup_error = yes
            > inet_interfaces = all
            > inet_protocols = ipv4
            > mailbox_command = /usr/bin/maildrop
            > mailbox_size_limit = 0
            > message_size_limit = 26214400
            > mydestination = $myhostname, $mydomain, localhost.$mydomain,
            > lists.domain.com
            > mydomain = domain.com
            > myhostname = mail.domain.com
            > mynetworks = 10.0.0.0/24, 10.5.0.0/24, 127.0.0.0/8, 159.250.29.243/32
            > myorigin = domain.com
            > recipient_delimiter = +
            > relay_domains = mailman.domain.com, domain.com, www.domain.com,
            > localhost.domain.com, 159.250.29.243, svahs.net, kong2.domain.com,
            > 10.5.0.25, 10.0.0.19, 10.0.0.4, 10.5.0.10, 10.0.0.10, hec-pdc,
            > mindtouch, mindtouch.domain.com, 10.0.0.128, kablink,
            > dev1.domain.com, dev2.domain.com, 10.0.0.15
            > smtp_tls_note_starttls_offer = yes
            > smtp_use_tls = yes
            > smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
            > smtpd_data_restrictions = reject_unauth_pipelining
            > smtpd_helo_required = yes
            > smtpd_recipient_restrictions =
            > permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service
            > inet:127.0.0.1:60000
            > smtpd_sasl_auth_enable = yes
            > smtpd_sasl_authenticated_header = yes
            > smtpd_sasl_local_domain =
            > smtpd_sasl_path = private/auth-client
            > smtpd_sasl_security_options = noanonymous
            > smtpd_sasl_type = dovecot
            > smtpd_tls_CAfile = /etc/ssl/sub.class2.server.ca.pem
            > smtpd_tls_auth_only = yes
            > smtpd_tls_cert_file = /etc/ssl/ssl.crt
            > smtpd_tls_key_file = /etc/ssl/ssl.key
            > smtpd_tls_loglevel = 1
            > smtpd_tls_received_header = yes
            > smtpd_tls_session_cache_timeout = 3600s
            > smtpd_use_tls = yes
            > tls_random_source = dev:/dev/urandom
            > transport_maps = hash:/etc/postfix/transport
            > unknown_local_recipient_reject_code = 550
            > virtual_alias_maps = hash:/etc/postfix/virtual
            > virtual_transport = maildrop
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.