Loading ...
Sorry, an error occurred while loading the content.

Problems with gmail

Expand Messages
  • John Allen
    I have been having an intermittent problem sending to gmail. For some reason the problem only seems to affect IPv6 connections. I get the following error
    Message 1 of 3 , Sep 9, 2013
    • 0 Attachment
      I have been having an intermittent problem sending to gmail. For some reason the problem only seems to affect IPv6 connections.
      I get the following error message:
      <zzz2002@...>: host gmail-smtp-in.l.google.com[2607:f8b0:400d:c01::1b]
          said: 550-5.7.1 [2001:dead:beef:10::182      16] Our system has detected
          that this 550-5.7.1 message does not meet IPv6 sending guidelines regarding
          PTR records 550-5.7.1 and authentication. Please review 550 5.7.1
          https://support.google.com/mail/answer/81126 for more information.
          a1si5706259qez.81 - gsmtp (in reply to end of DATA command)
      
      I think I understand the problem; 
      My server has multiple functions and uses, for various reasons, multiple IP addresses. 
      Postfix cycles through these when sending mail to out. Postfix is supposed to be using ....::178.
      Because of this a reverse look up does not return the correct info for my server. 
      Google, quite rightly objects and bounces my mail.
      From reading the Postfix documentation I think that I need to add the following to my master.cf
      smtp      unix  -       -       n       -       -       smtp
      	-o smtp_bind_address=n.n.n.178
      	-o smtp_bind_address6=2001:dead:beef:10::178
      
      This seems to have solved the problem. However, is there anything else that I should or could add, that might avoid similar problems in the future?
      Are then any gotcha that I should be aware of?
      
      postconf -Mfvx
      
      smtp       inet  n       -       n       -       -       smtpd
          -o cleanup_service_name=pre-cleanup
      pickup     fifo  n       -       n       60      1       pickup
          -o cleanup_service_name=pre-cleanup
      submission inet  n       -       n       -       30      smtpd
          -o syslog_name=postfix/submission -o smtpd_tls_security_level=encrypt
          -o smtpd_sasl_auth_enable=yes -o smtpd_client_connection_count_limit=15
          -o smtpd_client_connection_rate_limit=80 -o smtpd_delay_reject=yes
          -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
          -o cleanup_service_name=pre-cleanup
      qmgr       fifo  n       -       n       300     1       qmgr
      tlsmgr     unix  -       -       n       1000?   1       tlsmgr
      rewrite    unix  -       -       n       -       -       trivial-rewrite
      bounce     unix  -       -       n       -       0       bounce
      defer      unix  -       -       n       -       0       bounce
      trace      unix  -       -       n       -       0       bounce
      verify     unix  -       -       n       -       1       verify
      flush      unix  n       -       n       1000?   0       flush
      proxymap   unix  -       -       n       -       -       proxymap
      proxywrite unix  -       -       n       -       1       proxymap
      smtp       unix  -       -       n       -       -       smtp
          -o smtp_bind_address=74.116.186.178
          -o smtp_bind_address6=2001:470:b183:10::178
      relay      unix  -       -       n       -       -       smtp
      showq      unix  n       -       n       -       -       showq
      error      unix  -       -       n       -       -       error
      retry      unix  -       -       n       -       -       error
      discard    unix  -       -       n       -       -       discard
      local      unix  -       n       n       -       -       local
      virtual    unix  -       n       n       -       -       virtual
      lmtp       unix  -       -       n       -       -       lmtp
      anvil      unix  -       -       n       -       1       anvil
      scache     unix  -       -       n       -       1       scache
      smtp-amavis unix -       -       n       -       4       smtp
          -o smtp_data_done_timeout=1200 -o smtp_send_xforward_command=yes
          -o disable_dns_lookups=yes -o smtp_tls_note_starttls_offer=no -o max_use=20
      127.0.0.1:10025 inet n   -       n       -       -       smtpd
          -o content_filter= -o smtpd_delay_reject=no
          -o smtpd_client_restrictions=permit_mynetworks,reject
          -o smtpd_helo_restrictions= -o smtpd_sender_restrictions=
          -o smtpd_recipient_restrictions=permit_mynetworks,reject
          -o smtpd_data_restrictions=reject_unauth_pipelining
          -o smtpd_end_of_data_restrictions= -o smtpd_restriction_classes=
          -o mynetworks=127.0.0.0/8 -o smtpd_error_sleep_time=0
          -o smtpd_soft_error_limit=1001 -o smtpd_hard_error_limit=1000
          -o smtpd_client_connection_count_limit=0
          -o smtpd_client_connection_rate_limit=0 -o local_header_rewrite_clients=
          -o local_recipient_maps=
          -o receive_override_options=no_header_body_checks,no_unknown_recipient_checks,no_milters
          -o smtpd_tls_security_level=none -o local_recipient_maps=
          -o relay_recipient_maps=
      pre-cleanup unix n       -       n       -       0       cleanup
          -o virtual_alias_maps=
      cleanup    unix  n       -       n       -       0       cleanup
          -o mime_header_checks= -o nested_header_checks= -o header_checks=
          -o body_checks=
      
      
    • Wietse Venema
      ... This is incorrect. The Postfix SMTP client does not choose the source IP address unless you configure smtp_bind_address or smtp_bind_address6 settings.
      Message 2 of 3 , Sep 9, 2013
      • 0 Attachment
        John Allen:
        > I think I understand the problem;
        > My server has multiple functions and uses, for various reasons,
        > multiple IP addresses. Postfix cycles through these when sending
        > mail to out.

        This is incorrect. The Postfix SMTP client does not choose the
        source IP address unless you configure smtp_bind_address or
        smtp_bind_address6 settings.

        Wietse
      • Viktor Dukhovni
        ... Which is to say, that the O/S IP stack chooses a source address based on whatever algorithms it contains, interface status and the state of the routing
        Message 3 of 3 , Sep 9, 2013
        • 0 Attachment
          On Mon, Sep 09, 2013 at 01:42:45PM -0400, Wietse Venema wrote:

          > > I think I understand the problem;
          > > My server has multiple functions and uses, for various reasons,
          > > multiple IP addresses. Postfix cycles through these when sending
          > > mail to out.
          >
          > This is incorrect. The Postfix SMTP client does not choose the
          > source IP address unless you configure smtp_bind_address or
          > smtp_bind_address6 settings.

          Which is to say, that the O/S IP stack chooses a source address
          based on whatever algorithms it contains, interface status and the
          state of the routing tables.

          Postfix can optionaly override this choice, and the OP has already
          found the correct solution (assuming that it is impractical to
          configure all the machine's IPv6 addresses with suitable PTR
          records, ...).

          --
          Viktor.
        Your message has been successfully submitted and would be delivered to recipients shortly.