Loading ...
Sorry, an error occurred while loading the content.

Re: Sender address rejected

Expand Messages
  • Krzysztof Szarlej
    Well after i made some changes the postfix dont want to start. I mean the smpt, it says it that connect timeout exceeded. # tail /var/log/maillog Jul 19
    Message 1 of 6 , Jul 19, 2013
    • 0 Attachment
      Well after i made some changes the postfix dont want to start. I mean the smpt, it says it that connect timeout exceeded.

      # tail /var/log/maillog

      Jul 19 09:01:54 szarlej postfix/master[4428]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
      Jul 19 09:02:54 szarlej postfix/smtpd[4549]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
      Jul 19 09:02:55 szarlej postfix/master[4428]: warning: process /usr/libexec/postfix/smtpd pid 4549 exit status 1
      Jul 19 09:02:55 szarlej postfix/master[4428]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

      my recipient restrictions now:

      smtpd_recipient_restrictions = reject_non_fqdn_recipient, check_relay_domains, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit


    • /dev/rob0
      ... Not likely so, look at postconf smtpd_recipient_restrictions . ... Leading whitespace is required for line continuations. See man 5 postconf for file
      Message 2 of 6 , Jul 19, 2013
      • 0 Attachment
        On Fri, Jul 19, 2013 at 09:05:52AM +0200, Krzysztof Szarlej wrote:
        > Well after i made some changes the postfix dont want to start. I
        > mean the smpt, it says it that connect timeout exceeded.
        >
        > # tail /var/log/maillog
        >
        > Jul 19 09:01:54 szarlej postfix/master[4428]: warning:
        > /usr/libexec/postfix/smtpd: bad command startup -- throttling
        > Jul 19 09:02:54 szarlej postfix/smtpd[4549]: fatal: parameter
        > "smtpd_recipient_restrictions": specify at least one working
        > instance of: check_relay_domains, reject_unauth_destination,
        > reject, defer or defer_if_permit
        > Jul 19 09:02:55 szarlej postfix/master[4428]: warning: process
        > /usr/libexec/postfix/smtpd pid 4549 exit status 1
        > Jul 19 09:02:55 szarlej postfix/master[4428]: warning:
        > /usr/libexec/postfix/smtpd: bad command startup -- throttling
        >
        > my recipient restrictions now:

        Not likely so, look at "postconf smtpd_recipient_restrictions".

        > smtpd_recipient_restrictions = reject_non_fqdn_recipient,
        > check_relay_domains, permit_sasl_authenticated, permit_mynetworks,

        Leading whitespace is required for line continuations. See "man 5
        postconf" for file syntax. Also, remove check_relay_domains. It's
        deprecated and not needed anyway.

        > reject_unauth_destination, reject_unlisted_recipient,
        > reject_invalid_hostname, reject_non_fqdn_sender, permit

        Before posting again, review Noel's post and the URL given. Your
        followup was inadequate without "postconf -n" output.
        --
        http://rob0.nodns4.us/ -- system administration and consulting
        Offlist GMX mail is seen only if "/dev/rob0" is in the Subject:
      Your message has been successfully submitted and would be delivered to recipients shortly.