Loading ...
Sorry, an error occurred while loading the content.
 

Re: Sender address rejected

Expand Messages
  • Noel Jones
    ... Please show the full, unaltered log entry (in plain text only, HTML markup makes the logs difficult to read). For more help, please see:
    Message 1 of 6 , Jul 18, 2013
      On 7/18/2013 7:55 PM, Krzysztof Szarlej wrote:
      > Hey guys I've a problem with my SMTP. I have set the postfix
      > togoether with dovecot, I turned on sasl and tls and I can't send
      > the messages. I am getting error
      >
      > SMTP: '450 4.1.2 <user@... <mailto:user@...>>: Recipient
      > address rejected: Domain not found',

      Please show the full, unaltered log entry (in plain text only, HTML
      markup makes the logs difficult to read).

      For more help, please see:
      http://www.postfix.org/DEBUG_README.html#mail


      My wild guess is you need to turn off the chroot flag in master.cf
      for the submission service (and if that works, for every other
      service). http://www.postfix.org/DEBUG_README.html#no_chroot


      -- Noel Jones



      >
      > From main.cf <http://main.cf> here are my smtpd rules:
      >
      > -----
      > smtpd_recipient_restrictions = permit_mynetworks,
      > permit_sasl_authenticated, reject_unauth_destination
      > smtpd_sasl_auth_enable = yes
      > smtpd_sasl_path = private/auth
      > smtpd_sasl_security_options = noanonymous
      > smtpd_sasl_type = dovecot
      > smtpd_tls_auth_only = yes
      > smtpd_tls_cert_file = /etc/ssl/certs/mail.pem
      > smtpd_tls_key_file = /etc/ssl/private/mail.key
      > smtpd_tls_security_level = encrypt
      > smtpd_tls_wrappermode = no
      > unknown_local_recipient_reject_code = 550
      > -------
      >
      > Records in my zone seems to be alright: (i paste all but SOA)
      >
      > ----
      > mydomain.eu <http://mydomain.eu>. 86400 IN MX 10 mail.mydomain.eu
      > <http://mail.mydomain.eu>.
      > mydomain.eu <http://mydomain.eu>. 86400 IN NS fns1.42.pl
      > <http://fns1.42.pl>.
      > mydomain.eu <http://mydomain.eu>. 86400 IN NS fns2.42.pl
      > <http://fns2.42.pl>.
      >
      > mydomain.eu <http://mydomain.eu>. 86400 IN A vpsIP
      > mail.mydomain.eu <http://mail.mydomain.eu>. 86400 IN A vpsIP
      > www.mydomain.eu <http://www.mydomain.eu>. 86400 IN A vpsIP
      > -----
      >
      > I have revDNS configured. I am able to receive mails from outside
      > (i.e from gmail, but i am not able to send any messages).
      >
      > Any suggestions? Tried to play with smtpd_restrictions but I faild.
      > Also changed the smtpd_tls_securiity_level to may. Changed it also
      > in master.cf <http://master.cf> (i have configuration for port 587
      > there) and it still did not work. the port 587 configuration in
      > master.cf <http://master.cf> goes as follows:
      >
      > submission inet n - - - - smtpd
      > -o smtpd_tls_security_level=encrypt
      > -o smtpd_sasl_auth_enable=yes
      > -o milter_macro_daemon_name=ORIGINATING
      > -o smtpd_client_restrictions=
      > -o smtpd_helo_restrictions=
      > -o smtpd_sender_restrictions=reject_sender_login_mismatch,permit
      > -o smtpd_sender_restrictions=permit_sasl_authenticated,reject
      > -o
      > smtpd_recipient_restrictions=reject_non_fqdn_recipient,reject_unknown_recipient_domain,permit_sasl_authenticated,reject
      >
      >
      > regards
      > Krzysztof
    • Krzysztof Szarlej
      Well after i made some changes the postfix dont want to start. I mean the smpt, it says it that connect timeout exceeded. # tail /var/log/maillog Jul 19
      Message 2 of 6 , Jul 19, 2013
        Well after i made some changes the postfix dont want to start. I mean the smpt, it says it that connect timeout exceeded.

        # tail /var/log/maillog

        Jul 19 09:01:54 szarlej postfix/master[4428]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
        Jul 19 09:02:54 szarlej postfix/smtpd[4549]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
        Jul 19 09:02:55 szarlej postfix/master[4428]: warning: process /usr/libexec/postfix/smtpd pid 4549 exit status 1
        Jul 19 09:02:55 szarlej postfix/master[4428]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

        my recipient restrictions now:

        smtpd_recipient_restrictions = reject_non_fqdn_recipient, check_relay_domains, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit


      • /dev/rob0
        ... Not likely so, look at postconf smtpd_recipient_restrictions . ... Leading whitespace is required for line continuations. See man 5 postconf for file
        Message 3 of 6 , Jul 19, 2013
          On Fri, Jul 19, 2013 at 09:05:52AM +0200, Krzysztof Szarlej wrote:
          > Well after i made some changes the postfix dont want to start. I
          > mean the smpt, it says it that connect timeout exceeded.
          >
          > # tail /var/log/maillog
          >
          > Jul 19 09:01:54 szarlej postfix/master[4428]: warning:
          > /usr/libexec/postfix/smtpd: bad command startup -- throttling
          > Jul 19 09:02:54 szarlej postfix/smtpd[4549]: fatal: parameter
          > "smtpd_recipient_restrictions": specify at least one working
          > instance of: check_relay_domains, reject_unauth_destination,
          > reject, defer or defer_if_permit
          > Jul 19 09:02:55 szarlej postfix/master[4428]: warning: process
          > /usr/libexec/postfix/smtpd pid 4549 exit status 1
          > Jul 19 09:02:55 szarlej postfix/master[4428]: warning:
          > /usr/libexec/postfix/smtpd: bad command startup -- throttling
          >
          > my recipient restrictions now:

          Not likely so, look at "postconf smtpd_recipient_restrictions".

          > smtpd_recipient_restrictions = reject_non_fqdn_recipient,
          > check_relay_domains, permit_sasl_authenticated, permit_mynetworks,

          Leading whitespace is required for line continuations. See "man 5
          postconf" for file syntax. Also, remove check_relay_domains. It's
          deprecated and not needed anyway.

          > reject_unauth_destination, reject_unlisted_recipient,
          > reject_invalid_hostname, reject_non_fqdn_sender, permit

          Before posting again, review Noel's post and the URL given. Your
          followup was inadequate without "postconf -n" output.
          --
          http://rob0.nodns4.us/ -- system administration and consulting
          Offlist GMX mail is seen only if "/dev/rob0" is in the Subject:
        Your message has been successfully submitted and would be delivered to recipients shortly.