Loading ...
Sorry, an error occurred while loading the content.

Re: delivery status notification (DNS)

Expand Messages
  • Wietse Venema
    ... Can you translate that last sentence into plain language? ... Can you translate that sentence into plain language? ... Can you describe in plain language
    Message 1 of 5 , Jul 8, 2013
    • 0 Attachment
      Pol Hallen:
      > Follow official postfix page (http://www.postfix.org/DSN_README.html) I've:
      >
      > smtpd_discard_ehlo_keyword_address_maps = cidr:/etc/postfix/esmtp_access
      >
      > cat /etc/postfix/esmtp_access
      > # Allow DSN requests from local subnet only
      > 192.168.1.0/24 silent-discard
      > 0.0.0.0/0 silent-discard, dsn
      > ::/0 silent-discard, dsn
      >
      >
      > I've small lan on 192.168.1.0 and all clients uses a single smtp postfix
      > server.
      >
      > On clients, send the emails with "delivery status notification" option.
      >
      > After sent, postfix send me a delivery status notification:
      >
      > Successful Mail Delivery Report
      >
      > but that email is within postfix queue (why I stopped destination over
      > internet smtp server - purpose test).

      Can you translate that last sentence into plain language?

      > So, my postfix server always send a delivery status notification also if
      > there's a transmission problem.

      Can you translate that sentence into plain language?

      > What's the error?

      Can you describe in plain language what you expected to happen,
      and what (did not) happen instead?

      Wietse
    • lst_hoe02@...
      ... Do you have a AV scanner or some other after queue content filter? If yes postfix is maybe telling you that the message has been transfered to this next
      Message 2 of 5 , Jul 8, 2013
      • 0 Attachment
        Zitat von Pol Hallen <postfixml@...>:

        > Follow official postfix page (http://www.postfix.org/DSN_README.html) I've:
        >
        > smtpd_discard_ehlo_keyword_address_maps = cidr:/etc/postfix/esmtp_access
        >
        > cat /etc/postfix/esmtp_access
        > # Allow DSN requests from local subnet only
        > 192.168.1.0/24 silent-discard
        > 0.0.0.0/0 silent-discard, dsn
        > ::/0 silent-discard, dsn
        >
        >
        > I've small lan on 192.168.1.0 and all clients uses a single smtp postfix
        > server.
        >
        > On clients, send the emails with "delivery status notification" option.
        >
        > After sent, postfix send me a delivery status notification:
        >
        > Successful Mail Delivery Report
        >
        > but that email is within postfix queue (why I stopped destination over
        > internet smtp server - purpose test).
        >
        > So, my postfix server always send a delivery status notification also if
        > there's a transmission problem.
        >
        > What's the error?

        Do you have a AV scanner or some other after queue content filter? If
        yes postfix is maybe telling you that the message has been transfered
        to this next hop. IMHO you should ditch DSN because no one is
        using/allowing it anyway, so trying to get it right is a fruitless
        effort.

        Regards

        Andreas
      • Pol Hallen
        ... Hello and thanks for reply :-) Yep: I ve spamc and now that I think, the replied mail is: The mail system : delivery via spamassassin:
        Message 3 of 5 , Jul 8, 2013
        • 0 Attachment
          > Do you have a AV scanner or some other after queue content filter? If
          > yes postfix is maybe telling you that the message has been transfered
          > to this next hop. IMHO you should ditch DSN because no one is
          > using/allowing it anyway, so trying to get it right is a fruitless
          > effort.

          Hello and thanks for reply :-) Yep: I've spamc and now that I think, the
          replied mail is:

          The mail system

          <test@test-domain>: delivery via spamassassin: delivered via spamassassin
          service

          It's correct for postfix (because has delivered message to spamassassin).

          thanks

          Pol
        • Wietse Venema
          ... If you have spamassassin on 127.0.0.1, then add that address to your smtpd_discard_ehlo_keyword_address_maps table. Wietse
          Message 4 of 5 , Jul 8, 2013
          • 0 Attachment
            Pol Hallen:
            > > Do you have a AV scanner or some other after queue content filter? If
            > > yes postfix is maybe telling you that the message has been transfered
            > > to this next hop. IMHO you should ditch DSN because no one is
            > > using/allowing it anyway, so trying to get it right is a fruitless
            > > effort.
            >
            > Hello and thanks for reply :-) Yep: I've spamc and now that I think, the
            > replied mail is:
            >
            > The mail system
            >
            > <test@test-domain>: delivery via spamassassin: delivered via spamassassin
            > service
            >
            > It's correct for postfix (because has delivered message to spamassassin).

            If you have spamassassin on 127.0.0.1, then add that address to your
            smtpd_discard_ehlo_keyword_address_maps table.

            Wietse
          Your message has been successfully submitted and would be delivered to recipients shortly.