Loading ...
Sorry, an error occurred while loading the content.

Postfix sending issue

Expand Messages
  • Sam Flint
    Hi I ve been having issues sending email out through postfix. My postconf -n is: broken_sasl_auth_clients = yes config_directory = /etc/postfix home_mailbox =
    Message 1 of 3 , Jul 2, 2013
    • 0 Attachment
      Hi
      I've been having issues sending email out through postfix. My postconf
      -n is:

      broken_sasl_auth_clients = yes
      config_directory = /etc/postfix
      home_mailbox = Maildir/
      inet_interfaces = all
      inet_protocols = ipv4, ipv6
      message_size_limit = 30720000
      mydestination = $myhostname, localhost, localhost.localdomain
      mydomain = flintfam.org
      myhostname = mail.flintfam.org
      mynetworks = all
      myorigin = $mydomain
      proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
      relay_domains = .com .org .net .info $mydestination
      smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, permit
      smtpd_sasl_auth_enable = yes
      smtpd_sasl_authenticated_header = yes
      smtpd_sasl_path = private/auth
      smtpd_sasl_type = dovecot
      smtpd_tls_cert_file = /etc/pki/dovecot/certs/dovecot.pem
      smtpd_tls_key_file = /etc/pki/dovecot/private/dovecot.pem
      smtpd_use_tls = yes
      virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
      virtual_gid_maps = static:5000
      virtual_mailbox_base = /home/vmail
      virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
      virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
      virtual_transport = dovecot
      virtual_uid_maps = static:5000

      The log entries are:

      Jul 3 00:28:41 bell postfix/smtpd[15256]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
      Jul 3 00:28:41 bell postfix/smtpd[15256]: connect from localhost[::1]
      Jul 3 00:28:41 bell postfix/smtpd[15256]: NOQUEUE: reject: RCPT from localhost[::1]: 554 5.7.1 <harmonicnm7h@...>: Relay access denied; from=<swflint@...> to=<harmonicnm7h@...> proto=ESMTP helo=<flintfam.org>
      Jul 3 00:28:41 bell postfix/smtpd[15256]: lost connection after RCPT from localhost[::1]
      Jul 3 00:28:41 bell postfix/smtpd[15256]: disconnect from
      localhost[::1]

      The error in my mail client is:

      Transaction failed
      554 5.7.1 <harmonicnm7h@...>: Relay access denied

      Sam

      --
      Sam Flint
      Happy Hacking!
      swflint@...
      flintfam.org/~swflint
    • lists@rhsoft.net
      ... and why do you not simply enable authentication on your client? the log shows pretty clear that this does not happen and postfix *must not* accept the
      Message 2 of 3 , Jul 2, 2013
      • 0 Attachment
        Am 03.07.2013 02:34, schrieb Sam Flint:
        > Jul 3 00:28:41 bell postfix/smtpd[15256]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
        > Jul 3 00:28:41 bell postfix/smtpd[15256]: connect from localhost[::1]
        > Jul 3 00:28:41 bell postfix/smtpd[15256]: NOQUEUE: reject: RCPT from localhost[::1]: 554 5.7.1 <harmonicnm7h@...>: Relay access denied; from=<swflint@...> to=<harmonicnm7h@...> proto=ESMTP helo=<flintfam.org>
        > Jul 3 00:28:41 bell postfix/smtpd[15256]: lost connection after RCPT from localhost[::1]
        > Jul 3 00:28:41 bell postfix/smtpd[15256]: disconnect from
        > localhost[::1]
        >
        > The error in my mail client is:
        >
        > Transaction failed
        > 554 5.7.1 <harmonicnm7h@...>: Relay access denied

        and why do you not simply enable authentication on your client?
        the log shows pretty clear that this does not happen and
        postfix *must not* accept the message as otherwise you would
        have an open relay

        as well your postconf shows you have confugured SASL

        smtpd_sasl_auth_enable = yes
        smtpd_sasl_path = private/auth
        smtpd_sasl_type = dovecot
      • Wietse Venema
        ... Add ::1 to mynetworks. Wietse
        Message 3 of 3 , Jul 2, 2013
        • 0 Attachment
          Sam Flint:
          > Jul 3 00:28:41 bell postfix/smtpd[15256]: NOQUEUE: reject: RCPT from localhost[::1]:

          Add ::1 to mynetworks.

          Wietse
        Your message has been successfully submitted and would be delivered to recipients shortly.