Loading ...
Sorry, an error occurred while loading the content.

Error: unsupported dictionary type: ldap

Expand Messages
  • Vit Dua
    Hi all, I have compiled postfix 2.10.0 on Ubuntu 12.04. When I run postfix start , the mail log says: May 24 10:31:45 postfix01 postfix/proxymap[11670]:
    Message 1 of 10 , May 24, 2013
    • 0 Attachment
      Hi all,

      I have compiled postfix 2.10.0 on Ubuntu 12.04.

      When I run 'postfix start', the mail log says:

      May 24 10:31:45 postfix01 postfix/proxymap[11670]: error: unsupported dictionary type: ldap
      May 24 10:32:53  postfix/proxymap[11670]: last message repeated 11 times
      May 24 10:36:13 postfix01 postfix/proxymap[15445]: error: unsupported dictionary type: ldap
      May 24 10:37:24  postfix/proxymap[15445]: last message repeated 11 times
      May 24 11:20:30 postfix01 postfix/postfix-script[19984]: fatal: the Postfix mail system is already running
      May 24 11:20:35 postfix01 postfix/proxymap[20165]: error: unsupported dictionary type: ldap
      May 24 11:20:48  postfix/proxymap[20165]: last message repeated 11 times
      May 24 11:20:48 postfix01 postfix/proxymap[20396]: error: unsupported dictionary type: ldap
      May 24 11:21:56  postfix/proxymap[20396]: last message repeated 11 times
      May 24 11:22:16 postfix01 postfix/proxymap[21805]: error: unsupported dictionary type: ldap
      May 24 11:22:54  postfix/proxymap[21805]: last message repeated 11 times
      May 24 11:22:54 postfix01 postfix/proxymap[22414]: error: unsupported dictionary type: ldap
      May 24 11:23:56  postfix/proxymap[22414]: last message repeated 11 times
      May 24 11:29:09 postfix01 postfix/postfix-script[27598]: fatal: the Postfix mail system is not running
      May 24 11:29:26 postfix01 postfix/proxymap[27964]: error: unsupported dictionary type: ldap
      May 24 11:30:26  postfix/proxymap[27964]: last message repeated 11 times
      May 24 11:32:42 postfix01 postfix/postfix-script[30689]: fatal: the Postfix mail system is not running
      May 24 11:32:44 postfix01 postfix/proxymap[30818]: error: unsupported dictionary type: ldap
      May 24 11:33:57  postfix/proxymap[30818]: last message repeated 11 times


      I have re-installed postfix-ldap but no luck.

      I have read http://www.postfix.org/LDAP_README.html but cannot find solution there.

      Viet
    • DTNX Postmaster
      ... Have you compiled Postfix with LDAP support? Cya, Jona
      Message 2 of 10 , May 24, 2013
      • 0 Attachment
        On May 24, 2013, at 09:53, Vit Dua <vitdua@...> wrote:

        > Hi all,
        >
        > I have compiled postfix 2.10.0 on Ubuntu 12.04.
        >
        > When I run 'postfix start', the mail log says:
        >
        > May 24 10:31:45 postfix01 postfix/proxymap[11670]: error: unsupported dictionary type: ldap
        > May 24 10:32:53 postfix/proxymap[11670]: last message repeated 11 times
        > May 24 10:36:13 postfix01 postfix/proxymap[15445]: error: unsupported dictionary type: ldap
        > May 24 10:37:24 postfix/proxymap[15445]: last message repeated 11 times
        > May 24 11:20:30 postfix01 postfix/postfix-script[19984]: fatal: the Postfix mail system is already running
        > May 24 11:20:35 postfix01 postfix/proxymap[20165]: error: unsupported dictionary type: ldap
        > May 24 11:20:48 postfix/proxymap[20165]: last message repeated 11 times
        > May 24 11:20:48 postfix01 postfix/proxymap[20396]: error: unsupported dictionary type: ldap
        > May 24 11:21:56 postfix/proxymap[20396]: last message repeated 11 times
        > May 24 11:22:16 postfix01 postfix/proxymap[21805]: error: unsupported dictionary type: ldap
        > May 24 11:22:54 postfix/proxymap[21805]: last message repeated 11 times
        > May 24 11:22:54 postfix01 postfix/proxymap[22414]: error: unsupported dictionary type: ldap
        > May 24 11:23:56 postfix/proxymap[22414]: last message repeated 11 times
        > May 24 11:29:09 postfix01 postfix/postfix-script[27598]: fatal: the Postfix mail system is not running
        > May 24 11:29:26 postfix01 postfix/proxymap[27964]: error: unsupported dictionary type: ldap
        > May 24 11:30:26 postfix/proxymap[27964]: last message repeated 11 times
        > May 24 11:32:42 postfix01 postfix/postfix-script[30689]: fatal: the Postfix mail system is not running
        > May 24 11:32:44 postfix01 postfix/proxymap[30818]: error: unsupported dictionary type: ldap
        > May 24 11:33:57 postfix/proxymap[30818]: last message repeated 11 times
        >
        >
        > I have re-installed postfix-ldap but no luck.
        >
        > I have read http://www.postfix.org/LDAP_README.html but cannot find solution there.

        Have you compiled Postfix with LDAP support?

        Cya,
        Jona
      • Vit Dua
        ... I have built Postfix with: make CCARGS= -DNO_DB make install Is it enough? Viet
        Message 3 of 10 , May 24, 2013
        • 0 Attachment

          Have you compiled Postfix with LDAP support?
          

          I have built Postfix with:

          make CCARGS='-DNO_DB'
          make install  



          Is it enough?

          Viet



        • DTNX Postmaster
          ... Read the documentation. Understand what you are trying to accomplish, especially if you re going to compile things by yourself. Otherwise, use a
          Message 4 of 10 , May 24, 2013
          • 0 Attachment
            On May 24, 2013, at 10:57, Vit Dua <vitdua@...> wrote:

            >> Have you compiled Postfix with LDAP support?
            >
            > I have built Postfix with:
            >
            > make CCARGS='-DNO_DB'
            > make install
            >
            >
            > Is it enough?

            Read the documentation. Understand what you are trying to accomplish,
            especially if you're going to compile things by yourself. Otherwise,
            use a precompiled package supplied by your distribution.

            Cya,
            Jona
          • lists@...
            On Fri, 24 May 2013 15:57:46 +0700 ... Start and read from here: http://www.postfix.org/INSTALL.html
            Message 5 of 10 , May 24, 2013
            • 0 Attachment
              On Fri, 24 May 2013 15:57:46 +0700
              Vit Dua <vitdua@...> wrote:

              >
              > > Have you compiled Postfix with LDAP support?
              >
              > I have built Postfix with:
              >
              > make CCARGS='-DNO_DB'
              > make install
              >
              Start and read from here:
              http://www.postfix.org/INSTALL.html
            • Benny Pedersen
              ... if you compile self, its important to compile all needed parts, not just to install it congrats you make a dependice error now, ldd foo.so files to check
              Message 6 of 10 , May 24, 2013
              • 0 Attachment
                Vit Dua skrev den 2013-05-24 09:53:
                > I have compiled postfix 2.10.0 on Ubuntu 12.04.
                > I have re-installed postfix-ldap but no luck.

                if you compile self, its important to compile all needed parts, not
                just to install it

                congrats you make a dependice error now, ldd foo.so files to check

                or you falsy installed in /usr/local with is normal for make install,
                but for packagements is forbidden

                right way of doing it self, is to edit spec files, and build srpm with
                edited spec files, if ubuntu does not make it possible out of the box

                --
                senders that put my email into body content will deliver it to my own
                trashcan, so if you like to get reply, dont do it
              • Charles Marcus
                ... postconf -m output? -- Best regards, Charles
                Message 7 of 10 , May 25, 2013
                • 0 Attachment
                  On 2013-05-24 3:53 AM, Vit Dua <vitdua@...> wrote:
                  Hi all,

                  I have compiled postfix 2.10.0 on Ubuntu 12.04.

                  When I run 'postfix start', the mail log says:

                  May 24 10:31:45 postfix01 postfix/proxymap[11670]: error: unsupported dictionary type: ldap

                  I have re-installed postfix-ldap but no luck.

                  I have read http://www.postfix.org/LDAP_README.html but cannot find solution there.

                  postconf -m output?

                  -- 
                  
                  Best regards,
                  
                  Charles


                • Viktor Dukhovni
                  ... If the OP cannot follow the instructions in LDAP_README to build Postfix with LDAP support, the best option is to use pre-compiled packages from the
                  Message 8 of 10 , May 25, 2013
                  • 0 Attachment
                    On Sat, May 25, 2013 at 10:41:02AM -0400, Charles Marcus wrote:

                    > >I have read http://www.postfix.org/LDAP_README.html but cannot
                    > >find solution there.
                    >
                    > postconf -m output?

                    If the OP cannot follow the instructions in LDAP_README to build
                    Postfix with LDAP support, the best option is to use pre-compiled
                    packages from the distribution maintainer.

                    The comment in

                    http://www.postfix.org/LDAP_README.html#build

                    about Debian applies *only* when the base Postfix package is the
                    provided Debian Postfix, not when you build your own Postfix from
                    postfix.org source.

                    --
                    Viktor.
                  • Chiku
                    ... why don t you install it form package ? If you need ldap, just install postfix-ldap package http://packages.ubuntu.com/precise-updates/postfix-ldap If you
                    Message 9 of 10 , May 25, 2013
                    • 0 Attachment
                      Le 25/05/2013 16:49, Viktor Dukhovni a écrit :
                      > On Sat, May 25, 2013 at 10:41:02AM -0400, Charles Marcus wrote:
                      >
                      >>> I have read http://www.postfix.org/LDAP_README.html but cannot
                      >>> find solution there.
                      >> postconf -m output?
                      > If the OP cannot follow the instructions in LDAP_README to build
                      > Postfix with LDAP support, the best option is to use pre-compiled
                      > packages from the distribution maintainer.
                      >
                      > The comment in
                      >
                      > http://www.postfix.org/LDAP_README.html#build
                      >
                      > about Debian applies *only* when the base Postfix package is the
                      > provided Debian Postfix, not when you build your own Postfix from
                      > postfix.org source.
                      >
                      why don't you install it form package ?
                      If you need ldap, just install postfix-ldap package
                      http://packages.ubuntu.com/precise-updates/postfix-ldap

                      If you really need version 2.10 you can try ppa launchpad
                      https://launchpad.net/ubuntu/+source/postfix
                    • Vit Dua
                      Hi all, Thank you all for helpful support. I have read http://www.postfix.org/LDAP_README.html carefully again and corrected the problem. Viet
                      Message 10 of 10 , May 26, 2013
                      • 0 Attachment
                        Hi all,

                        Thank you all for helpful support.

                        I have read http://www.postfix.org/LDAP_README.html carefully again and
                        corrected the problem.

                        Viet

                        On 05/25/2013 10:00 PM, Chiku wrote:
                        > Le 25/05/2013 16:49, Viktor Dukhovni a écrit :
                        >> On Sat, May 25, 2013 at 10:41:02AM -0400, Charles Marcus wrote:
                        >>
                        >>>> I have read http://www.postfix.org/LDAP_README.html but cannot
                        >>>> find solution there.
                        >>> postconf -m output?
                        >> If the OP cannot follow the instructions in LDAP_README to build
                        >> Postfix with LDAP support, the best option is to use pre-compiled
                        >> packages from the distribution maintainer.
                        >>
                        >> The comment in
                        >>
                        >> http://www.postfix.org/LDAP_README.html#build
                        >>
                        >> about Debian applies *only* when the base Postfix package is the
                        >> provided Debian Postfix, not when you build your own Postfix from
                        >> postfix.org source.
                        >>
                        > why don't you install it form package ?
                        > If you need ldap, just install postfix-ldap package
                        > http://packages.ubuntu.com/precise-updates/postfix-ldap
                        >
                        > If you really need version 2.10 you can try ppa launchpad
                        > https://launchpad.net/ubuntu/+source/postfix
                      Your message has been successfully submitted and would be delivered to recipients shortly.