Loading ...
Sorry, an error occurred while loading the content.
 

Re: Dont add the $myorigin domain to the FROM header field

Expand Messages
  • Noel Jones
    ... http://www.postfix.org/ADDRESS_REWRITING_README.html#william http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain When you re using a
    Message 1 of 7 , Mar 22, 2013
      On 3/22/2013 11:44 AM, Victor d'Agostino wrote:
      > Hi all,
      >
      > I use postfix as relay server to several internal domains. xxx is
      > the main one.
      >
      > postconfig | grep domain prints :
      >
      > append_dot_mydomain = no
      > mydomain = xxx
      > myorigin = $mydomain
      > relay_domains = $mydomain yyy zzz
      >
      > If postfix receives an email with a FROM (headers and in the SMTP
      > dialog) without @xxx :
      >
      > mars 22 17:17:05 host=127.0.0.1 tls=off auth=off from=Administrateur
      > recipients=aaaa@... <mailto:aaaa@...> mailsize=72764
      > smtpstatus=250 smtpmsg='250 2.0.0 Ok: queued as 7C1A472' exitcode=EX_OK
      >
      >
      > Return-Path: <Administrateur@... <mailto:Administrateur@...>>
      > Received: [...]
      > Date: 22 Mar 2013 17:17:03 +0100
      > From: Administrateur
      > To: aaaa@... <mailto:aaaa@...>
      > Subject: aaa
      > [...]
      >
      >
      > it automaticly add @xxx to the FROM header when it transfers the
      > email to the next SMTP server.
      >
      > mars 22 17:17:06 myfinalhost postfix/qmgr[29863]: C0593684F41:
      > from=<Administrateur@xxx>, size=74777, nrcpt=1 (queue active)
      >
      >
      > I would like to know how to disable this behavior,
      > append_dot_mydomain is already set to no.
      >
      > Regards,
      >
      > Victor
      >


      http://www.postfix.org/ADDRESS_REWRITING_README.html#william
      http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain

      When you're using a content_filter, it's often useful to set:
      # main.cf
      remote_header_rewrite_domain = domain.invalid



      -- Noel Jones
    • Victor d'Agostino
      2013/3/22 Noel Jones ... Thanks for your reply, I do use a homemade content filter application. So I will try setting :
      Message 2 of 7 , Mar 22, 2013
        2013/3/22 Noel Jones <njones@...>
        On 3/22/2013 11:44 AM, Victor d'Agostino wrote:
        > Hi all,
        >
        > I use postfix as relay server to several internal domains. xxx is
        > the main one.
        >
        > postconfig | grep domain prints :
        >
        > append_dot_mydomain = no
        > mydomain = xxx
        > myorigin = $mydomain
        > relay_domains = $mydomain yyy zzz
        >
        > If postfix receives an email with a FROM (headers and in the SMTP
        > dialog) without @xxx :
        >
        > mars 22 17:17:05 host=127.0.0.1 tls=off auth=off from=Administrateur
        > recipients=aaaa@... <mailto:aaaa@...> mailsize=72764
        > smtpstatus=250 smtpmsg='250 2.0.0 Ok: queued as 7C1A472' exitcode=EX_OK
        >
        >
        > Return-Path: <Administrateur@... <mailto:Administrateur@...>>
        > Received: [...]
        > Date: 22 Mar 2013 17:17:03 +0100
        > From: Administrateur
        > To: aaaa@... <mailto:aaaa@...>
        > Subject: aaa
        > [...]
        >
        >
        > it automaticly add @xxx to the FROM header when it transfers the
        > email to the next SMTP server.
        >
        > mars 22 17:17:06 myfinalhost postfix/qmgr[29863]: C0593684F41:
        > from=<Administrateur@xxx>, size=74777, nrcpt=1 (queue active)
        >
        >
        > I would like to know how to disable this behavior,
        > append_dot_mydomain is already set to no.
        >
        > Regards,
        >
        > Victor
        >


        http://www.postfix.org/ADDRESS_REWRITING_README.html#william
        http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain

        When you're using a content_filter, it's often useful to set:
        # main.cf
        remote_header_rewrite_domain = domain.invalid



          -- Noel Jones

        Thanks for your reply,

        I do use a homemade content filter application. So I will try setting :

        remote_header_rewrite_domain =


        Victor
      • Noel Jones
        ... The default for that parameter is already empty, so setting it that way in main.cf probably won t make much difference. My suggestion was to set it to
        Message 3 of 7 , Mar 22, 2013
          On 3/22/2013 5:58 PM, Victor d'Agostino wrote:
          >
          >
          > 2013/3/22 Noel Jones <njones@...
          > <mailto:njones@...>>
          >
          > On 3/22/2013 11:44 AM, Victor d'Agostino wrote:
          > > Hi all,
          > >
          > > I use postfix as relay server to several internal domains. xxx is
          > > the main one.
          > >
          > > postconfig | grep domain prints :
          > >
          > > append_dot_mydomain = no
          > > mydomain = xxx
          > > myorigin = $mydomain
          > > relay_domains = $mydomain yyy zzz
          > >
          > > If postfix receives an email with a FROM (headers and in the SMTP
          > > dialog) without @xxx :
          > >
          > > mars 22 17:17:05 host=127.0.0.1 tls=off auth=off
          > from=Administrateur
          > > recipients=aaaa@... <mailto:aaaa@...>
          > <mailto:aaaa@... <mailto:aaaa@...>> mailsize=72764
          > > smtpstatus=250 smtpmsg='250 2.0.0 Ok: queued as 7C1A472'
          > exitcode=EX_OK
          > >
          > >
          > > Return-Path: <Administrateur@...
          > <mailto:Administrateur@...> <mailto:Administrateur@...
          > <mailto:Administrateur@...>>>
          > > Received: [...]
          > > Date: 22 Mar 2013 17:17:03 +0100
          > > From: Administrateur
          > > To: aaaa@... <mailto:aaaa@...> <mailto:aaaa@...
          > <mailto:aaaa@...>>
          > > Subject: aaa
          > > [...]
          > >
          > >
          > > it automaticly add @xxx to the FROM header when it transfers the
          > > email to the next SMTP server.
          > >
          > > mars 22 17:17:06 myfinalhost postfix/qmgr[29863]: C0593684F41:
          > > from=<Administrateur@xxx>, size=74777, nrcpt=1 (queue active)
          > >
          > >
          > > I would like to know how to disable this behavior,
          > > append_dot_mydomain is already set to no.
          > >
          > > Regards,
          > >
          > > Victor
          > >
          >
          >
          > http://www.postfix.org/ADDRESS_REWRITING_README.html#william
          > http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain
          >
          > When you're using a content_filter, it's often useful to set:
          > # main.cf <http://main.cf>
          > remote_header_rewrite_domain = domain.invalid
          >
          >
          >
          > -- Noel Jones
          >
          >
          > Thanks for your reply,
          >
          > I do use a homemade content filter application. So I will try setting :
          >
          > remote_header_rewrite_domain =
          >
          >
          > Victor


          The default for that parameter is already empty, so setting it that
          way in main.cf probably won't make much difference.

          My suggestion was to set it to "domain.invalid".
          remote_header_rewrite_domain = domain.invalid



          -- Noel Jones
        • Benny Pedersen
          ... as you see postfix will not do Shakira, Laundry Service All songs :) you have to fix it self before calling sendmail
          Message 4 of 7 , Mar 23, 2013
            Victor d'Agostino skrev den 2013-03-22 17:44:

            > I would like to know how to disable this behavior,
            > append_dot_mydomain is already set to no.

            as you see postfix will not do "Shakira, Laundry Service All songs" :)

            you have to fix it self before calling sendmail
          • Marko Weber | ZBF
            ... What is the goal of this? Why remove the FROM: Debugging would be alot harder i think. So why hiding this Information? And what would this
            Message 5 of 7 , Mar 26, 2013
              Am 2013-03-22 18:50, schrieb Noel Jones:
              > On 3/22/2013 11:44 AM, Victor d'Agostino wrote:
              >> Hi all,
              >>
              >> I use postfix as relay server to several internal domains. xxx is
              >> the main one.
              >>
              >> postconfig | grep domain prints :
              >>
              >> append_dot_mydomain = no
              >> mydomain = xxx
              >> myorigin = $mydomain
              >> relay_domains = $mydomain yyy zzz
              >>
              >> If postfix receives an email with a FROM (headers and in the SMTP
              >> dialog) without @xxx :
              >>
              >> mars 22 17:17:05 host=127.0.0.1 tls=off auth=off from=Administrateur
              >> recipients=aaaa@... <mailto:aaaa@...> mailsize=72764
              >> smtpstatus=250 smtpmsg='250 2.0.0 Ok: queued as 7C1A472'
              >> exitcode=EX_OK
              >>
              >>
              >> Return-Path: <Administrateur@... <mailto:Administrateur@...>>
              >> Received: [...]
              >> Date: 22 Mar 2013 17:17:03 +0100
              >> From: Administrateur
              >> To: aaaa@... <mailto:aaaa@...>
              >> Subject: aaa
              >> [...]
              >>
              >>
              >> it automaticly add @xxx to the FROM header when it transfers the
              >> email to the next SMTP server.
              >>
              >> mars 22 17:17:06 myfinalhost postfix/qmgr[29863]: C0593684F41:
              >> from=<Administrateur@xxx>, size=74777, nrcpt=1 (queue active)
              >>
              >>
              >> I would like to know how to disable this behavior,
              >> append_dot_mydomain is already set to no.
              >>
              >> Regards,
              >>
              >> Victor
              >>
              >
              >
              > http://www.postfix.org/ADDRESS_REWRITING_README.html#william
              > http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain
              >
              > When you're using a content_filter, it's often useful to set:
              > # main.cf
              > remote_header_rewrite_domain = domain.invalid

              What is the goal of this? Why remove the "FROM:"
              Debugging would be alot harder i think.
              So why hiding this Information?
              And what would this " remote_header_rewrite_domain = domain.invalid "
              cause?

              marko


              >
              >
              >
              > -- Noel Jones
            • Wietse Venema
              ... RTFM http://www.postfix.org/ADDRESS_REWRITING_README.html#william http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain
              Message 6 of 7 , Mar 26, 2013
                Marko Weber | ZBF:
                > > http://www.postfix.org/ADDRESS_REWRITING_README.html#william
                > > http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain
                > >
                > > When you're using a content_filter, it's often useful to set:
                > > # main.cf
                > > remote_header_rewrite_domain = domain.invalid
                >
                > What is the goal of this? Why remove the "FROM:"
                > Debugging would be alot harder i think.
                > So why hiding this Information?
                > And what would this " remote_header_rewrite_domain = domain.invalid "
                > cause?

                RTFM

                http://www.postfix.org/ADDRESS_REWRITING_README.html#william
                http://www.postfix.org/postconf.5.html#remote_header_rewrite_domain
              Your message has been successfully submitted and would be delivered to recipients shortly.