Loading ...
Sorry, an error occurred while loading the content.
 

Re: Submission on 587 and check_policy_service

Expand Messages
  • Titanus Eramius
    Thu, 21 Mar 2013 12:25:24 -0400 skrev Brian Evans ... Thank you for help, it was spot on. Cheers, Titanus
    Message 1 of 5 , Mar 21, 2013
      Thu, 21 Mar 2013 12:25:24 -0400 skrev Brian Evans
      <grknight@...>:

      > > submission inet n - - - - smtpd
      > > ...
      > > -o ... ,check_policy_service inet:127.0.0.1:10031,reject
      >
      > Change this to
      > "-o ... ,check_policy_service,inet:127.0.0.1:10031,reject"
      >
      > You cannot use spaces with in-line options in master.cf
      >
      > Brian

      Thank you for help, it was spot on.

      Cheers, Titanus
    • Wietse Venema
      ... In recent Postfix versions the master(5) manpage says: -o name=value Override the named main.cf configuration parameter. The parameter value can refer to
      Message 2 of 5 , Mar 21, 2013
        Titanus Eramius:
        > I have set Postfix only to allow relaying through submission on port
        > 587, and as extra safety, I have installed the PolicyD* service to run
        > some rate limiting, and is trying to configure it with Postfix.
        >
        > Since the PolicyD service only needs to check mail that gets relayed, I
        > am trying to call it from the submission block in master.cf like so:
        >
        > submission inet n - - - - smtpd
        > ...
        > -o ... ,check_policy_service inet:127.0.0.1:10031,reject
        >
        > But it does not work. The log gives this:

        In recent Postfix versions the master(5) manpage says:

        -o name=value
        Override the named main.cf configuration parameter. The
        parameter value can refer to other parameters as $name
        etc., just like in main.cf. See postconf(5) for syntax.

        NOTE 1: do not specify whitespace around the "=" or in
        parameter values. To specify a parameter value that con-
        tains whitespace, use commas instead of spaces, or spec-
        ify the value in main.cf. Example:

        /etc/postfix/master.cf:
        submission inet .... smtpd
        -o smtpd_mumble=$submission_mumble

        /etc/postfix/main.cf
        submission_mumble = text with whitespace...

        Instead of "mumble" use "recipient_restrictions" etc.

        This recommendation was added 1-2 years ago.

        Wietse
      • Benny Pedersen
        ... i still have to see why sending one msg pr day is a strong policy well postfix supports syslog (TM) :) and most syslogd nowadays support sql, got it ? all
        Message 3 of 5 , Mar 24, 2013
          Titanus Eramius skrev den 2013-03-21 14:49:
          > I have set Postfix only to allow relaying through submission on port
          > 587, and as extra safety, I have installed the PolicyD* service to
          > run
          > some rate limiting, and is trying to configure it with Postfix.

          i still have to see why sending one msg pr day is a strong policy

          well postfix supports syslog (TM) :)

          and most syslogd nowadays support sql, got it ?

          all that is left now is a postfix sql query based on sender restriction

          who will begin a guide wiki on this ?, i will be one that follow and
          commit to it if more can follow me :)
        Your message has been successfully submitted and would be delivered to recipients shortly.