Loading ...
Sorry, an error occurred while loading the content.

Message delivered despite restrictions

Expand Messages
  • Chris
    Hi all. Today this message was delivered to my inbox despite the fact that I ve listed ... postconf -n ... mysql:/etc/postfix/mysql-virtual_email2email.cf ...
    Message 1 of 8 , Mar 1, 2013
    • 0 Attachment
      Hi all.
      Today this message was delivered to my inbox despite the fact that I've listed
      the sender in a hash map. I can't figure out why:

      > Return-Path: <mailman-bounces@...>
      > Delivered-To: XXX
      > [...]
      > From: adsklix_advertisers-owner@...
      > To: XXX
      > Subject: XXX
      > Fri, 01 Mar 2013 05:00:08 -0600
      > Message-ID: <mailman.1488.1362135608.6366.mailman@...>

      postconf -n

      > alias_database = hash:/etc/aliases
      > alias_maps = hash:/etc/aliases
      > append_dot_mydomain = no
      > biff = no
      > broken_sasl_auth_clients = yes
      > config_directory = /etc/postfix
      > content_filter = amavis:[127.0.0.1]:10024
      > data_directory = /var/lib/postfix
      > header_checks = regexp:/etc/postfix/header_checks
      > html_directory = /usr/share/doc/postfix/html
      > inet_interfaces = all
      > inet_protocols = all
      > mailbox_command = procmail -a "$EXTENSION"
      > mailbox_size_limit = 0
      > maximal_queue_lifetime = 14d
      > message_size_limit = 0
      > milter_default_action = accept
      > mynetworks = [::1]/128, 127.0.0.0/8
      > myorigin = /etc/mailname
      > readme_directory = /usr/share/doc/postfix
      > recipient_bcc_maps = hash:/etc/postfix/recipient_bcc_map
      > recipient_delimiter = +
      > relayhost = [2a00:7b80:3019:12::e78f:b4d3]:587
      > sender_bcc_maps = hash:/etc/postfix/sender_bcc_map
      > sender_dependent_relayhost_maps = hash:/etc/postfix/relay_map
      > smtp_tls_loglevel = 1
      > smtp_tls_policy_maps = hash:/etc/postfix/tls-policy
      > smtp_tls_security_level = may
      > smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
      > smtpd_banner = $myhostname ESMTP $mail_name
      > smtpd_client_connection_count_limit = 150
      > smtpd_client_restrictions =
      > check_recipient_access hash:/etc/postfix/classes,
      > check_sender_access hash:/etc/postfix/origin_access_checks,
      > permit_mynetworks,
      > permit_sasl_authenticated,
      > check_recipient_access hash:/etc/postfix/cidr_bypass,
      > check_client_access cidr:/etc/postfix/cidr_checks,
      > check_client_access cidr:/etc/postfix/cidr_asia,
      > check_client_access pcre:/etc/postfix/fqrdns.regexp,
      > check_recipient_access hash:/etc/postfix/sqlgrey_optout,
      > reject_rbl_client b.barracudacentral.org,
      > reject_rbl_client zen.spamhaus.org,
      > permit
      > smtpd_data_restrictions = reject_unauth_pipelining
      > smtpd_helo_required = yes
      > smtpd_recipient_restrictions =
      > check_recipient_access hash:/etc/postfix/domain_user_blocks,
      > permit_mynetworks,
      > permit_sasl_authenticated,
      > reject_unauth_destination,
      > check_recipient_access regexp:/etc/postfix/accounts_regex,
      > check_recipient_access mysql:/etc/postfix/mysql-virtual_blocked.cf,
      > check_recipient_access hash:/etc/postfix/sqlgrey_optout,
      > check_policy_service inet:127.0.0.1:2501,
      > reject_unlisted_recipient,
      > permit
      > smtpd_reject_unlisted_recipient = yes
      > smtpd_reject_unlisted_sender = yes
      > smtpd_restriction_classes = nodnsfilter
      > smtpd_sasl_auth_enable = yes
      > smtpd_sasl_authenticated_header = yes
      > smtpd_sasl_path = private/auth
      > smtpd_sasl_type = dovecot
      > smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_check.cf
      > smtpd_sender_restrictions =
      > check_recipient_access hash:/etc/postfix/classes,
      > reject_authenticated_sender_login_mismatch,
      > check_sender_access hash:/etc/postfix/origin_access_checks,
      > permit_mynetworks,
      > permit_sasl_authenticated,
      > check_client_access hash:/etc/postfix/mx_whitelist,
      > check_sender_access hash:/etc/postfix/domain_user_blocks,
      > reject_unknown_sender_domain,
      > reject_non_fqdn_sender,
      > reject_rbl_client dul.dnsbl.sorbs.net,
      > reject_rbl_client dnsbl.njabl.org,
      > permit
      > smtpd_timeout = 60
      > smtpd_tls_cert_file = /etc/postfix/smtpd.cert
      > smtpd_tls_key_file = /etc/postfix/smtpd.key
      > smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
      > smtpd_use_tls = yes
      > strict_rfc821_envelopes = yes
      > tls_random_exchange_name = ${data_directory}/prng_exch
      > transport_maps = mysql:/etc/postfix/mysql-virtual_transport.cf
      > virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf
      mysql:/etc/postfix/mysql-virtual_email2email.cf
      > virtual_gid_maps = static:5000
      > virtual_mailbox_base = /var/mail/virtual
      > virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
      > virtual_mailbox_limit = 0
      > virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
      > virtual_transport = dovecot
      > virtual_uid_maps = static:5000

      I have "adsklix.com" explicitly listed in
      /etc/postfix/domain_user_blocks:

      > news@... REJECT Junkmail.

      and the local recipient is NOT listed in /etc/postfix/sqlgrey_optout.
      Thanks.

      Chris
    • Reindl Harald
      ... but the sender is not adsklix.com the From header is not relevant for SMTP hint: envelope-sender
      Message 2 of 8 , Mar 1, 2013
      • 0 Attachment
        Am 01.03.2013 12:26, schrieb Chris:
        >> Return-Path: <mailman-bounces@...>
        >> Delivered-To: XXX
        >> [...]
        >> From: adsklix_advertisers-owner@...
        >> To: XXX
        >> Subject: XXX
        >> Fri, 01 Mar 2013 05:00:08 -0600
        >> Message-ID: <mailman.1488.1362135608.6366.mailman@...>

        > I have "adsklix.com" explicitly listed in
        > /etc/postfix/domain_user_blocks:

        but the sender is not "adsklix.com"
        the "From" header is not relevant for SMTP

        hint: envelope-sender
      • Wietse Venema
        ... That is the envelope sender address (in SMTP, the MAIL FROM command). ... That is not the envelope sender address (in SMTP, the MAIL FROM command). Wietse
        Message 3 of 8 , Mar 1, 2013
        • 0 Attachment
          Chris:
          > Return-Path: <mailman-bounces@...>

          That is the envelope sender address (in SMTP, the MAIL FROM command).

          > I have "adsklix.com" explicitly listed in
          > /etc/postfix/domain_user_blocks:

          That is not the envelope sender address (in SMTP, the MAIL FROM command).

          Wietse
        • Chris
          On Fri, 01 Mar 2013 12:36:27 +0100 Reindl Harald wrote ... Fair enough, but what if I want to block specifically adsklix.com and not
          Message 4 of 8 , Mar 1, 2013
          • 0 Attachment
            On Fri, 01 Mar 2013 12:36:27 +0100 Reindl Harald <h.reindl@...> wrote

            > Am 01.03.2013 12:26, schrieb Chris:
            > >> Return-Path: <mailman-bounces@...>
            > >> Delivered-To: XXX
            > >> [...]
            > >> From: adsklix_advertisers-owner@...
            > >> To: XXX
            > >> Subject: XXX
            > >> Fri, 01 Mar 2013 05:00:08 -0600
            > >> Message-ID: <mailman.1488.1362135608.6366.mailman@...>
            >
            > > I have "adsklix.com" explicitly listed in
            > > /etc/postfix/domain_user_blocks:
            >
            > but the sender is not "adsklix.com"
            > the "From" header is not relevant for SMTP
            >
            > hint: envelope-sender

            Fair enough, but what if I want to block specifically "adsklix.com" and not the
            whole hostgator domain? header_checks?

            Chris
          • Noel Jones
            ... hostgator is a (mostly) legitimate mass mailer. Just unsubscribe from the unwanted list. Or check your logs; maybe gator843.hostgator.com is a customer ID
            Message 5 of 8 , Mar 1, 2013
            • 0 Attachment
              On 3/1/2013 6:06 AM, Chris wrote:
              > On Fri, 01 Mar 2013 12:36:27 +0100 Reindl Harald <h.reindl@...> wrote
              >
              >> Am 01.03.2013 12:26, schrieb Chris:
              >>>> Return-Path: <mailman-bounces@...>
              >>>> Delivered-To: XXX
              >>>> [...]
              >>>> From: adsklix_advertisers-owner@...
              >>>> To: XXX
              >>>> Subject: XXX
              >>>> Fri, 01 Mar 2013 05:00:08 -0600
              >>>> Message-ID: <mailman.1488.1362135608.6366.mailman@...>
              >>
              >>> I have "adsklix.com" explicitly listed in
              >>> /etc/postfix/domain_user_blocks:
              >>
              >> but the sender is not "adsklix.com"
              >> the "From" header is not relevant for SMTP
              >>
              >> hint: envelope-sender
              >
              > Fair enough, but what if I want to block specifically "adsklix.com" and not the
              > whole hostgator domain? header_checks?
              >
              > Chris
              >
              >

              hostgator is a (mostly) legitimate mass mailer. Just unsubscribe
              from the unwanted list.

              Or check your logs; maybe gator843.hostgator.com is a customer ID
              you can block.


              -- Noel Jones
            • Reindl Harald
              ... why? if they ignore abuse-mails and support sending spam block them if you registered for the mailinglist unsubscribe as many people out there are that
              Message 6 of 8 , Mar 1, 2013
              • 0 Attachment
                Am 01.03.2013 13:06, schrieb Chris:
                > On Fri, 01 Mar 2013 12:36:27 +0100 Reindl Harald <h.reindl@...> wrote
                >
                >> Am 01.03.2013 12:26, schrieb Chris:
                >>>> Return-Path: <mailman-bounces@...>
                >>>> Delivered-To: XXX
                >>>> [...]
                >>>> From: adsklix_advertisers-owner@...
                >>>> To: XXX
                >>>> Subject: XXX
                >>>> Fri, 01 Mar 2013 05:00:08 -0600
                >>>> Message-ID: <mailman.1488.1362135608.6366.mailman@...>
                >>
                >>> I have "adsklix.com" explicitly listed in
                >>> /etc/postfix/domain_user_blocks:
                >>
                >> but the sender is not "adsklix.com"
                >> the "From" header is not relevant for SMTP
                >>
                >> hint: envelope-sender
                >
                > Fair enough, but what if I want to block specifically "adsklix.com" and not the
                > whole hostgator domain? header_checks?

                why?

                if they ignore abuse-mails and support sending spam block them

                if you registered for the mailinglist unsubscribe as many people
                out there are that foolish to replae unsubscribe with "mark as spam"
                if thex no longer want subscribed newsletters
              • Chris
                On Fri, 01 Mar 2013 13:28:26 +0100 Reindl Harald wrote ... I usually unsub the clean way but their mailman installation gives a cgi
                Message 7 of 8 , Mar 1, 2013
                • 0 Attachment
                  On Fri, 01 Mar 2013 13:28:26 +0100 Reindl Harald <h.reindl@...> wrote

                  > Am 01.03.2013 13:06, schrieb Chris:
                  > > On Fri, 01 Mar 2013 12:36:27 +0100 Reindl Harald <h.reindl@...>
                  > > wrote
                  > >> Am 01.03.2013 12:26, schrieb Chris:
                  > >>>> Return-Path: <mailman-bounces@...>
                  > >>>> Delivered-To: XXX
                  > >>>> [...]
                  > >>>> From: adsklix_advertisers-owner@...
                  > >>>> To: XXX
                  > >>>> Subject: XXX
                  > >>>> Fri, 01 Mar 2013 05:00:08 -0600
                  > >>>> Message-ID:
                  > >>>> <mailman.1488.1362135608.6366.mailman@...> >>
                  > >>> I have "adsklix.com" explicitly listed in
                  > >>> /etc/postfix/domain_user_blocks:
                  > >>
                  > >> but the sender is not "adsklix.com"
                  > >> the "From" header is not relevant for SMTP
                  > >>
                  > >> hint: envelope-sender
                  > >
                  > > Fair enough, but what if I want to block specifically "adsklix.com" and not
                  > > the whole hostgator domain? header_checks?
                  >
                  > why?
                  >
                  > if they ignore abuse-mails and support sending spam block them
                  >
                  > if you registered for the mailinglist unsubscribe as many people
                  > out there are that foolish to replae unsubscribe with "mark as spam"
                  > if thex no longer want subscribed newsletters

                  I usually unsub the clean way but their mailman installation gives a cgi error
                  and does not seem to understand requests in email messages. I'm confident that
                  after a couple bounces they will disable my subscription.

                  Anyways hostgator appears to be using always the same host with that particular
                  customer, shouldn't be too hard to block

                  Chris
                • Reindl Harald
                  ... well, normally for that are postmaster-addresses and not blocking
                  Message 8 of 8 , Mar 1, 2013
                  • 0 Attachment
                    Am 01.03.2013 13:44, schrieb Chris:
                    > On Fri, 01 Mar 2013 13:28:26 +0100 Reindl Harald <h.reindl@...> wrote
                    >>> Fair enough, but what if I want to block specifically "adsklix.com" and not
                    >>> the whole hostgator domain? header_checks?
                    >>
                    >> why?
                    >>
                    >> if they ignore abuse-mails and support sending spam block them
                    >>
                    >> if you registered for the mailinglist unsubscribe as many people
                    >> out there are that foolish to replae unsubscribe with "mark as spam"
                    >> if thex no longer want subscribed newsletters
                    >
                    > I usually unsub the clean way but their mailman installation gives a cgi error
                    > and does not seem to understand requests in email messages. I'm confident that
                    > after a couple bounces they will disable my subscription

                    well, normally for that are postmaster-addresses and not blocking
                  Your message has been successfully submitted and would be delivered to recipients shortly.