Loading ...
Sorry, an error occurred while loading the content.

Re: virtual-regex problem

Expand Messages
  • Alex
    Hi Noel, Furthermore wildcard seems to have an effect only on email addresses for the parent domain of the postfix host. If I send email to @yahoo and regex
    Message 1 of 23 , Feb 15, 2013
    • 0 Attachment
      Hi Noel,

      Furthermore wildcard seems to have an effect only on email addresses
      for the parent domain of the postfix host.
      If I send email to @yahoo and regex changes it to @..., this works fine.
      If I send email to @mydomain regex changes it to wildcard.

      Does it make sense?
    • Noel Jones
      ... I m sure postfix is doing exactly what you ve told it to do. Postfix is documented here: http://www.postfix.org/documentation.html -- Noel Jones
      Message 2 of 23 , Feb 15, 2013
      • 0 Attachment
        On 2/15/2013 5:25 PM, Alex wrote:
        > Hi Noel,
        >
        > Furthermore wildcard seems to have an effect only on email addresses
        > for the parent domain of the postfix host.
        > If I send email to @yahoo and regex changes it to @..., this works fine.
        > If I send email to @mydomain regex changes it to wildcard.
        >
        > Does it make sense?
        >


        I'm sure postfix is doing exactly what you've told it to do.

        Postfix is documented here:
        http://www.postfix.org/documentation.html



        -- Noel Jones
      • Alex
        No doubt about it. I just wish I can understand how to change it. :) Any ideas?
        Message 3 of 23 , Feb 15, 2013
        • 0 Attachment
          No doubt about it. I just wish I can understand how to change it. :)
          Any ideas?
        • /dev/rob0
          ... Did you see my post yesterday? Pay close attention to the setting (unsetting, actually) of virtual_alias_domains.
          Message 4 of 23 , Feb 15, 2013
          • 0 Attachment
            On Fri, Feb 15, 2013 at 02:35:31PM -0800, Alex wrote:
            > It seems that regex is indeed working, but something is forcing
            > email into local host instead of outside. This only happens with
            > wildcard in place.
            >
            > Here is an extract from maillog:
            >
            > Feb 15 14:30:54 qa6 postfix/error[9898]: A6EC61F88989:
            > to=<somename@...>, orig_to=<somename@...>, relay=none,
            > delay=0.02, delays=0.01/0/0/0.01, dsn=5.0.0, status=bounced (User
            > unknown in virtual alias table)

            Did you see my post yesterday? Pay close attention to the setting
            (unsetting, actually) of virtual_alias_domains.

            http://www.postfix.org/ADDRESS_CLASS_README.html#virtual_alias_class
            http://www.postfix.org/VIRTUAL_README.html#virtual_alias
            http://www.postfix.org/postconf.5.html#virtual_alias_domains
            http://www.postfix.org/postconf.5.html#virtual_alias_maps
            --
            http://rob0.nodns4.us/ -- system administration and consulting
            Offlist GMX mail is seen only if "/dev/rob0" is in the Subject:
          • Alex
            Solved. One typo. I guess I was staring at the file to long.
            Message 5 of 23 , Feb 15, 2013
            • 0 Attachment
              Solved. One typo. I guess I was staring at the file to long.
            Your message has been successfully submitted and would be delivered to recipients shortly.