Loading ...
Sorry, an error occurred while loading the content.

Re: Missing smtp delivery log event with smtp_tls_loglevel = 3

Expand Messages
  • Viktor Dukhovni
    ... Still you never need a tls log level greater than 2 when doing trouble-shoots or 1 in production. Log levels 3 and 4 are for packet-level SSL traffic
    Message 1 of 6 , Feb 1, 2013
    • 0 Attachment
      On Fri, Feb 01, 2013 at 10:39:31AM -0500, Asa Gage wrote:

      > This was right on. Thanks Wietse.
      >
      > The rsyslogd service had rate limiting enabled by default and the log
      > lines were getting dropped.
      >
      > I fixed it by adding the following line to /etc/rsyslog.conf
      >
      > $SystemLogRateLimitInterval 0 # turn off rate limiting

      Still you never need a tls log level greater than 2 when doing
      trouble-shoots or 1 in production. Log levels 3 and 4 are for
      packet-level SSL traffic debugging by Postfix developers, to
      diagnose potential issues in the SSL I/O plumbing, not for
      general use. If you want to capture traffic, it is better
      to use tcpdump not syslog.

      While you may not want to have rate limits on syslog for other
      reasons, the fix for this problem is to not set a tls log level of
      3 or more in either the SMTP client or server.

      --
      Viktor.
    Your message has been successfully submitted and would be delivered to recipients shortly.