Loading ...
Sorry, an error occurred while loading the content.

Re: Missing smtp delivery log event with smtp_tls_loglevel = 3

Expand Messages
  • James Griffin
    ... I believe setting the tls log level to 1 is all you need to see the relevant session details. Setting the logging too high renders it difficult to make
    Message 1 of 6 , Jan 31, 2013
    • 0 Attachment
      * Asa Gage <agage@...> [2013-01-30 17:07:47 -0500]:

      > I seem to be missing smtp log events regarding delivery status for TLS
      > enabled mail when smtp_tls_loglevel = 3. I see a ton of TLS data as
      > expected, but the actual smtp result is no longer present. Is there any
      > explanation for this behavior?
      > mail_version = 2.6.6

      I believe setting the tls log level to 1 is all you need to see the
      relevant session details. Setting the logging too high renders it
      difficult to make sense of imo. Also, as pointed out by /dev/rob0,
      are you trying to see the details for incoming (smtpd(8)) or outgoing
      (smtp(8))?


      --
      Primary Key: 4096R/1D31DC38 2011-12-03
      Key Fingerprint: A4B9 E875 A18C 6E11 F46D B788 BEE6 1251 1D31 DC38
    • Asa Gage
      This was right on. Thanks Wietse. The rsyslogd service had rate limiting enabled by default and the log lines were getting dropped. I fixed it by adding the
      Message 2 of 6 , Feb 1, 2013
      • 0 Attachment
        This was right on. Thanks Wietse.

        The rsyslogd service had rate limiting enabled by default and the log
        lines were getting dropped.

        I fixed it by adding the following line to /etc/rsyslog.conf

        $SystemLogRateLimitInterval 0 # turn off rate limiting


        ________________________________________
        Asa Gage
        Senior Systems Engineer, NOC | Next Jump, Inc.
        One Kendall Square, STE B2401, Cambridge, MA 02139
        P: 617.682.4660 x5574 24/7: 617-682-4665
        agage@... | oo.com

        "BETTER Me+You=Us"
        Check out our culture video http://nxj.me/nextjump


        -----Original Message-----
        From: wietse@... [mailto:wietse@...]
        Sent: Wednesday, January 30, 2013 5:27 PM
        To: Asa Gage
        Cc: postfix-users@...
        Subject: Re: Missing smtp delivery log event with smtp_tls_loglevel = 3

        Asa Gage:
        > I seem to be missing smtp log events regarding delivery status for TLS

        > enabled mail when smtp_tls_loglevel = 3. I see a ton of TLS data as
        > expected, but the actual smtp result is no longer present. Is there
        > any explanation for this behavior?

        syslog uses a connection-less transport. The more logging you turn on,
        the more events will be lost.

        Wietse
      • Viktor Dukhovni
        ... Still you never need a tls log level greater than 2 when doing trouble-shoots or 1 in production. Log levels 3 and 4 are for packet-level SSL traffic
        Message 3 of 6 , Feb 1, 2013
        • 0 Attachment
          On Fri, Feb 01, 2013 at 10:39:31AM -0500, Asa Gage wrote:

          > This was right on. Thanks Wietse.
          >
          > The rsyslogd service had rate limiting enabled by default and the log
          > lines were getting dropped.
          >
          > I fixed it by adding the following line to /etc/rsyslog.conf
          >
          > $SystemLogRateLimitInterval 0 # turn off rate limiting

          Still you never need a tls log level greater than 2 when doing
          trouble-shoots or 1 in production. Log levels 3 and 4 are for
          packet-level SSL traffic debugging by Postfix developers, to
          diagnose potential issues in the SSL I/O plumbing, not for
          general use. If you want to capture traffic, it is better
          to use tcpdump not syslog.

          While you may not want to have rate limits on syslog for other
          reasons, the fix for this problem is to not set a tls log level of
          3 or more in either the SMTP client or server.

          --
          Viktor.
        Your message has been successfully submitted and would be delivered to recipients shortly.