Loading ...
Sorry, an error occurred while loading the content.

from <> ->

Expand Messages
  • Feel Zhou
    Hello, my friend This is Tom, I am sending my greetings from China I have a mail server with postfix working in the internet. I permit my customer send mail
    Message 1 of 4 , Jan 20, 2013
    • 0 Attachment
      Hello, my friend

      This is Tom, I am sending my greetings from China

      I have a mail server with postfix working in the internet. I permit my customer send mail via my postfix server. My customer domain is example.com and ip in mx is d.d.d.d

      Something write in the main.cf  like that:
      /etc/postfix/main.cf
      mynetworks = hash:/etc/postfix/mynetworks_table.feel
      /etc/postfix/mynetworks_table.feel
      example.com    PERMIT
      d.d.d.d             PERMIT
      I have already set more settingsin main.cf, just like that
      /etc/postfix/main.cf
      smtpd_helo_required = yes
      strict_rfc821_envelopes = yes
      smtpd_reject_unlisted_sender = yes
      smtpd_reject_unlisted_recipient = yes
      smtpd_delay_reject = yes
      smtpd_recipient_restrictions =
              reject_unknown_recipient_domain
              reject_unlisted_recipient
              permit_sasl_authenticated
              permit_mynetworks
              reject_unauth_destination
      sometimes,my customer send mail without email address, just like that
      Jan 20 23:26:51 shcx amavis[21760]: (21760-01) Passed CLEAN, [d.d.d.d] [d.d.d.d] <> -> <someone@...>

      How can I stop it send mail with empty mail address

      Thanks for your time
    • Robert Schetterer
      ... from normally is a bounce etc, so it might be ok after all you have amavis configured too, look at its setup too Best Regards MfG Robert Schetterer --
      Message 2 of 4 , Jan 20, 2013
      • 0 Attachment
        Am 20.01.2013 17:22, schrieb Feel Zhou:
        > Hello, my friend
        >
        > This is Tom, I am sending my greetings from China
        >
        > I have a mail server with postfix working in the internet. I permit my
        > customer send mail via my postfix server. My customer domain is
        > example.com <http://example.com> and ip in mx is d.d.d.d
        >
        > Something write in the main.cf <http://main.cf> like that:
        > /etc/postfix/main.cf <http://main.cf>
        > mynetworks = hash:/etc/postfix/mynetworks_table.feel
        > /etc/postfix/mynetworks_table.feel
        > example.com <http://example.com> PERMIT
        > d.d.d.d PERMIT
        > I have already set more settingsin main.cf <http://main.cf>, just like that
        > /etc/postfix/main.cf <http://main.cf>
        > smtpd_helo_required = yes
        > strict_rfc821_envelopes = yes
        > smtpd_reject_unlisted_sender = yes
        > smtpd_reject_unlisted_recipient = yes
        > smtpd_delay_reject = yes
        > smtpd_recipient_restrictions =
        > reject_unknown_recipient_domain
        > reject_unlisted_recipient
        > permit_sasl_authenticated
        > permit_mynetworks
        > reject_unauth_destination
        > sometimes,my customer send mail without email address, just like that
        > Jan 20 23:26:51 shcx amavis[21760]: (21760-01) Passed CLEAN, [d.d.d.d]
        > [d.d.d.d] <> -> <someone@... <mailto:someone@...>>
        >
        > How can I stop it send mail with empty mail address
        >
        > Thanks for your time

        from <> normally is a bounce etc, so it might be ok
        after all you have amavis configured too, look at its setup too



        Best Regards
        MfG Robert Schetterer

        --
        [*] sys4 AG

        http://sys4.de, +49 (89) 30 90 46 64
        Franziskanerstraße 15, 81669 München

        Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
        Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
        Aufsichtsratsvorsitzender: Joerg Heidrich
      • Feel Zhou
        Hello, My friend For now, I relly want to stop my customer send mail who use null sender address, just like that Jan 20 23:26:51 shcx amavis[21760]:
        Message 3 of 4 , Feb 28 7:16 PM
        • 0 Attachment
          Hello, My friend
          For now, I relly want to stop my customer send mail who use null sender address, just like that
          "Jan 20 23:26:51 shcx amavis[21760]: (21760-01) Passed CLEAN, [d.d.d.d] [d.d.d.d] <> -> <someone@...>"
          It's always spam mail or virus mail, sometimes, recipient address domain is illegal
          So I want to stop any other send address with "<>"
          How can I setting main.cf  with smtp level in the postfix? Thanks for your time
          TOM


          2013/1/21 Robert Schetterer <rs@...>
          Am 20.01.2013 17:22, schrieb Feel Zhou:
          > Hello, my friend
          >
          > This is Tom, I am sending my greetings from China
          >
          > I have a mail server with postfix working in the internet. I permit my
          > customer send mail via my postfix server. My customer domain is
          > example.com <http://example.com> and ip in mx is d.d.d.d
          >
          > Something write in the main.cf <http://main.cf>  like that:
          > /etc/postfix/main.cf <http://main.cf>
          > mynetworks = hash:/etc/postfix/mynetworks_table.feel
          > /etc/postfix/mynetworks_table.feel
          > example.com <http://example.com>    PERMIT
          > d.d.d.d             PERMIT
          > I have already set more settingsin main.cf <http://main.cf>, just like that
          > /etc/postfix/main.cf <http://main.cf>
          > smtpd_helo_required = yes
          > strict_rfc821_envelopes = yes
          > smtpd_reject_unlisted_sender = yes
          > smtpd_reject_unlisted_recipient = yes
          > smtpd_delay_reject = yes
          > smtpd_recipient_restrictions =
          >         reject_unknown_recipient_domain
          >         reject_unlisted_recipient
          >         permit_sasl_authenticated
          >         permit_mynetworks
          >         reject_unauth_destination
          > sometimes,my customer send mail without email address, just like that
          > Jan 20 23:26:51 shcx amavis[21760]: (21760-01) Passed CLEAN, [d.d.d.d]
          > [d.d.d.d] <> -> <someone@... <mailto:someone@...>>
          >
          > How can I stop it send mail with empty mail address
          >
          > Thanks for your time

          from <> normally is a bounce etc, so it might be ok
          after all you have amavis configured too, look at its setup too



          Best Regards
          MfG Robert Schetterer

          --
          [*] sys4 AG

          http://sys4.de, +49 (89) 30 90 46 64
          Franziskanerstraße 15, 81669 München

          Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
          Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
          Aufsichtsratsvorsitzender: Joerg Heidrich

        • Robert Schetterer
          ... as i wrote before sender is mailer daemon dont do it anything against it if the content is spam then the client may have been infected so drop him in
          Message 4 of 4 , Feb 28 11:38 PM
          • 0 Attachment
            Am 01.03.2013 04:16, schrieb Feel Zhou:
            > Hello, My friend
            > For now, I relly want to stop my customer send mail who use null sender
            > address, just like that
            > "Jan 20 23:26:51 shcx amavis[21760]: (21760-01) Passed CLEAN, [d.d.d.d]
            > [d.d.d.d] <> -> <someone@... <mailto:someone@...>>"
            > It's always spam mail or virus mail, sometimes, recipient address domain
            > is illegal
            > So I want to stop any other send address with "<>"
            > How can I setting main.cf <http://main.cf> with smtp level in the
            > postfix? Thanks for your time
            > TOM

            as i wrote before sender "<>" is mailer daemon
            dont do it anything against it

            if the content is spam then the client may have been infected
            so drop him in total, second alternative stop his spam going outbound
            with some content filter like amavis etc, in any case inform him that he
            might got infected, or have some missconfigure , sometimes some
            anti/spam virus software likes to inform the mostly faked sender that
            his mail may was stopped filtered or not delivered by spam tag, this is
            a totally missbehave going outbound


            Best Regards
            MfG Robert Schetterer

            --
            [*] sys4 AG

            http://sys4.de, +49 (89) 30 90 46 64
            Franziskanerstraße 15, 81669 München

            Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
            Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
            Aufsichtsratsvorsitzender: Joerg Heidrich
          Your message has been successfully submitted and would be delivered to recipients shortly.