Loading ...
Sorry, an error occurred while loading the content.

troubleshooting inability to receive email: should I see a process running on port 25?

Expand Messages
  • Tracy Wise
    Hi I m setting up a dedicated server from 1&1 Internet which has CentOS 6.3 with Postfix 2.8.4 and Plesk 11.0.9 pre-installed. Though I ve added the main
    Message 1 of 7 , Jan 17, 2013
    • 0 Attachment
      Hi I'm setting up a dedicated server from 1&1 Internet which has CentOS 6.3 with Postfix 2.8.4 and Plesk 11.0.9 pre-installed.

      Though I've added the main domain name (and set the server hostname to be the same), and a mailbox for that domain, in Plesk, and set Plesk to activate mail for the domain, no one is able to send an email to the server.  I tried to telnet to port 25 of my server and it says Connection refused.  I did "sudo netstat -nlp" and I can't find any process running on port 25.

      Should there be a postfix process running on port 25, in order for me to receive mail?  If so then at least I know what direction to go in troubleshooting.

      Any guidance would be greatly appreciated.

      Thanks!

      Tracy


    • Reindl Harald
      ... main.cf: inet_interfaces = all master.cf: smtp inet n - n - - smtpd _______________________________ however, you
      Message 2 of 7 , Jan 17, 2013
      • 0 Attachment
        Am 18.01.2013 05:50, schrieb Tracy Wise:
        > Should there be a postfix process running on port 25, in order for me to receive mail? If so then at least I know
        > what direction to go in troubleshooting.
        >
        > Any guidance would be greatly appreciated

        main.cf:
        inet_interfaces = all

        master.cf:
        smtp inet n - n - - smtpd
        _______________________________

        however, you should carefully read documentations before
        starting to setup a from the internet reachable smtpd!

        http://www.postfix.org/documentation.html
        http://www.postfix.org/BASIC_CONFIGURATION_README.html
      • Tracy Wise
        Thanks Reindl. I do indeed have that line in main.cf. However in master.cf there is a slight difference. Mine says: smtp unix - - n -
        Message 3 of 7 , Jan 17, 2013
        • 0 Attachment
          Thanks Reindl.

          I do indeed have that line in main.cf.

          However in master.cf there is a slight difference.  Mine says:

          smtp      unix  -       -       n       -       -       smtp

          Notice "unix" instead of "inet".  Do you think that's the problem?  But I would think it should be set right out of the box with Plesk pre-installed, or that there should be a setting in Plesk to enable it.

          And am I right in assuming that there should be a process running on port 25?

          On Fri, Jan 18, 2013 at 12:55 PM, Reindl Harald <h.reindl@...> wrote:


          Am 18.01.2013 05:50, schrieb Tracy Wise:
          > Should there be a postfix process running on port 25, in order for me to receive mail?  If so then at least I know
          > what direction to go in troubleshooting.
          >
          > Any guidance would be greatly appreciated

          main.cf:
          inet_interfaces = all

          master.cf:
          smtp            inet  n       -       n       -       -      smtpd
          _______________________________

          however, you should carefully read documentations before
          starting to setup a from the internet reachable smtpd!

          http://www.postfix.org/documentation.html
          http://www.postfix.org/BASIC_CONFIGURATION_README.html


        • Reindl Harald
          ... this is NOT the smtpd line why do you not post your config file to help others helping you? ... no, that one is for sending messages FROM your server that
          Message 4 of 7 , Jan 17, 2013
          • 0 Attachment
            Am 18.01.2013 06:13, schrieb Tracy Wise:
            > Thanks Reindl.
            >
            > I do indeed have that line in main.cf <http://main.cf>.
            >
            > However in master.cf <http://master.cf> there is a slight difference. Mine says:
            >
            > smtp unix - - n - - smtp

            this is NOT the smtpd line
            why do you not post your config file to help others helping you?

            > Notice "unix" instead of "inet". Do you think that's the problem?

            no, that one is for sending messages FROM your server
            that is why i referred to the basic documentation!

            > But I would think it should be set right out of
            > the box with Plesk pre-installed, or that there should be a setting in Plesk to enable it.

            sorry, this is the postfix-list not the plesk one

            > And am I right in assuming that there should be a process running on port 25?

            surely - vut as default a sane setup does not listen on the network
            because it is HIGHLY dangerous before a secure configuration to
            get a spam-relay
          • Muzaffer Tolga Ozses
            myPhone dan gönderdim 18 Oca 2013 tarihinde 07:25 saatinde, Reindl Harald ... Hi, please post your postconf -n output. M
            Message 5 of 7 , Jan 17, 2013
            • 0 Attachment
              myPhone'dan gönderdim

              18 Oca 2013 tarihinde 07:25 saatinde, Reindl Harald
              <h.reindl@...> şunları yazdı:

              >
              >
              > Am 18.01.2013 06:13, schrieb Tracy Wise:
              >> Thanks Reindl.
              >>
              >> I do indeed have that line in main.cf <http://main.cf>.
              >>
              >> However in master.cf <http://master.cf> there is a slight difference. Mine says:
              >>
              >> smtp unix - - n - - smtp
              >
              > this is NOT the smtpd line
              > why do you not post your config file to help others helping you?
              >
              >> Notice "unix" instead of "inet". Do you think that's the problem?
              >
              > no, that one is for sending messages FROM your server
              > that is why i referred to the basic documentation!
              >
              >> But I would think it should be set right out of
              >> the box with Plesk pre-installed, or that there should be a setting in Plesk to enable it.
              >
              > sorry, this is the postfix-list not the plesk one
              >
              >> And am I right in assuming that there should be a process running on port 25?
              >
              > surely - vut as default a sane setup does not listen on the network
              > because it is HIGHLY dangerous before a secure configuration to
              > get a spam-relay
              >

              Hi, please post your postconf -n output.

              M
            • Tracy Wise
              Thank you Rendl and Muzzaffer. Well I did some things in Plesk and restarted the server and it works now. And yes I understand what you mean now. Thank you
              Message 6 of 7 , Jan 18, 2013
              • 0 Attachment
                Thank you Rendl and Muzzaffer.

                Well I did some things in Plesk and restarted the server and it works now.  And yes I understand what you mean now.  Thank you very much.

                Tracy


                On Fri, Jan 18, 2013 at 1:25 PM, Reindl Harald <h.reindl@...> wrote:


                Am 18.01.2013 06:13, schrieb Tracy Wise:
                > Thanks Reindl.
                >
                > I do indeed have that line in main.cf <http://main.cf>.
                >
                > However in master.cf <http://master.cf> there is a slight difference.  Mine says:
                >
                > smtp      unix  -       -       n       -       -       smtp

                this is NOT the smtpd line
                why do you not post your config file to help others helping you?

                > Notice "unix" instead of "inet".  Do you think that's the problem?

                no, that one is for sending messages FROM your server
                that is why i referred to the basic documentation!

                >  But I would think it should be set right out of
                > the box with Plesk pre-installed, or that there should be a setting in Plesk to enable it.

                sorry, this is the postfix-list not the plesk one

                > And am I right in assuming that there should be a process running on port 25?

                surely - vut as default a sane setup does not listen on the network
                because it is HIGHLY dangerous before a secure configuration to
                get a spam-relay


              • Muzaffer
                ... Sure thing, It would be nice to share what you did with us.
                Message 7 of 7 , Jan 18, 2013
                • 0 Attachment
                  On 18 January 2013 11:11, Tracy Wise <wiseagape@...> wrote:
                  Thank you Rendl and Muzzaffer.

                  Well I did some things in Plesk and restarted the server and it works now.  And yes I understand what you mean now.  Thank you very much.

                  Sure thing, It would be nice to share what you did with us. 

                  Tracy


                  On Fri, Jan 18, 2013 at 1:25 PM, Reindl Harald <h.reindl@...> wrote:


                  Am 18.01.2013 06:13, schrieb Tracy Wise:
                  > Thanks Reindl.
                  >
                  > I do indeed have that line in main.cf <http://main.cf>.
                  >
                  > However in master.cf <http://master.cf> there is a slight difference.  Mine says:
                  >
                  > smtp      unix  -       -       n       -       -       smtp

                  this is NOT the smtpd line
                  why do you not post your config file to help others helping you?

                  > Notice "unix" instead of "inet".  Do you think that's the problem?

                  no, that one is for sending messages FROM your server
                  that is why i referred to the basic documentation!

                  >  But I would think it should be set right out of
                  > the box with Plesk pre-installed, or that there should be a setting in Plesk to enable it.

                  sorry, this is the postfix-list not the plesk one

                  > And am I right in assuming that there should be a process running on port 25?

                  surely - vut as default a sane setup does not listen on the network
                  because it is HIGHLY dangerous before a secure configuration to
                  get a spam-relay



                Your message has been successfully submitted and would be delivered to recipients shortly.