Loading ...
Sorry, an error occurred while loading the content.

Re: Fiddling with smtp_fallback_relay

Expand Messages
  • Wietse Venema
    ... The way smtp_fallback_relay is implemented, it adds each relay as a low-priority MX host with a safety check: if the relay does not resolve, then mail is
    Message 1 of 17 , Jan 16, 2013
    • 0 Attachment
      Steve Jenkins:
      > I've got two machines on my network - mailer1 and mailer2. Both running
      > Postfix 2.9.5. I've got
      >
      > smtp_fallback_relay = mailer2.example.com
      >
      > configured in mailer1's main.cf.

      The way smtp_fallback_relay is implemented, it adds each relay as
      a low-priority MX host with a safety check: if the relay does not
      resolve, then mail is not bounced.

      If you see deferred mail on mailer1, then it still needs to be
      forwarded to the smtp_fallback_relay. The maillog file should
      say why that hasn't happened yet.

      Wietse
    • Steve Jenkins
      ... Hey, Wietse. I appreciate the reply. Ok - as far as I can tell, the relay IS resolving. And actually, I ve got it configured as smtp_fallback_relay =
      Message 2 of 17 , Jan 16, 2013
      • 0 Attachment
        On Wed, Jan 16, 2013 at 4:00 PM, Wietse Venema <wietse@...> wrote:
        The way smtp_fallback_relay is implemented, it adds each relay as
        a low-priority MX host with a safety check: if the relay does not
        resolve, then mail is not bounced.

        Hey, Wietse. I appreciate the reply.

        Ok - as far as I can tell, the relay IS resolving. And actually, I've got it configured as smtp_fallback_relay = [mailer2.example.com] in brackets to eliminate the MX lookup.
         
        If you see deferred mail on mailer1, then it still needs to be
        forwarded to the smtp_fallback_relay. The maillog file should
        say why that hasn't happened yet.

        qshape isn't showing deferred mail on mailer1, though. qshape deferred is all zeros. The active queue is massive, however (over 91K messages in it now) and more than half of them are in the 1280 column.

        When a destination replies to mailer1 like this:

        Jan 16 16:10:15 mailer1 postfix-aol/smtp[1744]: 41C4F4F6F7D: host mailin-04.mx.aol.com[64.12.90.34] refused to talk to me: 554 mtain-mh04.r1000.mx.aol.com ESMTP not accepting connections

        Should that not trigger handing the message over to the fallback relay for subsequent attempts?

        Thx,

        Steve
      • Wietse Venema
        ... With smtp_skip_5xx_greeting = yes by default, Postfix pretends that the session failed due to a temporary error and tries the next MX host (or fall-back
        Message 3 of 17 , Jan 16, 2013
        • 0 Attachment
          Steve Jenkins:
          > qshape isn't showing deferred mail on mailer1, though. qshape deferred is
          > all zeros. The active queue is massive, however (over 91K messages in it
          > now) and more than half of them are in the 1280 column.
          >
          > When a destination replies to mailer1 like this:
          >
          > Jan 16 16:10:15 mailer1 postfix-aol/smtp[1744]: 41C4F4F6F7D: host
          > mailin-04.mx.aol.com[64.12.90.34] refused to talk to me: 554
          > mtain-mh04.r1000.mx.aol.com ESMTP not accepting connections
          >
          > Should that not trigger handing the message over to the fallback relay for
          > subsequent attempts?

          With "smtp_skip_5xx_greeting = yes" by default, Postfix pretends
          that the session failed due to a temporary error and tries the next
          MX host (or fall-back relay).

          If the mail is still in the active queue then Postfix is still
          trying other hosts.

          grep '41C4F4F6F7D' will show some of the delivery history, but
          you will need grep 'smtp.1744' for details.

          Wietse
        • Steve Jenkins
          ... Hold on... maybe it IS handing it off, now that I look at it more closely. This is from mailer1: Jan 16 16:14:32 mailer1 postfix-aol/smtp[1732]:
          Message 4 of 17 , Jan 16, 2013
          • 0 Attachment
            On Wed, Jan 16, 2013 at 4:12 PM, Steve Jenkins <stevejenkins@...> wrote:
            Should that not trigger handing the message over to the fallback relay for subsequent attempts?

            Hold on... maybe it IS handing it off, now that I look at it more closely. This is from mailer1:

            Jan 16 16:14:32 mailer1 postfix-aol/smtp[1732]: 97092438FFD: host mailin-01.mx.aol.com[64.12.90.1] refused to talk to me: 554 mtain-me04.r1000.mx.aol.com ESMTP not accepting connections
            Jan 16 16:14:35 mailer1 postfix-aol/smtp[1732]: 97092438FFD: host mailin-02.mx.aol.com[64.12.90.65] refused to talk to me: 554 mtain-ma05.r1000.mx.aol.com ESMTP not accepting connections
            Jan 16 16:14:36 mailer1 postfix-aol/smtp[1732]: 97092438FFD: host mailin-04.mx.aol.com[205.188.146.194] refused to talk to me: 554 mtain-dh06.r1000.mx.aol.com ESMTP not accepting connections
            Jan 16 16:14:37 mailer1 postfix-aol/smtp[1732]: 97092438FFD: host mailin-02.mx.aol.com[64.12.137.162] refused to talk to me: 554 mtain-mj01.r1000.mx.aol.com ESMTP not accepting connections
            Jan 16 16:14:40 mailer1 postfix-aol/smtp[1732]: 97092438FFD: host mailin-03.mx.aol.com[64.12.90.97] refused to talk to me: 554 mtain-mc05.r1000.mx.aol.com ESMTP not accepting connections
            Jan 16 16:14:40 mailer1 postfix-aol/smtp[1732]: 97092438FFD: to=<xxxxx@...>, relay=mailer2.example.com[xx.xx.xx.xx]:25, delay=7365, delays=6096/1261/8.3/0.13, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 1AB9F142131)

            And then over on mailer2 I'm seeing the message to to xxxxx@... (which is actually an aol.com address) get delivered.

            So I guess I should change my question - it looks like mailer1 is attempting to deliver to 5 AOL mail servers before passing off to the relay. Any way I can make it hand off to the fallback relay with fewer attempts?

            Thanks,

            SteveJ
          • Stan Hoeppner
            ... Why not simply spread the newsletter load over both your outbounds to begin with? And BTW, if you re not a spammer, don t say double opt in . There is no
            Message 5 of 17 , Jan 16, 2013
            • 0 Attachment
              On 1/16/2013 6:23 PM, Steve Jenkins wrote:

              > So I guess I should change my question - it looks like mailer1 is
              > attempting to deliver to 5 AOL mail servers before passing off to the
              > relay. Any way I can make it hand off to the fallback relay with fewer
              > attempts?

              Why not simply spread the newsletter load over both your outbounds to
              begin with?

              And BTW, if you're not a spammer, don't say "double opt in". There is
              no such thing. Spammers invented this term. If you are a legit sender,
              the proper term is "confirmed opt in", or "COI".

              --
              Stan
            • Steve Jenkins
              ... OK - that makes sense and explains my huge queue! ... Yes - as I discovered in the message above, after looking at more log lines together it seems mailer1
              Message 6 of 17 , Jan 16, 2013
              • 0 Attachment
                On Wed, Jan 16, 2013 at 4:22 PM, Wietse Venema <wietse@...> wrote:
                With "smtp_skip_5xx_greeting = yes" by default, Postfix pretends
                that the session failed due to a temporary error and tries the next
                MX host (or fall-back relay).

                If the mail is still in the active queue then Postfix is still
                trying other hosts.

                OK - that makes sense and explains my huge queue!
                 
                grep '41C4F4F6F7D' will show some of the delivery history, but
                you will need grep 'smtp.1744' for details.

                Yes - as I discovered in the message above, after looking at more log lines together it seems mailer1 is trying multiple mailers on AOL's network (and I assume the number of MX servers Postfix tries is controlled by AOL's DNS records) before passing off to mailer2. So I suppose it's working like it's supposed to.

                I guess my only other option is to turn off smtp_skip_5xx_greeting, in which case it will hand off to mailer2 on the first failure, correct? Is there any option to configure the number of failed attempts before handing off to the fallback relay, other than just ON/OFF?

                Thx,

                SteveJ
              • Wietse Venema
                ... [5x 554 greeting] ... You can twiddle with smtp_mx_mumble_limit, but why bother sending from mailer1, when the mail is accepted only from mailer2? Wietse
                Message 7 of 17 , Jan 16, 2013
                • 0 Attachment
                  Steve Jenkins:
                  > This is from mailer1:
                  [5x 554 greeting]
                  > mtain-mc05.r1000.mx.aol.com ESMTP not accepting connections
                  > Jan 16 16:14:40 mailer1 postfix-aol/smtp[1732]: 97092438FFD: to=<
                  > xxxxx@...>, relay=mailer2.example.com[xx.xx.xx.xx]:25, delay=7365,
                  > delays=6096/1261/8.3/0.13, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as
                  > 1AB9F142131)
                  >
                  > And then over on mailer2 I'm seeing the message to to
                  > xxxxx@...(which is actually an
                  > aol.com address) get delivered.
                  >
                  > So I guess I should change my question - it looks like mailer1 is
                  > attempting to deliver to 5 AOL mail servers before passing off to the
                  > relay. Any way I can make it hand off to the fallback relay with fewer
                  > attempts?

                  You can twiddle with smtp_mx_mumble_limit, but why bother sending
                  from mailer1, when the mail is accepted only from mailer2?

                  Wietse
                • Wietse Venema
                  ... Nope. 5xx is a permanent delivery error. Wietse
                  Message 8 of 17 , Jan 16, 2013
                  • 0 Attachment
                    Steve Jenkins:
                    > I guess my only other option is to turn off smtp_skip_5xx_greeting, in
                    > which case it will hand off to mailer2 on the first failure, correct?

                    Nope. 5xx is a permanent delivery error.

                    Wietse
                  • Steve Jenkins
                    On Wed, Jan 16, 2013 at 4:35 PM, Stan Hoeppner ... Until this week, we were using an OLD server to act as our fallback relay
                    Message 9 of 17 , Jan 16, 2013
                    • 0 Attachment
                      On Wed, Jan 16, 2013 at 4:35 PM, Stan Hoeppner <stan@...> wrote:
                      Why not simply spread the newsletter load over both your outbounds to
                      begin with?

                      Until this week, we were using an OLD server to act as our fallback relay (graveyard) machine and nothing else, since we really couldn't lean on it that hard (or depend on it for anything mission-critical) . But we've upgraded it to one that's the exact same specs as our primary mailer, so moving forward that's probably what we'll do.

                      And BTW, if you're not a spammer, don't say "double opt in".  There is
                      no such thing.  Spammers invented this term.  If you are a legit sender,
                      the proper term is "confirmed opt in", or "COI".

                      Gotit - thanks. I am certainly NOT a spammer. Although a spammer probably wouldn't admit to being a spammer anyway... So COI it is. :)

                      SteveJ
                    • Steve Jenkins
                      ... I think mailer1 got blocked initially by AOL because my aol_destination_concurrency_limit, aol_destination_recipient_limit, and aol_destination_rate_delay
                      Message 10 of 17 , Jan 16, 2013
                      • 0 Attachment
                        On Wed, Jan 16, 2013 at 4:35 PM, Wietse Venema <wietse@...> wrote:
                        You can twiddle with smtp_mx_mumble_limit, but why bother sending
                        from mailer1, when the mail is accepted only from mailer2?

                        I think mailer1 got blocked initially by AOL because my aol_destination_concurrency_limit, aol_destination_recipient_limit, and aol_destination_rate_delay were probably set too aggressively when we initiated the send last night. I've since cranked them down on mailer1 to match the settings of mailer2, but AOL hasn't reacted yet. We're still twiddling with those settings, too. :)

                        Our PHP script we use to send the mail is currently only configured to run from mailer1, and is running right now, and we don't want to have to interrupt it to move a copy over to mailer2 and write something that keeps track of which mailer sent the newsletter to which recipients.

                        Any way to use the transport maps on mailer1 to tell Postfix to use mailer2 for aol.com addresses? Then I could just change that setting, do a postfix reload, and let mailer1 "cool off" in AOL's eyes.

                        Thx,

                        SteveJ
                      • Steve Jenkins
                        ... FYI - Google returns NO results (nor does the search function on Postfix.org... since it s Google-powered) for smtp_mx_mumble_limit. Any docs on that?
                        Message 11 of 17 , Jan 16, 2013
                        • 0 Attachment
                          On Wed, Jan 16, 2013 at 4:35 PM, Wietse Venema <wietse@...> wrote:
                          You can twiddle with smtp_mx_mumble_limit

                          FYI - Google returns NO results (nor does the search function on Postfix.org... since it's Google-powered) for "smtp_mx_mumble_limit." Any docs on that?

                          SteveJ
                        • Wietse Venema
                          ... mumble is a wild-card. grep smtp_mx_ in postconf output. Wietse
                          Message 12 of 17 , Jan 16, 2013
                          • 0 Attachment
                            Steve Jenkins:
                            > On Wed, Jan 16, 2013 at 4:35 PM, Wietse Venema <wietse@...> wrote:
                            >
                            > > You can twiddle with smtp_mx_mumble_limit
                            >
                            > FYI - Google returns NO results (nor does the search function on
                            > Postfix.org... since it's Google-powered) for "smtp_mx_mumble_limit." Any
                            > docs on that?

                            mumble is a wild-card.

                            grep smtp_mx_ in postconf output.

                            Wietse
                          • Steve Jenkins
                            ... DOH! Roger that. :) Also, any way to use transport in some way on mailer1 to tell Postfix to use mailer2 for aol.com addresses? I could set that
                            Message 13 of 17 , Jan 16, 2013
                            • 0 Attachment
                              On Wed, Jan 16, 2013 at 5:27 PM, Wietse Venema <wietse@...> wrote:
                              mumble is a wild-card.

                              grep smtp_mx_ in postconf output.

                              DOH! Roger that. :)

                              Also, any way to use transport in some way on mailer1 to tell Postfix to use mailer2 for aol.com addresses? I could set that temporarily for the remainder of this mailing.

                              Thx,

                              SteveJ
                            • Steve Jenkins
                              ... For those who are learning along with me, since I didn t want to leave the smtp_mx_address_limit settings at the default of 5 for all other destinations,
                              Message 14 of 17 , Jan 16, 2013
                              • 0 Attachment
                                On Wed, Jan 16, 2013 at 4:35 PM, Wietse Venema <wietse@...> wrote:
                                You can twiddle with smtp_mx_mumble_limit, but why bother sending
                                from mailer1, when the mail is accepted only from mailer2?

                                For those who are learning along with me, since I didn't want to leave the smtp_mx_address_limit settings at the default of 5 for all other destinations, and I already had a transport set up for a number of aol.com related domains, I added -o smtp_mx_address_limit=2 to my AOL section in master.cf, and then restarted Postfix.

                                SteveJ
                              • Stan Hoeppner
                                ... I know you re not Steve. I should have said as you re not a spammer.. instead of if you re... -- Stan
                                Message 15 of 17 , Jan 17, 2013
                                • 0 Attachment
                                  On 1/16/2013 6:49 PM, Steve Jenkins wrote:
                                  > On Wed, Jan 16, 2013 at 4:35 PM, Stan Hoeppner <stan@...>
                                  > wrote:

                                  >> And BTW, if you're not a spammer...

                                  > Gotit - thanks. I am certainly NOT a spammer.

                                  I know you're not Steve. I should have said "as you're not a spammer.."
                                  instead of "if you're..."

                                  --
                                  Stan
                                • Steve Jenkins
                                  ... No.. I AM Steve! ;)
                                  Message 16 of 17 , Jan 17, 2013
                                  • 0 Attachment
                                    On Thu, Jan 17, 2013 at 3:45 AM, Stan Hoeppner <stan@...> wrote:
                                    I know you're not Steve.

                                    No.. I AM Steve! ;) 
                                  Your message has been successfully submitted and would be delivered to recipients shortly.