Loading ...
Sorry, an error occurred while loading the content.
 

SASL authentication fails

Expand Messages
  • Muzaffer
    Hi, I m trying to get postfix/dovecot working on a Webmin enabled server and I can t get SASL working for the life of me. Below are my logs and postconf -n.
    Message 1 of 6 , Jan 14, 2013
      Hi,

      I'm trying to get postfix/dovecot working on a Webmin enabled server and I can't get SASL working for the life of me. Below are my logs and postconf -n. 

      Logs
      ---
      Jan 14 19:47:12 ommuse postfix/smtpd[8911]: connect from mail-da0-f45.google.com[209.85.210.45]
      Jan 14 19:47:12 ommuse postfix/smtpd[8911]: warning: SASL: Connect to private/auth failed: No such file or directory
      Jan 14 19:47:12 ommuse postfix/smtpd[8911]: fatal: no SASL authentication mechanisms
      Jan 14 19:47:13 ommuse postfix/master[8477]: warning: process /usr/lib/postfix/smtpd pid 8911 exit status 1
      Jan 14 19:47:13 ommuse postfix/master[8477]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

      ---
      postconf -n
      ---
      alias_database = hash:/etc/aliases
      alias_maps = hash:/etc/aliases
      allow_percent_hack = no
      append_dot_mydomain = no
      biff = no
      broken_sasl_auth_clients = yes
      config_directory = /etc/postfix
      home_mailbox = Maildir/
      inet_interfaces = all
      mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
      mailbox_size_limit = 0
      mydestination = ommuse, localhost, localhost.localdomain, localhost, server.ommuse.com
      myhostname = ommuse.com
      mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
      myorigin = /etc/mailname
      readme_directory = no
      recipient_delimiter = +
      relayhost = 
      sender_bcc_maps = hash:/etc/postfix/bcc
      smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
      smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
      smtpd_recipient_restrictions = permit_sasl_authenticated,  permit_mynetworks,  reject_unauth_destination,  reject_non_fqdn_hostname,  reject_non_fqdn_sender,  reject_non_fqdn_recipient,  reject_unauth_pipelining,  reject_invalid_hostname,  reject_rbl_client sbl.spamhaus.org,  reject_rbl_client xbl.spamhaus.org
      smtpd_sasl_auth_enable = yes
      smtpd_sasl_authenticated_header = yes
      smtpd_sasl_local_domain = $myhostname
      smtpd_sasl_path = private/auth
      smtpd_sasl_security_options = noanonymous
      smtpd_sasl_type = dovecot
      smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
      smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
      smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
      smtpd_use_tls = yes
      virtual_alias_maps = hash:/etc/postfix/virtual
      queue_directory = /var/spool/postfix

      What am I missing?

      Regards,
    • Brian Evans
      ... This line is showing that Dovecot is not creating the socket required to auth as you have configured Postfix to send to. Did you add the auth socket in
      Message 2 of 6 , Jan 14, 2013
        On 1/14/2013 3:02 PM, Muzaffer wrote:
        Hi,

        I'm trying to get postfix/dovecot working on a Webmin enabled server and I can't get SASL working for the life of me. Below are my logs and postconf -n. 

        Logs
        ---
        Jan 14 19:47:12 ommuse postfix/smtpd[8911]: connect from mail-da0-f45.google.com[209.85.210.45]
        Jan 14 19:47:12 ommuse postfix/smtpd[8911]: warning: SASL: Connect to private/auth failed: No such file or directory


        This line is showing that Dovecot is not creating the socket required to auth as you have configured Postfix to send to.

        Did you add the auth socket in your dovecot configuration and restart dovecot?

        Brian
      • Muzaffer Tolga Ozses
        myPhone dan gönderdim 14 Oca 2013 tarihinde 22:37 saatinde, Brian Evans þunlarý yazdý: On 1/14/2013 3:02 PM, Muzaffer wrote: Hi,
        Message 3 of 6 , Jan 14, 2013


           myPhone'dan gönderdim

          14 Oca 2013 tarihinde 22:37 saatinde, Brian Evans <grknight@...> şunları yazdı:

          On 1/14/2013 3:02 PM, Muzaffer wrote:
          Hi,

          I'm trying to get postfix/dovecot working on a Webmin enabled server and I can't get SASL working for the life of me. Below are my logs and postconf -n. 

          Logs
          ---
          Jan 14 19:47:12 ommuse postfix/smtpd[8911]: connect from mail-da0-f45.google.com[209.85.210.45]
          Jan 14 19:47:12 ommuse postfix/smtpd[8911]: warning: SASL: Connect to private/auth failed: No such file or directory


          This line is showing that Dovecot is not creating the socket required to auth as you have configured Postfix to send to.

          Did you add the auth socket in your dovecot configuration and restart dovecot?

          Brian

          Yes, I can show you when I get to work. 
        • Erwan David
          ... Then check wether your postfix is chrooted, in that cas postfix would look for the socket in its chroot.
          Message 4 of 6 , Jan 14, 2013
            Le 15/01/2013 05:53, Muzaffer Tolga Ozses a écrit :
            >
            >
            > myPhone'dan gönderdim
            >
            > 14 Oca 2013 tarihinde 22:37 saatinde, Brian Evans
            > <grknight@... <mailto:grknight@...>> şunları yazdı:
            >
            >> On 1/14/2013 3:02 PM, Muzaffer wrote:
            >>> Hi,
            >>>
            >>> I'm trying to get postfix/dovecot working on a Webmin enabled server
            >>> and I can't get SASL working for the life of me. Below are my logs
            >>> and postconf -n.
            >>>
            >>> Logs
            >>> ---
            >>> Jan 14 19:47:12 ommuse postfix/smtpd[8911]: connect from
            >>> mail-da0-f45.google.com <http://mail-da0-f45.google.com>[209.85.210.45]
            >>> Jan 14 19:47:12 ommuse postfix/smtpd[8911]: warning: SASL: Connect
            >>> to private/auth failed: No such file or directory
            >>>
            >>
            >> This line is showing that Dovecot is not creating the socket required
            >> to auth as you have configured Postfix to send to.
            >>
            >> Did you add the auth socket in your dovecot configuration and restart
            >> dovecot?
            >>
            >> Brian
            >
            > Yes, I can show you when I get to work.

            Then check wether your postfix is chrooted, in that cas postfix would
            look for the socket in its chroot.
          • Muzaffer Tolga Özses
            ... service auth { mechanisms = plain login passdb pam {} userdb passwd {} socket listen { client { path = /var/spool/postfix/private/auth mode = 0660 user =
            Message 5 of 6 , Jan 15, 2013
              On 01/15/2013 07:11 AM, Erwan David wrote:
              > Le 15/01/2013 05:53, Muzaffer Tolga Ozses a écrit :
              >>
              >>
              >> myPhone'dan gönderdim
              >>
              >> 14 Oca 2013 tarihinde 22:37 saatinde, Brian Evans
              >> <grknight@... <mailto:grknight@...>> şunları
              >> yazdı:
              >>
              >>> On 1/14/2013 3:02 PM, Muzaffer wrote:
              >>>> Hi,
              >>>>
              >>>> I'm trying to get postfix/dovecot working on a Webmin enabled
              >>>> server and I can't get SASL working for the life of me. Below are
              >>>> my logs and postconf -n.
              >>>>
              >>>> Logs
              >>>> ---
              >>>> Jan 14 19:47:12 ommuse postfix/smtpd[8911]: connect from
              >>>> mail-da0-f45.google.com
              >>>> <http://mail-da0-f45.google.com>[209.85.210.45]
              >>>> Jan 14 19:47:12 ommuse postfix/smtpd[8911]: warning: SASL: Connect
              >>>> to private/auth failed: No such file or directory
              >>>>
              >>>
              >>> This line is showing that Dovecot is not creating the socket
              >>> required to auth as you have configured Postfix to send to.
              >>>
              >>> Did you add the auth socket in your dovecot configuration and
              >>> restart dovecot?
              >>>
              >>> Brian
              >>
              >> Yes, I can show you when I get to work.
              service auth {
              mechanisms = plain login
              passdb pam {}
              userdb passwd {}
              socket listen {
              client {
              path = /var/spool/postfix/private/auth
              mode = 0660
              user = postfix
              group = postfix
              }
              }
              }

              I got this from wiki2.dovecot.org.
              >
              > Then check wether your postfix is chrooted, in that cas postfix would
              > look for the socket in its chroot.
              It was indeed chrooted, so I edited master.conf and restarted postfix,
              however I'm still getting that error :S

              Regards,
              Muzaffer
            • Benny Pedersen
              ... http://wiki.dovecot.org/HowTo/PostfixAndDovecotSASL its well explained here i hope :)
              Message 6 of 6 , Jan 23, 2013
                Muzaffer skrev den 2013-01-14 21:02:

                > smtpd_sasl_path = private/auth
                > smtpd_sasl_type = dovecot

                > What am I missing?

                http://wiki.dovecot.org/HowTo/PostfixAndDovecotSASL

                its well explained here i hope :)
              Your message has been successfully submitted and would be delivered to recipients shortly.