Loading ...
Sorry, an error occurred while loading the content.

Re: destination_rate_delay and connection_reuse_time_limit

Expand Messages
  • Viktor Dukhovni
    ... mumble_destination_concurrency_limit = 1 ... The connection cache is used automatically when there is a backlog of mail to the destination. You are
    Message 1 of 74 , Jan 7, 2013
    • 0 Attachment
      On Mon, Jan 07, 2013 at 11:34:45AM -0200, Rafael Azevedo - IAGENTE wrote:

      > This is what I'm trying to do:
      >
      > - I need to have only one process to this transport's queue.

      mumble_destination_concurrency_limit = 1

      > - This queue must respect the destination's policy, so I can't
      > have more than 20 opened connections in 10 minutes timeframe. Thats
      > why I want to use connection cache.

      The connection cache is used automatically when there is a backlog
      of mail to the destination. You are defeating the connection cache
      by enforcing a rate limit of 1, which rate limits deliveries, not
      connections. DO NOT set a rate limit.

      > According to my configuration, I'm having only one process for
      > this transport, also limiting the sending time, holding down delivery
      > process, waiting 1 second for each sent message before sending
      > another one.

      Instead of setting a process limit of 1, you can just specify an
      explicit nexthop for the domains whose concurrency you want to
      aggregate:

      example.com mumble:example.com
      example.net mumble:example.com
      example.edu mumble:example.com
      ...

      This should the queue manager schedule deliveries to these domains
      as it will combine the queues for all the domains that use the
      transport into a single queue (while using the MX records for
      a suitably chosen single domain).

      > And since this transport handles only specific domains, I really
      > don't have to worry about receiver policies, because they told me
      > to send as much as I can using the same connection, avoiding opening
      > one connection per message.

      Don't enable rate delays. Do specify a common nexthop for all domains
      that share the transport. Don't mess with the connection cache timers.

      --
      Viktor.
    • Wietse Venema
      ... No it doesn t. Postfix logs delivery temporarily suspended and skips Yahoo until the dead host timer expires. Wietse
      Message 74 of 74 , Jan 9, 2013
      • 0 Attachment
        Rafael Azevedo - IAGENTE:
        > > When all greetings fail with 4xx or whatever then Postfix will
        > > suspend deliveries.
        >
        > I have no idea about what I'm doing wrong, this really doesn't
        > happen in my servers.

        No it doesn't. Postfix logs "delivery temporarily suspended" and
        skips Yahoo until the "dead host" timer expires.

        Wietse
      Your message has been successfully submitted and would be delivered to recipients shortly.