Loading ...
Sorry, an error occurred while loading the content.

transportmap ignores A record?

Expand Messages
  • Robert Joosten
    Hi, #currently investigating a masive mailbounce I m running postfix 2.9.4 on freebsd boxen. Is it intentional that a transportmap reading in the form
    Message 1 of 2 , Dec 13, 2012
    • 0 Attachment
      Hi,

      #currently investigating a masive mailbounce

      I'm running postfix 2.9.4 on freebsd boxen.

      Is it intentional that a transportmap reading in the form

      <domain> etrn-only:<hostname>

      intentionally ignores the A record of <hostname>?

      In dns, <hostname> is like
      <domainname> has address A
      <domainname> has IPv6 address AAAA-1
      <domainname> has IPv6 address AAAA-2
      <domainname> mail is handled by 10 <blah-1>
      <domainname> mail is handled by 10 <blah-2>

      It keeps trying both AAAA addresses in a loadballanced manner I intented,
      but blatantly ignores a usabable A host.

      Am I missing some point here, or overlook a snippet of doc.

      Regards,
      Robert
    • Noel Jones
      ... Some possibly related doc snippets; http://www.postfix.org/transport.5.html ... In the case of SMTP, specify a service on a non-default port as
      Message 2 of 2 , Dec 13, 2012
      • 0 Attachment
        On 12/13/2012 7:53 AM, Robert Joosten wrote:
        > Hi,
        >
        > #currently investigating a masive mailbounce
        >
        > I'm running postfix 2.9.4 on freebsd boxen.
        >
        > Is it intentional that a transportmap reading in the form
        >
        > <domain> etrn-only:<hostname>
        >
        > intentionally ignores the A record of <hostname>?


        Some possibly related doc snippets;

        http://www.postfix.org/transport.5.html
        ...
        In the case of SMTP, specify a service on a
        non-default port as host:service, and disable MX (mail
        exchanger) DNS lookups with [host] or [host]:port


        http://www.postfix.org/postconf.5.html#smtp_address_preference
        ...
        The setting "smtp_address_preference = ipv6" is unsafe. It can fail
        to deliver mail when there is an outage that affects IPv6, while the
        destination is still reachable over IPv4.


        Sorry for the generic help, but that kind of goes along with the
        generic problem report. If you need more help, please see
        http://www.postfix.org/DEBUG_README.html#mail




        -- Noel Jones
      Your message has been successfully submitted and would be delivered to recipients shortly.