Loading ...
Sorry, an error occurred while loading the content.

Re: Problem migrating a mail domain (loops back)

Expand Messages
  • d.davolio@mastertraining.it
    Hi Wietse, my machine is no more the final destination. It was but now no more. Basically i removed the example.com from the config and changed the DNS to
    Message 1 of 17 , Dec 4, 2012
    • 0 Attachment
      Hi Wietse,
      my machine is no more the final destination. It was but now no more.
      Basically i removed the example.com from the config and changed the DNS
      to point to different MX records.
      That's what is driving me crazy :)

      Now it MX records are:
      # dig example.com MX +noall +answer
      example.com. 12889 IN MX 10 ASPMX.L.GOOGLE.COM.
      example.com. 12889 IN MX 20 ALT1.ASPMX.L.GOOGLE.COM.
      example.com. 12889 IN MX 20 ALT2.ASPMX.L.GOOGLE.COM.
      example.com. 12889 IN MX 30 ASPMX2.GOOGLEMAIL.COM.
      example.com. 12889 IN MX 30 ASPMX3.GOOGLEMAIL.COM.



      On 12/04/2012 03:40 PM, Wietse Venema wrote:
      > d.davolio@...:
      >> Hi everybody,
      >> I'm running a postfix 2.5.5-1 on a old debian server, managing different
      >> mail domains. I'm migrating now to a different mail provider, one domain
      >> at time (es. example.com).
      >> I removed example.com from "virtual_alias_domains" and/or
      >> "mydestination" in main.cf. And restarted postfix.
      > If you machine is final destination for example.com, Postfix WILL
      > report a mail loop, unless you list the domain in mydestinaton OR
      > virtual_alias_domains OR virtual_mailbox_domains.
      >
      > Further reading:
      > http://www.postfix.org/ADDRESS_CLASS_README.html
      >
      > Wietse
    • Wietse Venema
      ... Is your Postfix system is getting stale information from DNS? Postfix may be using a different resolv.conf file, thanks to the brain-damaged way that some
      Message 2 of 17 , Dec 4, 2012
      • 0 Attachment
        d.davolio@...:
        > Hi Wietse,
        > my machine is no more the final destination. It was but now no more.
        > Basically i removed the example.com from the config and changed the DNS
        > to point to different MX records.

        Is your Postfix system is getting stale information from DNS?
        Postfix may be using a different resolv.conf file, thanks to
        the brain-damaged way that some Linux systems install Postfix.

        Otherwise, perhaps someone else is willing to look at anonymized
        evidence. I don't have time for such things.

        Wietse
      • d.davolio@mastertraining.it
        The anonymized dig output I wrote before was the real one, except the domain name. It was run directly from the debian mail server I m having the problem. I
        Message 3 of 17 , Dec 4, 2012
        • 0 Attachment
          The anonymized dig output I wrote before was the real one, except the
          domain name.
          It was run directly from the debian mail server I'm having the problem.
          I don't want to waste anybody's time, just asking for some hint on what
          and where to check.
          Like if there is a way to debug the dns query postfix is doing or if
          someone is seeing something strange on the MX record I get.
          Thanks anyway.
          Davo


          On 12/04/2012 04:32 PM, Wietse Venema wrote:
          > d.davolio@...:
          >> Hi Wietse,
          >> my machine is no more the final destination. It was but now no more.
          >> Basically i removed the example.com from the config and changed the DNS
          >> to point to different MX records.
          > Is your Postfix system is getting stale information from DNS?
          > Postfix may be using a different resolv.conf file, thanks to
          > the brain-damaged way that some Linux systems install Postfix.
          >
          > Otherwise, perhaps someone else is willing to look at anonymized
          > evidence. I don't have time for such things.
          >
          > Wietse
        • Wietse Venema
          ... What is the complete logfile record with the error message? Wietse
          Message 4 of 17 , Dec 4, 2012
          • 0 Attachment
            d.davolio@...:
            > The anonymized dig output I wrote before was the real one, except the
            > domain name.
            > It was run directly from the debian mail server I'm having the problem.
            > I don't want to waste anybody's time, just asking for some hint on what
            > and where to check.
            > Like if there is a way to debug the dns query postfix is doing or if
            > someone is seeing something strange on the MX record I get.

            What is the complete logfile record with the error message?

            Wietse
          • d.davolio@mastertraining.it
            This is from /var/log/syslog: Dec 4 15:13:41 mail2 postfix/smtpd[26204]: 4E21EA735A: client=unknown[192.168.2.203] Dec 4 15:13:41 mail2
            Message 5 of 17 , Dec 4, 2012
            • 0 Attachment
              This is from /var/log/syslog:

              Dec 4 15:13:41 mail2 postfix/smtpd[26204]: 4E21EA735A:
              client=unknown[192.168.2.203]
              Dec 4 15:13:41 mail2 postfix/cleanup[26207]: 4E21EA735A:
              message-id=<20121204151341.3478.f-zambella@...>
              Dec 4 15:13:41 mail2 postfix/qmgr[24532]: 4E21EA735A:
              from=<f.zambella@...>, size=1062, nrcpt=1 (queue active)
              Dec 4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A:
              to=<e.bosoli@...>, relay=none, delay=0.1, delays=0.1/0/0/0,
              dsn=5.4.6, status=bounced (mail for mastervoice.it loops back to myself)
              Dec 4 15:13:41 mail2 postfix/bounce[26228]: 4E21EA735A: sender
              non-delivery notification: 7EA7FA735D
              Dec 4 15:13:41 mail2 postfix/qmgr[24532]: 4E21EA735A: removed

              "mastervoice.it" is the domain I removed from the postfix configuration,
              "mastertraining.it" is the domain still working on the mail server.
              Thanks for any suggestion.
              Davo


              On 12/04/2012 05:21 PM, Wietse Venema wrote:
              > d.davolio@...:
              >> The anonymized dig output I wrote before was the real one, except the
              >> domain name.
              >> It was run directly from the debian mail server I'm having the problem.
              >> I don't want to waste anybody's time, just asking for some hint on what
              >> and where to check.
              >> Like if there is a way to debug the dns query postfix is doing or if
              >> someone is seeing something strange on the MX record I get.
              > What is the complete logfile record with the error message?
              >
              > Wietse
            • Ralf Hildebrandt
              ... If you removed mastervoice.it from the postfix, then postfix asks the DNS where to send the mail -- and sends it to itself. That s why it s looping. mail
              Message 6 of 17 , Dec 4, 2012
              • 0 Attachment
                * d.davolio@... <d.davolio@...>:
                > This is from /var/log/syslog:
                >
                > Dec 4 15:13:41 mail2 postfix/smtpd[26204]: 4E21EA735A: client=unknown[192.168.2.203]
                > Dec 4 15:13:41 mail2 postfix/cleanup[26207]: 4E21EA735A: message-id=<20121204151341.3478.f-zambella@...>
                > Dec 4 15:13:41 mail2 postfix/qmgr[24532]: 4E21EA735A: from=<f.zambella@...>, size=1062, nrcpt=1 (queue active)
                > Dec 4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A: to=<e.bosoli@...>, relay=none, delay=0.1,
                > delays=0.1/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it loops back to myself)
                > Dec 4 15:13:41 mail2 postfix/bounce[26228]: 4E21EA735A: sender non-delivery notification: 7EA7FA735D
                > Dec 4 15:13:41 mail2 postfix/qmgr[24532]: 4E21EA735A: removed

                > "mastervoice.it" is the domain I removed from the postfix
                > configuration, "mastertraining.it" is the domain still working on
                > the mail server.

                If you removed mastervoice.it from the postfix, then postfix asks the
                DNS where to send the mail -- and sends it to itself.

                That's why it's looping.
                "mail for mastervoice.it loops back to myself"

                --
                [*] sys4 AG

                http://sys4.de, +49 (89) 30 90 46 64
                Franziskanerstraße 15, 81669 München

                Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
                Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
                Aufsichtsratsvorsitzender: Joerg Heidrich
              • Ralf Hildebrandt
                ... What is the result of % host -t mx mastervoice.it on that machine? -- [*] sys4 AG http://sys4.de, +49 (89) 30 90 46 64 Franziskanerstraße 15, 81669
                Message 7 of 17 , Dec 4, 2012
                • 0 Attachment
                  * d.davolio@... <d.davolio@...>:

                  > Dec 4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A: to=<e.bosoli@...>, relay=none, delay=0.1,
                  > delays=0.1/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it loops back to myself)

                  What is the result of
                  % host -t mx mastervoice.it
                  on that machine?

                  --
                  [*] sys4 AG

                  http://sys4.de, +49 (89) 30 90 46 64
                  Franziskanerstraße 15, 81669 München

                  Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
                  Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
                  Aufsichtsratsvorsitzender: Joerg Heidrich
                • Wietse Venema
                  ... There s also an A record. Postfix will deliver mail there if disable_dns_lookups=yes or smtp_host_lookup does not contain dns . Wietse
                  Message 8 of 17 , Dec 4, 2012
                  • 0 Attachment
                    Ralf Hildebrandt:
                    > * d.davolio@... <d.davolio@...>:
                    >
                    > > Dec 4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A: to=<e.bosoli@...>, relay=none, delay=0.1,
                    > > delays=0.1/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it loops back to myself)
                    >
                    > What is the result of
                    > % host -t mx mastervoice.it
                    > on that machine?

                    There's also an A record. Postfix will deliver mail there if
                    "disable_dns_lookups=yes" or smtp_host_lookup does not contain
                    "dns".

                    Wietse
                  • Daniele Davolio
                    Here the requested output: mail2:~# host -t mx mastervoice.it mastervoice.it MX 10 ASPMX.L.GOOGLE.COM mastervoice.it MX 20 ALT1.ASPMX.L.GOOGLE.COM
                    Message 9 of 17 , Dec 4, 2012
                    • 0 Attachment
                      Here the requested output:
                      mail2:~# host -t mx mastervoice.it
                      mastervoice.it MX 10 ASPMX.L.GOOGLE.COM
                      mastervoice.it MX 20 ALT1.ASPMX.L.GOOGLE.COM
                      mastervoice.it MX 20 ALT2.ASPMX.L.GOOGLE.COM
                      mastervoice.it MX 30 ASPMX2.GOOGLEMAIL.COM
                      mastervoice.it MX 30 ASPMX3.GOOGLEMAIL.COM

                      I'm at home now, I'll look first for your hints tomorrow morning in
                      office!
                      I'll let you know what I'll discover.
                      Thanks for your always needed help, and patience.
                      Davo


                      On Tue, 4 Dec 2012 13:16:45 -0500 (EST), Wietse Venema
                      <wietse@...> wrote:
                      > Ralf Hildebrandt:
                      >> * d.davolio@... <d.davolio@...>:
                      >>
                      >> > Dec 4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A:
                      >> > to=<e.bosoli@...>, relay=none, delay=0.1,
                      >> > delays=0.1/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it
                      >> > loops back to myself)
                      >>
                      >> What is the result of
                      >> % host -t mx mastervoice.it
                      >> on that machine?
                      >
                      > There's also an A record. Postfix will deliver mail there if
                      > "disable_dns_lookups=yes" or smtp_host_lookup does not contain
                      > "dns".
                      >
                      > Wietse
                    • Viktor Dukhovni
                      ... Naturally, loops can also happen when routing is forced via transport table entries, content filters, ... So the MX records may be fine, but the OP s
                      Message 10 of 17 , Dec 4, 2012
                      • 0 Attachment
                        On Tue, Dec 04, 2012 at 08:48:47PM +0100, Daniele Davolio wrote:

                        > Here the requested output:
                        > mail2:~# host -t mx mastervoice.it
                        > mastervoice.it MX 10 ASPMX.L.GOOGLE.COM
                        > mastervoice.it MX 20 ALT1.ASPMX.L.GOOGLE.COM
                        > mastervoice.it MX 20 ALT2.ASPMX.L.GOOGLE.COM
                        > mastervoice.it MX 30 ASPMX2.GOOGLEMAIL.COM
                        > mastervoice.it MX 30 ASPMX3.GOOGLEMAIL.COM
                        >
                        > I'm at home now, I'll look first for your hints tomorrow morning in
                        > office!
                        > I'll let you know what I'll discover.
                        > Thanks for your always needed help, and patience.
                        > Davo
                        >
                        >
                        > On Tue, 4 Dec 2012 13:16:45 -0500 (EST), Wietse Venema
                        > <wietse@...> wrote:
                        > > Ralf Hildebrandt:
                        > >> * d.davolio@... <d.davolio@...>:
                        > >>
                        > >> > Dec 4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A:
                        > >> > to=<e.bosoli@...>, relay=none, delay=0.1,
                        > >> > delays=0.1/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it
                        > >> > loops back to myself)
                        > >>
                        > >> What is the result of
                        > >> % host -t mx mastervoice.it
                        > >> on that machine?
                        > >
                        > > There's also an A record. Postfix will deliver mail there if
                        > > "disable_dns_lookups=yes" or smtp_host_lookup does not contain

                        Naturally, loops can also happen when routing is forced via transport
                        table entries, content filters, ...

                        So the MX records may be fine, but the OP's configuration may
                        specify an explicit relayhost, default_transport with a nexthop,
                        relay_transport with a nexthop, a transport table entry, ...

                        --
                        Viktor.
                      • d.davolio@mastertraining.it
                        Hi, I managed to do some test but with no luck. As suggested I specified two parameters in main.cf that where not present before: disable_dns_lookups = no
                        Message 11 of 17 , Dec 5, 2012
                        • 0 Attachment
                          Hi, I managed to do some test but with no luck.
                          As suggested I specified two parameters in main.cf that where not present before:
                          disable_dns_lookups = no
                          smtp_host_lookup = dns

                          Sure mastervoice.it has an A record that point to 2.229.104.67 (web server) while the mail server is at 2.229.104.69.
                          I checked also the the transport table that is:
                          .fax    smtp:[192.168.1.211]
                          autoreply.mastertraining.it    gnarwl:


                          Ans here the actual postconf -n output:
                          alias_database = hash:/etc/aliases
                          alias_maps = hash:/etc/aliases
                          anvil_rate_time_unit = 5
                          append_dot_mydomain = no
                          biff = no
                          config_directory = /etc/postfix
                          disable_dns_lookups = no
                          home_mailbox = Maildir/
                          html_directory = /usr/share/doc/postfix/html
                          inet_interfaces = all
                          local_transport = virtual
                          mailbox_size_limit = 0
                          message_size_limit = 51200000
                          mydestination = mail2.mastercom, localhost.mastercom, localhost, mastertraining.it, registroelettronico.com, masterscuola.it, mastercom
                          myhostname = mail.mastertraining.it
                          mynetworks = 127.0.0.0/8, 192.168.1.0/24, 192.168.2.0/24, 10.10.0.0/24, 10.8.0.0/24, 10.9.0.0/24
                          myorigin = /etc/mailname
                          readme_directory = /usr/share/doc/postfix
                          recipient_delimiter = +
                          relay_domains = $mydestination
                          relayhost =
                          smtp_host_lookup = dns
                          smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
                          smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
                          smtpd_sender_restrictions = reject_non_fqdn_sender reject_unknown_sender_domain
                          smtpd_tls_cert_file = /etc/courier/imapd.pem
                          smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
                          smtpd_use_tls = yes
                          transport_maps = hash:/etc/postfix/transport
                          virtual_alias_domains =
                          virtual_gid_maps = static:5000
                          virtual_mailbox_base = /home
                          virtual_mailbox_limit = 0
                          virtual_mailbox_maps = ldap:mastermail
                          virtual_uid_maps = static:5000


                          With this config I keep having the bounce:
                          Dec  5 12:06:10 mail2 postfix/smtpd[20844]: 7FDFDA711C: client=unknown[192.168.1.14]
                          Dec  5 12:06:10 mail2 postfix/cleanup[20848]: 7FDFDA711C: message-id=<50BF2AA1.6050301@...>
                          Dec  5 12:06:10 mail2 postfix/qmgr[20841]: 7FDFDA711C: from=<d.davolio@...>, size=1985, nrcpt=1 (queue active)
                          Dec  5 12:06:10 mail2 postfix/smtp[20849]: 7FDFDA711C: to=<d.davolio@...>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it loops back to myself)
                          Dec  5 12:06:10 mail2 postfix/bounce[20850]: 7FDFDA711C: sender non-delivery notification: 8438FA734A
                          Dec  5 12:06:10 mail2 postfix/qmgr[20841]: 7FDFDA711C: removed

                          I share this because it's odd enough in my eyes. I bet is some DNS

                          Anyway, I had to modify the transport table as workaround to deliver the email for mastervoice.it domain. Like this:
                          .fax    smtp:[192.168.1.211]
                          mastervoice.it    smtp:[ASPMX.L.GOOGLE.COM]
                          autoreply.mastertraining.it    gnarwl:

                          Please don't insult me, I see that it not the best configuration but right now is keeping users from biting me.
                          If I'll solve this strange problem I'll share.

                          Thanks everybody!
                          Davo


                          On 12/04/2012 11:21 PM, Viktor Dukhovni wrote:
                          On Tue, Dec 04, 2012 at 08:48:47PM +0100, Daniele Davolio wrote:
                          
                          
                          Here the requested output:
                          mail2:~# host -t mx mastervoice.it 
                          mastervoice.it      	MX	10 ASPMX.L.GOOGLE.COM
                          mastervoice.it      	MX	20 ALT1.ASPMX.L.GOOGLE.COM
                          mastervoice.it      	MX	20 ALT2.ASPMX.L.GOOGLE.COM
                          mastervoice.it      	MX	30 ASPMX2.GOOGLEMAIL.COM
                          mastervoice.it      	MX	30 ASPMX3.GOOGLEMAIL.COM
                          
                          I'm at home now, I'll look first for your hints tomorrow morning in
                          office!
                          I'll let you know what I'll discover.
                          Thanks for your always needed help, and patience.
                          Davo
                          
                          
                          On Tue, 4 Dec 2012 13:16:45 -0500 (EST), Wietse Venema
                          <wietse@...> wrote:
                          
                          Ralf Hildebrandt:
                          
                          * d.davolio@... <d.davolio@...>:
                          
                          
                          Dec  4 15:13:41 mail2 postfix/smtp[26167]: 4E21EA735A:
                          to=<e.bosoli@...>, relay=none, delay=0.1,
                          delays=0.1/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it
                          loops back to myself)
                          
                          What is the result of
                          % host -t mx mastervoice.it 
                          on that machine?
                          
                          There's also an A record. Postfix will deliver mail there if
                          "disable_dns_lookups=yes" or smtp_host_lookup does not contain
                          
                          Naturally, loops can also happen when routing is forced via transport
                          table entries, content filters, ...
                          
                          So the MX records may be fine, but the OP's configuration may
                          specify an explicit relayhost, default_transport with a nexthop,
                          relay_transport with a nexthop, a transport table entry, ...
                          
                          

                        • Wietse Venema
                          ... Turn on ONE LEVEL of verbose logging: smtp unix - - n - - smtp -v Type postfix reload and send one message, then
                          Message 12 of 17 , Dec 5, 2012
                          • 0 Attachment
                            d.davolio@...:
                            > Dec 5 12:06:10 mail2 postfix/smtp[20849]: 7FDFDA711C:
                            > to=<d.davolio@...>, relay=none, delay=0.01,
                            > delays=0.01/0/0/0, dsn=5.4.6, status=bounced (mail for mastervoice.it
                            > loops back to myself)

                            Turn on ONE LEVEL of verbose logging:

                            smtp unix - - n - - smtp -v

                            Type "postfix reload" and send one message, then report the
                            logging for the smtp process.

                            Wietse
                          • Benny Pedersen
                            ... is dns ok to the new server or domain ? this must be ok before you change the current server ... why ? ... localhost.mastercom is invalid ... invalid ...
                            Message 13 of 17 , Dec 5, 2012
                            • 0 Attachment
                              d.davolio@... skrev den 04-12-2012 14:03:
                              > Hi everybody,
                              > I'm running a postfix 2.5.5-1 on a old debian server, managing
                              > different mail domains. I'm migrating now to a different mail
                              > provider, one domain at time (es. example.com).
                              > I removed example.com from "virtual_alias_domains" and/or
                              > "mydestination" in main.cf. And restarted postfix.
                              > Now, when sending an email to user@... i keep receiving the
                              > "loops back to myself" error and I don't understand why.
                              > I think the DNS MX records for example.com are right. I checked the
                              > virtual table but i commented out the aliases belonging to
                              > example.com, not the aliases that forward to other example.com email
                              > address.
                              > Can anyone suggest me where and what to check?

                              is dns ok to the new server or domain ?

                              this must be ok before you change the current server

                              > Thanks for any help!
                              > Davo
                              >
                              > Follow the postconf -n:
                              > alias_database = hash:/etc/aliases
                              > alias_maps = hash:/etc/aliases
                              > anvil_rate_time_unit = 5
                              > append_dot_mydomain = no

                              why ?

                              > biff = no
                              > config_directory = /etc/postfix
                              > disable_dns_lookups = no
                              > home_mailbox = Maildir/
                              > html_directory = /usr/share/doc/postfix/html
                              > inet_interfaces = all
                              > local_transport = virtual
                              > mailbox_size_limit = 0
                              > message_size_limit = 51200000
                              > mydestination = localhost.mastercom, localhost, example.net,
                              > example.org

                              localhost.mastercom is invalid

                              > myhostname = mail.example.net
                              > mynetworks = 127.0.0.0/8, 192.168.1.0/24, 192.168.2.0/24,
                              > 10.10.0.0/24, 10.8.0.0/24, 10.9.0.0/24

                              > myorigin = /etc/mailname

                              invalid

                              > readme_directory = /usr/share/doc/postfix
                              > recipient_delimiter = +

                              > relay_domains = $mydestination

                              remove

                              > relayhost =

                              remove

                              > smtp_tls_session_cache_database =
                              > btree:${queue_directory}/smtp_scache
                              > smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
                              > smtpd_sender_restrictions = reject_non_fqdn_sender
                              > reject_unknown_sender_domain
                              > smtpd_tls_cert_file = /etc/courier/imapd.pem
                              > smtpd_tls_session_cache_database =
                              > btree:${queue_directory}/smtpd_scache
                              > smtpd_use_tls = yes
                              > transport_maps = hash:/etc/postfix/transport
                              > virtual_alias_domains =
                              > virtual_gid_maps = static:5000
                              > virtual_mailbox_base = /home
                              > virtual_mailbox_limit = 0
                              > virtual_mailbox_maps = ldap:mastermail
                              > virtual_uid_maps = static:5000

                              loops back to myself is dns relayted with this config
                            • Benny Pedersen
                              ... dig @8.8.8.8 example.com MX +noall +answer is ok ?
                              Message 14 of 17 , Dec 5, 2012
                              • 0 Attachment
                                d.davolio@... skrev den 04-12-2012 15:52:

                                > Now it MX records are:
                                > # dig example.com MX +noall +answer

                                dig @8.8.8.8 example.com MX +noall +answer

                                is ok ?

                                > example.com. 12889 IN MX 10
                                > ASPMX.L.GOOGLE.COM.
                                > example.com. 12889 IN MX 20
                                > ALT1.ASPMX.L.GOOGLE.COM.
                                > example.com. 12889 IN MX 20
                                > ALT2.ASPMX.L.GOOGLE.COM.
                                > example.com. 12889 IN MX 30
                                > ASPMX2.GOOGLEMAIL.COM.
                                > example.com. 12889 IN MX 30
                                > ASPMX3.GOOGLEMAIL.COM.
                              • Viktor Dukhovni
                                ... Remove the transport table entry responsible for this. ... Almost certainly not, unless you have a chrooted /etc/resolv.conf that uses an unexpected DNS
                                Message 15 of 17 , Dec 5, 2012
                                • 0 Attachment
                                  On Wed, Dec 05, 2012 at 12:45:37PM +0100, d.davolio@... wrote:

                                  > mydestination = mail2.mastercom, localhost.mastercom, localhost,
                                  > mastertraining.it, registroelettronico.com, masterscuola.it,
                                  > mastercom
                                  > myhostname = mail.mastertraining.it
                                  > relay_domains = $mydestination
                                  > transport_maps = hash:/etc/postfix/transport
                                  >
                                  > With this config I keep having the bounce:
                                  >
                                  > Dec 5 12:06:10 mail2 postfix/smtp[20849]: 7FDFDA711C:
                                  > to=<d.davolio@...>, relay=none, delay=0.01,
                                  > delays=0.01/0/0/0, dsn=5.4.6, status=bounced (mail for
                                  > mastervoice.it loops back to myself)

                                  Remove the transport table entry responsible for this.

                                  > I share this because it's odd enough in my eyes. I bet is some DNS

                                  Almost certainly not, unless you have a chrooted /etc/resolv.conf
                                  that uses an unexpected DNS server. (Debian systems like yours
                                  often have chroot on by default).

                                  > Anyway, I had to modify the transport table as workaround to deliver
                                  > the email for mastervoice.it domain. Like this:
                                  > .fax smtp:[192.168.1.211]
                                  > mastervoice.it smtp:[ASPMX.L.GOOGLE.COM]
                                  > autoreply.mastertraining.it gnarwl:

                                  Are there any other entries in the transport table? Barring
                                  explicit transport overrides the smtp(8) delivery agent uses
                                  MX records, which it is clearly not doing.

                                  Therefore, you may have content_filter settings in master.cf, or
                                  a "*" entry in the transport table.

                                  The order of precedence is roughly:

                                  - content_filter
                                  - transport_maps exact match
                                  - transport_maps "*" entry
                                  - sender_dependent_default_transport_maps,
                                  default_transport,
                                  sender_dependent_relayhost_maps,
                                  - relayhost

                                  Any of these can override the default nexthop. A wildcard possibility
                                  is a firewall that rewrites all port 25 traffic back to your machine!
                                  Report what you see when you telnet to the Google MX hosts from "mail2".

                                  --
                                  Viktor.
                                Your message has been successfully submitted and would be delivered to recipients shortly.