Loading ...
Sorry, an error occurred while loading the content.

Postfix multiple instances + Dovecot

Expand Messages
  • WebprodsPT
    Hello, I have a multiple instance Postfix setup. The first (original) one was configured with dovecot with the property: smtpd_sasl_path = private/auth-client
    Message 1 of 4 , Dec 1, 2012
    • 0 Attachment
      Hello,

      I have a multiple instance Postfix setup. The first (original) one was
      configured with dovecot with the property:

      smtpd_sasl_path = private/auth-client

      This path represents a socket where dovecot listens to postfix
      connections (pardon me if this description is not 100% accurate).

      Now the other postfix instances doesn't have this special socket "file"
      in their spool directory, so I receive the following error in other
      Postfix instances:

      warning: SASL: Connect to private/auth-client failed: No such file or
      directory

      Since the property smtpd_sasl_path is relative to the instance spool
      directory, and the new instances have a separate spool directory, how
      can I configure the new instances to use the same socket descriptor as
      the original?

      Already tried to use an absolute path in smtpd_sasl_path but I had no
      success.

      Thank you
      gm
    • WebprodsPT
      ... Problem solved. Running cloned instances as not chrooted and set smtpd_sasl_path as absolute. Also had to clone lib folder to avoid process locking
      Message 2 of 4 , Dec 1, 2012
      • 0 Attachment
        On 12/01/2012 10:15 AM, WebprodsPT wrote:
        > Hello,
        >
        > I have a multiple instance Postfix setup. The first (original) one was
        > configured with dovecot with the property:
        >
        > smtpd_sasl_path = private/auth-client
        >
        > This path represents a socket where dovecot listens to postfix
        > connections (pardon me if this description is not 100% accurate).
        >
        > Now the other postfix instances doesn't have this special socket "file"
        > in their spool directory, so I receive the following error in other
        > Postfix instances:
        >
        > warning: SASL: Connect to private/auth-client failed: No such file or
        > directory
        >
        > Since the property smtpd_sasl_path is relative to the instance spool
        > directory, and the new instances have a separate spool directory, how
        > can I configure the new instances to use the same socket descriptor as
        > the original?
        >
        > Already tried to use an absolute path in smtpd_sasl_path but I had no
        > success.
        >
        > Thank you
        > gm
        >

        Problem solved.

        Running cloned instances as not chrooted and set smtpd_sasl_path as
        absolute.

        Also had to clone lib folder to avoid process locking problems.

        If this configuration is not advisable I ask you to reply please.

        Thanks,
        gm
      • Wietse Venema
        ... You can t share a relative pathname. You may, however, be able to specify an IP address (127.0.0.1) and port instead: smtpd_sasl_path =
        Message 3 of 4 , Dec 1, 2012
        • 0 Attachment
          WebprodsPT:
          > On 12/01/2012 10:15 AM, WebprodsPT wrote:
          > > Hello,
          > >
          > > I have a multiple instance Postfix setup. The first (original) one was
          > > configured with dovecot with the property:
          > >
          > > smtpd_sasl_path = private/auth-client

          You can't share a relative pathname. You may, however, be able to
          specify an IP address (127.0.0.1) and port instead:

          smtpd_sasl_path = inet:127.0.0.1:whatever

          See your Dovecot docs if TCP sockets are supported in your version.

          > Running cloned instances as not chrooted and set smtpd_sasl_path as
          > absolute.

          That will also work.

          > Also had to clone lib folder to avoid process locking problems.

          Indeed: each instance requires its own queue_directory and
          data_directory setting.

          Wietse
        • mouss
          ... create a socket for each postfix instance. With dovecot 1.x, that would look like client { path = /var/spool/postfix/private/dovecot-auth mode = 0660 user
          Message 4 of 4 , Dec 2, 2012
          • 0 Attachment
            Le 01/12/2012 11:15, WebprodsPT a écrit :
            > Hello,
            >
            > I have a multiple instance Postfix setup. The first (original) one was
            > configured with dovecot with the property:
            >
            > smtpd_sasl_path = private/auth-client
            >
            > This path represents a socket where dovecot listens to postfix
            > connections (pardon me if this description is not 100% accurate).
            >
            > Now the other postfix instances doesn't have this special socket
            > "file" in their spool directory, so I receive the following error in
            > other Postfix instances:
            > [snip]


            create a socket for each postfix instance.

            With dovecot 1.x, that would look like


            client {
            path = /var/spool/postfix/private/dovecot-auth
            mode = 0660
            user = postfix
            group = postfix
            }

            client {
            path = /d/spool/postfix2/private/dovecot-auth
            mode = 0660
            user = postfix
            group = postfix
            }
            ...

            With dovecot 2.x, something like

            unix_listener /var/spool/postfix/private/dovecot-auth {
            mode = 0666
            user = postfix
            group = postfix
            }

            unix_listener /var/spool/postfix2/private/dovecot-auth {
            mode = 0666
            user = postfix
            group = postfix
            }
            ...





            ...
          Your message has been successfully submitted and would be delivered to recipients shortly.