Loading ...
Sorry, an error occurred while loading the content.

Re: make error - "ATTENTION: Unknown system type: FreeBSD 9.0-RELEASE"

Expand Messages
  • Ed Flecko
    Wow...thank you Wietse! I *think* I know how to apply this, but can someone confirm this for me - I think I can just copy and paste your code into a file, name
    Message 1 of 4 , Nov 30, 2012
    • 0 Attachment
      Wow...thank you Wietse!

      I *think* I know how to apply this, but can someone confirm this for me -

      I think I can just copy and paste your code into a file, name it, and then:

      patch –p0 < /path/to/patch/patch_name.patch

      Right so far?

      What file am I applying the patch to? The "makedefs" file, right?

      I have to execute the patch command from within the same directory
      that the makedefs file is also in, right?

      Ed
    • Ed Flecko
      Solved! With the help of a co-worker, I used the -l parameter of patch to get it to ignore whitespace. Prior to that, I kept getting hunk failures. The command
      Message 2 of 4 , Nov 30, 2012
      • 0 Attachment
        Solved!

        With the help of a co-worker, I used the -l parameter of patch to get
        it to ignore whitespace. Prior to that, I kept getting hunk failures.
        The command I used is:

        patch –Cl –p0 < patch_name.patch

        first to "Check" for errors and then just

        patch –l –p0 < patch_name.patch.

        Thank you Wietse.

        Ed
      Your message has been successfully submitted and would be delivered to recipients shortly.