Loading ...
Sorry, an error occurred while loading the content.

Re: MTA Deferring e-mail

Expand Messages
  • /dev/rob0
    ... The higher-level explanation is that by using the getaddrinfo() system library routine, you are not able to look up the MX records which control mail
    Message 1 of 11 , Oct 2, 2012
    • 0 Attachment
      On Tue, Oct 02, 2012 at 10:02:35AM +0200, Reindl Harald wrote:
      > Am 02.10.2012 02:56, schrieb Jason T. Slack-Moehrle:
      > >>> So it looks like incoming e-mail might be working now, outgoing
      > >>> not so much.
      > >>
      > >>> Oct 1 16:34:03 www postfix/smtp[3362]: connect to
      > >>> gmail.com[74.125.224.149]:25: Connection timed out
      > >>
      > >> This looks quite like a "disable_dns_lookups=yes" issue. The
      > >> question then would be: how was it working before?
      > >
      > > $ postconf -n
      > > disable_dns_lookups = yes
      > >
      > > I now changed it to 'no' and things seem to be working again.
      > >
      > > I dont understand why, though, this would be creating the
      > > problem. Could you explain?
      >
      > see docs: http://www.postfix.org/postconf.5.html#disable_dns_lookups
      >
      > disable_dns_lookups (default: no)

      The higher-level explanation is that by using the getaddrinfo()
      system library routine, you are not able to look up the MX records
      which control mail routing.

      > > If it creates this problem, why do people set it?

      The better question: why did Jason set it? :) Don't change defaults
      if you don't understand them.

      > nobody does set it global
      >
      > it makes sense on internal transports like LMTP in
      > master.cf but NOT as global setting!
      >
      > dbmail-lmtp unix - - n - - lmtp -o disable_dns_lookups=yes -o max_use=100

      It might also simplify things in a relayhost + transport_maps
      configuration, but that is not really important. Bottom line here:
      Postfix comes with a lot of knobs and dials you can tweak and turn.
      Resist the urge. :)
      --
      http://rob0.nodns4.us/ -- system administration and consulting
      Offlist GMX mail is seen only if "/dev/rob0" is in the Subject:
    Your message has been successfully submitted and would be delivered to recipients shortly.