Loading ...
Sorry, an error occurred while loading the content.
 

Re: The Yahoo trickle

Expand Messages
  • Joey Prestia
    ... Hi Stan, I did that some time ago. I am white listed with them and have published SPF Records and use DKIM to sign all outgoing mail. I am not receiving
    Message 1 of 6 , Sep 3 6:04 AM
      On 9/3/2012 3:50 AM, Stan Hoeppner wrote:
      > On 9/2/2012 10:07 PM, Joey Prestia wrote:
      >> Hi all,
      >>
      >> I am familiar with yahoo being difficult to send email to
      >
      > [snip]
      >
      >> Can anyone offer any guidance on what direction I need to go?
      >
      > Start here:
      > http://help.yahoo.com/l/us/yahoo/mail/postmaster/bulkv2.html
      >

      Hi Stan,

      I did that some time ago. I am white listed with them and have published
      SPF Records and use DKIM to sign all outgoing mail. I am not receiving
      any error codes only (250 ok dirdel) in my logs.

      I will recheck with yahoo on my bulk sending status and validate it
      indeed as it should be.

      Joey
    • Viktor Dukhovni
      ... You have serialized deliveries to Yahoo, they happen one at a time. Given that each delivery takes ~5s, there is not much point in doing that, you can
      Message 2 of 6 , Sep 3 10:43 AM
        On Sun, Sep 02, 2012 at 08:07:21PM -0700, Joey Prestia wrote:

        > yahoo_destination_concurrency_limit = 20

        This setting is trumpted by the setting below:

        > yahoo_destination_rate_delay = 1s

        You have serialized deliveries to Yahoo, they happen one at a time.
        Given that each delivery takes ~5s, there is not much point in
        doing that, you can instead set a low concurrency, and get a bunch
        more throughput by not setting an explicit rate limit. (perhaps
        2 deliveries per second with a concurrency of 10, rather than 1
        delivery every 5 seconds).

        For more throughput, you need more IP addresses, perhaps even in
        distint address blocks, ...

        Sadly, Yahoo discriminates the Postfix connection cache which limits
        connection re-use by time rather than delivery count. Limiting by
        delivery count behaves poorly when one or more of the MX hosts for
        a site is slower than the rest, it becomes a connection "attractor",
        so Postfix uses a better strategy.

        You can just disable connection caching with Yahoo, they rarely
        have unreachable MX hosts, your deliveries are just as slow whether
        connections are cached or not.

        --
        Viktor.
      • Joey Prestia
        ... So what I would need then is in main.cf and in master.cf in my transport would be this? yahoo_destination_concurrency_limit = 10 -o
        Message 3 of 6 , Sep 3 3:44 PM
          On 9/3/2012 10:43 AM, Viktor Dukhovni wrote:
          > On Sun, Sep 02, 2012 at 08:07:21PM -0700, Joey Prestia wrote:
          >
          >> yahoo_destination_concurrency_limit = 20
          >
          > This setting is trumpted by the setting below:
          >
          >> yahoo_destination_rate_delay = 1s
          >
          > You have serialized deliveries to Yahoo, they happen one at a time.
          > Given that each delivery takes ~5s, there is not much point in
          > doing that, you can instead set a low concurrency, and get a bunch
          > more throughput by not setting an explicit rate limit. (perhaps
          > 2 deliveries per second with a concurrency of 10, rather than 1
          > delivery every 5 seconds).

          So what I would need then is in main.cf and in master.cf in my transport
          would be this?

          yahoo_destination_concurrency_limit = 10


          -o smtp_connection_cache_on_demand=no


          >
          > For more throughput, you need more IP addresses, perhaps even in
          > distint address blocks, ...
          >
          > Sadly, Yahoo discriminates the Postfix connection cache which limits
          > connection re-use by time rather than delivery count. Limiting by
          > delivery count behaves poorly when one or more of the MX hosts for
          > a site is slower than the rest, it becomes a connection "attractor",
          > so Postfix uses a better strategy.
          >

          I thought we were making good use of our connection caching?

          > You can just disable connection caching with Yahoo, they rarely
          > have unreachable MX hosts, your deliveries are just as slow whether
          > connections are cached or not.
          >
        • Stan Hoeppner
          ... Connection caching needs two good dance partners to work effectively. In this case Yahoo is stepping on Postfix toes. -- Stan
          Message 4 of 6 , Sep 3 5:18 PM
            On 9/3/2012 5:44 PM, Joey Prestia wrote:
            > On 9/3/2012 10:43 AM, Viktor Dukhovni wrote:

            >> Sadly, Yahoo discriminates the Postfix connection cache which limits
            >> connection re-use by time rather than delivery count. Limiting by
            >> delivery count behaves poorly when one or more of the MX hosts for
            >> a site is slower than the rest, it becomes a connection "attractor",
            >> so Postfix uses a better strategy.

            > I thought we were making good use of our connection caching?

            Connection caching needs two good dance partners to work effectively.
            In this case Yahoo is stepping on Postfix' toes.

            --
            Stan
          Your message has been successfully submitted and would be delivered to recipients shortly.