Loading ...
Sorry, an error occurred while loading the content.
 

Cannot smtp unless logon before sending

Expand Messages
  • Gmail-teopro
    Hi all, I ve already finished a Postfix server setup with virtual users and Dovecot as virtual transport. I just cannot find out why MS Outlook fails the smtp
    Message 1 of 4 , Jul 28, 2012
      Hi all,

      I've already finished a Postfix server setup with virtual users and Dovecot
      as virtual transport.
      I just cannot find out why MS Outlook fails the smtp test unless I check
      the "Log on to incoming mail server before sending mail" on the More
      settings/ Outgoing Server tab.


      Thanks in advance for any hint you can help.



      --
      Best regards,
      Gmail-teopro mailto:teopro@...
    • Gmail-teopro
      Hello again, I apologize that in my previous message I didn t provide additional informations. I was hoping to be a trivial problem(and it was), so it doesn t
      Message 2 of 4 , Jul 29, 2012
        Hello again,
        I apologize that in my previous message I didn't provide additional
        informations. I was hoping to be a trivial problem(and it was), so it
        doesn't need too much to be solved.

        I've solved the problem after sending my first post. It was in main.cf, the
        following statement:
        smtpd_sasl_exceptions_networks = $mynetworks

        Commenting it out solved all problems:
        - first: the MsOulook2007 must to have "Log on to incoming mail server
        before sending mail" option checked.
        - second: mobile android device access(through local net) and smtp auth
        offer;

        Hoping this will will be useful sometime, I thank everyone who read my
        message.



        --
        Best regards,
        Gmail-teopro mailto:teopro@...
      • Wietse Venema
        ... No-one answered because there are about a dozen Postfix features that may be set wrong (eight configuration parameters that control how SASL authentication
        Message 3 of 4 , Jul 29, 2012
          Gmail-teopro:
          > Hello again,
          > I apologize that in my previous message I didn't provide additional
          > informations. I was hoping to be a trivial problem(and it was), so it
          > doesn't need too much to be solved.

          No-one answered because there are about a dozen Postfix features
          that may be set wrong (eight configuration parameters that control
          how SASL authentication is made available for SMTP clients, and
          perhaps another half-dozen features that depend on what input the
          client provides).

          Wietse

          > I've solved the problem after sending my first post. It was in main.cf, the
          > following statement:
          > smtpd_sasl_exceptions_networks = $mynetworks
          >
          > Commenting it out solved all problems:
          > - first: the MsOulook2007 must to have "Log on to incoming mail server
          > before sending mail" option checked.
          > - second: mobile android device access(through local net) and smtp auth
          > offer;
          >
          > Hoping this will will be useful sometime, I thank everyone who read my
          > message.
          >
          >
          >
          > --
          > Best regards,
          > Gmail-teopro mailto:teopro@...
          >
          >
        • Manish Kathuria
          ... You might have configured SMTP Authentication / POP Before SMTP in your mail server.
          Message 4 of 4 , Aug 1, 2012
            On Sun, Jul 29, 2012 at 12:23 AM, Gmail-teopro <teopro@...> wrote:
            > Hi all,
            >
            > I've already finished a Postfix server setup with virtual users and Dovecot
            > as virtual transport.
            > I just cannot find out why MS Outlook fails the smtp test unless I check
            > the "Log on to incoming mail server before sending mail" on the More
            > settings/ Outgoing Server tab.
            >
            >
            > Thanks in advance for any hint you can help.
            >
            >
            >
            > --
            > Best regards,
            > Gmail-teopro mailto:teopro@...
            >

            You might have configured SMTP Authentication / POP Before SMTP in
            your mail server.
          Your message has been successfully submitted and would be delivered to recipients shortly.