Loading ...
Sorry, an error occurred while loading the content.

Re: Question how do i keep incoming mails from causing an error message send back

Expand Messages
  • Noel Jones
    ... That s the POP server and has nothing to do with postfix. ... again, nothing to do with postfix. ... Check the postfix logs for more detailed information
    Message 1 of 2 , Jul 23, 2012
    • 0 Attachment
      On 7/23/2012 7:24 AM, janbro@... wrote:
      > Hello list,
      > I'm new to this list hoping to receive some help. I posted my question on June 20 on the Zarafa community page, but did not get a feedback since, so I hope you tolerate my double posting. This is what I'm struggeling with:
      >
      > I'm quit proud to say that I have sucessfully managed to install zarafa on Centos 6. Unfortunately as I haven't found any working tutorials I had to collect my pieces on the way. I am now left with a problem, which I guess is related to the missing communication between zarafa and postfix.
      >
      > This is my postfix/master.cf added lines:
      > zarafa unix - n n - 10 pipe
      > flags= user=vmail argv=/usr/bin/zarafa-dagent ${user}
      > __________________________________________________ __________________________________________________ ________
      > and that's my postfix/main.cf:
      > mailbox_command = /usr/bin/zarafa-dagent "$USER"
      > local_recipient_maps =
      > mailbox_transport = zarafa:
      > zarafa_destination_recipient_limit = 1
      >
      > # zarafa unix - n n - 10 pipe
      > # flags= user=vmail argv=/usr/bin/zarafa-dagent ${user}
      >
      > # fallback_transport = lmtp:unix:/var/lib/imap/socket/lmtp
      > myhostname = mail.example.de
      > mydomain = mail.example.de
      >
      > mydestination = $myhostname, $mydomain, localhost.$mydomain, localhost
      > __________________________________________________ __________________________________________________ ________
      >
      > now if I do a telnet mail.example.de 110
      > I get a
      > +OK Zarafa POP3 gateway ready

      That's the POP server and has nothing to do with postfix.

      >
      > now I try my user abcde
      > and the pass secret
      > and get a -ERR Wrong username or password
      >
      > The login via zarafa webinterface works just fine.

      again, nothing to do with postfix.

      > Now if I send an email to my account the mail is delivered, but the sender receives the following report:
      >
      > Reporting-MTA: dns; mail.example.de
      > X-Postfix-Queue-ID: 620C47D08589
      > X-Postfix-Sender: rfc822; abcde@...
      > Arrival-Date: Wed, 20 Jun 2012 07:53:43 +0200 (CEST)
      >
      > Final-Recipient: rfc822; abcde@...[abcde@...]
      > Original-Recipient: rfc822;abcde@...
      > Action: failed
      > Status: 5.3.0
      > [...]
      > Naturally I have replaced my domain with example, everything else is unchanged.
      > I figure it's a authorization issue between postfix and zarafa, but I don't know, how to solve it. Please take into account that I have somewhat limit linux skills. I hope I have provided all information needed and somebody could help me out here.


      Check the postfix logs for more detailed information about why this
      was marked failed. Postfix intentionally does not provide failure
      details in mail to strangers.
      Start with this:
      http://www.postfix.org/DEBUG_README.html#logging



      If you need more help, please see
      http://www.postfix.org/DEBUG_README.html#mail



      -- Noel Jones
    Your message has been successfully submitted and would be delivered to recipients shortly.