Loading ...
Sorry, an error occurred while loading the content.

Re: AW: AW: special characters in mail address

Expand Messages
  • Benny Pedersen
    ... dont list mydestination here
    Message 1 of 17 , Jul 3, 2012
    • 0 Attachment
      Den 2012-07-03 12:24, Dentzer, Daniel skrev:
      > Here it is, but I have shortend/anonymized a few names.

      > relay_domains = $mydestination, hash:/etc/postfix/local_domains

      dont list mydestination here
    • Dentzer, Daniel
      Thank you, but after the change, the behavior is the same. We don t use the local mail (mydestination) on this server. ... Von: owner-postfix-users@postfix.org
      Message 2 of 17 , Jul 3, 2012
      • 0 Attachment
        Thank you, but after the change, the behavior is the same.

        We don't use the local mail (mydestination) on this server.

        -----Ursprüngliche Nachricht-----
        Von: owner-postfix-users@... [mailto:owner-postfix-users@...] Im Auftrag von Benny Pedersen
        Gesendet: Dienstag, 3. Juli 2012 12:37
        An: postfix-users@...
        Betreff: Re: AW: AW: special characters in mail address

        Den 2012-07-03 12:24, Dentzer, Daniel skrev:
        > Here it is, but I have shortend/anonymized a few names.

        > relay_domains = $mydestination, hash:/etc/postfix/local_domains

        dont list mydestination here
      • Benny Pedersen
        ... sure but it an failure to let postfix see mydestination in relay_domains mydestination is local, while relay_domains is remote hosted relay access denied
        Message 3 of 17 , Jul 3, 2012
        • 0 Attachment
          Den 2012-07-03 12:40, Dentzer, Daniel skrev:
          > Thank you, but after the change, the behavior is the same.

          sure but it an failure to let postfix see mydestination in
          relay_domains

          mydestination is local, while relay_domains is remote hosted

          relay access denied means recipient domain is not in mydestination or
          sender is outside of mynetworks

          check where abc.de is in your hashes, or if its just that you use hash
          table for mynetworks
        • Dentzer, Daniel
          The server is running for years now, the only thing is that with an exclamation mark in the local part of the mail address the email is not forwarded, hundreds
          Message 4 of 17 , Jul 3, 2012
          • 0 Attachment
            The server is running for years now, the only thing is that with an exclamation mark in the local part of the mail address the email is not forwarded, hundreds of user mail addresses work.

            I think the configuration is (mostly) correct and working, but when I use special characters (until now only "!") the server has problems with the domain name and didn't relay.

            -----Ursprüngliche Nachricht-----
            Von: owner-postfix-users@... [mailto:owner-postfix-users@...] Im Auftrag von Benny Pedersen
            Gesendet: Dienstag, 3. Juli 2012 13:01
            An: postfix-users@...
            Betreff: Re: AW: AW: AW: special characters in mail address

            Den 2012-07-03 12:40, Dentzer, Daniel skrev:
            > Thank you, but after the change, the behavior is the same.

            sure but it an failure to let postfix see mydestination in relay_domains

            mydestination is local, while relay_domains is remote hosted

            relay access denied means recipient domain is not in mydestination or sender is outside of mynetworks

            check where abc.de is in your hashes, or if its just that you use hash table for mynetworks
          • Erwan David
            Le Tue 3/07/2012, Dentzer, Daniel disait ... Beware that ! is a site separator in UUCP addresses. -- Erwan
            Message 5 of 17 , Jul 3, 2012
            • 0 Attachment
              Le Tue 3/07/2012, Dentzer, Daniel disait
              > The server is running for years now, the only thing is that with an exclamation mark in the local part of the mail address the email is not forwarded, hundreds of user mail addresses work.
              >
              > I think the configuration is (mostly) correct and working, but when I use special characters (until now only "!") the server has problems with the domain name and didn't relay.
              >

              Beware that ! is a site separator in UUCP addresses.

              --
              Erwan
            • Dentzer, Daniel
              Good information. Is there a way to turn this off? ... Von: owner-postfix-users@postfix.org [mailto:owner-postfix-users@postfix.org] Im Auftrag von Erwan David
              Message 6 of 17 , Jul 3, 2012
              • 0 Attachment
                Good information.

                Is there a way to turn this off?

                -----Ursprüngliche Nachricht-----
                Von: owner-postfix-users@... [mailto:owner-postfix-users@...] Im Auftrag von Erwan David
                Gesendet: Dienstag, 3. Juli 2012 13:21
                An: postfix-users@...
                Betreff: Re: special characters in mail address

                Le Tue 3/07/2012, Dentzer, Daniel disait
                > The server is running for years now, the only thing is that with an exclamation mark in the local part of the mail address the email is not forwarded, hundreds of user mail addresses work.
                >
                > I think the configuration is (mostly) correct and working, but when I use special characters (until now only "!") the server has problems with the domain name and didn't relay.
                >

                Beware that ! is a site separator in UUCP addresses.

                --
                Erwan
              • Reindl Harald
                do not top-post after get reply at bottom! ... this makes absolutely no sense you have to keep in mind that EVERY mailserver involved for delivering a message
                Message 7 of 17 , Jul 3, 2012
                • 0 Attachment
                  do not top-post after get reply at bottom!

                  Am 03.07.2012 13:53, schrieb Dentzer:
                  > -----Ursprüngliche Nachricht-----
                  > Von: owner-postfix-users@... [mailto:owner-postfix-users@...] Im Auftrag von Erwan David
                  > Gesendet: Dienstag, 3. Juli 2012 13:21
                  > An: postfix-users@...
                  > Betreff: Re: special characters in mail address
                  >
                  > Le Tue 3/07/2012, Dentzer, Daniel disait
                  >> The server is running for years now, the only thing is that with an exclamation mark in the local part of the mail address the email is not forwarded, hundreds of user mail addresses work.
                  >>
                  >> I think the configuration is (mostly) correct and working, but when I use special characters (until now only "!") the server has problems with the domain name and didn't relay.
                  >>
                  >
                  > Beware that ! is a site separator in UUCP addresses.
                  >
                  > Good information.
                  >
                  > Is there a way to turn this off?

                  this makes absolutely no sense
                  you have to keep in mind that EVERY mailserver involved for
                  delivering a message (and that can be many hops) has to
                  accept a address as valid

                  so usually do not use special chars at all!
                • Dentzer, Daniel
                  ... Without quotes, local-parts may consist of any combination of alphabetic characters, digits, or any of the special characters ! # $ % & * + - / = ? ^ _
                  Message 8 of 17 , Jul 3, 2012
                  • 0 Attachment
                    > -----Original Message-----
                    > From: owner-postfix-users@... [mailto:owner-postfix-users@...]
                    > On Behalf Of Reindl Harald
                    > Sent: Tuesday, July 03, 2012 2:02 PM
                    > To: postfix-users@...
                    > Subject: Re: special characters in mail address
                    >
                    > do not top-post after get reply at bottom!
                    >
                    > Am 03.07.2012 13:53, schrieb Dentzer:
                    > > -----Ursprüngliche Nachricht-----
                    > > Von: owner-postfix-users@...
                    > > [mailto:owner-postfix-users@...] Im Auftrag von Erwan David
                    > > Gesendet: Dienstag, 3. Juli 2012 13:21
                    > > An: postfix-users@...
                    > > Betreff: Re: special characters in mail address
                    > >
                    > > Le Tue 3/07/2012, Dentzer, Daniel disait
                    > >> The server is running for years now, the only thing is that with an
                    > exclamation mark in the local part of the mail address the email is not
                    > forwarded, hundreds of user mail addresses work.
                    > >>
                    > >> I think the configuration is (mostly) correct and working, but when I use
                    > special characters (until now only "!") the server has problems with the
                    > domain name and didn't relay.
                    > >>
                    > >
                    > > Beware that ! is a site separator in UUCP addresses.
                    > >
                    > > Good information.
                    > >
                    > > Is there a way to turn this off?
                    >
                    > this makes absolutely no sense
                    > you have to keep in mind that EVERY mailserver involved for delivering a
                    > message (and that can be many hops) has to accept a address as valid
                    >
                    > so usually do not use special chars at all!


                    Why does it makes no sense, these Characters are valid as written in RFC 3696:
                    ----------
                    Without quotes, local-parts may consist of any combination of
                    alphabetic characters, digits, or any of the special characters

                    ! # $ % & ' * + - / = ? ^ _ ` . { | } ~

                    period (".") may also appear, but may not be used to start or end the
                    local part, nor may two or more consecutive periods appear.
                    ----------

                    After all, my postfix is not working like defined in the RFCs, may be due to this UUCP-Problem, but we don't use UUCP.
                    (and I don't know much about UUCP)

                    Is there any other option, other than stop using special characters?
                  • Reindl Harald
                    ... one thing is RFC and the other one how useable is a address in the real life * register forms with breaking validation * other servers / relays /
                    Message 9 of 17 , Jul 3, 2012
                    • 0 Attachment
                      Am 03.07.2012 14:48, schrieb Dentzer:
                      >
                      >
                      >> -----Original Message-----
                      >> From: owner-postfix-users@... [mailto:owner-postfix-users@...]
                      >> On Behalf Of Reindl Harald
                      >> Sent: Tuesday, July 03, 2012 2:02 PM
                      >> To: postfix-users@...
                      >> Subject: Re: special characters in mail address
                      >>
                      >> do not top-post after get reply at bottom!
                      >>
                      >> Am 03.07.2012 13:53, schrieb Dentzer:
                      >>> -----Ursprüngliche Nachricht-----
                      >>> Von: owner-postfix-users@...
                      >>> [mailto:owner-postfix-users@...] Im Auftrag von Erwan David
                      >>> Gesendet: Dienstag, 3. Juli 2012 13:21
                      >>> An: postfix-users@...
                      >>> Betreff: Re: special characters in mail address
                      >>>
                      >>> Le Tue 3/07/2012, Dentzer, Daniel disait
                      >>>> The server is running for years now, the only thing is that with an
                      >> exclamation mark in the local part of the mail address the email is not
                      >> forwarded, hundreds of user mail addresses work.
                      >>>>
                      >>>> I think the configuration is (mostly) correct and working, but when I use
                      >> special characters (until now only "!") the server has problems with the
                      >> domain name and didn't relay.
                      >>>>
                      >>>
                      >>> Beware that ! is a site separator in UUCP addresses.
                      >>>
                      >>> Good information.
                      >>>
                      >>> Is there a way to turn this off?
                      >>
                      >> this makes absolutely no sense
                      >> you have to keep in mind that EVERY mailserver involved for delivering a
                      >> message (and that can be many hops) has to accept a address as valid
                      >>
                      >> so usually do not use special chars at all!
                      >
                      >
                      > Why does it makes no sense, these Characters are valid as written in RFC 3696:
                      > ----------
                      > Without quotes, local-parts may consist of any combination of
                      > alphabetic characters, digits, or any of the special characters
                      >
                      > ! # $ % & ' * + - / = ? ^ _ ` . { | } ~
                      >
                      > period (".") may also appear, but may not be used to start or end the
                      > local part, nor may two or more consecutive periods appear

                      one thing is RFC and the other one how useable is a address
                      in the real life

                      * register forms with breaking validation
                      * other servers / relays / mail-filters

                      yes, in case of problems you can say XYZ is violating the RFC
                      but this does not help the user much

                      that is why we are restricting e-mail to a-z,0-9 and -
                    • Viktor Dukhovni
                      ... The RFC only defines SMTP, not the whole email ecosystem. Sure mimsy!chris@umd.edu is a local address at umd.edu from the perspective of SMTP, but
                      Message 10 of 17 , Jul 3, 2012
                      • 0 Attachment
                        On Tue, Jul 03, 2012 at 12:48:58PM +0000, Dentzer, Daniel wrote:

                        > > > Beware that ! is a site separator in UUCP addresses.
                        > > >
                        > > > Good information.
                        > > >
                        > > > Is there a way to turn this off?
                        > >
                        > > this makes absolutely no sense
                        > > you have to keep in mind that EVERY mailserver involved for delivering a
                        > > message (and that can be many hops) has to accept a address as valid
                        > >
                        > > so usually do not use special chars at all!
                        >
                        > Why does it makes no sense, these Characters are valid as written in RFC 3696:

                        The RFC only defines SMTP, not the whole email ecosystem. Sure

                        mimsy!chris@...

                        is a local address at "umd.edu" from the perspective of SMTP, but (still!) the
                        majority of non-border Sendmail and Postfix systems will treat these as UUCP
                        addresses and become multi-hop open relays if the border MTA does not refuse
                        to forward these. Hence Postfix correctly treats these as source routes by
                        default.

                        If your system consists of just your server and is not a border
                        relay and either refuses incoming mail or delivers it locally, then:

                        swap_bangpath = no

                        will disable UUCP support and allow incoming "abc!de" local parts,
                        but these will be treated with prejudice everywhere else, so RFC
                        or no RFC this address is not useful. There are de-facto standards
                        that should or must not be ignored.

                        --
                        Viktor.
                      • Dentzer, Daniel
                        ... After a bit searching, and the great comments of you all, it looks like -see text above- a general problem of Postfix (and other mailsystems). But on the
                        Message 11 of 17 , Jul 3, 2012
                        • 0 Attachment
                          > -----Original Message-----
                          > From: owner-postfix-users@... [mailto:owner-postfix-users@...]
                          > On Behalf Of Viktor Dukhovni
                          > Sent: Tuesday, July 03, 2012 3:21 PM
                          > To: postfix-users@...
                          > Subject: Re: special characters in mail address
                          >
                          > On Tue, Jul 03, 2012 at 12:48:58PM +0000, Dentzer, Daniel wrote:
                          >
                          > > > > Beware that ! is a site separator in UUCP addresses.
                          > > > >
                          > > > > Good information.
                          > > > >
                          > > > > Is there a way to turn this off?
                          > > >
                          > > > this makes absolutely no sense
                          > > > you have to keep in mind that EVERY mailserver involved for
                          > > > delivering a message (and that can be many hops) has to accept a
                          > > > address as valid
                          > > >
                          > > > so usually do not use special chars at all!
                          > >
                          > > Why does it makes no sense, these Characters are valid as written in RFC
                          > 3696:
                          >
                          > The RFC only defines SMTP, not the whole email ecosystem. Sure
                          >
                          > mimsy!chris@...
                          >
                          > is a local address at "umd.edu" from the perspective of SMTP, but (still!) the
                          > majority of non-border Sendmail and Postfix systems will treat these as UUCP
                          > addresses and become multi-hop open relays if the border MTA does not refuse
                          > to forward these. Hence Postfix correctly treats these as source routes by
                          > default.
                          >
                          > If your system consists of just your server and is not a border relay and
                          > either refuses incoming mail or delivers it locally, then:
                          >
                          > swap_bangpath = no
                          >
                          > will disable UUCP support and allow incoming "abc!de" local parts, but these
                          > will be treated with prejudice everywhere else, so RFC or no RFC this address
                          > is not useful. There are de-facto standards that should or must not be
                          > ignored.
                          >
                          > --
                          > Viktor.


                          After a bit searching, and the great comments of you all, it looks like -see text above- a general problem of Postfix (and other mailsystems). But on the other side, it is well known, that nobody should use unusual special characters.

                          E.g. in http://en.wikipedia.org/wiki/Email_address#Specification are some more explanations:

                          "Systems that send mail must be capable of handling outgoing mail for all valid addresses. Contrary to the relevant standards, some defective systems treat certain legitimate addresses as invalid and fail to handle mail to these addresses. Hotmail, for example, refuses to send mail to any address containing any of the following standards-permissible characters: !#$%*/?^`{|}~"

                          But under Valid email addresses:
                          !#$%&'*+-/=?^_`{}|~@...

                          The result for me is, that I will persuade my company not to use most of the characters.


                          Thank you all for the very fast and competent help.

                          Daniel
                        • Viktor Dukhovni
                          ... The above text is unjustifiably pejorative. Systems that deal with the real world outside the standards group are not necessarily defective . Postfix is
                          Message 12 of 17 , Jul 3, 2012
                          • 0 Attachment
                            On Tue, Jul 03, 2012 at 01:26:37PM +0000, Dentzer, Daniel wrote:

                            > E.g. in http://en.wikipedia.org/wiki/Email_address#Specification are some more explanations:
                            >
                            > "Systems that send mail must be capable of handling outgoing mail
                            > for all valid addresses. Contrary to the relevant standards, some
                            > defective systems treat certain legitimate addresses as invalid
                            > and fail to handle mail to these addresses.

                            The above text is unjustifiably pejorative. Systems that deal with the
                            real world outside the standards group are not necessarily "defective".

                            Postfix is quite capable of handling all the allowed RFC 2821/2822
                            non-special characters in address localparts. By default, sensible
                            security precautions and backwards compatibility settings are in
                            place:

                            - swap_bangpath = yes

                            This protects internal systems (Sendmail, Postfix or other)
                            from becoming multi-hop open relays if they support "host!user"
                            UUCP address rewriting.

                            - allow_percent_hack = yes

                            Much the same, but for "user%internal@external" legacy addresses.

                            - allow_min_user = no

                            Protects careless administrators and shell script authors from their
                            own folly. For example in master.cf pipe(8) argv= specs:

                            SAFE:
                            argv=myscript -f ${sender} -- ${recipient}
                            UNSAFE:
                            argv=myscript -f${sender} ${recipient}
                            argv= argv=myscript -f ${sender} ${recipient}
                            null_sender= argv=myscript -f${sender} -- ${recipient}

                            Disable these measures at your peril. If your installation is simple
                            and carefully maintained these are not needed. In practice people
                            are lazy and sloppy and benefit from the extra care that Postfix
                            takes to save them from themselves.

                            --
                            Viktor.
                          Your message has been successfully submitted and would be delivered to recipients shortly.